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= Each section is indicated by a section boundary. These lines indicate the separation of the areas and do not print to paper. You
can move these bars to change the amount of space reserved for each section. You click and drag the section divider to the
desired position.

= The names of the five areas can also be shortened to their abbreviated forms (RH, PH, D, RF, and PF). You set the Short
Section Name option in the Design View area of the Layout tab in the Options dialog box from the File menu.
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Report Header Page Header

Report Footer

Page Footer

Printed only on Printed at the Body of the
first page top of each report

Used for titles, page Printed once
name of the Used for per record
report, print column Used for the
date and logo headings, print data fields
Charts that read date, chapter

from the entire name and page

report number

Printed only
once at the end
of the report
Used for grand
totals, total
number of
pages

Charts that read
from the entire
report

Printed at the
bottom of each
page

Used for page
numbers and
other info

Vision33

B When starting a new report, by default 5 areas are created:

Report Header —

Page Header

& Details

Printed only on first page
Used for titles, name of the report, print date and logo

Charts that read from the entire report

Printed at the top of each page

Used for column headings, print date, chapter name and page number

Body of the report

Printed once per record
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B Used for the data fields

@ Report Footer

B Printed only once at the end of the report
B Used for grand totals, total number of pages
B Charts that read from the entire report

¢ Page Footer

B Printed at the bottom of each page

B Used for page numbers and other info
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= Group Header
= Group Footer

| Design |

Report Header

Report Areas - With Groups ViSiOT!;! ALBCA3RE+

= When the report is grouped, for each grouping level, 2 additional areas are added:

Page Header

Print Date |

E

3 -
Group #1 Hame §
rouniarne Liacurm - LardLnde
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B Group #1 Name i

Grand Total:

E
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B When the report is grouped, for each grouping level, additional 2 areas are added:
@ Group Header — printed at the top of each group. Used for printing the group name

@ Group Footer — printed at the bottom of each group. Used for printing sub totals
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Preview & Design Modes ViSi('.||‘|33+
TOTAL CARE

Easy to distinguish between WYSIWYG

sections Toggle Preview Pane icon — easy

Use Guidelines navigation

Use to add new fields Certain changes require

Where the majority of your refreshing the data

report development is done Zoom, skip pages and Drill
Down

Vision33

B You can design reports in 2 modes:

@ Design
® Easier to distinguish between sections
® Used for adding new fields
® Use horizontal and vertical Guidelines to align fields in the reports

@ Preview
® See actual data from the database
® Can easily navigate in the report data using the Toggle Preview Pan
® Can refresh data in case the report updates (new fields are added for example)
® You can save the data with the report it self and save a preview picture of the first page of the report.
® Zoom browse to other pages.

® Double click to drill down to certain group for example. Will open a new tab for that group.
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The Design tab is where you do most of the initial work when creating a report. It designates and labels the various sections of
the report. You can do the initial formatting, place objects in the sections where you want them to appear, specify sorting,
grouping, and totaling needs, and so forth.

The report created in the Design tab is a kind of virtual report; it has the structure and instructions for creating the final report, but
it is not the report itself.

While working in the Design tab you manipulate “representatives” or placeholders of objects, not the objects themselves.

The Design window offers faster previewing of information and layout because you are not working with the actual data itself.
You can add and delete fields and other objects, move them around, set up complex formulas, and more, without tying up the
computer or network resources needed to gather the data. ...
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Positioning Objects Using Guidelines ViSi0n33+
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Cesian | Preview
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| Reooit Header
Page Header z .
o Print Date |
Ll Cardcod } Cardiam s ginCod .. Balance
B CardCode 4 ardhame y Z\pCUde 4 . Balance

If you want to line objects up with one another, you can insert a guideline and attach objects
toit.

Then, in one step, you can move the guideline to reposition all the objects attached to the
guideline.

When the Insert Detail Field Headings option is turned on Crystal automatically places a
vertical marker in the ruler for each field you place in the Details area.

These markers or “handles” let you move the fields and their column headings horizontally on
your report at the same time by moving the guideline arrowhead.

When you click a field to move or resize the object, “tracker guidelines” appear, aligning the
object against the horizontal and vertical rulers to let you clearly see the placement.

Visionaz
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When you preview a report, the program gathers the data, makes the
necessary calculations, and displays the report in the Preview tab.

With the data in place, you can review the spacing and formatting of your report
and see the actual results of all your summaries, formula calculations, and
record and group selections.

The first time the Preview tab is used, it retrieves data from your underlying
data source(s) and saves it with the report (unless you have set up the program
not to save data).

From that point on, the program uses the saved data whenever you preview the
report unless you specifically refresh (F5) it or add a field that requires the
program to retrieve new data.

Sales By Customer Group

Vision33
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rystal Reports Toolbars ViSiOTE! §§+
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Design
Prink Previsw
Preview Sample...

HTML Preview

Eield Explorer

Report Explarer
Repository Explorer
Dependency Checker
‘Workbench

Toolbars. ..

Status Bar

Zoom...

Rulers
Guidelines
Grid
Taoolkips

Produck Locale

Preferred Viewing Locale

CtrD

mWorking with toolbars
The Report Designer window includes several toolbars.

To move a toolbar, click and hold in an unused part of the
toolbar, between groups of buttons, or on the unused area at
the beginning or end of the toolbar. Drag the entire toolbar to

the desired location.

The toolbars are “floating” toolbars. You can position them on
any of the four sides of the screen, or float them on your design

area.

Toolbars @

Toolbars:

/| Standard [ oK
[7]Formatting

[Z]Insert Tools
[7]Expert Tocls

[7]Navigation Tools
[7]External Command

[#] Show ToolTips

[¥] Autohide Animation

["]Reset all toolbars and explorers on next restart.

Vision33
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Field Explorer Tool V|S|0n33+
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Desion cerl+D The Field Explorer displays a tree view of database fields,
i Freviom iR special fields formula fields, SQL expression fields, parameter
e fields, group name fields, and running total fields that you
have defined for use in your report

Preview Sample..,

[T] HTML Preview
7 Use the Field Explorer to insert, modify, or delete these
= objects on the Design and Preview tabs. You'll see the Field
Eield Explorer K
21| bt Eiorsr Explorer_ after you have.
B Ressity Explrer m Clicked the Field Explorer button on the Standard
25! Dependency Checker toolbar.
| iorkbench . .
il = Selected the Field Explorer from the View menu.

Toolars. . Field Explorer nx
iz £l | B 2 B8 X
| StatusBar =
=l =0
2 reviewRansl & [T} JOT1 [Journal Entry - Rows]

Zoom.., @ [T] 0ACT [G/L Accounts]

fx Formula Fields
Rulers M SQL Expression Fields
Guidelines [i7]] Parameter Fields
n T Running Total Fields
S = {2 Group Name Fields
Tooltips =2 Group #1 Name: JDTL.RefDate
o2 Group #2 Name: JOT 1.FinncPriod
Product Locale == Group #3 Name: OACT.Segment_0
Preferred Yiewing I &/ % specal Fields

ISAP £
—_
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Using the Field Explorer you can add the following field types:

B Database — add database fields from the selected tables, or open the database expert to add additional tables.

B Formulas — create new formulas using the formula editor. Once the formula is created it can be added to the report
B SQL expressions

B Parameters — add parameters to the report in order to dynamically filter it

B Running totals — add running totals to the report details

B Group Names — displays group names in case the report is grouped. The group name can be added to the printed
report

B Special Fields — built in and ready to use functions, such as current data and time, record number, page number
and more.
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Field Explorer - Browse Data Vision33
TOTAL CAR

Field Explorer
"?ﬂ‘r’ﬁ’_"-f-‘
= [ ocRD
== CardCode
== CardMame
o= CardType

Lk

2= GroupCode
== CmpPrivate
== Address
o= ZipCode
== Mailsddres
o= MailZipCad
== Phonel

= Phone2
= Fax

o= CntekPrsn
= Motes

== Balance

Insert to Report

Browse Data...

=2

Database Expett...
Set Datasource Location, ..

Log On or OFf Server...
Find in Farmulas. ..

Show Field Type
Refresh

5= ChecksBal

“=| 4 OCRD.CardMame

=

=0

[E=] Field Explors Tipsas Silig

Length: 100

Anthony Smith
Aquent Systems

CTI Computers

-
ADA Technologies
Andreas Ackemann

Bike Customer #1
Blockies Corporation

[

E+

You can take a look at a sample of the actual data in the table
before you place the field on your report in the Browse Field
Data dialog box.

To browse field data

1. Select the field.

2. From the Field Explorer, click Browse.
3. Scroll through the list.

4. Click Close when finished.

Default settings are the first 500 records or it times out at five

seconds, depending on what has been set up in the registry
setting.

Vision33
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'.I’ || Preview
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HTML Preview

X

Close Current Vi

Eield Explorer
Report Explarer

% | [

Repositor
Depender
‘Workbeng

Else

Toolbars.
| Status Ba
[ preview

|[=

Zoom, .
Rulers
iuideling:
Grid
Taoolkips

Produck L

Freferred

Preview Sample,

ChrHD
ChrR

e

Report Explorer

Report groupec
=| Report Header
2] Page Headsr

amer Group rpk

2| Group Header #1: OCRG.Grouphame - &
I ==] Details
== GroupMamel: OCRG,GroupMame
~E=1 Dochiuml: OINY.Dackium
== CardCodel: OTMY.CardCode
-2 CardMamel: OINY, Cardhiame
== DocTotall: OIMY.DocTokal
:t__] Group Footer #1: OCRG.GroupMame - &
t&_-_] Report Footer
| Page Footer

[EiFild Explarer ! Report Explorer

Report Explorer Tool VlSlOﬂéé;,

The Report Explorer displays a tree view of the sections in
your report and lists the report objects contained in each
section and works like a “report navigator.” You can work with
report objects directly from the explorer.

The content of the Report Explorer represents the content of
the report in a tree view. The root node is the report itself,
while the first-level nodes represent the report's sections.

The Report Explorer appears when you select the Report
Explorer command from the View menu, or when you click the
Report Explorer button on the Standard toolbar.

Within each section, the report's fields and objects are listed.
Any item you select in the tree view will be selected in the
report (in either Design or Preview modes).

ISAP A4
—_
Vision33

B The report explorer displays the areas in the report, as well as the fields in each area

B Use the report explorer as a working tool, to locate, and select one or more fields.
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Program Options VlSlOﬂégM

Use the Options choice on the File menu to configure the
Designer defaults
Use the Options dialog box to change the default values for
the entire program.

= Layout (Design, Preview, Grid & Fields)

= Database (Tables & Fields, Data Explorer)

= Formula Editor (Font, Color and Syntax)

= Reporting (Save & NULL Options)

= Fields (Default Field Formatting Options)

= Fonts (Fonts Defaults by Field Types)

= Smart Tag & HTML Preview

= Dependency Checker (Report Checking)

Eile Edit

Ctrles

Y Cutep
Page Setup.
Export ,
sendTo ,
Options.
Report Options,

Summery Info.

TR
Options g
Forts I Smart Tog & HTML Preview | Dependency Checker |
Layout ‘ Database Formula Editor I Reporting | Fields |
Design View Preview
[¥] Rulers [ Rulers
[ Guidelines [] Guidelines
[ClGid [ Grid
[¥] Tool Tips [¥] Tool Tips
|| Short Section Names [¥] Section Names
[¥] Show Hidden Sections [#] Page Breaks in Wide Pages
Pages Start With
Grid options
: (@) Full Size (100 %)
|¥] Srap To Grid =
() Fit Width
Giid Size: ) Fit Page
0083 [¥] Display Preview Panel
in
Field options
[] Show Field Names
[¥] Insert Detail Field Headings
[¥] Insert Group Name: with Group
ok | [ cConcel |[ hHeo |
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Report Options Vi3i0n33+
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This dialog box appears when you choose the

¥ Report Options % |
Generslsetings Report Options command from the File menu.
[] Convert Database NULL Values to Default [] save Data With Report . .
|| Convert Other HULL Values to Default ["] suppress Printing If No Records Use the Report Optlons dlalog bOX tO Change
T e the options for only the current report.
[l by Sort Localy @ishon reven pand Most of the defaults should be left as is
[¥]Database Server s Case-Insensitve [9]Disply Alerts on Refrest = Save Data with Report - Is typically the only
7 Perform Grouping on Server [IRead-orly option non technical folks change
] Use Indexes Or Server For Speed [ select Distinct Records
[+/] verify on First Refresh [/] select Distinct Data for Eronsing LY L
MNew 3
[ Verify Stored Procedures on First Refresh [~ Retain Original Image Color Depth = Open. CtrleO
|| Respect Keep Group Together On First Page [] Prompt For Hyperlinks Close
[ save Lodk Report Design H] | save Ctrl+§
Initial Report Part Settings Save As..,
Paste the Report Part Ink: i) paste Link Is Save Data with Report
Object Name:
Data Context:
5 | Print... Ctrl+P
‘ Preview Pages Start With : {Fuu size -] PagESetup..
Export 3
[ * ] I Lol J [ ek ] Send To 3
Options..,
Report Options...
Summary Info..,
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New
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= Local
= Open.. b0
Close Crystal reports can be saved as files to a
= s Cohs local or network drive
| Save fis.. . . . .
Save Dt with Report The saving function is the same in Crystal
reports as in many other applications.
= i — The Open, Save, and Save As dialog boxes
Page Setip... enable you to open or save a report
Export > conveniently to personalized folders that are
Send T R created by your operating system.
CQptions...
B ~ Save As

n

I e e

m

Savein: |, Sohutions

Name :

¥ Bxercise2tpt

¥ Exercisedapt

¥ Exercised.rpt

' Exercised_Template.rpt
4| Exercise5 9-2010.rpt
7 ExerciseS.rpt

¥ Bxerciseurpt

! ExerciseT.rpt

-0 d > E
Dete modified Type
9182008 115PM  Crys
9/18/2008 4:50 PM Crys:
9/18/2008 5:56 PM Crys
9182008534 PM Crys
9/30/2010 5:38 PM Crys:
9/20/2008 9:27 AM Crys
9/23/2008235PM  Crys
10/10/2008 151 PM  Crys

&l i

File name.

Save astype: [Coystal Reports

e
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Saving Your Report (Option 2) ViSi('.lT!;!}élBRE+

Business One Database ot | A Window. B

ithi SAP Business One D!:H Save
Crystal reports can be saved as Layouts or Reports within a S

Business One database. B\ | Preview in SAP Business One
Use the Add-ins>SAP Business One menu to Save or Save kg

As to save the report definition to Business One # Soveds. - OEC Computers i
You will be asked to logon using your Business One N .

credentials

You have superuser permissions in Business One U i | sl

ACEL - Account Balance
« » . « » ACT1 - Account Index
ACT2 - GJL Accounts and BP Index
Any “Report” type is saved to the “Lost Reports” folder ACT2 - Gl Accouts
ADV1 - Advances on Corp. Tax on Tumover Report
AGE1 - Business Partner Aging - Summary
AGE2 - Business Partner Aging - Detail
AGE3 - Collection Report
AGE4 - Customer Receivables Aging (by 5LP) - Sum
AGE5 - Customer Receivables Aging (by SLP) - Detail
AGEE - Collection Report (by SLP)
3 LogOn = BALY - Balance Sheet
= BAL2 - Vertical Balance Sheet Comparison
W?L%‘”f‘s BALS - Periodic Balance Sheet
One BAL# - Vertical Balance Sheet
BALS - Balance Sheet Comparison
License Server PALNGOB 1526 BETO - Eudget

A

BGT! - Budget Report
Databose ServerType  [sqLserver 2008 BGT2 - Annual Budget Report
S BGT: - BudgetReport - Graph

Databsse Server PAD8 16280 BGT4 - Budget Balance Sheet

BGTS - Profit & Loss Statement Budget Report

BGTE - Budget Trial Balance

BGT7 - Periodic Budget Balance Sheet

BGTE - Periodic Profit & Loss Statement Budget Rep
bty D [se00emous 3 BGTS - Periodic Budget Trial Balance

BMUL - BOM Update Repart
BNKO - Bank Statement Report
Festsd fm—— ] BOE1 - Bill of Exchange - Payables = -

User Name manager
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Simple Customer Listing
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XL Reporter Workshop 67
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