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|Design |

= Each section is indicated by a section boundary. These lines indicate the separation of the areas and do not print to paper. You
can move these bars to change the amount of space reserved for each section. You click and drag the section divider to the
desired position.

= The names of the five areas can also be shortened to their abbreviated forms (RH, PH, D, RF, and PF). You set the Short
Section Name option in the Design View area of the Layout tab in the Options dialog box from the File menu.
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Page Header
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Page Footer

Printed only on
first page

Used for titles,
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report, print
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Charts that read
from the entire
report
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page
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headings, print
date, chapter
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number

Body of the
report
Printed once
per record
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data fields

Printed only
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pages

Charts that read
from the entire
report
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bottom of each

page
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Report Areas - With Groups VISIOTI(;!"léA3%+

m When the report is grouped, for each grouping level, 2 additional areas are added:

= Group Header
m Group Footer
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Preview & Design Modes ViSi0n33+
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Easy to distinguish between WYSIWYG

sections Toggle Preview Pane icon — easy

Use Guidelines navigation

Use to add new fields Certain changes require

Where the majority of your refreshing the data

report development is done Zoom, skip pages and Drill
Down
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The Design tab is where you do most of the initial work when creating a report. It designates and labels the various sections of
the report. You can do the initial formatting, place objects in the sections where you want them to appear, specify sorting,
grouping, and totaling needs, and so forth.

The report created in the Design tab is a kind of virtual report; it has the structure and instructions for creating the final report, but
it is not the report itself.

While working in the Design tab you manipulate “representatives” or placeholders of objects, not the objects themselves.
The Design window offers faster previewing of information and layout because you are not working with the actual data itself.

You can add and delete fields and other objects, move them around, set up complex formulas, and more, without tying up the
computer or network resources needed to gather the data. ...
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Positioning Objects Using Guidelines VISI(]|'|33+
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| Design | Presview

| o | 2 o 3 | P o) 5 | 8 o | 7 |
Report Header .
Page Header - .
. Frint Date |
R CardCod > CardMam } Zincod 1. Balance
@ CardCode . CardMame T ZipCode .. Balance
|

If you want to line objects up with one another, you can insert a guideline and attach objects
to it.

Then, in one step, you can move the guideline to reposition all the objects attached to the
guideline.

When the Insert Detail Field Headings option is turned on Crystal automatically places a
vertical marker in the ruler for each field you place in the Details area.

These markers or “handles” let you move the fields and their column headings horizontally on
your report at the same time by moving the guideline arrowhead.

When you click a field to move or resize the object, “tracker guidelines” appear, aligning the
object against the horizontal and vertical rulers to let you clearly see the placement.
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When you preview a report, the program gathers the data, makes the
necessary calculations, and displays the report in the Preview tab.

With the data in place, you can review the spacing and formatting of your report
and see the actual results of all your summaries, formula calculations, and
record and group selections.

The first time the Preview tab is used, it retrieves data from your underlying
data source(s) and saves it with the report (unless you have set up the program
not to save data).

From that point on, the program uses the saved data whenever you preview the
report unless you specifically refresh (F5) it or add a field that requires the
program to retrieve new data.
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Crystal Reports Toolbars

\f .| Design
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Print Preview
Preview Sample...

HTML Prewview

Field Explorer

Report Explorer
Repository Explorer
Dependency Checker
‘Workbench

Toolbars. ..

| Gkatus Bar

Zoom...

Rulers
Guidelines
Grid
Toolkips

Product Locale

Preferred Wiewing Locale

«+o  ®WWorking with toolbars
The Report Designer window includes several toolbars.
To move a toolbar, click and hold in an unused part of the

Vision33,
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toolbar, between groups of buttons, or on the unused area at
the beginning or end of the toolbar. Drag the entire toolbar to
the desired location.

The toolbars are “floating” toolbars. You can position them on
any of the four sides of the screen, or float them on your design

area.

-

Toolbars

Toolbars:

i7|standard

[¥|Formatting
[¥]Insert Tools
[¥|Expert Tools

[ |Mavigation Tools
|V |External Command

OK

Cancel

i g

Show ToolTips

Autohide Animation

[|reset all toolbars and explorers on next restart,
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Field Explorer Tool V|S|0n33+
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Design Chrl+Dr

Prestiew Chrl+R,

Preview Sample..,

HTML Preview

Close Current Yiew

Field Explorer

Report Explarer

Repositary Explorer

Dependency Checker

wWorkbench

Field Explorer
Toolbars. .. P
: B B 3

Status Bar fﬂ | B2 35 & X
e |=8
Jp =heNIBER R & [ 1DT1 [ournal Entry - Rows]
| Zoar,.. # [T OACT [GAL Accounts]

fx Formula Fields
Rulers T 5L Expression Fields
Guidelines [(7]] Parameter Fields
o =4 Running Total Fields
Gl = {2 Group Name Fields
Tooltips o= Group #1 Name: JOT1.RefDate

Product Locale

== Group #2 Name: JOT 1.FinncPriod
=) Group #3 Name: OACT. Segment_0

Preferred Yiewing | & % Special Fields

The Field Explorer displays a tree view of database fields,
special fields formula fields, SQL expression fields, parameter
fields, group name fields, and running total fields that you
have defined for use in your report

Use the Field Explorer to insert, modify, or delete these
objects on the Design and Preview tabs. You'll see the Field
Explorer after you have:
m Clicked the Field Explorer button on the Standard
toolbar.

m Selected the Field Explorer from the View menu.
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Fiold Explorer - Browsebata___________________ |[SlIIEE]

Field Explorer
= | B
= ] ocRD
o= CardCode
o= Cardhlame

o= CardTvpe
o= GroupCode Insert to Repark

o
s B X

x

|
[

o= CrpPrivate Erowse Daka. .

o= Address
o= FipCode
o= Maildddres
o= MailZipCod
== Phonel
o= Phonez
o= Fax

o= CnkckPrsn
o= Mokes

=]

Show Field Tyvpe

o= Balance Refresh

Find in Formulas.

Database Expert...
Set Datasource Location. ..

Log On or OFF Server. ..

o= EhecksBaI
= 4 OCRD.CardName

=

=] Field Ex_plorf

Type: String
Length: 100

.
ADA Technologies |—

Andreas Ackemann 5 |
Anthory Smith

Agquent Systems

Bilie Customer #1

Blockies Comporation

CTl Computers el

=

TOTAL CARE

You can take a look at a sample of the actual data in the table
before you place the field on your report in the Browse Field
Data dialog box.

To browse field data

1. Select the field.
2. From the Field Explorer, click Browse.
3. Scroll through the list.
4. Click Close when finished.
Default settings are the first 500 records or it times out at five

seconds, depending on what has been set up in the registry
setting.
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Report Explorer Tool VlSlOTQééJ,
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Design ChrlD
[

Preview Sample. .,

HTML Preview

Close Current: Wiew

|| Preview Chrl+R

Field Explorer

Report Explorer

Repositor:- ™ ='==

Report Explorer
Depender i
% |[={wafe]
workber L = ; »
=R Y4l -2les Report grouped by Custormer Group rpk

Toolbars, l:ﬁ Report Header
i =] Page Header
i &3] Group Header #1: OCRG. Grouphlame - &
|| Preview F [ =2 Details

Zoam ~E=1 GroupMamel: QCRG, Grouphame
b -2 Dochurnl s OINY. DocMurn

Rulers 2= CardCodel: OINY, CardCode

_. ] ~m= CardMamel: OIMY Cardiams

Guigene; ~E= DocTotall: OINY. DocTotal

Grid == Group Footer #1: OCRG, Grouphlame - &

Taolkips ‘:“.j Report Footer

=] Page Footer
Product L
Preferred

Field Explarar |9 Repart Explorer

The Report Explorer displays a tree view of the sections in
your report and lists the report objects contained in each
section and works like a “report navigator.” You can work with
report objects directly from the explorer.

The content of the Report Explorer represents the content of
the report in a tree view. The root node is the report itself,
while the first-level nodes represent the report's sections.

The Report Explorer appears when you select the Report
Explorer command from the View menu, or when you click the
Report Explorer button on the Standard toolbar.

Within each section, the report's fields and objects are listed.
Any item you select in the tree view will be selected in the
report (in either Design or Preview modes).
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Program Options

Use the Options choice on the File menu to configure the
Designer defaults

Use the Options dialog box to change the default values for

the entire program.
m Layout (Design, Preview, Grid & Fields)

m Database (Tables & Fields, Data Explorer)
m Formula Editor (Font, Color and Syntax)

m Reporting (Save & NULL Options)

m Fields (Default Field Formatting Options)
m Fonts (Fonts Defaults by Field Types)

m Smart Tag & HTML Preview

m Dependency Checker (Report Checking)

File  Edit

MNew >
(= Open.. Ctrl+0
Close
[H] | save Ctrl+5
Save As...

Save Data with Report

& print.. Ctrl+P

Options...

Report Options...
Summary Info...

- m—r,
Cptions E
| Forts | Smart Tag & HTML Preview Dependency Checker
Layout | Database I Formula Editor Reporting I Fields
Design View Preview
[¥] Rulers [ Rulers
[7] Guidelines [7] Guidelines
[ Grid [} Gnd
[@] Tool Tips [¥] Toal Tips
[7] Short Section Names |¥] Section Names
[¥] Show Hidden Sections [/] Page Breaks in Wide Pages
Pages Start With:
Grid options: ;
] Snap To Gid \‘-_il Full Size {100 %)
) Fit Width
Grid Size: ) Fit Page
0083 : || Display Preview Panel
in
Field options:
[¥] Show Field Names
[¥] Insert Detail Field Headings
[¥] Insert Group Mame with Group
[ ok || cacel || Hep |
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Report Options VISIOI‘I33+
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(@ Report Options ~= 1| ™ This dialog box appears when you choose the
General Sefings Report Options command from the File menu.
[] Convert Database MULL Values to Default [T save Data With Report . .
N Use the Report Options dialog box to change
[] Convert Other NULL Values to Default [C] suppress Printing If Mo Records .
[] show &ll Headers On Drill Down [ Perform Query Asynchronously the optlons for on Iy the cu rrent report
7] Avays Sort Locally (7]show Preview Panel Most of the defaults should be left as is
Database Server is Case-Insensitive [¥] pisplay Alerts on Refresh | Save Data Wlth Report - IS typlca”y the Only
[7 Perform Grouping On Server [Read-only option non technical folks change
[#] Use Indexes Or Server For Speed [ select Distinct Records
File Edit
[¥] verify on First Refresh Select Distinct Data for Browsing Ty o
[ verify Stored Procedures on First Refresh 7| retain Original Image Color Depth e le pen... Chite 0
|| Respect Keep Group Together On First Fage Frompt For Hyperlinks - Close
["] save Lock Report Design [ Legacy XML Expert. .. ] [H | save Ctrl+5
Initial Report Part Settings Save As..,
Paste the Repart Part link: = Paste Link I Save Data with Report
Ohject Mame:
Data Context:
=4 Print... Ctrl+P
Preview Pages Start With : IF""” Sia ,] —
Export k
[ % ] [ S I [ eln ] Send To »
Opticns...
Report Opticns...

Summary Infa...
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Saving Your Report (Option 1) VISIOT!)"er_3CA3FﬁE+

..l ' Local
= Open... CheH-C
Clase = Crystal reports can be saved as .rpt files to a
&l | save Qs local or network drive
| Save hs... | . . . .
T T = The saving function is the same in Crystal
T reports as in many other applications.
o — . = The Open, Save, and Save As dialog boxes
s St enable you to open or save a report
Export » conveniently to personalized folders that are
i 8 created by your operating system.
Orptions... i .
R ~§# Save As E
I'g Savein: _1-, Solutions - & [ A
MName ° Date modified Type
1 1 ExerciseZt.rpt 9/18/2008115PM  Crys
- "l Exercise3.rpt 9/18/2008 4:50 PM Crys
¥ Exercised.rpt 9/18/2008 556 PM  Crys
3 ¢ Exercised_Template.rpt 9/18/2008 5:34 PM Crys
4 % Exercise5 9-2010.rpt 9/30/2010 5:38 PM  Crys
B el ExerciseS.rpt 9/20/2008 9:27 AM Crys
E 191 Exerciseb.rpt 9/23/2008 235 PM Crys
] Exercisel.rpt 10/10/2008 1:51 PM  Crys
[l i |
: File name: [
Save as type: [Crystal Reports Y] [ Cancel ] v
L = w
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Saving Your Report (Option 2) ViSi0n33+
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Business One Database Hipor o a i

};:H SE'\"E

Crystal reports can be saved as Layouts or Reports within a bl 08 o
. l o
Business One database.

Preview in S4P Business One

Use the Add-ins>SAP Business One menu to Save or Save Lag O
As to save the report definition to Business One (33 Save . - 0EC Computers =

You will be asked to logon using your Business One e
. Ype @ Layo () Repo
credentials

You have superuser permissions in Business One e |l e e

ACB1 - Account Balance

13 ” H 113 ” - Account Index
Any “Report” type is saved to the “Lost Reports” folder ACT2 - Gl Acaita snd 5P nde
ADV1
AGE1

RTEI

Advances on Corp. Tax on Turnover Report
Business Partner Aging - Summary

AGE2 - Business Partner Aging - Detail
AGE3 Collection Report
AGE4 Customer Receivables Aging (by 5LP)- Sum

AGES Customer Receivables &ging (by SLF) - Detail
=Ty AGEG Collection Report {by SLP)
3 Log On e BAL1 - Balance Sheet

= BAL2 - Vertical Balance Sheet Comparison
W ?"f‘"%‘,”?s‘s BAL3 Periodic Balance Sheet
LI BAL4 - Vertical Balance Sheet

BALS

License Server PALNOD451628A BE
BGTL

Database Server Type (501 Server 2008 - BGT2

Balance Sheet Comparison
Budget

Budget Report

Annual Budget Report

= = BGT3 Budget Report - Graph
Database Server |PALNDD481628A BGT4 Budget Balance Sheet
R BGTS Profit & Loss Statement Budget Report
BGTE Budget Trial Balance

BGT7 Periodic Budget Balance Sheet
BGTS Periodic Profit & Loss Statement Budget Rep
Company Database |SEDDemoUS = BGTY Periodic Budget Trial Balance

BEMUL - BOM Update Report

bl T ENKO - Bank Statement Report
Password prs— BOE1 - Bill of Exchange - Payahles > -
\ | )
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Simple Customer Listing




