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CRYSTAL REPORTS
For SAP Business One

Understanding the Business One Data Model
& Data Source
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Understanding the Business One Database Structure V|S|0|‘|3 3
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m  Use the View>System Information to see the table and field names
Eile Edit View Data Goto Modules Business Partner Master Data
User-Defined Fields  Cirl+Shift+U Code 20000 Customer Local Currency -
System Information Ctrl+Shift+I ame Morm Thempson Account Balance = 21,9453
o Foreign Name Deliveries = -328.50
Rickers Display Group Canstruction - Orders = 57,272.14
Indicator Display 2 Currency US Dollar ¥ Opportunities =3 2z
Restore Column Width e US25-967634
lumn Width General || /ConftactPersons | Addresses | PaymentTerms | Payment System | Accounting | Properties | Remarks |
Legend Cirl+L Tel1 (519) 5657576 Cantact Parsan Narm Thempsen
Tel 2 503 345-1234 ID Mo, 2
Mabile Phane
Fax
E-Mail Remarks
tieh Site
Shipping/Type Federal Express EM Ssles Emplowes Brad Thompsen -[=)
Passwayd
Factoring Indicato = =
Projstt Government Works - BR Channel Code
Technician = Buyer, Fred
Tarritory =
[] Active
] on Hald
ok J Related Sarvice Calls [ activky || Related Activities
BP Mame (100 Characters) 09/24/2008
Maorm Thompson [Farm=134 Tkem=7 Pane=0 Varisbles 1 OCRD,CardName] 912280
AP A4
P
Vision33 T

B Use the View>System Information to see the table and field names on the screen

B Place your cursor on the field, and look at the lower tool bar to find out the table and field name
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Business One Database Structure ViSi0n33+
TOTAL CARE

m Distinguish between related tables and a field with multiple values:

Business Partner Master Data

Mame

Forsign Name

Group Construction
Currency US Dollar
Federal Tax ID

-

OCRD.CardType

Cod=

Hame

Forsign Hame

Group Censtruction

Currency Construction

Federsi Tex 1D Gk

Distributors

General | Governmant

Tel1 High T=ch

Tel2 Large Accounts

Machie Bt Non-Prafts

Tt Broduction

o Srall Accounts

Shipping Type

Customer

-

OCRG.GroupName

Link (join) tables OCRD to OCRG
where OCRD.GroupCode = OCRG.GroupCode

\v/

Vision33
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The Complete Database Reference Vision33+
TOTAL CARE

Use the Database Tables B b =
Reference help file of the L )
Business One Software Comrts | e | {[sarg I i
Development Kit (SDK) et T 1
Filename: REFDB.chm > i ||| Tatte rome: o
Organized by Business One > Field Description ltype  [size |Relatedo 2" |constraints
module < s z DocEntry  |Internal Number  [int 1
@ 4/P Credit Yemo Docum  |Document Number [fint It
Complete table reference with S o P F S P A A A
data types, size, defaults and | L ervce
constraints (values) CANCELED [cencelied frcrac [t | | -
Also contains Primary Key o
information for table joins Handwrtten [Manual Numbering [VarChar (1 — N - Nis
Printed Printed IVarChar |[1 [ N [Copy
M original
2 [amended
DocStatus [Document Status  [[VarChar |1 — o] o [Open
Ic [Closed
InvntSttus Warehouse Status [[VarChar |1 [ o o (Open

ISAP. &
pAS

Vision33

B Use the SDK Help to learn about the objects structure

B The SDK help is installed from the SDK install package files located in every full installation or upgrade of SAP Business One.
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Crystal Reports Data Source Vismﬂéé"

Each crystal report must have at least one Data Source

Release 2005/2007 Crystal used “OLE DB (ADQO)” Data Source (*still supported in 8.8)

Crystal Reports for SAP Business One has new Data Source “SAP Business One”

SAP Business One source will connect via the license server (B1 user-id) OR database user-id
For security, B1 User-id is preferred and maybe required by your database administrator

m SAP Business One -
Enter connection details below:

Browse the data source for the tables you want to add. o S T

(Note: to edit the alias for a table, select the table inthe "Selected Tables'tree and click on it or

press the F2 key)

Available Diata Sources Sidectod Tobles SAP Business Ore Server:  [hanab1:30015 |
[ [CAMS 11S/Proxy Log Files - SLD Server: [ranab:40000 |
& CINT Archived Evertt Log
[ CINT Current Event Log _\ G [s2P HaNA v]
# [CJODEC (RDO)
@ (ZOLE DB (ADO) e Company Database: v
B C0utiook
(] Outlook/Exchange Company User ID [mer |

& [(Public Folder ACL
& (C3Public Folder Admin
i (1Public Folder Replica
&
@ CIWeb/IS Log Flles
= [Z1Repository

[ [ZJMore Data Sources

Company User Password | .......... ‘

Trusted Cennection {optional): [ ]

Database User ID (optional): | ‘

Database Passward {optional) | \

< Back Next [ Fosh | [ Cancd | [ Heb |

ISAP £
—_

Vision33

B If you are familiar with using Crystal Reports, you should know Crystal Reports designer connects to database via supported data source.

B To work with current B1 releases, report designers normally use OLE DB/ADO data source to connect Crystal Report designer with b1 database. You
need to have a good knowledge on Business One database schema since under ADO data view, all B1 database tables are listed and sorted by
alphabetic order. If your report involves multiple tables, you also need to understand the underlying relationships among tables.
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Make New Connections

If no connections exist

Create New Connection > SAP
Business One

Click on SAP Business One

Enter connection details for
connecting to you Business One
database (If SQL...)

m SQL Server Name

m License Server Name and Port

= Database Version
(MSSQL2005/2008)

Company Database Name
m Business One User ID & Password

Once the connection is made you
will see your company database
name

Expand that and “B1 Tables” to start
selecting your tables for your report

SAP Business One

E

Vision 33,
=

Enter connection details below:

SAP Business One Server: ‘hanab1:3DD15 ‘
SLD Server: [ranab1:40000 |
Server Type: [54P HANA v
Compary Database: v

Company User ID

Trusted Connection {optional):  []

Database User |0 (optional):
Database Password {optional):

Company User Password

< Back Mext >

o [

Browse the data source for the tables you want to add.

(Note: to edt the aiasfor atable, select the table in the ‘Selected Tables'tree and cick on t or
pressthe

Available Data Sources:

48 Add Command Py
E [E] SBODemolIS
= [E]B1 Tables

[ [E] 01 Administration

= [ 02 Financials
® & Budost Setup
(= [E] Chart of Accounts

JEIOACT [G/L Accouri] |

(@ [E] Cost Accounting
(@ [E] Financial Reportt Templates
(@ [E] Irtemal Reconcilistions
(@ & Joumal Entry
(@ [E] Posting Templates
(@ [E] Recuring Postings
@ B Tax

@ [EF] 03 Sales Opportunties

[ [] 04 Sales - A/R

[ [ 05 Purchasing - AP

# [] 06 Business Partners

@ [E) 07 Banking

[ [iZ] 08 Inventory

[ [E] 09 Production

@ [ 10 MRP

51 111 Samvien

)

I

Vision33
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Selecting Objects from a Data Source Vismﬂéé‘“

m  Once Connection is defined or selected, you can select tables/views from the data source

' Database Expert ===

Deta | Links

Browse the data source for the tables you want to add.
(Note: to edit the alias for a table, select the table in the "Selected Tables"tree and click on it or

press the F2key)
Available Data Sources: Selected Tables
= Add Command] - 5 -8 PALND0431628A
= [&] 5B0Demol3 JoTi
= [ 81 Tables = = OACT
l 1l [E 01 Administration

© [ 02 Financials
[ |E] Budget Setup
= |E] Chart of Accounts
= E OACT <
(# [E5] Cost Accounting
@ [E Financial Report Templates
# [E] Intemal Reconcilations
= [E] Joumal Entry
00T
JoTi
OTRC
OBTD
OETF
BTF1
OCFH
CFH1
ocFW
ocFL
B ocFT
5 1E Postinn Temnlates

I

T =T

y

Vision33 e

B You can add, remove, or change the data source in an existing report.
B Use the Database menu, Database Expert to add or remove current tables from the report

B Use the Set Data source location to replace the data source for the report.

38



Database Table & Field Display Options Vision

+
TOTAL CARE
options =)
Add to Report Database
Add Command to Report
] Sort Tables Alphabetical
Make New Connection s '
[l Sort frelds Alphabetcaly
Remove from Report
Properties
Table rame LIKE:
Rename Connection (5]
[]System Tables o
Delete Connection I smonyms ——
Stored Procedures Cor)
Remove from reposito ‘Advanced Options
Rename reposiory | i iy
7] Database Server is Case-Insensitve
Options [ select Distinct Data for Browsing
[ perform Query Asynchronously
Refresh F5 [¥] Verify On First Refresh
Verify Stored Procedures On First Refresh
. . Verify When Database Driver Upgraded
* Right click on Database Expert to 7] Automatic SmartLinking
access this pop-up menu
e
Show Description Show Name Show Both
= = )My Connections ‘onnections
PALNOD4E1628A
ALNO0481628A_1
=l [ 5B00emollS ] Add Command
= [ B1 Tables 8 SEODemollS
= [ B Tables
V

Vision33
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Linking Report Tables VISIOTQ§§+

Selected Tables:

B - PALNO0481628A
OACT [G/L Accounts]
JDT1 [Joumal Ertry - Rows]

JDTH 0ACT

B Transld - B AcctCode

B Linc ID |j| / AcctName

B Account i= | CurrTotal
Debit = EndTotal
Credit Finanse
S¥SCred Groups
SVSDeb Budget
FCDebit Frozen
FCCredit Free2

B FCCurrency Postable

B DueDate Fixed
SourcelD Levels

P Scurceline ExportCode

B ShortName Grpline

B IntrnMatch I FatherNum
ExtrMatch AccntntCod
ContraAct CashBox
LineMemo - Grouphask

[T

If your report contains data from two or more database tables,
these tables will be “linked”.

Linking requires that you use a field that is common or “alike”
to both tables.

You define the linking setup in the Links tab of the Database
Expert.

The new SAP Business One data Source is “aware” of default
joins between tables and will link the tables based on
knowledge of key structure

Review the default links set up. It is a good opportunity to
become familiar with how Business One tables are linked
(joined).

You can also override or re-order the default links based on
your report requirements.

If you use any other Data Source, (ex. OLE DB (ADOQ)) please
review all links carefully

Vision33
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Linking Repo ables VlSlOﬂégM

m  Use Query Generator to help with these table linkages...
Bold fields in table field list are key (linked) fields in other tables.

Drag these bold fields to the table list column on the left, and the linked table will appear and the JOIN will be created

between the correct fields

0ACT Line 1D Row Nurmber
Account Account Code
Debit Debit Amount
Credit Credit Amount
S¥SCred System Credit Amount
SYSDeb System Debit Amount
FCDebit Debit Amount (FC)
FCCredit Credit Amount (FC)
FCCurrency  Forsign Currency
DusDste Due Date
Shorthame BP/Account Code
IntnMaich Internal Reconciiation No.
ExirMatch External Reconciiation No.
ContraAct Offset Account
LineMemo Row Details

X Refiline Addtional Reference

| oo | |TransType Original Journal

|£J LLJ RefDate Posting Date

=1

From
JDTLTO INNER JOIN OACT T1 ON
T0.Account = TLA

Whers

Group By

fial

ok Coen ) [0 )

Vision33
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Table Linkage - Examples 1 VISIO&&;@

m OCRD (Business Partner Master)
OCRG (Card Groups)
OSLP (SalesPersons)
OUSR (Users)
CRD1 (Address)
OCPR (Contacts)
OPLN (Price Lists)

m  OITM (Item Master)
OITB (ltem Groups)
OMRC (Manufacture)
ITM1 (Item Prices)
OACT (GL Accounts)

Vision33
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Table Linkages - Examples 2 VISIOTQ§§+

mORDR (Sales Order Header)
OCRD (Business Partners)
RDR1 (Order Rows)
RDR3 (Order Freight)
OCTG (Payment Terms)
OFPR (Financial Period)

mOINV (AR Invoice Header)
OCRD (Business Partners)
INV1 (Invoice Rows)
OJDT (Journal Entry)
OCTG (Payment Terms)
OFPR (Financial Period)
OPKL (Pick List)

nJDT1 (Journal Entry Detail)
OACT (CL Account)

using
using
using
using
using

using
using
using
using
using
using

using

ISAP A4
—_—
Vision33 B
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Table Join Types - *Advanced Topic VisioTQ§§+

] — (DEFAULT) An inner join requires each record in the two joined tables to have a matching record. An inner join
essentially combines the records from two tables (A and B) based on one or more fields.

] - The result of a left outer join (or simply left join) for tables A and B always contains all records of the "left"
table (A), even if the join-condition does not find any matching record in the "right" table (B).

] -A right outer join (or right join) closely resembles a left outer join, except with the tables reversed. Every
record from the "right" table (B) will appear in the joined table at least once. If no matching row from the "left" table (A) exists,
NULL will appear in columns from A for those records that have no match in A.

u - A full outer join combines the results of both left and right outer joins. The joined table will contain all records
from both tables, and fill in NULLs for missing matches on either side.

ISAP A4
-
Vision33
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Changing a Data Source on a Report ViSiOTQ§§+

. et Datasource Lacation ==
Set Datasource Location e -~ o —
Can be required when running reports e
from report designer. B1 will use the 5 Hroot
(= 3, PALND04B16284
current company database. e
Current Data Source el e
Server Type: MSSQL2008
This list displays the database and i il
tables currently used in the report. The o e
. . = EJT1
main report is shown as the root node. BB Popanes
Replace with Repce v
@ (L1 Public Folder Replica - Update
This list displays the same options as = }
5] 8, PALNDOAS128A 0 Database Expert...
the Data tab of the Database Expert. = 5 raLiossiszsa
id Command Set Datasource Locakion...
See Data tab (Database Expert) for ok o7 O
information about how to select a new o =
o} INFORMATION_SCHEMA -
data source or table. & Eoe
® EWeb/11S Log Fiss ek OLAR Cube Locstion.. .
Update Click the Update button to & B s :
. . ‘erify Database
update the new data source information e
in the Current Data Source list. If the AR 0 —
new data source is different from the PatoiTiGEolinT on e del

Select Distinct Records

one you're replacing, the Map Fields
dialog box appears.

Vision33
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N Vision33.

Business One Data Model

llllll

XL Reporter Workshop 46
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PO P QU IZ Multiple Choice and True or False ViSion 33+

TOTAL CARE

What tool(s) do ALL SAP Business One users have at their disposal to view database field and table information
Microsoft SQL Server Management Studio \/
View > System Information
The SDK Help files \/
SAP Community Network (SDN \/
Query Generator J

There is a new SAP Data Source in the Current release of Crystal Reports for SAP Business One. Its name is
OLE DB (ADO)
ODBC (RDO)
ADO NET (XML)
SAP Business One
VSAM (LMNOP)

To use the new SAP Data Source in Crystal Report, each user must know the ‘sa’ database password

Vision33
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PO P QU IZ Continued - Multiple Choice and True or False ViSion 33+

TOTAL CARE

If you don’t know the ‘sa’ password and you're using the new SAP Data Source in Crystal Report, does the SAP Business One License Manager have to be running?
True

False

If you import a Crystal Report or Layout from your Partners Test SQL 2005 database to your Production SQL 2008 database you will have to change your report “data
source”

True

False

What Menu Option do you select in Crystal to see the Table Descriptions as well as the Table Names when viewing tables for your report
File > Report Options
File > Options
View > Field Explorer
Right Click > Show Field Type

If you select more than one SAP Business One table for your report or layout, you must link these tables via a LEFT OUTER JOIN
True

False

Vision33
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Continued - Multiple Choice and True or False

POP QUIZ

Vision33.

TOTAL CARE

If you want to print the Salespersons Name on your report along with customer or vendor data what two tables do you need to join in your report.

OCRD and OSLP
CRD1 and OCRD
ORDR and RDR1
OCRD and OCPR

The default table JOIN between two tables selected for a report in Crystal is a?
LEFT OUTER JOIN
RIGHT OUTER JOIN
FULL OUTER JOIN
FULLY MONTY
INNER JOIN \/

You have to buy the Software Development Kit from your Partner to get access to the SAP Database Tables Reference help file?
True

False

What table contains a list of all SAP Business One table names used by Query Generator?
OTBL
OMG
ATBL

ok

Vision33
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END Session #1 - Introduction ViSiOﬂ 33+
TOTAL CARE

Crystal Reports for SAP Business One
Version 8.8 family, 9.0 family, and beyond

Carl Britton Lewis — Chief SAP Business One Ambassador
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