## Typographic Conventions

<table>
<thead>
<tr>
<th>Type Style</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Example</em></td>
<td>Words or characters quoted from the screen. These include field names, screen titles, pushbuttons labels, menu names, menu paths, and menu options. Textual cross-references to other documents.</td>
</tr>
<tr>
<td><em>Example</em></td>
<td>Emphasized words or expressions.</td>
</tr>
<tr>
<td><em>EXAMPLE</em></td>
<td>Technical names of system objects. These include report names, program names, transaction codes, table names, and key concepts of a programming language when they are surrounded by body text, for example, SELECT and INCLUDE.</td>
</tr>
<tr>
<td><em>Example</em></td>
<td>Output on the screen. This includes file and directory names and their paths, messages, names of variables and parameters, source text, and names of installation, upgrade and database tools.</td>
</tr>
<tr>
<td><em>Example</em></td>
<td>Exact user entry. These are words or characters that you enter in the system exactly as they appear in the documentation.</td>
</tr>
<tr>
<td><code>&lt;Example&gt;</code></td>
<td>Variable user entry. Angle brackets indicate that you replace these words and characters with appropriate entries to make entries in the system.</td>
</tr>
<tr>
<td><strong>EXAMPLE</strong></td>
<td>Keys on the keyboard, for example, F2 or ENTER.</td>
</tr>
</tbody>
</table>
# Table of Contents

Document History................................................................................................................................6

1 Introduction .................................................................................................................................... 7
1.1 Application Architecture .............................................................................................................. 7
1.2 Application Components Overview .............................................................................................. 8
1.2.1 Server Components .................................................................................................................. 8
1.2.2 Client Components .................................................................................................................. 10
1.2.3 Compatibility Between 32-bit and 64-bit Components and Applications .................................. 11
1.3 Software Download ..................................................................................................................... 12

2 Prerequisites .................................................................................................................................. 13
2.1 Constraints ................................................................................................................................... 14
2.2 User Privileges ............................................................................................................................ 14

3 Installing SAP Business One ....................................................................................................... 15
3.1 Installing Server Components ..................................................................................................... 15
3.1.1 Installing the Browser Access Service ...................................................................................... 27
3.2 Installing Client Components ..................................................................................................... 30
3.3 Installing the Microsoft Outlook Integration Component (Standalone Version) ......................... 33

4 Installing SAP Crystal Reports, version for the SAP Business One Application ....................... 36
4.1 Installing SAP Crystal Reports, version for the SAP Business One application ......................... 36
4.2 Running the Integration Package Script ...................................................................................... 38
4.3 Updates and Patches for SAP Crystal Reports, version for the SAP Business One application .. 39

5 Uninstalling SAP Business One .................................................................................................... 40
5.1 Uninstalling SAP Business One Client Agent ............................................................................. 41
5.2 Uninstalling the Integration Framework of SAP Business One ................................................... 41

6 Upgrading SAP Business One ...................................................................................................... 43
6.1 Upgrade Methods ......................................................................................................................... 43
6.2 Supported Releases ...................................................................................................................... 44
6.3 Upgrade Process .......................................................................................................................... 44
6.3.1 Upgrading SAP Business One Components and Databases .................................................. 45
6.3.2 Upgrading the SAP Business One Client .................................................................................. 60
6.3.3 Upgrading SAP Add-Ons ......................................................................................................... 61
6.4 Performing Silent Upgrades ....................................................................................................... 62

7 Performing Post-Installation Activities ......................................................................................... 64
7.1 Configuring Services ................................................................................................................... 64
7.1.1 Configuring the License Manager ............................................................................................ 64
7.1.2 SBO DI Server ......................................................................................................................... 67
7.1.3 Job Service .............................................................................................................................. 67
7.1.4 Configuring Fax Services ........................................................................................................ 75
### Table of Contents

9.5.1 Restricting Database Access ................................................................. 135
9.5.2 Changing Security Levels ................................................................. 136

9.6 Network Security .................................................................................. 137
9.6.1 Communication Channels ............................................................... 137
9.6.2 SSL Encryption ................................................................................. 138

9.7 Application Security ............................................................................. 141
9.7.1 Password Encryption ....................................................................... 141
9.7.2 B1_SHR Folder Permissions ............................................................. 143
9.7.3 Queries ............................................................................................ 143
9.7.4 Add-On Access Protection ............................................................... 144
9.7.5 SAP Business One Dashboards ......................................................... 144

9.8 Security Solutions for Microsoft SQL Server and Database Tips ................. 145
9.8.1 Upgrading Microsoft SQL Server ..................................................... 145
9.8.2 Securing Microsoft SQL Server ....................................................... 145
9.8.3 Revoking Guest Access to the msdb Database .................................. 147

9.9 Data Storage Security ........................................................................... 147
9.9.1 Exporting Configuration Files ......................................................... 147
9.9.2 Importing Configuration Files ......................................................... 149
9.9.3 Configuration Logs and User Settings .............................................. 151

9.10 Security Information for Integration Solutions ........................................... 152
9.10.1 Security Aspects Related to the DATEV-HR Solution ....................... 152
9.10.2 Security Aspects Related to the Mobile Solution .............................. 152
9.10.3 Security Aspects Related to the Integration with SAP Customer Checkout 153
9.10.4 Security Aspects Related to the RFQ Scenario with Online Quotation 153

9.11 Troubleshooting Security .................................................................... 154

10 Troubleshooting .................................................................................... 156

11 Getting Support ..................................................................................... 157
11.1 Using Online Help and SAP Notes ....................................................... 157
11.2 Using the Support Desk ................................................................. 158
## Document History

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>2015-11-10</td>
<td>First version.</td>
</tr>
<tr>
<td>1.0.1</td>
<td>2015-12-04</td>
<td>SAP Business One company Support user.</td>
</tr>
<tr>
<td>1.1</td>
<td>2015-12-24</td>
<td>- Section 2: Browser access is supported for Google Chrome.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Section 3.1.1: Browser access service is supported on 64-bit operating systems as well as on 32-bit operating systems.</td>
</tr>
<tr>
<td>1.2</td>
<td>2016-02-26</td>
<td>Section 7.5.9: Information about using proxy groups for the integration framework</td>
</tr>
<tr>
<td>1.3</td>
<td>2016-05-19</td>
<td>- Section 2: Microsoft .NET Framework 4.5.2 is required.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Section 8.1.4: Naming convention of company databases.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Section 7.1.2.1: Idle processes setting for Browser Access service.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Section 7.1.2.3: How to monitor Browser Access processes.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Installation instructions for Excel Report and Interactive Analysis are removed. You can find the instructions in the Administrator's Guide for SAP Business One analytics powered by SAP HANA.</td>
</tr>
<tr>
<td>1.4</td>
<td>2016-08-08</td>
<td>- Section 2: Microsoft Edge and Apple Safari (Mac and iPad) are supported for browser access.</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Section 7: A new chapter 7.2 is added for Browser Access setup.</td>
</tr>
</tbody>
</table>
1 Introduction

The SAP Business One Administrator’s Guide provides a central point of guidance for the technical implementation of SAP Business One. Use this guide for reference and instructions before and during the implementation project.

Note
Visit sappartneredge.com and select SAP Business One in your profile to ensure you receive the latest information about SAP Business One directly on your home page.

For the latest information that may not appear in this guide, see the following SAP Notes:
- SAP Note 2172820 (Central Note for SAP Business One 9.2)
- SAP Note 2243999 (Release Update Note for SAP Business One 9.2 Limitations)
- SAP Note 2172877 (Collective Note for SAP Business One 9.2 Upgrade issues)
- SAP Note 2172863 (Collective Note for SAP Business One 9.2 General issues)

1.1 Application Architecture

SAP Business One is a client-server application consisting of a fat client, a database server, and various services. The database stores only data and does not use triggers. However, the database does use views, especially for reporting and upgrade purposes.

The following figure provides an overview of the server architecture of SAP Business One:
The following figure provides an overview of the client architecture of SAP Business One:

![SAP Business One Architecture](image)

1.2 Application Components Overview

This section provides a description of the software components of SAP Business One and how they are used by the business processes of SAP Business One.

1.2.1 Server Components

Some server components are essential to the system landscape and are thus mandatory, while the others are optional and you can install them if there’s a business need.

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
<th>Mandatory?</th>
</tr>
</thead>
<tbody>
<tr>
<td>SLD (System Landscape Directory)</td>
<td>Authentiﬁes users and manages an entire SAP Business One landscape. Precondition for all other components.</td>
<td>Yes</td>
</tr>
<tr>
<td>License Service</td>
<td>Manages license requests.</td>
<td>Yes</td>
</tr>
<tr>
<td>Component</td>
<td>Description</td>
<td>Mandatory?</td>
</tr>
<tr>
<td>----------------------------------------</td>
<td>-----------------------------------------------------------------------------</td>
<td>------------</td>
</tr>
<tr>
<td>Extension Manager</td>
<td>Manages deployment of lightweight add-ons.</td>
<td>No</td>
</tr>
<tr>
<td>Job Service</td>
<td>Manages alert settings and SBO Mailer settings on the server side.</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>The SBO Mailer allows you to send documents directly from the client application through email.</td>
<td></td>
</tr>
<tr>
<td>Workflow Service</td>
<td>Enables you to implement user-defined business processes.</td>
<td>No</td>
</tr>
<tr>
<td>Browser Access Service</td>
<td>Enables you to access the SAP Business One client application in a Web browser.</td>
<td>No</td>
</tr>
<tr>
<td>Data Interface Server (DI Server)</td>
<td>Supports high-volume data integration and enables multiple clients to access and manipulate SAP Business One company schemas.</td>
<td>No</td>
</tr>
<tr>
<td>Repository</td>
<td>Includes:</td>
<td>Yes</td>
</tr>
<tr>
<td></td>
<td>· Common database <strong>SBOCOMMON</strong> that holds system data, version information, and upgrade information.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>· Unlike company databases, <strong>SBOCOMMON</strong> does not store any business or transactional data.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>· Shared folder <strong>B1_SHR</strong> that contains central configuration data as well as installation files for various client components.</td>
<td></td>
</tr>
<tr>
<td>Remote Support Platform (RSP)</td>
<td>Proactively monitors the health of an SAP Business One installation and provides automated healing, backup support, and download of software patches.</td>
<td>Yes</td>
</tr>
<tr>
<td>Integration Framework</td>
<td>A set of business scenarios that enable integration of the SAP Business One application with third-party software and mobile devices.</td>
<td>No</td>
</tr>
<tr>
<td></td>
<td>The integration packages include:</td>
<td></td>
</tr>
<tr>
<td></td>
<td>· Mobile Solution</td>
<td></td>
</tr>
<tr>
<td></td>
<td>For more information about mobile scenarios, search for the user guide for the SAP Business Mobile app on sappartneredge.com. Note that there are different user guides for the iOS and the Android versions.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>· DATEV HR (Germany only)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>For more information about DATEV HR, see Leitfaden zur Personalabrechnung mit DATEV HR (German only) in the ...\Documentation\B1 Integration Component folder of the product DVD.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>· Electronic Invoices (Mexico only)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>For more information, see SAP Note 1580236.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>· Support for Document Approval (Portugal only)</td>
<td></td>
</tr>
<tr>
<td></td>
<td>For more information, see SAP Note 1886319.</td>
<td></td>
</tr>
<tr>
<td></td>
<td>· Support for SAP Customer Checkout</td>
<td></td>
</tr>
</tbody>
</table>
### Component Description

<table>
<thead>
<tr>
<th>Component</th>
<th>Description</th>
<th>Mandatory?</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Outlook Integration Server</td>
<td>Includes Microsoft Office templates required for the Microsoft Outlook integration add-on and the standalone version.</td>
<td>No</td>
</tr>
<tr>
<td>SAP Business One Client</td>
<td>The application executable. You can also install the client application on a terminal server or in a Citrix environment.</td>
<td>Yes</td>
</tr>
</tbody>
</table>
| SAP Business One Client Agent | - Performs actions that require administrator rights on the local system (for example, upgrading the SAP Business One client and add-ons).  
- Moves SAP Business One log files to the central log folder in the shared folder.  

**Note**  
The client agent is part of the client installation process and is installed by default. | Yes |
| DI API | Data interface API, a COM-based API and an applicative DLL file (OBSever.dll) that enables add-ons to access and use SAP Business One business objects. | Yes |
| UI API | User interface API, a COM-based API that is connected to the running application and which enables add-ons to perform runtime manipulation and enhancement of the SAP Business One GUI and its flow. | Yes |
| Software Development Kit | Documentation and samples for the SAP Business One SDK. | No |
| DTW | Data transfer workbench which enables importing and updating data in large volumes. | No |
| SAP Business One Studio Suite | An integrated development environment based on the Microsoft .NET Framework, which supports you in developing extensions on top of SAP Business One. | No |
| Solution Packager | A tool for packaging your industry solutions for fast deployment. For example, you can package your user-defined tables and fields, queries, reports, and configurations, and then use the package to create new, but pre-configured, companies in SAP Business One. | No |
1.2.3 Compatibility Between 32-bit and 64-bit Components and Applications

Both 32-bit and 64-bit versions are available for some SAP Business One client components. As a general rule, 32-bit components work with 32-bit components and external applications; 64-bit components work with 64-bit components and external applications.

SAP Business One Client

While it is possible to install and run both versions of SAP Business One client on the same machine running a 64-bit operating system, in order to reduce complexity and avoid potential problems during future upgrades, we strongly recommend that you install only one version of the SAP Business One client application on the same machine.

A 64-bit SAP Business One client can work only with 64-bit add-ons; likewise, a 32-bit SAP Business One client can work only with 32-bit add-ons.

Data Transfer Workbench (DTW)

To use the DTW, you must ensure that the following components and external applications have the same system type (for example, 32-bit):

- SAP Business One DI API
- SAP Business One DTW
- Microsoft Office
- [Applicable only if you have selected ODBC as the connection type] ODBC driver

If you are using a 64-bit operating system, ensure that you have added the data source (SQL Server) in the ODBC Data Source Administrator window of the correct system type.

**Note**

Microsoft Windows 7 does not provide a menu entry for the ODBC Data Source Administrator (32-bit) window. To open this window, open the odbcad32 file in the path C:\Windows\SysWOW64.

Microsoft Outlook Integration Add-on and Standalone Version

To use the Microsoft Outlook integration add-on or the standalone version, you must ensure that the following components and external applications have the same system type (for example, 32-bit):

- SAP Business One DI API
- Microsoft Outlook integration add-on or the standalone version of SAP Business One
- Microsoft Office
SAP Crystal Reports, Version for the SAP Business One Application

To use the SAP Business One add-ins in SAP Crystal Reports for SAP Business One, you must ensure that you have installed the 32-bit DI API on the same machine.

1.3 Software Download

Download the SAP Business One product package (installation package or upgrade package) from the SAP Support Portal, as follows:

2. Do one of the following:
   1. To download an installation package, click Installation.
   2. To download an upgrade package, click Updates.
3. Navigate to and select the relevant download objects.

   Note
   
   The package may be divided into several download objects. In this case, select and download all objects under the same patch level designation.

4. Add the selected objects to the download basket.
   
   We recommend that you read the Info file for the selected download objects.

5. Download the selected objects from your download basket.
6. Extract files from the downloaded objects (archives) to your computer.

If you experience problems when downloading software, send a message to SAP as follows:

1. Go to the SAP Business One support center on sappartneredge.com.
2. In the left navigation panel, click Partner Support Dashboard.
3. Use SAP Message Wizard to write the message and assign it to component SBO-CRO-SUP.

   Note
   
   If your download fails due to an unstable internet connection, try using the SAP Download Manager, which supports resumable downloads. In the SAP Business One Software Center, first move your objects into Download Basket and then download them with the SAP Download Manager. To install the SAP Download Manager, click the Get the SAP Download Manager link in the left navigation pane.
2 Prerequisites

- For information on hardware requirements, see the *SAP Business One Hardware Requirements Guide* on sappartneredge.com.
- For an overview of support platforms for SAP Business One and related products, see the *SAP Business One Platform Support Matrix* on sappartneredge.com.
- For information about platform availability, including database platforms and operating systems, see the *Product Availability Matrix* on sappartneredge.com.
- For compatibility information regarding SAP Business One and SAP Business One Cloud, see SAP Note 1756002.
- You have installed one of the following Microsoft SQL Server versions:
  - Microsoft SQL Server 2008
  - Microsoft SQL Server 2008 R2
  - Microsoft SQL Server 2012
  - Microsoft SQL Server 2014
- You have installed Microsoft .NET Framework 4.5.2 on the server as well as on the client workstations.

  **Note**
  
  If you do not have Microsoft .NET Framework 4.5.2 installed, it is installed during the SAP Business One installation process. However, you will have to restart your machine. To avoid a restart, you may choose to install the framework before starting the SAP Business One installation.

- If you want to access the System Landscape Directory service, be sure to use one of the following Web browsers:
  - Microsoft Internet Explorer 8 or later
  - Mozilla Firefox 9 or later
  - Google Chrome 12 or later
- If you want to access SAP Business One in a Web browser, be sure to use one of the following Web browsers:
  - Mozilla Firefox
  - Google Chrome
  - Microsoft Edge
  - Apple Safari (Mac)
- To display dashboards in the SAP Business One client application, ensure you have installed Adobe Flash Player for the embedded browser Google Chrome on each of your workstations. You can download Adobe Flash Player at [http://www.adobe.com](http://www.adobe.com).

  **Note**
  
  The download link provided by Adobe is by default for Microsoft Internet Explorer. To download Adobe Flash Player for other browsers, choose to download for a different computer, and then select the correct operating system and a Flash Player version for other browsers.
2.1 Constraints

You can run the SAP Business One for 31 days without a license. To continue working with the application after 31 days, you must install a valid license key assigned by SAP.

Note

If you are a partner, for more information about installing the license key, see SAP Business One License Guide on sappartneredge.com.

The demonstration databases provided are not for productive use. The application supports 40 localizations in the demonstration databases.

2.2 User Privileges

The following table summarizes the requirements and recommendations for the group setup of the displayed operating system:

<table>
<thead>
<tr>
<th>Operation</th>
<th>Operating System</th>
<th>User Group</th>
</tr>
</thead>
<tbody>
<tr>
<td>Client installation</td>
<td>Microsoft® Windows operating systems</td>
<td>Administrator</td>
</tr>
<tr>
<td>Client upgrade</td>
<td>Administrator</td>
<td>Administrator</td>
</tr>
<tr>
<td>Runtime</td>
<td>Users</td>
<td>Users</td>
</tr>
</tbody>
</table>

Note

For more information about possible installer issues related to the user account control (UAC) in Microsoft Windows operating systems, see SAP Note 1492196.
3 Installing SAP Business One

The overall installation procedure of SAP Business One is as follows:

1. On a Windows server, install server components.
2. On each workstation, install client components.

**Note**

All SAP Business One components must be installed in the same LAN (local area network). For users outside the LAN of the server (for example, those using VPN connection), we recommend that you use a remote desktop to access the SAP Business One client instead of installing the SAP Business One client directly.

For demonstration or testing purposes, you can install all components on the same Windows computer. You can also install the SAP Business One client on a terminal server or in a Citrix environment.

3.1 Installing Server Components

You need to install the following components on the server:

- Server tools, including the following:
  - SLD, license manager, extension manager
  - Data interface server
  - Job service
  - Workflow service
- Repository
  - It includes the shared folder B1_SHR, the common database SBOCOMMON, and online help files in all supported languages
- Demo databases

**Note**

Only the installation package provides the option to install demo databases; the upgrade package does not.

- Microsoft Outlook integration server
- Remote support platform
- Integration framework
- Add-ons

By installing the SAP add-ons as part of the server installation process, you register them to all companies on the server. If you do not install them now, you will have to register the add-ons manually later in the SAP Business One client.

If you want to enable access to the SAP Business One client in a Web browser, follow the instructions in Installing the Browser Access Service.
Caution

The SAP Business One installation creates a new SQL user and password. Do not modify or delete this user ID or password. They are essential for the correct operation of the SAP Business One application.

Prerequisites

- The installation computer complies with all hardware and software requirements. For information on hardware and software requirements, search for related information on sappartneredge.com.
- You have administrator rights on the machine on which you are performing the installation.

Note

For more information about possible installer issues related to the user account control (UAC) in Microsoft Windows operating systems, see SAP Note 1492196.

- The host name of the Microsoft SQL Server does not contain any special characters, such as: & (ampersand), < (left angle bracket), > (right angle bracket), " (double quotation mark), ’ (single quotation mark), or _ (underscore).
- Your Microsoft SQL Server has been installed with the following settings:

<table>
<thead>
<tr>
<th>Setting</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>TCP/IP</td>
<td>Enabled</td>
</tr>
<tr>
<td>Service Account</td>
<td>Use the built-in system account – Local System</td>
</tr>
<tr>
<td>Authentication Mode</td>
<td>Mixed mode (Windows authentication and SQL Server authentication)</td>
</tr>
<tr>
<td>Collation Settings</td>
<td>SQL collations – Dictionary order case-insensitive, for use with 1252 Character set, Accent Sensitive (SQL_Latin1_General_CP1_CI_AS).</td>
</tr>
</tbody>
</table>

Note

In some versions of Microsoft SQL Server, this collation may be available only for backward compatibility.

- You have installed the Microsoft SQL Server database client on the machine on which you are performing the installation.
- The license service uses the Common Object Request Broker Architecture (CORBA). To ensure that the license service works properly, ensure the following:
  - Install only one network interface card (NIC) on the CORBA license server.
  - Assign only one IP address to the CORBA license server.
  - Do not use a dial-up or VPN interface-configured server.
- [For the Integration Framework] You have not yet configured a default Tomcat installation on your machine; otherwise, you cannot proceed with the installation. During the installation process, the setup checks for the following registry entries, and if they are found, the setup terminates:
  - 32-bit systems
    - HKEY_LOCAL_MACHINE\SOFTWARE\Apache Software Foundation\Procrun 2.0\Tomcat6
  - 64-bit systems
**Procedure**

A setup wizard is used for installation as well as for upgrade. The following procedure describes how to install all server components (except for the remote support platform and the browser access service) in a clean environment where no SAP Business One components exist.

**Note**

The installation of remote support platform is performed by a separate installation wizard. For more information, see the Administrator’s Guide to the Remote Support Platform for SAP Business One. You can find the guide (RSP_AdministratorGuide.pdf) under `...\Documentation\Remote Support Platform\System Setup` on the SAP Business One product DVD, or search for related information on sappartneredge.com.

1. Navigate to the root folder of the product package and run the `setup.exe` file.
   
   If you are using Windows Server 2008 or Windows 7, right-click the `setup.exe` file and choose Run as administrator.

2. In the welcome window, select your setup language and choose Next.

3. In the Setup Type window, select Perform Setup and choose Next.
4. In the **Setup Configuration** window, select **New Configuration** and choose **Next**.

5. In the **System Landscape Directory** window, select **Install Local System Landscape Directory** and choose **Next**.
6. In the **New System Landscape Directory** window, specify a password for the site super user B1SiteUser, confirm the password, and then choose **Next**.

   For details on which special characters are not allowed for a site user password, see SAP Note 2330114.

   **Recommendation**

   For security reasons, you should set a strong site user password, at least as strong as that defined in your company’s password policy, and change it frequently. For more information, see *Managing Security in SAP Business One*.

   For more information about site users, see *User Types*.

7. In the **Database Server Registration** window, enter the database server information as follows:

   1. Specify the Microsoft SQL Server version.

      For example, select **MSSQL_2012** for Microsoft SQL Server 2012.
2. In the **Server Name** field, enter the hostname or the IP address of the database server.
   To specify a local machine, enter **localhost**. Do not enter **local**.
   If your database server does not use the default TCP port "1433", you must add the alternative port (for example, 9033) to the server name as follows: **SERVER_NAME, 9033**.

3. Do one of the following:
   - To use database authentication to validate access to the Microsoft SQL server instance, deselect **Use Trusted Connection** and then specify the database user name and password.
   - To use Windows authentication to validate access to the Microsoft SQL server instance, select **Use Trusted Connection**.

   > Recommendation

   Do not use a trusted connection unless for test or development purposes, as Windows authentication has the following limitations:
   - Windows authentication in SAP Business One is a server level configuration. All users on the same SAP Business One server can use Windows authentication to connect to Microsoft SQL Server.
   - Windows authentication requires you to maintain each computer added to the domain, while SQL Server authentication shares database users (such as *sa*) on the same SAP Business One server.
   - Windows authentication requires the Microsoft Windows account on which the SLD service runs to have administrative permissions on the database.

   > Note:

   If you later change the password of the database user used to install the System Landscape Directory (SLD), the SLD will stop working. For more information, see the section **Cannot change database user password for System Landscape Directory** in Troubleshooting Security.

4. Choose **Next**.

---

8. In the **Component Selections** window, select the appropriate components and choose **Next**.
9. In the **Demo Database Selection** window, select the required demo databases and choose **Next**.
   Note that demo databases are available only for installation packages, but not for upgrade packages.

10. In the **System Landscape Directory Service Preferences** window, enter a valid PKCS12 certificate store and password, or select the **Use Self-Signed Certificate** radio button.
    Communication between the SLD and SAP Business One clients or DI API is encrypted using the HTTPS protocol, so a certificate is required for authentication. You can obtain a certificate using the following methods:
    - Third-party certificate authority – You can purchase certificates from a third-party global Certificate Authority that Microsoft Windows trusts by default. If you use this method, select the **Specify PKCS12 Certificate Store and Password** radio button and enter the required information.
    - Certificate authority server – You can configure a Certificate Authority (CA) server in the SAP Business One landscape to issue certificates. You must configure all servers in the landscape to trust the CA’s root
certificate. If you use this method, select the Specify PKCS12 Certificate Store and Password radio button and enter the required information.

- [Not recommended] Generate a self-signed certificate – You can let the installer generate a self-signed certificate; however, your browser will display a certificate exception when you access the SLD server, as the browser does not trust this certificate. To use this method, select the Use Self-Signed Certificate radio button.

11. If you selected to use trusted connection, another System Landscape Directory Service Preferences window appears. In this window, enter the credentials for a domain user.

12. For the integration framework, perform the following steps:

1. In the Integration Solution - Change Administration Password window, enter and confirm a new password for the integration server administrator account (B1iadmin).
In the Integration Solution - B1i Database Connection Settings window, specify the following:

- **Server Type**: Specify the Microsoft SQL Server version. For example, select `MSSQL_2012` for Microsoft SQL Server 2012.
- **Server Name**: Enter the hostname or the IP address of the database server. To specify a named instance, enter `<hostname\instance name>` and leave the **Database Port** field empty.
- **Port**: Specify the port for the database server.
- **Database Name**: Specify a name for the integration framework database. The default database name is `IFSERV`.
- **Database User ID**: Enter the user name of a database administrator account (role: PUBLIC; system privilege: CREATE SCHEMA).
- **Database Password**: Enter the password for the database administrator account.

In the Integration Solution - Additional Information window, do the following:

3. In the Integration Solution - Additional Information window, do the following:
Enter the connection credentials. If you did not select to use a trusted connection (Windows authentication) for connections to the database server instance, specify an SAP Business One user account (B1i by default) and a password. This user account will be used for DI calls.

If you selected to use a trusted connection (Windows authentication) for connections to the database server instance, in addition to specifying an SAP Business One user account for DI calls and a password, enter also the user name and password of a database server administrator account.

Select the version of SAP Business One DI API to use. We recommend using the 64-bit SAP Business One DI API. For more information, see SAP Note 2066060.
If a version of DI API is not installed or is not selected for installation, that version of DI API is not available for selection. If no DI API is selected or installed, you cannot proceed with the installation of the integration framework.

4. In the Integration Solution - Scenario Packages window, select the corresponding checkboxes to activate required scenario packages.

13. In the Review Settings window, review the settings you have made and choose Next. This window provides an overview of the settings that you have configured for the setup process. To modify any of the settings, edit the values in the table.

14. In the Setup Summary window, review the component list and choose Setup to start the setup process.
15. In the **Setup in Process** window, wait for the setup to finish.

16. Depending on the results of the setup, one of the following windows is displayed:
   - **Setup Result: Successful** window: The wizard opens this window if the setup of all components was successful. To continue, choose **Next**.
   - **Setup Result: Errors** window: The wizard opens this window if the setup of one or more components failed. To continue, choose **Next** and then in the **Restoration** window, do either of the following:
     - Select the failed component and proceed to start the restoration process.
     - Choose **Next** to skip the restoration.
   
   **Note**
   
   If the installation of remote support platform for SAP Business One fails, it does not affect the successful installation of SAP Business One.
Results

You can now proceed to install client components on all workstations.

An operating system user `B1_Tech_User` (repository access user) is created and used to move log files from client machines to a central log folder in the shared folder `B1_SHR`. You may change the user in the SLD by editing the server information. The user must be either a local user or a domain user that has write permissions to the central log folder (`\B1_SHR\Log`) and read permissions to the entire shared folder.

The installation of remote support platform does not impact SAP Business One business processes. There is no technical dependency between SAP Business One and the remote support platform.

3.1.1 Installing the Browser Access Service

To enable access to SAP Business One in a Web browser, you must install the browser access service on a server where the SAP Business One client is also installed.

Recommendation

Reserve as much RAM as possible for the browser access service. For example, install the browser access service on a separate Windows server or install the 32-bit SAP Business One client.

Compared with desktop access, browser access has certain limitations. For more information, see SAP Notes 2194215 and 2194233.

Prerequisite

If you want to use a certificate for the HTTPS connection, but have used a self-signed certificate for the SLD, do either of the following:

- If your current SAP Business One version is 9.2, change the certificate following the instructions in the section "Cannot change security certificate for System Landscape Directory" in Troubleshooting Security.
- If your current SAP Business One version is lower than 9.2, upgrade your system to 9.2 and then change the certificate following the instructions in the section "Cannot change security certificate for System Landscape Directory" in Troubleshooting Security.

Procedure

A setup wizard is used for installation as well as for upgrade. The following procedure describes how to install the browser access service.

1. Navigate to the root folder of the product package and run the `setup.exe` file.
   
   If you are using Windows Server 2008 or Windows 7, right-click the `setup.exe` file and choose Run as administrator.

2. In the welcome window, select your setup language and choose Next.

3. In the Setup Type window, select Perform Setup and choose Next.

4. In the Setup Configuration window, select New Configuration and choose Next.

5. In the System Landscape Directory window, do the following:

⚠️ Caution

Select this option even if you are installing the browser access service on the SLD server.

2. Enter the FQDN of the SLD server.
3. Choose Next.

6. In the Site User Logon window, enter the password for the site super user B1SiteUser. This site user was created during the installation of the SLD.

7. In the Database Server Connection window, enter the database server information as follows:
   1. Specify the database server type.
   2. In the Server Name field, enter the hostname or the IP address of the database server.
   3. Choose Next.

8. In the Component Selections window, select the following components and choose Next:
   - Browser access service
   - SAP Business One client application (32-bit or 64-bit)

   Note that the browser access service can be selected only if you have selected (or installed) either version of SAP Business One client.

9. In the Parameters for Browser Access Service window, specify the following information for the browser access service:
   - Internal access URL: For the internal access URL of the service, specify:
     - The network address (hostname, IP address, or FQDN) of the machine
     - The port for the service (default: 8100)
   - Security certificate: Enter a valid PKCS12 certificate store and password or select the Use Self-Signed Certificate radio button.

   Communication between the browser access gatekeeper and SAP Business One clients or DI API is encrypted using the HTTPS protocol, so a certificate is required for authentication. You can obtain a certificate using the following methods:
**Third-party certificate authority** – You can purchase certificates from a third-party global Certificate Authority that Microsoft Windows trusts by default. If you use this method, select the **Specify PKCS12 Certificate Store and Password** radio button and enter the required information.

**Certificate authority server** – You can configure a Certificate Authority (CA) server in the SAP Business One landscape to issue certificates. You must configure all servers in the landscape to trust the CA’s root certificate. If you use this method, select the **Specify PKCS12 Certificate Store and Password** radio button and enter the required information.

**[Not recommended] Generate a self-signed certificate** – You can let the installer generate a self-signed certificate; however, your browser will display a certificate exception when you access SAP Business One in a Web browser, as the browser does not trust this certificate. To use this method, select the **Use Self-Signed Certificate** radio button.

10. In the next **Parameters for Browser Access Service** window, select the version of SAP Business One to be used by the browser access service.
11. In the Review Settings window, review your settings and proceed as follows:
   - To continue, choose Next.
   - To change the settings, choose Back.
12. In the Setup Summary window, choose Next.
13. In the Setup Status window, wait for the system to perform the required actions.

3.2 Installing Client Components

You can install the following client components on every workstation:

- SAP Business One client application (together with SAP Business One client agent and DI API)
- Software development kit (SDK)
- Data transfer workbench
- Solution packager
- SAP Business One studio

If you want to use the Microsoft Outlook integration features on a workstation without the SAP Business One client application, install the Microsoft Outlook integration component (standalone version). For more information, see Installing the Microsoft Outlook Integration Component (Standalone Version).

Note

Both 32-bit and 64-bit versions are available for some client components. While it is possible to install and run both versions on the same machine running a 64-bit operating system, in order to reduce complexity and avoid potential problems during future upgrades, we strongly recommend that you install only one version of SAP Business One client on the same machine.

A 64-bit SAP Business One client can work only with 64-bit add-ons; likewise, a 32-bit SAP Business One client can work only with 32-bit add-ons.

Prerequisites

- The installation computer complies with all hardware and software requirements. For information on hardware and software requirements, search for relevant information on sappartneredge.com.
- You have installed Microsoft .NET Framework 4.5.2. During the installation of the SAP Business One Client, the system checks whether Microsoft .NET Framework 4.5.2 is installed. If it is not installed yet, you can install it during the client installation process.
- You have installed Microsoft Visual C++ 2005 SP1 Redistributable Package. If it is not installed yet, you can install it during client installation.
- You have installed Microsoft Excel.
- If the machines on which the SAP Business One client and DI API run use an HTTP proxy for network access, you have added the System Landscape Directory server to the list of proxy exceptions.
Procedure

A setup wizard is used for installation as well as for upgrade. The following procedure describes how to install all client components in a clean environment where no SAP Business One components exist.

1. Navigate to the root folder of the product package and run the setup.exe file.
   If you are using Windows Server 2008 or Windows 7, right-click the setup.exe file and choose Run as administrator.

2. In the welcome window, select your setup language and choose Next.

3. In the Setup Type window, select Perform Setup and choose Next.

4. In the Setup Configuration window, select New Configuration and choose Next.

5. In the System Landscape Directory window, do the following:
   2. Specify the hostname or the IP address of the server where the SLD is installed.
   3. Choose Next.

6. In the Site User Logon window, enter the password for the site super user B1SiteUser.
   This site user was created during the installation of the SLD.
7. In the **Database Server Connection** window, enter the database server information as follows:
   1. Specify the database server type.
   2. In the **Server Name** field, enter the hostname or the IP address of the database server.
   3. Choose **Next**.

8. In the **Component Selections** window, select the required client components and choose **Next**.
9. In the *Review Settings* window, review the settings you have made and choose *Next*.

10. In the *Setup Summary* window, review the component list and then choose *Setup* to start the setup process.

11. In the *Setup in Process* window, wait for the setup to finish.

   In the course of the setup, some additional wizards are displayed to guide you through the setup of corresponding components.

12. Depending on the results of the setup, one of the following windows is displayed:

    o *Setup Result: Successful* window: The wizard opens this window if the setup of all components was successful. To continue, choose *Next*.

    o *Setup Result: Errors* window: The wizard opens this window if the setup of one or more components failed. To continue, choose *Next*, and then in the *Restoration* window, do either of the following:

        o Select the failed component and proceed to start the restoration process.

        o Choose *Next* to skip the restoration.

13. In the *Congratulations* window, choose *Finish* to close the wizard.

### 3.3 Installing the Microsoft Outlook Integration Component (Standalone Version)

The Microsoft Outlook integration component enables you to exchange and share data between SAP Business One and Microsoft Outlook. This component is a standalone version that does not require the SAP Business One client to be installed on the same computer.

If you want to use the Outlook integration features on a computer on which you have installed the SAP Business One client, you can install either the Outlook integration add-on or the standalone version. For more information, see [Assigning SAP Business One Add-Ons](#).
Caution

The Microsoft Outlook integration component is a standalone version of the Outlook integration add-on and they cannot coexist.

If you install the add-on while you have the standalone version installed on the same computer, a subsequent upgrade of the standalone version will be prevented; if you install the standalone version while you have the add-on installed on the same computer, the installation fails.

Note

Both 32-bit and 64-bit versions of the Microsoft Outlook integration component are available. You can install and run both versions on the same machine, but you must install each version separately.

Prerequisites

- You have installed the SAP Business One DI API with the same system type as that of the Outlook integration component. For example, install the 32-bit DI API for the 32-bit Microsoft Outlook integration component.
- You have installed Microsoft Outlook with the same operating system type as that of the Outlook integration component. For example, install the 32-bit Outlook integration component for the 32-bit Microsoft Outlook.
- You have assigned the following to the SAP Business One user account which is used for the connection:
  - The Microsoft Outlook integration add-on in the SAP Business One client
  - The SAP AddOns license
- You have started the Microsoft Outlook integration add-on in the company at least once. This ensures the necessary user-defined tables are added to the company database.

Procedure

1. Navigate to the root folder of the product package and run the setup.exe file.
   If you are using Windows Server 2008 or Windows 7, right-click the setup.exe file and choose Run as administrator.
2. In the welcome window, select your setup language and choose Next.
3. In the Setup Type window, select Perform Setup and choose Next.
4. In the Setup Configuration window, select New Configuration and choose Next.
5. In the System Landscape Directory window, do the following:
   2. Enter the IP address or the hostname of the SLD server.
   3. Choose Next.
6. In the Site User Logon window, enter the password for the site super user B1SiteUser.
   This site user was created during the installation of the SLD.
7. In the Database Server Connection window, enter the database server information as follows:
   1. Specify the database server type.
   2. In the Server Name field, enter the hostname or the IP address of the database server.
   3. Choose Next.
8. In the Component Selections window, select the version of Outlook Integration Standalone, depending on your Outlook version (32-bit or 64-bit), and choose Next.

9. In the Review Settings window, review your settings and proceed as follows:
   - To continue, choose Next.
   - To change the settings, choose Back.

10. In the Setup Summary window, choose Next.

11. In the Setup Status window, wait for the system to perform the required actions.

12. In the Complete window, choose Finish.
4 Installing SAP Crystal Reports, version for the SAP Business One Application

SAP Crystal Reports, version for the SAP Business One application provides integration with the SAP Crystal Reports software, which allows you to create, view, and manage reports and layouts.

SAP Business One 9.2 supports SAP Crystal Reports 2013 SP5, version for the SAP Business One application.

If you already have SAP Crystal Reports installed on your computer, first uninstall the software and then perform the installation operations below.

**Note**
The operating system of the computer on which you want to install SAP Crystal Reports for SAP Business One must be Windows 7 SP1 or higher.

To use SAP Crystal Reports, version for the SAP Business One application, perform the following operations:

1. **Install SAP Crystal Reports 2013, version for the SAP Business One application**
2. **Run the SAP Crystal Reports integration script**
   This step ensures that SAP Business One data sources are available in the application.


4.1 Installing SAP Crystal Reports, version for the SAP Business One application

**Note**
If you have SAP Crystal Reports 2011 or 2013 installed on the computer where you want to install SAP Crystal Reports, version for the SAP Business One application, you are prompted to uninstall it during the installation procedure.

**Prerequisite**

You have downloaded the installation package of SAP Crystal Reports 2011 or 2013, version for the SAP Business One application from the SAP Business One Software Download Center on SAP Support Portal at [https://support.sap.com/b1software](https://support.sap.com/b1software).
Procedure

1. In the installation package, double-click the `setup.exe` file. If you are using Windows 7, Windows Server 2008, or Windows 8, right-click the `setup.exe` file and choose Run as administrator.
2. In the SAP Crystal Reports for SAP Business One setup window, select a setup language and choose OK.
3. The Prerequisites check window appears. If you have fulfilled all critical prerequisites, you can continue with the installation; otherwise, follow the instructions in the wizard to resolve any issues before proceeding.
4. In the welcome window, choose Next.
5. In the License Agreement window, read the software license agreement, select the radio button I accept the License Agreement, and then choose Next.
6. In the Specify the Destination Folder window, specify a folder where you want to install the software.
7. In the Choose Language Packs window, select the checkboxes of the languages you want to install and choose Next.
8. In the Choose Install Type window, select one of the following installation types and choose Next:
   - Typical
     Installs all application features. For a typical installation, proceed to step 9.
   - Custom
     Allows you to do the following:
     - Select features that you want to install.
     - Note
     If you have installed SAP Crystal Reports, version for the SAP Business One application, you can select the Custom install type to add or remove features.
     - Select whether or not you want to receive the web update service
     - Check the disk cost of the installation
4.2 Running the Integration Package Script

To make the SAP Business One data sources and the Add-ins menu available in the SAP Crystal Reports designer, run the SAP Business One Crystal Reports integration script. The SAP Business One tables are organized according to the modules in the SAP Business One Main Menu.

Procedure

1. In the SAP Business One product or upgrade package, locate the ...\Packages\SAP CRAAddin Installation folder and double-click the SAP Business One Crystal Report Integration Package.exe file. If you are using Windows 7 or Windows Server 2008, right-click the setup.exe file and choose Run as administrator.
2. The integration package has been installed successfully. To exit the wizard, choose Finish.
4.3 Updates and Patches for SAP Crystal Reports, version for the SAP Business One application

⚠️ Caution
Since you are using SAP Business One together with an Original Equipment Manufacturer (OEM) version of SAP Crystal Reports, do not apply standard SAP Crystal Reports file or product updates (including Hot Fixes and Service Packs) as they are not designed to work with OEM versions of SAP Crystal Reports.

File or product updates are provided in the following ways:
- Integrated runtime version: distributed together with SAP Business One
- Designer: provided separately via a dedicated folder location in the SAP Business One Software Download Center on SAP Support Portal at https://support.sap.com/b1software.

⚠️ Note
If you are using both the integrated runtime version and the designer, make sure that they are either on the same patch or Service Pack level or that the Report Designer is on an earlier patch or Service Pack level than the Runtime version. If not, inconsistencies may occur.

To find out if you are using an OEM version of SAP Crystal Reports, start the designer and look for either of these two indicators:
- The title bar of the designer indicates SAP Crystal Reports for a certain product (such as SAP Crystal Reports for SAP Business One).
- In the Help menu, choose About (for example, About Crystal Reports). The technical support phone number in the About Crystal Reports box is not listed as (604) 669 8379.

If either of these indicators exists in your product, you are using an OEM version of SAP Crystal Reports.
5 Uninstalling SAP Business One

When you uninstall SAP Business One, you remove the application and all its components.

**Note**
You must uninstall all SAP Business One add-ons before uninstalling the SAP Business One server and client components.

**Procedure**

1. Uninstall SAP Business One add-ons:
   1. From the SAP Business One Main Menu, choose Administration → Add-Ons → Add-On Administration. The Add-On Administration window appears.
   2. On the Company Preferences tab, under Company Assigned Add-Ons, select the add-ons you want to remove.
   3. Choose the arrow button between the two panels. This removes the add-ons from the list.
   4. In the Available Add-Ons list, select the add-ons you want to remove.
   5. Choose the Remove Add-On button, and then choose Update.

   SAP Business One automatically removes the add-ons that you have uninstalled the next time you start the SAP Business One application from any workstation that is connected to the server.

   **Note**
   You can move XL Reporter to the Available Add-Ons panel but you cannot remove XL Reporter in the Add-On Administration window. The Remove Add-On button is disabled for XL Reporter.

2. Uninstall the server and client components:
   1. In Windows, choose Start → Control Panel → Programs and Features.
   2. In the Programs and Features window, select the following items one at a time, and choose the Uninstall/Change button after each selection:
      - SAP Business One Server Tools
      - SAP Business One Client
      - SAP Business One Server
      - Data Transfer Workbench
      - SAP Business One SDK

3. Remove DI API:
   - If you installed DI API as part of the SAP Business One client installation, the system removes the DI API when you uninstall the SAP Business One client.
   - If you installed DI API separately, you must remove it by selecting SAP Business One DI API in the Programs and Features window, and then choosing the Uninstall/Change button.
Result

SAP Business One entries no longer appear in the Programs menu and any shortcuts that you may have on the Microsoft Windows desktop are removed.

You can now do the following:

- Manually delete the SAP Business One folders in Microsoft Windows Explorer.
- Remove SAP Business One databases using your database management application.

5.1 Uninstalling SAP Business One Client Agent

To uninstall SAP Business One Client Agent, in the Programs and Features window, select SAP Business One Client Agent and choose the Uninstall/Change button.

5.2 Uninstalling the Integration Framework of SAP Business One

To uninstall the integration framework, use the Change SAP Business One Integration program. With this program you can add or remove features, repair the installation or uninstall the integration framework.

Prerequisites

- To disable further event creation for the company databases in SAP Business One, run the event sender setup and in step 4, deselect the company databases.
- You have administrative rights on the PC where you uninstall the integration framework.
- You have made a backup of the database of the integration framework.
- You have made a backup of the B1iXcellerator folder.
  To find the folder select IntegrationServer → Tomcat → webapps → B1iXcellerator.

Procedure

1. Choose Start → All programs → Integration solution for SAP Business One → Change SAP Business One Integration.
   The SAP Business One Integration Wizard Introduction window opens.
2. In the Maintenance Mode window select Uninstall Product and choose Next.
   The system notifies you that it uninstalls the integration framework.
3. Choose Uninstall.
   The system uninstalls your installation.
4. To finish the procedure, choose the Done button.
Result

The program uninstalls the integration framework, but it does not remove the database. Remove it separately.
6 Upgrading SAP Business One

To upgrade your SAP Business One application to a new minor or major release and run it successfully, you must do the following:

1. **Upgrade your SAP Business One successfully.**
2. **Update the system information in the system data maintenance area:**
   - **Partners:** On the SAP Business One Support area on sappartneredge.com, in the Quick Links area, choose System Data Maintenance.
   - **Customers:** On the SAP Business One Customer Portal at http://service.sap.com/smb/sbocustomer, in the left-hand navigation bar, choose System Data Maintenance.
3. **Import the license file for the new release.**

For the latest information about upgrade issues that may not appear in this guide, see SAP Note 2004987.

If you are using the intercompany integration solution for SAP Business One, make sure the intercompany version is compatible with this SAP Business One patch level as specified in SAP note 1844555. You may need to upgrade the intercompany version as well.

*Note*

If your SAP Business One is of a hotfix version, we strongly recommend that you upgrade to the next regular patch once it is available, as hotfixes are intended only as temporary solutions.

To upgrade to a new minor or major release, you must upgrade to a regular patch first, and then you can proceed with the upgrade to the new release.

6.1 Upgrade Methods

You can use either of the following upgrade methods to upgrade a previous SAP Business One version:

- **Using the SAP Business One setup wizard in the upgrade package**
  
  You can use the setup wizard to guide you through the process of upgrading SAP Business One to a higher major release, a higher minor release, a support package, or a new patch level.

  If any of the upgrade steps fail, you can use the restoration mechanism to reverse all the database changes made to your SAP Business One landscape by the wizard, and return to the SAP Business One version before the upgrade.

  *Caution*

  To detect any errors or warnings that may arise in the SAP Business One upgrade process, it is mandatory that you perform a trial run. The results of the pre-upgrade tests indicate where you may need to correct any errors before performing the actual upgrade. If no issues are found, you may continue with the upgrade procedure.

- **Silent upgrade**
  
  You can upgrade SAP Business One in a silent mode using command line arguments.
6.2 Supported Releases

The following major or minor releases are currently supported for upgrade to 9.2:

- SAP Business One 8.8
- SAP Business One 8.81
- SAP Business One 8.82
- SAP Business One 9.0
- SAP Business One 9.1

For more information about upgrading from specific patches of supported releases, see the Readme or Patch Readme file for the respective SAP Business One version.

Note

To upgrade an SAP Business One version that is lower than 8.8, first upgrade your current version to 9.1 PL08, and then perform the upgrade to 9.2.

6.3 Upgrade Process

To upgrade SAP Business One, do the following:

1. To determine the upgrade path, read the Overview Note for the required version.
   For example, check which versions are supported for upgrade to the required higher version. If direct upgrade is not supported, you first need to upgrade your system to a supported version and perform the server upgrade operation (step 2) for more than one time.

2. On your server, run the setup wizard for the required version to upgrade the common database, company databases, and all server components. For more information, see Upgrading Databases and Other Components.

   Recommendation

   Upgrade all the server components at one time, and not separately. Otherwise you may have problems fixing certain errors in the pre-upgrade test.

3. On each workstation, do the following:
   - If you have installed such client components as the DTW, run the setup wizard to upgrade these client components. For more information, see Upgrading Databases and Other Components.
   - Upgrade the SAP Business One client application. For more information, see Upgrading Client Workstations.
Prerequisites

- You have downloaded the upgrade package from the SAP Support Portal. For more information, see Downloading the Upgrade Package.
- You have ensured that company databases are not connected to any SAP Business One clients, SQL Server clients, or other applications.
- You have the SAP Business One 9.2 license file available. You need this license file for connecting your company after the upgrade process is finished. If you do not import a valid license file after the upgrade process, you cannot work with your company.
- You have administrator rights on the computer that runs the SAP Business One setup wizard.
- You have added the System Landscape Directory server to the list of proxy exceptions on the computer on which you want to run the setup wizard.
- The SBO-COMMON database that you have installed on your computer is not a later release than the upgrade package.
- If any components of SAP Business One integration for SAP NetWeaver (B1iSN) were previously installed on your server, you have uninstalled them manually before installing any integration solutions delivered with SAP Business One. This step is required due to compatibility reasons. For more information about uninstalling components of B1iSN, see the SAP Business One integration for SAP NetWeaver Installation and Upgrade Guide.
- You have installed the SAP Crystal Reports software.

\* Note

If you want to install the SAP Crystal Reports software after upgrading the SAP Business One client, you may need to run the SAP Crystal Reports integration package script. For more information, see Running the Integration Package Script.

For more installation information about installing the Crystal Reports software, see Installing Crystal Reports for SAP Business One, version for the SAP Business One Application.

- During the upgrade of SAP Business One, you have the option of installing remote support platform for SAP Business One. For more information about installing remote support platform for SAP Business One, see Administrator’s Guide to Remote Support Platform for SAP Business One. You can find the guide (RSP_AdministratorGuide.pdf) under ...\Documentation\Remote Support Platform\System Setup\ on the SAP Business One product DVD, or on sappartneredge.com.
- If the machines on which the SAP Business One client and DI API run use an HTTP proxy for network access, you have added the System Landscape Directory server to the list of proxy exceptions.

6.3.1 Upgrading SAP Business One Components and Databases

A setup wizard is used for installation as well as for upgrade. The following procedure describes how to upgrade the common database, the company databases, server components, and client components).

Note that the setup wizard does not support remote upgrade and can upgrade only local components. To upgrade components on other machines, you must run the setup wizard repetitively.

In addition, for upgrade of the SAP Business One client within a release family, you can perform silent upgrade instead of using the setup wizard. For more information, see Upgrading the SAP Business One Client.
If you intend to install the browser access service during the upgrade process, first read the instructions in Installing the Browser Access Service.

Procedure

1. In the root folder of the upgrade package, double-click the \setup.exe file.
   If you are using Windows Server 2008 or Windows 7, right-click the \setup.exe file and choose Run as administrator.
2. In the welcome window, select your setup language, and choose Next.
3. In the Setup Type window, select the Perform Setup checkbox, and choose Next.

![Setup Type window](image)

The other option Test System Environment verifies if the system environment and the company databases are ready for an upgrade. The existing installation and data are not changed. For each company database that passes the test, you can generate a passcode, which allows you to bypass the pre-upgrade test when upgrading the database later. The passcode is in the form of an XML file that contains details on the tested company databases. It is valid for three days, and any changes to the company configuration render the passcode invalid.

The Perform Setup option both performs the pre-upgrade tests and upgrades selected components and databases. If you carried out a pre-upgrade test for a company database earlier, you can enter the passcode to bypass the pre-upgrade tests for this company database.

4. In the Setup Configuration window, select one of the following options and choose Next:
   - New Configuration: Select this radio button to manually enter all the required settings. Go directly to step 6.
   - Use Settings from the Last Wizard Run – Select this radio button to use the settings from the last wizard run, which are stored in the configuration file generated during that run.
   - Load Settings from File – Select this radio button to use the settings stored in a configuration file generated during a previous wizard run, and then specify the location of the file you want to use.
To obtain the required `Config.XML` file, first run the setup wizard and select the `New Configuration` option. After generating this file, you can make a copy and use a text editor to modify the values for future use as required.

5. If you selected to use the settings from the previous wizard run or a file, the `Review Settings` window appears. This window provides an overview of the settings that you have configured for the upgrade process. To modify any of the settings, edit the values in the table. Otherwise, choose `Next` to proceed with the upgrade.

⚠️ Note
If you are sure that all the settings are correct, you can select the `Skip Remaining Steps and Automatically Start Pre-Upgrade Test and Upgrade` checkbox to bypass the remaining wizard steps and begin the process immediately.
6. In the **System Landscape Directory** window, do either of the following:
   - If you are upgrading the System Landscape Directory and other components that are installed on the same machine, select **Connect to Local System Landscape Directory** and choose **Next**.
     
     Note that the local System Landscape Directory will be upgraded forcibly if it is not already upgraded to the required version.
   - If you are upgrading components that are installed on a different machine from that of the System Landscape Directory, select **Connect to Remote System Landscape Directory**, specify the server, and then choose **Next**.
     
     Note that the remote System Landscape Directory must have already been upgraded to the required version.

7. In the **Site User Logon** window, enter the password for the site super user B1SiteUser.
8. In the **Database Server Connection** window, specify the Microsoft SQL Server version (for example, select *MSSQL_2012* for Microsoft SQL Server 2012) and select the database server instance. Then choose **Next** to proceed.

![Database Server Connection](image)

If you do not find the database server you want to upgrade in the server list, you can register it in the System Landscape Directory. To do so, choose the **Register New Database Server** button, specify the relevant information, and then choose **Back** to continue with the upgrade.

9. In the **Component Selections** window, select the corresponding checkboxes of the components that you want to upgrade.

If a component has already been upgraded to the current version, its checkbox is enabled but not selected. If you select an already upgraded component, the wizard overwrites all instances of installed components. The wizard also lists all third-party add-ons present in the `…\Packages\Add-Ons Autoreg` or `…\Packages.x64\Add-Ons Autoreg` folders, which you can select to upgrade.

**Note**

Upgrading the repository is a prerequisite for upgrading other components or company databases. If a component is indicated as **Not Found**, you can select the corresponding checkbox to install the component.
10. In the **Database Selection** window, select the checkboxes of the databases that you want to upgrade.

11. To view additional options and information, select the row of a company database, select the **Advanced Settings** checkbox, and then specify the following:
   - **Backup** – From the dropdown lists in the **Backup** column, select whether to back up each database before the upgrade.
Caution

If you select not to back up a database before upgrade, you cannot restore the database should the upgrade fail. SAP does not provide support for such databases in the case of an upgrade failure; a backup of the pre-upgrade database is required to qualify for SAP support.

- **Upgrade By** – From the dropdown list, select the SAP Business One superuser that you want to use to perform the upgrade. By default, the wizard uses the `manager` account.
- **Stop on Test Error** – Select this checkbox to force the wizard to stop the entire upgrade process if it encounters an error during a pre-upgrade test.
- **Stop on Upgrade Error** – Select this checkbox to force the wizard to stop the entire upgrade process if it encounters an error while upgrading the database.

12. If errors occur which are preventing you from upgrading the company databases, do the following for each company database that is not ready for upgrade:

1. In the **Status** column, click the **Not Ready** link.
   
   Specific information appears.

2. Do either of the following:
   
   - If the error can be fixed, fix the error and choose **Refresh**.
   - If the error cannot be fixed and you must contact SAP Support, deselect the checkbox.

In any of the following cases, the status of the company database is **Not Ready** and you cannot select it for upgrade:

- Upgrade is not possible:
  
  - The wizard does not support the company database version.
  - The wizard cannot find the localization for the company database from the locale list in the common database.
You must fix the errors to proceed with the upgrade:
- The wizard finds more than one connection to the company database.
- The database user registered with the server is either locked or is not a database admin user.

When all the selected databases have the status *Ready*, choose **Next**.

**Note**

If any of the selected databases has the status *Not Ready*, the wizard disables the **Next** button. You cannot proceed to the next step until you have fixed the problem.

14. In the **Upgrade - Backup Settings** window, specify the location where you want to store the backup files created before upgrading the selected components.
   - To use the default backup path configured in SQL Server, choose **Use the Default SQL Server Backup Location**.
   - To use another location on the database server, choose **Browse directories on database server** and click **Browse** to choose a directory.
   - To use a network drive, choose **Enter a network path** and specify the path.

After you specify a location for the backup, the wizard displays the amount of space required for database backups and the available space on the corresponding drives.

15. If you previously selected the integration framework for upgrade, do the following:
   1. In the **Integration Solution - B1i Database Connection Settings** window, enter the database password.
2. In the subsequent *Integration Solution - Scenario Packages* windows, if you want to activate any new scenarios, select the corresponding checkboxes and specify the necessary information.

16. In the *Review Settings* window, review your configuration setting. To modify any of the settings, choose *Back* to return to the relevant window; otherwise, choose *Next*. 
17. In the *Pre-Upgrade Test* window, do the following:
   - To bypass the tests for a database, choose the *Enter Passcodes* button and upload one or more of the passcode files you saved earlier. After uploading the files, choose *Next* and proceed to step 23.
     
     **Note**
     
     A passcode file is only valid for three days. Any changes to the company configuration render the passcode file invalid.
   - To perform pre-upgrade tests on each database to ensure its readiness for the upgrade and to reduce the possibility of upgrade failure, choose the *Start* button.
     
     **Note**
     
     For the latest information about pre-upgrade tests, see SAP Note 1357462.

18. In the *Pre-Upgrade Testing In Progress* window, the wizard first checks the common database and then checks the company databases one by one.

   **Note**
   
   If the common database does not pass the checks, the wizard does not continue with the rest of the checks.

19. The *Pre-Upgrade Test* window provides a detailed overview of the results of the pre-upgrade tests. You can view information about individual checks, possible solutions to errors, and recommendations for dealing with warnings by clicking the links to the corresponding notes in the *SAP Note* column.

   Depending on the results of the pre-upgrade tests, one of the following windows appears:
   - **Pre-Upgrade Test: Passed** – All components and databases successfully passed the pre-upgrade tests. Proceed to the next step.
- **Pre-Upgrade Test: Errors Detected** – One or more components or databases contain errors. You cannot continue upgrading. You must fix the reported errors or contact SAP for support, and then start the setup wizard again.

- **Pre-Upgrade Test: Warnings Detected** – One or more components or databases contain warnings. You can still continue upgrading; however, first you must confirm all warnings, as follows:
  1. For each component or database that contains warnings, click the corresponding link in the Details column.
  2. The Pre-Upgrade Test Result window appears.

3. In the Pre-Upgrade Test Result window, do the following:
   - To ignore a warning, select the corresponding checkbox in the Confirmation column.
   - To fix an issue, click the corresponding hyperlink in the SAP Note column and follow the recommendations. After fixing the issue, select the checkbox in the Confirmation column.

4. After confirming all the warnings, choose Back to return to the Pre-Upgrade Test window.

5. After you have confirmed all warnings for all components and databases, choose Next to open the Pre-Upgrade Test: Warnings Confirmed window, and then proceed to the next step.
The **Setup Summary** window displays an overview of the components and databases that you have selected to upgrade (or install if some selected components are not installed). Do either of the following:

- To begin the upgrade process, choose **Upgrade**.
- To change the settings, choose **Back** to return to the previous steps.

The **Upgrade in Process** window displays the upgrade progress of each component and database.

21. According to the upgrade results, one of the following windows appears:
Upgrade Result: Upgraded window: This window appears if the upgrade of all components and databases was successful. To continue, choose Next.

Upgrade Result: Errors window: This window appears if the upgrade of any component or database fails. To continue restoring the failed components and databases, choose Next and then proceed to the Restoring Components and Databases section.

22. In the Congratulations window, choose Finish to close the wizard.
   To view a summary report of the various upgrade steps, such as company databases and pre-upgrade test results, click the Upgrade Summary link.

Post-requisites

1. Update the system information in the system data maintenance area:
   - Partners: On the SAP Business One Support area on sappartneredge.com, in the Quick Links area, choose System Data Maintenance.

2. In the service manager, import the license file for the new release. For more information, see License Control Center.

3. On each client workstation, upgrade the SAP Business One client.

6.3.1.1 Restoring Components and Databases

If the upgrade process fails, the SAP Business One setup wizard restores the databases and certain components. The other components must be restored manually.

Note

The procedure below continues from the penultimate step in the previous section, Upgrading Databases and Other Components. It is relevant for situations only where the upgrade has failed.

Procedure

To restore components and databases, do the following:

1. In the Restoration window, select the checkboxes of the components and databases that you want to restore, and choose Restore.
Depending on the results of the restoration process, one of the following windows appears:

- If the restoration is successful, the **Restoration Result: Restored** window appears. To complete the restoration, do the following:
  1. In the **Restoration Result: Restored** window, choose **Next**.

2. In the **Congratulations** window, choose **Finish** to complete the restoration process.
If the restoration fails, the *Restoration Result: Failed* window appears. To complete the restoration, do the following:

1. In the *Restoration Result: Failed* window, choose *Next*.

2. In the displayed window, choose *Finish* to exit.

*Note*

If the restoration fails, to roll back SAP Business One to the version before the upgrade, you must do a manual restoration.

### 6.3.1.2 Troubleshooting Upgrades

- The root user that runs the setup wizard has read, write, and execute permissions to the shared folder `B1_SHR` on the SAP Business One server computer.
- If you cannot connect to the System Landscape Directory using the server name, use the IP address of the server computer.
- To have SBO Mailer’s signature copied after upgrade, do the following:
  1. To open the *SAP Business One Service Manager* window, in Windows, choose *Start* → *All Programs* → *SAP Business One* → *Server Tools* → *Service Manager*.
  2. In the *SAP Business One Manager* window, from the *Service* dropdown list, select *SBO Mailer*, and then choose the *Connection* button.
  3. In the *Connection Settings* window, specify values in the *DB Type* and *DB Server* fields, and then choose the *OK* button.
  4. Log off SAP Business One and log on to SAP Business One again. You will find that the signature was copied.
6.3.2 Upgrading the SAP Business One Client

After the server upgrade, you must upgrade the SAP Business One client on all your workstations.

Recommendation

If you have installed both 32-bit and 64-bit SAP Business One clients on a client workstation, we recommend uninstalling one client and keeping only the one of your choice. Otherwise, errors might occur during the upgrade.

Upgrade to a Higher Release Family

For an upgrade from a previous release family (for example, from the 8.82 release to the 9.2 release), run the setup wizard on each workstation to upgrade the SAP Business One client.

Alternatively, you can uninstall the old client and then install the new client using the client installation program. The client installation package is available in the entire product package as well as in the shared folder B1_SHR.

Upgrade Within a Release Family

For an upgrade within a release family (for example, from the 9.1 release to the 9.2 release), you can directly upgrade the SAP Business One client. The auto-upgrade is performed by the SAP Business One client agent, which is installed automatically with the SAP Business One client.

Prerequisites

For the SAP Business One client agent to upgrade third-party add-ons in a silent mode, you must recreate the ARD file of the add-on using the latest version of the Add-On Registration Data Generator. For more information, see Enabling Silent Upgrades for Third-Party Add-Ons.

Procedure

1. Run the client as the administrator.
2. Log on to a company.
   A system message appears to inform you that the client is not updated.
3. In the system message window, choose OK to upgrade the client.

Alternatively, you can run the setup wizard to upgrade the client or reinstall the client using the client installation program. The client installation package is available in the entire product package as well as in the shared folder B1_SHR.

Note

Automatic upgrade for the 9.0 PL11 client is not possible. You must use the setup wizard to upgrade the client or reinstall the client to a higher version.

Note

If you want to install or upgrade the SAP Business One client manually in silent mode, you can use the following command line parameters:
setup.exe /S /z"c:\Program Files (x86)\SAP\SAP Business One Client\*127.0.0.1:30000"

Where:
/S means "silent mode"
/z is followed by installation parameters: Full Installation Path*System Landscape Directory Address:Port

6.3.3 Upgrading SAP Add-Ons

When you select the Add-On checkbox in the Component Selections window of the setup wizard, the following occurs:

- New versions of all SAP add-ons are automatically registered on the SAP Business One server.
- New installers are uploaded to the server during the upgrade of the common database.

Add-ons that were already installed and assigned to a company are reregistered with new releases and assigned to the same company.

On a client computer, upon the next logon to a company assigned with add-ons, installers for the new add-on releases run automatically.

6.3.3.1 Troubleshooting Add-On Upgrades

When upgrading add-ons in an upgraded company for which the server name was previously something like (local), you may encounter a message about installation failure.

SAP Business One has introduced a license security mechanism, and we do not recommend that you specify a server name such as (local). In this case, during an upgrade, the user defines the server name as an IP address or a computer name. The application does not find the previous, (local), name of the upgraded company, which prevents the previous add-ons from being upgraded.

To solve this problem, do the following:

1. Go to the ...\SAP Business One\ folder and locate the AddonsLocalRegistration.sbo file.
2. Change the server name of each related add-on to the new name specified in the license server.

   Example

   - Old name: <Common ID="1" Name="(local)"/>
   - New name: <Common ID="1" Name="MyServerName"/>

6.3.3.2 Enabling Silent Upgrades for Third-Party Add-Ons

To enable the SAP Business One client agent to upgrade a third-party add-on in silent mode, do either of the following:
If your add-on needs to be installed, you must recreate the add-on’s ARD file using the latest version of the Add-On Registration Data Generator to enable silent upgrades (and installations).

If your add-on does not need to be installed, you can use the Extension Manager to manage its upgrade. For more information, see the guide How to Package and Deploy Lightweight Extensions for SAP Business One on sappartneredge.com.

**Procedure**

To enable silent upgrades using the Add-On Registration Data Generator, do the following:

1. To start the Add-On Registration Data Generator, run the AddOnRegDataGen.exe file, which is typically located in the ...\SAP Business One SDK\Tools\AddOnRegDataGen folder.

2. Load an existing file, or enter the mandatory information.

3. For more information, see the Online Help for the SAP Business One Software Development Kit.

4. Select the **Silent Mode** checkbox.

5. If necessary, in the **Installer/Uninstaller/Upgrade Command Line** field, enter any required command line arguments.

6. Choose the **Generate File** button.

   **Note**

   You may be required to rebuild the installation package of the add-on and redesign the installation and configuration process. For example, if the add-on uses an installation wizard that requires the user to specify some information, then you can perform the configuration steps in the SAP Business One client after installing the add-on instead. Alternatively, you can provide the required information as command line arguments in the ARD file.

**6.4 Performing Silent Upgrades**

You can upgrade SAP Business One using a silent mode by calling ...\Wizard\Setup.exe from the upgrade package.

**Caution**

You can use the silent mode to upgrade only the server and the integration framework. Silent upgrade of implementation tools is not supported.

To upgrade SAP Business One, provide the following argument:

```
setup.exe <Config.XML> <parameter> <value>
```

**Note**

To obtain the required Config.XML file, first run the setup wizard in the interactive mode. After generating this file, you can make a copy and use a text editor to modify the values for future use as required.

You can find the configuration file in the ...\%PROGRAMDATA%\SAP\SAP Business One\Log\SAP Business One\SetupWizard\Config folder.
You can provide several different parameters, or multiple parameters, as shown in the following table.

<table>
<thead>
<tr>
<th>Type</th>
<th>Parameter</th>
<th>Value</th>
</tr>
</thead>
<tbody>
<tr>
<td>Database Server and License</td>
<td>-DbPassword</td>
<td>Database server password</td>
</tr>
<tr>
<td>Server authentication</td>
<td>-SitePassword</td>
<td>Site user password</td>
</tr>
<tr>
<td>SLD configuration</td>
<td>-SLDCertPassword</td>
<td>SLD certificate password</td>
</tr>
<tr>
<td></td>
<td>-SLDDomainPassword</td>
<td>SLD domain user password</td>
</tr>
<tr>
<td>B1i configuration</td>
<td>-B1iDBPassword</td>
<td>B1i database server password</td>
</tr>
<tr>
<td></td>
<td>-B1iAdminPassword</td>
<td>B1i Tomcat server administrator password</td>
</tr>
<tr>
<td></td>
<td>-B1iDIPassword</td>
<td>Company password for DI calls</td>
</tr>
</tbody>
</table>

Example

```
Setup.exe "C:\my_config\Config.XML" -DbPassword x1Y3s -SitePassword p03kAnk3
```
7 Performing Post-Installation Activities

Immediately after installing SAP Business One, you are required to perform the following activities:

- Configuring services
- Installing the license key
- Configuring SAP Business One clients
- Assigning SAP Business One add-ons
- Installing the Outlook integration standalone version
- Performing post-installation activities for the integration framework

Recommendation

We also recommend you configure a backup strategy for databases and application folders. For more information, see Backing Up Databases.

You can use the remote support platform for SAP Business One to automatically backup data according to a defined strategy. For more information, see the Online Help for the remote support platform.

7.1 Configuring Services

You must configure the services you have installed if they are to operate properly.

Note

The first time you configure any service in the service manager, you must enter the site user password. This is not for authentication purposes, but to obtain the database password. After entering the site user password once, you do not have to enter it again when configuring other services.

The subsections below introduce how to configure the following SAP Business One services:

- License service
- Browser access service
- SBO DI Server
- Job service, including SBO Mailer and alert settings
- Fax service
- Workflow service

7.1.1 Configuring the License Manager

Configuring the license manager is essential for the successful operation of SAP Business One. This service manages license requests and lets you install a license key, which is required to run SAP Business One, according to your contract.
For new installations, you can use the application for a period of 31 days without a license key. After that period, the SAP Business One application needs a license key to run. We strongly recommend that you request a license key immediately after installing the application.

**Procedure**

1. To open the *SAP Business One Service Manager* window, in the Microsoft Windows task bar, double-click (SAP Business One Service Manager).
   Alternatively, in Windows, choose **Start → All Programs → SAP Business One → Server Tools → Service Manager**.

2. From the **Service** dropdown list, select **License Manager** and choose the **Settings** button.

3. The **General Settings** window displays information about the license service. Choose the **Connect** button.
**Note**

If you installed the license service on the SAP Business One server, SAP Business One sets localhost by default. Otherwise, you must enter a name or IP address of the server. We recommend that you not change the default port number.

**Caution**

If you have installed a firewall on the machine running the license service, ensure that the firewall does not block ports 30000–30010; otherwise, the license service and SLD cannot work.

If you are using Port X, ensure that you open ports from Port X to Port (X+10) in the firewall. For example, if you are using port 10000, ensure to also open ports 10001, 10002, 10003 ... 10010.

4. To save your settings and close the **General Settings** window, choose the **OK** button.
   
   If you already have a license key file, you can continue to **Installing License Key**.

5. Choose (Play) and select the **Start when operating system starts** checkbox.
7.1.2 SBO DI Server

This optional service enables multiple clients to access and manipulate the SAP Business One company database. To use it, you are required to have a special license. For more information, see the SDK Help Center.

7.1.3 Job Service

The job service manages the following settings on the server side:

- SBO Mailer settings
- Alert settings

7.1.3.1 Configuring SBO Mailer

The process of configuring SBO Mailer comprises of the following steps:

- Starting SBO Mailer
- Defining the mail settings
- Connecting to the database
- Selecting company databases
- Setting the mail processing schedules
Prerequisites

You have installed the SBO Mailer service.
For information, see Error! Reference source not found.

Procedure

1. To open the SAP Business One Service Manager window, in the Microsoft Windows task bar, double-click (SAP Business One Service Manager).
   Alternatively, in Windows, choose Start → All Programs → SAP Business One → Server Tools → Service Manager.
2. From the Service dropdown list, select Job Service - Mailer.

3. Choose (Play) and select the Start when operating system starts checkbox.
4. Define mail settings:
   1. In the SAP Business One Service Manager window, choose the Settings button.
      The General Settings window appears.
In the **General Settings** window, specify the following:

- **SMTP Server** — Enter the name or IP address of your outgoing mail server. To make changes in this field later, you must stop the Mailer service.
- **SMTP Port** — Specify the port number for mail services.
- **Encoding** — Select the language for e-mail text.
- **HTML direction right-to-left** — Select this checkbox if you are using a right-to-left language to define the direction of the e-mail text.
- **Include Subject in Message Body** — Select this checkbox to include the subject line in the body of the message.
- **Fax Settings** — Select the required fax service. For more information, see Configuring Fax Services.
- **Scheduled Report Settings** — Specify the required information for configuring SBO Mailer for report scheduling and mailing. For more information, see Configuring Report Scheduling.

Connect to the database:

1. In the **SAP Business One Service Manager** window, from the Service dropdown list, select **SBO Mailer**, and then choose the **Connection** button.
2. In the Connection Settings window, do the following:
   1. To connect to a database, specify a valid user name and password.
   2. To use Windows authentication, select the Use Trusted Connection checkbox.
   3. Choose the OK button.

6. Select a database:
   1. In the SAP Business One Service Manager window, from the Service dropdown list, select SBO Mailer, and then choose the Database button.

2. In the Select databases to use window, select the databases for which you want to enable mailing services, and then choose the OK button.
3. In the *SAP Business One Service Manager* window, from the *Service* dropdown list, select *SBO Mailer*, and then choose the *Settings* button.

4. In the *General Settings* window, in the *Mail Settings* area, select components according to your network definitions, and then choose the *OK* button.
Performing Post-Installation Activities

7. Set the mail processing schedules:
   1. In the SAP Business One Service Manager window, from the Service dropdown list, select SBO Mailer, and then choose the Schedule button.

   ![SAP Business One Service Manager window]

   2. In the Scheduler – SBO Mailer window, select one of the following options:
      - By Intervals — Sets mail and fax processing to start regularly every x hours and y minutes.
      - On Specific Date — Defines mail and fax processing for a specific date and time.
Performing Post-Installation Activities

8. Choose the OK button to return to the SAP Business One Service Manager window.

9. In the SAP Business One Service Manager window, choose (Play), and select the Start when operating system starts checkbox.

10. To close the SAP Business One Service Manager window, choose OK.

Result

You can now proceed to define the email signature settings. To access the email signature settings, from the SAP Business One Main Menu, choose Administration → System Initialization → E-Mail Settings.

7.1.3.1.1 Troubleshooting

The following troubleshooting information may be helpful when configuring the mail services:

- Ensure that you have already set up an e-mail account for the SAP Business One users on your mail server.
- To verify the connection with the mail server, choose the Test Connection button.
- The mail service checks the connection with the specified mail server and e-mail account and displays an appropriate message.
- If the SMTP server requires authentication, for example, if the SMTP server is configured to accept only logon-authenticated mails, you must not select the Anonymous Access option in the Mail Settings area.
- To check whether the connection to the SMTP server works, send a test e-mail. If the connection fails, ensure that you have done the following:
  - Entered the correct name of your mail server
  - Entered the correct user ID and password
  - Restarted the SBO-Mailer service after changing any of the settings
7.1.3.2 Alert Settings

In order to use the alert function to have SAP Business One automatically notify selected users whenever certain system events occur, you must first start the alert service for the companies on the server side.

Procedure

1. In a Web browser, navigate to the following URL:
   
   `https://<Server Address>:<Port>/job`

   Alternatively, on the Services tab in the system landscape directory, you can click the Job Service link to access the settings.

   Notes
   
   - If you use a proxy for your Internet connection, you must add the full hostname or IP address of any Web server (for example, SLD) to the proxy exception list of your Web browser; in other words, do not use a proxy for these addresses.
   - The URL of the service is case-sensitive.

2. If you have not logged on to the SLD service, in the logon page, enter the site user name (`B1SiteUser`) and password, and then choose the Log On button.

   Note
   
   The site user name is case sensitive.

3. On the Alert Settings tab, if you want to change the technical user used to execute the alerts, enter the user code for an SAP Business One user and then choose Save.

   Note
   
   If you want to use a different user than the default user `AlertSvc`, you must ensure the user is created in all the companies. Otherwise, all the alert settings are ineffective for the companies missing this user.

   This technical user is used for database connection and not intended for any business transactions. You do not have to assign a license to this technical user and we recommend that you don’t.

4. From the Database Server dropdown list, select an appropriate server.

5. Select the companies for which you want to use the alert function, and choose Save.

6. To start the alert service, choose Start.

   The status changes to RUNNING and the button changes to Stop.

   Note
   
   To change the technical user or change the company selection, you must first stop the connection by choosing Stop.

Result

You can now log on to each of your companies in the SAP Business One client and define the alert settings on the client side. For more information, see the online help.
7.1.4 Configuring Fax Services

SAP Business One offers fax services through Microsoft Fax Services. For more information, see How To Install and Configure Microsoft Fax Services on sappartneredge.com.

This service can send several attachments as separate fax messages, added to a fax message. For supported file types, see the Microsoft documentation at www.msdn.microsoft.com.

7.1.5 Configuring Report Scheduling

The report scheduling function of SAP Business One allows you to schedule report execution and send generated reports via e-mail. To do so, you must first define the mail settings and scheduled report settings. For more information, see How to Schedule Report Execution and Mailing on sappartneredge.com.

7.1.6 SAP Business One Workflow

The workflow service enables you to standardize your business operations to increase overall efficiency. With predefined conditions, the system automatically executes various tasks, liberating labor resources for more creative activities.

For more information, see How to Configure the Workflow Service and Design the Workflow Process Templates at http://service.sap.com/smb/sbocustomer/documentation. The guide includes samples and additional reference materials.

7.2 Enabling External Browser Access

The SAP Business One Browser Access service helps you use SAP Business One outside your corporate networks. For secure access, you must be sure to do the following:

1. Use an appropriate method to handle external requests.
2. Use valid certificates to install relevant SAP Business One services.
3. Assign an external address to each relevant SAP Business One service.
4. Build proper mapping between the external addresses and the internal addresses.

Alternatively, you can use Citrix or similar solutions for external access. These third-party solutions are not covered in this guide.

7.2.1 Choosing a Method to Handle External Requests

As the Browser Access service enables you to access SAP Business One from external networks, it is essential that external requests can be sent properly to internal services.
To handle external requests, we recommend deploying a reverse proxy rather than using NAT/PAT (Network Address Translation/Port Address Translation). Compared with NAT/PTA, the reverse proxy is more flexible and can filter incoming requests.

Note

Regardless of the method, the database services are not exposed to external networks; only the SAP Business One services are exposed. However, you must never directly assign an external IP address to any server with SAP Business One components installed.

To improve your landscape security, you can install your database server on a machine other than the one holding SAP Business One components.

Reverse Proxy

A reverse proxy works as an interchange between internal SAP Business One services and external clients. All the external clients send requests to the reverse proxy and the reverse proxy forwards their requests to the internal SAP Business One services.

To use a reverse proxy to handle incoming external requests, you need to:

1. Import a trusted root certificate for all SAP Business One services during the installation.
   
   The certificate can be issued by a third-party certification authority (CA) or a local enterprise CA. For instructions on setting up a local certification authority to issue internal certificates, see Microsoft documentation.

   All the components (including the reverse proxy) in the SAP Business One landscape should trust the root CA which issued the internal certificate for all SAP Business One services.

2. Purchase a certificate from a third-party public CA and import the certificate to the reverse proxy server.
   
   Note that this certificate must be different from the first certificate. While the first certificate allows the reverse proxy to trust the CA and, in turn, the SAP Business One services, the second certificate allows the reverse proxy to be trusted by external clients.

   All clients from external networks naturally trust the public CA and, in turn, the reverse proxy. A chain of trust is thus established from the internal SAP Business One services to the reverse proxy, and to the external clients.

NAT/PAT

If you prefer NAT/PAT to a reverse proxy, be aware that all clients connect directly to the internal SAP Business One services, external clients and internal clients alike.

To use NAT/PAT, you must purchase a certificate from a third-party CA and import the certificate to all machines installed with SAP Business One services. All the clients must trust this third-party public CA.

7.2.2 Preparing Certificates for HTTPS Services

Any service listening on HTTPS needs a valid PKCS12 (.pfx) certificate to function properly, especially for external access using the Browser Access service.
How you prepare PKCS12 (.pfx) certificates depends on how you plan to expose your SAP Business One services (including the Browser Access service) to the Internet (external networks).

When preparing the certificates, pay attention to the following points:

- Ensure the entire certificate chain is included in the certificates.
- To streamline certificate management, set up a wildcard DNS (*.DomainName).
- The public key must be a 2048-bit RSA key.
  - Note that JAVA does not support 4096-bit RSA keys and 1024 bits are no longer secure.
  - Alternatively, you can use 256-bit ECDH keys, but RSA-2048 is recommended.
- The signature hash algorithm must be at least SHA-2 (for example, SHA256).

### Reverse proxy (recommended)

For a reverse proxy, prepare an internal certificate for the internal domain and import the internal root certificate to all Windows servers. Then purchase for the external domain another external certificate issued by a third-party CA and import this certificate to the reverse proxy server.

### NAT/PAT

If you use NAT/PAT to handle external client requests, purchase a certificate issued by a third-party CA for both internal and external domains.

If the internal and external domains have different names, this certificate should list both domains in the Subject Alternative Name field. However, we recommend that you use the same domain name for both internal and external domains.

### 7.2.3 Preparing External Addresses

To expose your SAP Business One services to the Internet (external networks), you must prepare external addresses for relevant components.

**Note**

The Service Layer is for internal component calls only and you do not need to expose it to the Internet.

Please pay attention to the following points:

- The external address and the internal address of each component must be different; otherwise, the external networks cannot be distinguished from the internal network, making browser access impossible.
- Only one set of external addresses is supported. Communication via the DNS alias of an external address will lead to error.
Reverse Proxy Mode

If you intend to handle client requests using a reverse proxy, we recommend that you use different domain names for internal and external domains. For example, the internal domain is `abc.corp` and the external domain is `def.com`.

Prepare the external addresses as follows:

- Prepare one external address for each of these components:
  - System Landscape Directory (SLD)
  - Browser Access service
  - Integration framework (if you use the SAP Business One mobile solution)

- The internal address of each component must match the common name of the certificate for the internal domain; the external address of each component must match the common name of the purchased certificate for the external domain.

  **Example**

  The internal URLs of the components are as follows:
  - System Landscape Directory: `https://SLDInternalAddress.abc.corp:Port`
  - Browser Access service: `https://BASInternalAddress.abc.corp:Port/dispatcher`
  - Integration framework: `https://B1iInternalAddress.abc.corp:Port/B1iXcellerator`

  The external URLs are as follows:
  - System Landscape Directory: `https://SLDExternalAddress.def.com:Port`
  - Browser Access service: `https://BASExternalAddress.def.com:Port/dispatcher`
  - Integration framework: `https://B1iExternalAddress.def.com:Port/B1iXcellerator`

NAT/PAT

If you intend to handle client requests using NAT/PAT, we recommend that you use the same domain name across internal and external networks. For example, both the internal and external domains are `abc.com`.

Prepare the external addresses as follows:

- Prepare one external address (hostname or IP address) for each of these components:
  - System Landscape Directory (SLD)
  - Browser Access service
  - Integration framework (if you use the SAP Business One mobile solution)

- The combination of external address and port must be different for these components. In other words, if two components have the same external address, the ports they listen on must be different; and vice versa.

- The internal address and external address of each component must match the common name of the certificate purchased for both the internal and external domains.

  **Example**

  The internal URLs of the components are as follows:
  - System Landscape Directory: `https://SLDInternalAddress.abc.com:Port`
  - Browser Access service: `https://BASInternalAddress.abc.com:Port/dispatcher`
Performing Post-Installation Activities

The external URLs are as follows:
- Integration framework: https://B1iInternalAddress.abc.com:Port/B1iXcellerator
- System Landscape Directory: https://SLDExternalAddress.abc.com:Port
- Browser Access service: https://BASEnvironmentAddress.abc.com:Port/dispatcher
- Integration framework: https://B1iExternalAddress.abc.com:Port/B1iXcellerator

7.2.4 Configuring Browser Access Service

The Browser Access service enables remote access to the SAP Business One client in a Web browser. The Windows service name is SAP Business One Browser Access Server Gatekeeper.

Prerequisite

Ensure that the date and time on the Browser Access server is synchronized with the database server.

Procedure

1. In a Web browser, log on to the system landscape directory using this URL:
2. On the Services tab, select the Browser Access entry for the particular Browser Access server and click Edit.
3. In the Edit Service window, edit the following information:
   - Service URL: Edit the URL used to access the service. For example, you may want to use the IP address instead of the hostname. Or the hostname, IP address, or the port has changed and you must update the service URL to reflect the changes.
   - Initial Processes: Specify the initial number of SAP Business One client processes that the Browser Access service hosts.
   - Maximum Processes: Specify the maximum number of SAP Business One client processes that the Browser Access service can host.
   - Idle Processes: Specify the number of standby SAP Business One client processes. When a new SAP Business One user attempts to log on, an idle process is ready for use.
   - Description: Enter a description for this Browser Access server.

Example

Specify the following:
- Initial processes: 20
- Maximum processes: 100
- Idle processes: 2

Twenty (20) SAP Business One client processes are constantly running on the Browser Access server and allow 20 SAP Business One users to access the SAP Business One client in a Web browser at the same time.
When the 19th SAP Business One user logs on, one (1) more SAP Business One process is started to ensure that two (2) idle processes are always running in the background.

If more SAP Business One users attempt to access the SAP Business One client in a Web browser, more idle processes are started, but at most, 100 users are allowed for concurrent access.

4. To save the changes, choose OK.

5. To apply the changes immediately, on the Browser Access server, restart the SAP Business One Browser Access Server Gatekeeper service.

### 7.2.5 Mapping External Addresses to Internal Addresses

You must register in the System Landscape Directory the mapping between the external address of each of the following components and its internal address:

- System Landscape Directory (SLD)
- Browser Access service

Note that you do not need to register the mapping for the integration framework.

**Procedure**

1. In a Web browser, log on to the system landscape directory using this URL: https://<Hostname>:<Port+10>/ControlCenter.

2. On the External Address Mapping tab, choose Register.

3. In the Register External Address window, specify the following information:
   1. Component
   2. Hostname or IP address of the machine on which the component is installed
   3. External URL
      - The external access URL must have the format `<protocol>://<Path>:<Port>`.

   ![Example]
   
   ![http://10.58.9.100:8080]

4. Choose OK.

**Post-requisite**

After finishing mapping external addresses to all required components, you must restart the services on the machines where they’re installed.

For example, if you have registered the external address mapping for a Browser Access server, you must restart the SAP Business One Browser Access Server Gatekeeper service.

Note that the restart of SAP Business One Browser Access Server Gatekeeper service may take from 5 to 10 minutes.
7.2.6 Accessing SAP Business One in a Web Browser

By default, no load balancing mechanism is applied. You can create a Web access portal and redirect requests to different Browser Access servers using a load balancing mechanism of your own choice, for example, round robin.

Prerequisites

- You have ensured that you can log on to the SAP Business One client installed on the Browser Access server.
- You are using one of the following Web browsers:
  - Mozilla Firefox
  - Google Chrome
  - Microsoft Edge
    - Ensure that you have enabled *Automatically Detect Intranet Network*.
  - Apple Safari (Mac and iPad)
    - Ensure that you have enabled Adobe Flash Player. This is a prerequisite for Crystal dashboards.

Procedure

The following procedure illustrates how to access SAP Business One directly in a Web browser.

1. In a Web browser, navigate to the external URL of the Browser Access service. For example:
   https://BASEExternalAddress.abc.com:Port/dispatcher
   If you are uncertain about it, you can check the external address mapping in the SLD.
   The Browser Access page is opened.

2. Choose the company and log on.
   Now you can work with SAP Business One in your Web browser.
7.2.7 Monitoring Browser Access Processes

As of release 9.2 PL02, you can monitor the Browser Access processes in a Web page using this URL: https://dispatcherHostname:port/dispatcher/serviceMonitor/.

7.2.8 Logging

The log files for the browser access service are stored at <Installation Folder>\SAP Business One BAS GateKeeper\tomcat\logs.

If you need to troubleshoot problems, edit the file <Installation Folder>\SAP Business One BAS GateKeeper\tomcat\webapps\dispatcher\WEB-INF\classes\logback.xml, and change the logging level from the default WARN to DEBUG. Note that you must change the logging level back to the default value after the investigation.

7.3 Configuring the SAP Business One Client

After you have installed SAP Business One and logged on to the application for the first time, you must provide the license server address and port number in the License Server Selection window.
To start the SAP Business One client, choose **Start → All Programs → SAP Business One → SAP Business One Client**. To start the SAP Business One Client using the command line, enter the following command:

```
"SAP Business One.exe" -DbServerType <Microsoft SQL Server version> -Server <Microsoft SQL Server instance name> -CompanyDB <Company Database> -UserName <User ID> -Password <Password> -LicenseServer <License Server address:port>
```

For the `DbServerType` parameter, depending on version of Microsoft SQL Server you are using, enter one of the following:

- For Microsoft SQL Server 2014, enter 8.
- For Microsoft SQL Server 2012, enter 7.
- For Microsoft SQL Server 2008, enter 6.
- For Microsoft SQL Server 2005, enter 4.

**Note**

Command line parameters are case-sensitive.

**Caution**

For security reasons, do not start the SAP Business One client using the command line in productive environments. You should use this method only for testing.

In the SAP Business One toolbar, you can check the log configurations by choosing **Help → Support Desk → Logger Setting**. You can see the relevant configuration log file under `...\SAP\SAP Business One\Conf\B1logconfig.xml`.

### 7.4 Installing License Keys

To use your SAP Business One application according to your contract, you are required to install a license key assigned by SAP.

You also must install a new license key when:

- You add additional users or components.
- The hardware key changes.
- The current license key expires.
- You have a new installation of SAP Business One.

To avoid changing the hardware key accidentally, do not perform the following actions on the machine running the license server:

- Formatting the computer and reinstalling Microsoft Windows using another product key
- Changing the computer name
- Changing the domain (hardware key does not change back when you return to the previous domain)

The following actions are safe and do not change the hardware key:

- Adding a new user logon
- Changing the computer date or time
Procedure

1. To open the SAP Business One Service Manager window, in the Microsoft Windows task bar, double-click (SAP Business One Service Manager).
   Alternatively, in Windows, choose Start → All Programs → SAP Business One → Server Tools → Service Manager.
   In the SAP Business One Service Manager window, from the Service dropdown list, select License Manager and choose the Settings button.

![SAP Business One Service Manager window]

2. In the General Settings window, do the following:
   1. Enter the name or IP address of the machine on which the server tools are installed.
      
      ![Note]
      Use localhost only in standalone installations.
   2. To install the license key file, choose the Browse button and select the txt file you received from SAP.
3. Choose the *Import License File* button.
4. To save your settings and close the *General Settings* window, choose the *OK* button.
5. To complete the process and close the *SAP Business One Service Manager* window, choose the *OK* button.

### 7.5 Assigning SAP Business One Add-Ons

Add-ons are additional components or extensions for SAP Business One. Installing the server and client applications automatically registers the SAP add-ons and makes them available for installation from the SAP Business One application. The application automatically registers the following add-ons:

- **32-bit add-ons:**
  - DATEV FI Interface
  - Electronic File Manager
  - Microsoft Outlook integration
  - Payment Engine
  - Screen Painter

- **64-bit add-ons:**
  - Electronic File Manager
- Microsoft Outlook integration
- Payment Engine
- Screen Painter

Note

The ELSTER Electronic Tax Return add-on is available for download in the SAP Business One Software Download Center and is no longer included in the SAP Business One download package. For more information, see SAP Note 2064562.

Prerequisites

- You have a Professional license from SAP.
- You have installed Microsoft XML 3.0 Service Pack 4 on your workstation. To ensure that this software is installed on the hard drive of the workstation, check that the msxml3.dll file is saved in the system32 directory in the main Windows directory.
- If you chose Custom for the installation of server components, ensure that SAP Add-ons is selected in the Select Features window.
- You must have Power User or Administrator rights, especially in the terminal server environment.

The following table displays the SAP Business One add-ons and their prerequisites.

<table>
<thead>
<tr>
<th>Add-On</th>
<th>Prerequisites</th>
</tr>
</thead>
<tbody>
<tr>
<td>Payment Engine</td>
<td>Inbound Functionality is activated only when the Bank Statement Processing checkbox is deselected.</td>
</tr>
<tr>
<td>Screen Painter</td>
<td>You have installed Microsoft .NET Framework 2.0 or higher on the SAP Business One workstation intended to run Screen Painter.</td>
</tr>
<tr>
<td></td>
<td>• After installing Microsoft Outlook, you created an e-mail account for sending and receiving e-mails.</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Outlook is set as your default mail client. To check your default mail client, open the Control Panel window, and choose Internet Options. On the Programs tab, ensure that in the E-mail field, Microsoft Outlook is selected.</td>
</tr>
<tr>
<td></td>
<td>• Your version of Microsoft Outlook is of the same system type as that of the SAP Business One client. For example, both are the 32-bit versions.</td>
</tr>
<tr>
<td></td>
<td>After installing the Microsoft Outlook integration add-on, the SAP Business One entry appears in the Add-ins menu of the following Microsoft Office applications:</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Outlook</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Word</td>
</tr>
<tr>
<td></td>
<td>• Microsoft Excel</td>
</tr>
</tbody>
</table>
|                                     | For more information about how to use the feature, see the Microsoft Outlook integration online help. The help is available in the Add-ins menu of the above
### 7.5.1 Constraints

When you run SAP Business One, you can use only SAP Business One add-ons valid for the version of the application you are running.

If you are using the 32-bit version of the SAP Business One client, you can install and run only 32-bit add-ons. If you are using the 64-bit version of the SAP Business One client, you can install and run only 64-bit add-ons. The add-ons run under the SAP Add-Ons license, which is included in the Professional User license.

#### Procedure

For information about how to assign SAP add-ons, see the Assigning Add-Ons online help document.

You can find the online help document at the following locations:

- Partners — SAP Channel Partner Portal on sappartneredge.com

### 7.6 Performing Post-Installation Activities for the Integration Framework

After installation is complete, you can begin using the integration framework. No mandatory post-installation activities are necessary.

However, for certain use cases, you need additional settings in the integration framework. The following sections provide information about additional configuration options and settings you can check to ensure a correct setup.

#### Note

The integration framework is implemented as a Microsoft Windows service with the SAP Business One Integration Service identifier. The service starts automatically after successful installation.

If you cannot start the integration framework, stop and restart the service.

You can locate the service by choosing Start → Control Panel → Administrative Tools → Services.

<table>
<thead>
<tr>
<th>Add-On</th>
<th>Prerequisites</th>
</tr>
</thead>
<tbody>
<tr>
<td>Microsoft Office apps</td>
<td>Microsoft Office applications and from within the relevant windows in the SAP Business One client application (by pressing F1 in the windows).</td>
</tr>
<tr>
<td>Datev FI Interface</td>
<td>You have created a new company to work with the DATEV add-on and deselected the checkboxes: Copy User-Defined Fields and Tables and Copy User-Defined Objects. The DATEV add-on may not work with demo databases.</td>
</tr>
</tbody>
</table>
7.6.1 Maintaining Technical Settings in the Integration Framework

Procedure

1. In Microsoft Windows, choose Start → All Programs → Integration solution for SAP Business One → Integration Framework. The Administrative Logon user interface opens.

2. In the B1i User field, enter B1iadmin and in the Password field, enter the password that has been provided during installation.

Note that entries in the B1i User field are case-sensitive.

3. To add or change integration framework technical settings, in the integration framework, choose Maintenance.

   - To define proxy settings for your network and provide connection information for your e-mail server, choose Cfg Connectivity.
   - To get an overview about configuration information for message exchange between SAP Business One and the integration framework and about integration packages setup, choose Tools → Troubleshooting, and in the Functional Group field, choose B1 Setup.

For more information about maintenance functions, in the integration framework choose Help → Documents → Operations Part 2, section System Administration.

7.6.2 Maintenance, Monitoring and Security

Monitoring

For technical monitoring purposes, choose Start → All programs → Integration solution for SAP Business One → Integration Framework, and in the integration framework, choose Monitoring.

You can use the message log, access the error inbox, display SAP Business One (B1) events and use other monitoring functions.

By default, the message log is active after installation. We recommend deactivating the message log in a productive environment.

For additional documentation, choose Start → All programs → Integration solution for SAP Business One → Integration Framework, and then choose Help → Documents → Operations Part 1 and Operations Part 2.

System Landscape Directory (SLD)

To maintain systems connecting to the integration framework, choose Start → All programs → Integration solution for SAP Business One → Integration Framework, and then choose SLD.

For all integration packages, SAP delivers the necessary system entries in SLD.
In SLD, make sure that you keep the entry in the `b1Server` field for the SAP Business One system in sync with the entry in the `associatedSrvIP` field for the `WSforMobile` system.

### Integration with SAP Business One integration for SAP NetWeaver

If your SAP Business One is connected as a subsidiary to the SAP Business One integration for SAP NetWeaver server, it is necessary to add entries to the event subscriber manually.

To configure the SAP Business One event subscriber to send events to a remote integration framework server, choose `Start → All programs → Integration solution for SAP Business One → Integration Framework`, and then choose `Maintenance → Cfg B1 Event Subscriber`.

For more information, click the documentation (Book) icon in the function.

### Security Information

The integration framework security guide gives you information that explains how to implement a security policy and provides recommendations for meeting security demands for the integration framework.

For more information, choose `Start → All programs → Integration solution for SAP Business One → Integration Framework`, and then choose `Help → Documents → Operations Part 2`, section `Integration Framework Security Guide`.

### 7.6.3 Technical B1i User

SAP Business One creates a user with the `B1i` user code for each company database. The default process requires that you set the same password for each company database. The integration framework uses the `B1i` user to connect to SAP Business One (for example, to check authentication when using the mobile solution).

Ensure that the password that you provided during installation of the integration framework is the same you set in SAP Business One.

### 7.6.4 Licensing

Ensure that the SAP Business One `B1i` user has been assigned with the following two free licenses:

- `B1iINDIRECT_MSS`
- `B1i`

No additional licenses are required for the `B1i` user.

Mobile users must be licensed to access the SAP Business One system through the mobile channel. License administration is integrated with the SAP Business One user and license.
7.6.5 Assigning More Random-Access Memory

We recommend checking the performance aspects in the related documentation.

Choose Start → All programs → Integration solution for SAP Business One → Integration Framework, and then choose Help → Documents → Operations Part 2, section 2.

If you expect your system to run under very high load and to process a high amount of messages, you can assign more random-access memory (RAM) to the integration framework server to improve performance.

Procedure

1. On your local drive C:\Program Files\SAP\SAP Business One Integration\IntegrationServer\tomcat\bin\ double-click tomcat6w.exe.
   If the system denies access, select tomcat6w.exe, open the context menu and select the Run as Administrator option.
2. Select the Java tab, and increase the maximum memory pool amount as follows:
   - In a 32-bit operating system, Tomcat supports a maximum memory pool of 1024 MB.
   - In a 64-bit operating system, the default is 2048 MB for the maximum memory pool amount for Tomcat, you can assign more RAM.

7.6.6 Changing Integration Framework Server Ports

By default, the integration framework server uses port 8080 for http and 8443 for https. If another application is already using one of these ports, change the integration framework ports.

Procedure

1. If SAP Business One Event Sender Service is already running, stop the service.
2. In the ...\Program Files (x86)\SAP\ Integration Solution for SAP Business One\IntegrationServer\Tomcat\conf folder, double-click the server.xml Tomcat file and in the connector port tag, change the settings as necessary. Do not change any other settings in the file.
3. Log on to the integration framework, choose Maintenance → Cfg Runtime and change the port or ports.
   The integration framework also updates the setting in the SLSPP table in SAP Business One.
4. Restart the SAP Business One Integration Service.
5. Choose Start → All Programs → Integration solution for SAP Business One → EventSender → Setup, follow the steps of the wizard and in the Configure B1i Parameters section, change the B1i Server Port entry, and then test the connection.
6. Restart the SAP Business One EventSender Service.
7. To change the properties for the menu entry, choose Start → All programs → Integration solution for SAP Business One → Integration Framework. Be sure to use the correct port number.
7.6.7 Changing Event Sender Settings

SAP Business One writes events for new data, changes and deletions to the SEVT table. Based on filter settings, the event sender accesses the table, retrieves data and hands over the events to the integration framework for further processing.

The installation program installs and sets up the event sender on the SAP Business One server. The following section describes event sender settings, although usually no further changes are required.

Note
Only call the event sender setup in the following cases:
- You must change the password for database access.
- You have changed the B1admin password for the runtime user.
- You have moved to another server.
- To reduce the message load, you want to include or exclude some objects.
- You want to exclude users.

To check the settings for the event sender, use the integration framework troubleshooting function. In the integration framework, choose Tools → Troubleshooting, and in the Functional Group field, choose Event Sender.

Procedure

1. To call the event sender setup, choose Start → All Programs → Integration Solution for SAP Business One → EventSender → Setup.
2. In step 1, in the Choose a DB Type field, select the SAP Business One database type.
3. In the DB Connection Settings section, you can set the following:
   - In the DB Server Name field, enter the computer name or IP address of the machine, where the database of the SAP Business One server is installed. Do not use localhost.
   - Use the hostname of the server. Only if you have problems specifying the hostname, use the IP address instead.
   - In the Port field, enter the port number of the database server, where the SAP Business One server is installed.
   - In the Setup DB Account and Password fields, the installation has set the database user name and password for database access during setup.
   - This user must have access rights to create tables and store procedures.
   - In the Running DB Account and Password fields the installation has set the database user name and password for database access at runtime.
   - This user must have access rights to the event log and event lock tables.

Recommendation

Use the hostname of the server. Only if you have problems specifying the hostname, use the IP address instead.

Caution

In the SAP Business One integration for SAP NetWeaver installation, this setting must be identical with the value in the b1Server field. If the values are not identical, they appear in the Filtered section.
- In the Port field, enter the port number of the database server, where the SAP Business One server is installed.
- In the Setup DB Account and Password fields, the installation has set the database user name and password for database access during setup.
  - This user must have access rights to create tables and store procedures.
- In the Running DB Account and Password fields the installation has set the database user name and password for database access at runtime.
  - This user must have access rights to the event log and event lock tables.
If you want to use the Microsoft Windows authentication mechanism to connect to the database, select the **Trusted Connection** option. If you select this option, you do not have to specify the **Setup DB Account**, **Running DB Account** and **Password** fields.

4. In step 2, the following settings are available in the **Monitor Settings** section.
   - In the **Idle Time (millisecond)** field, you can change the time period the event sender waits until it polls events from SAP Business One. The default is 3000 milliseconds.
   - In the **Batch Count** field, you can set the number of events the event sender polls each time. The default is 10.

5. In step 3, you can change general settings for the integration framework.
   - By default, the installation program sets the **Sending Method to Direct**.
     - If you select the **Direct** method, the event sender directly sends events to a dedicated server address. This can either be an integration framework server or the SAP Business One integration for SAP NetWeaver server.
     - If you select the **Distributed** method, the event sender sends all events to the local server address and the event dispatcher takes over the task of distributing the events to other systems. Before selecting this method, make sure that you have configured the event subscriber. For more information, see the *Operations Guide Part 2*, section **Configuring the B1 Event Subscriber**

6. In the **General B1i Settings**, you can configure the following:
   - In the **Protocol Type** field, select the protocol for the connection between the event sender and the integration framework. To enable https, make settings in the Tomcat administration.
   - In the **Authentication** field, always use the **Basic** option. This is the default.
   - In the **B1i Server** field, enter the name or IP address of your integration framework or the SAP Business One integration for SAP NetWeaver server.
   - In the **B1i Server Port** field, enter the port number of your integration framework or the SAP Business One integration for SAP NetWeaver server.
   - If you work in a network with a proxy, in the **Proxy Host** field, enter the name or IP address of your network proxy.
   - If you work in a network with a proxy, in the **Proxy Port** field, enter the port number of your network proxy.
   - In the **User Name** field, enter the user name for accessing the integration framework or SAP Business One integration for SAP NetWeaver server. The default is **B1iadmin**.
   - In the **Password** field, enter the password for accessing the integration framework or SAP Business One integration for SAP NetWeaver server.
   - To test the connection, choose the **Test Connect…** button.

7. In step 4, choose the company databases.
   - The setup program displays the company databases in your SAP Business One system. For each company database, you can set up the following:
     1. Deselect the checkbox in front of the SAP Business One company database, if the company does not use the integration framework. If you deselect the checkbox, SAP Business One does not create events for the company database in the **SEVT** table.
     2. To define for which SAP Business One objects the event sender sends events, chose the **Event Filter** button.
In the Include List B1 Object(s) field, enter the object identifier of the SAP Business One object or objects. Separate entries by comma.

If you enter, for example 22, 17, the event sender sends events for purchase orders and orders to the integration framework or the SAP Business One integration for SAP NetWeaver server.

If you leave the field empty, the event sender sends events for all SAP Business One objects to the integration framework or the SAP Business One integration for SAP NetWeaver server.

In the Exclude List B1 Object(s) field, enter the object identifier of the SAP Business One object or objects. Separate entries by comma.

If you enter for example 85 the event sender excludes events for special prices for groups.

If you leave the field empty, the event sender sends events for all SAP Business One objects to the integration framework or the SAP Business One integration for SAP NetWeaver server.

Note

Use either the Include B1 Object(s) or the Exclude List B1 Object(s) function. Do not use the functions together.

In the Exclude List B1 User field, enter SAP Business One users for which the event sender does not send events to the integration framework. Enter the SAP Business One user name, not the user code. Separate entries by comma.

If you want the company database to create events based on indirect journal entries, select the Create Complete Journal Entry Events checkbox. Standard SAP Business One processing does not create events for indirect journal entries.

3. To define the receiver of events, choose the Default Inbound button. You have the following options:

   - Default Inbound
     This is the default. The event sender hands over events to B1iP. The event dispatcher hands over the events to the event subscriber that distributes the events to the target application or applications.

   - SAP Business One integration for SAP NetWeaver 2005
     This option is available for SAP Business One integration for SAP NetWeaver 2005 to be backwards compatible.
     - If you select this option, choose the Receiver button and enter the B1i application URI. To test the connection, choose the Test connection button.

   - OTR (Other)
     - If you select this option, choose the Receiver button and enter the B1i application URI. To test the connection, choose the Test connection button.

4. To test the connection to the receiver of SAP Business One events, choose the Receiver and then on the Test Connection button.

8. Step 5 gives you a summary of the event sender settings.

9. To save the settings, choose the Finish button.

10. Restart the SAP Business One EventSender service.

Result

The setup program stores the settings in the datasource.properties and eventsenderconfig.properties configuration files.
7.6.8 Changing SAP Business One DI Proxy Settings

SAP Business One DI Proxy is the SAP Business One-related component that enables data exchange with SAP Business One using the DI API. No additional steps are required to set up the SAP Business One DI Proxy service.

To influence the behavior of the SAP Business One DI Proxy service, parameters are available in the diproxyserver.properties file.

Procedure

1. To change parameters, access the diproxyserver.properties file in the ...
   SAP\SAP Business One Integration\DIPr oxy path.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>RMI_PORT</td>
<td>The parameter is obsolete.</td>
</tr>
<tr>
<td>HTTPS_PORT</td>
<td>DI Proxy TCP port for HTTPS.</td>
</tr>
<tr>
<td>MAXDIERRORS</td>
<td>If this property exists and has a value greater than 0, the value defines the number of DI errors that may occur before the DI Proxy restarts. The default is 50.</td>
</tr>
<tr>
<td>RESTARTPERIOD</td>
<td>If this property exists and has a value greater than 0, the value determines the time in minutes after which the DI Proxy restarts. The default is 60.</td>
</tr>
<tr>
<td>ORPHANED</td>
<td>This property defines the value in minutes after which the system defines a pending and not yet completed DI transaction as orphaned. The DI Proxy removes the transaction from the internal transaction list. If this property does not exist or does not have a positive value, the default is 10. If it exists, the default is 30.</td>
</tr>
<tr>
<td>JCOPATH</td>
<td>If this property exists and is not empty, it defines the path the DI Proxy uses to search for the JCo installation. In this case the system ignores any value coming from B1IP requested by an adapter. If the property does not exist, the system uses any value coming from B1IP requested by an adapter. In this case the setting is probably not definite. SAP recommends setting the JCo path in the diproxyserver.properties file. If you want to change a JCo path that someone has already maintained and that the system has used for connection, you can apply this change only after you have restarted the SAP Business One DI Proxy Service. Use / or \ instead of \ as a separator in the JCOPATH value. Use for example C:\Program Files\SAP\SAP Business One DI API\JCO\LIB</td>
</tr>
<tr>
<td>JCOVERSION</td>
<td>If this property exists and is not empty, it defines the version the DI Proxy uses to search for the JCo installation.</td>
</tr>
</tbody>
</table>
### Using Proxy Groups

The DI adapter allows defining multiple proxy groups in the global adapter configuration properties. This allows load balancing by processing requests to multiple proxies. Requests can come from IPO steps that are independent of each other. If you process a step using a certain proxy, the step uses the proxy during the complete step processing.

You can find the following information in the proxy log file:

- The proxy logs the processing start and stop time and describes how the proxy was stopped.
- Find a usage statistics summary, which lets you decide whether the proxy suits the processing requirements or whether it should be enhanced to a proxy group to fulfill the overall requests.

### Providing Further Proxies

To use proxy groups, provide several DI proxies.

#### Procedure

1. To enable a configuration set for a second `DIProxy` instance, copy the `DIProxy` folder and paste it. The system creates the `DIProxy - Copy` folder.
2. Rename the folder to `DIProxy2`.
3. In the `...\DIProxy2` folder, open the `service.ini` file and change the following entries:
   - `ServiceName = SAPB1iDIProxy2`
   - `DisplayName = SAP Business One DI Proxy 2 Service`
4. In the `...\DIProxy2` folder, open the `diproxyserver.properties` file.
5. Change the `HTTPS_PORT` parameter to `2098`, if port `2098` is available on your machine.

<table>
<thead>
<tr>
<th>Property</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td>restartAttemptDelay</td>
<td>As of DI Proxy version 30002211, you can overlay the default for a restart delay (500 milliseconds). Provide a value in milliseconds. The parameter is not part of the default <code>diproxyserver.properties</code> file. If you want to use it, add it manually.</td>
</tr>
<tr>
<td>restartAttemptCap</td>
<td>As of DI Proxy version 30002211, you can overlay the default number of restart attempts (10). The parameter is not part of the default <code>diproxyserver.properties</code> file. If you want to use it, add it manually.</td>
</tr>
</tbody>
</table>

2. If you change any settings, restart the SAP Business One DI Proxy Service.
6. Choose Start, right-click Command Prompt and choose the Run as administrator option.
7. Run service.exe with the -install parameter in the ..\DIProy2 folder.
8. Start the SAP Business One DI Proxy 2 Service Monitor service.
9. Repeat the steps above for the number of DIProxies you want to use.

7.6.9.2 Adding Proxy Groups to the DI Adapter Global Configuration

In the integration framework, you have the option of defining proxy groups with proxies. Define the proxy groups and proxies in the DI adapter global configuration.

Procedure

1. In the integration framework, choose Tools → Control Center → Configuration → Global Adapter Config.
2. In the Global Adapter Configuration Properties user interface, for the BIDI adapter, click the Edit Global Configuration Properties link.
3. For the diProxyGroupList property, define the proxy groups in the following way:
   - [<grouppname1> <hostname1>:<port1>,<port2>] [<grouppname2> <hostname2>:<port1>,<port2>]
   - <grouppname1,2> are the proxy group names
   - <hostname1,2> are the host names or IP addresses of the proxies
   - port1,2 are the port numbers

Example

You want to provide the following proxy groups:
- alpha and beta
- Each group has two proxies
  [alpha abc:2099 def:3701] [beta 1.2.3.4:2099,3000]

7.6.9.3 Using Proxy Groups in SLD

In SLD, enter the proxy group definition that you want to use for a certain company database in the diProxyhost field of the SAP Business One company database entry in the following way, for example: [alpha]

If you use a proxy group, leave the diProxyport field empty.
7.6.10 Integration Framework-Related Information About Dashboard Widgets for the Cockpit

- If the B1i user password is not correct or licenses are not properly assigned to the user, Dashboard widgets display the **401 not authorized** error.
  
  In the integration framework, adjust the B1i user password in SLD. Ensure that licenses are correctly assigned.
  
  For more information, see the *Licensing* section.

- If Dashboards have been activated, but not properly deployed in the integration framework, the **404 file not found** error mentioning **DASHBOARD** is displayed.
  
  Check that all services for the integration framework are running.
  
  Deactivate the Dashboard widgets, log off and logon again, and activate the Dashboard widgets.

- To support the display of dashboards, ensure that Adobe Flash Player 10.0 is installed on the client workstation.

8 Maintaining Databases

This section provides information about checking and maintaining your database system. Database activities depend on the nature of your organization’s day-to-day work. There are many factors influencing system performance, such as disk space availability, the number of transactions occurring each day, and so on. It is essential to perform daily and regular checks to ensure the efficient operation of SAP Business One. System performance depends on the correct administration of the database.

This section also lists all the stored procedures quoted in the SAP Business One application.

8.1 Database Server Administration

This section provides basic information about the SQL Server environment, the way a database management system stores and accesses the data, and the database administration tool. The information comprises the following topics:

- Starting and stopping database services
- Performing weekly tasks
- Performing regular tasks
- Performing backups
- Performing restoration

8.1.1 Starting and Stopping Database Services

Occasionally, it is necessary to stop and start database services manually, for example, when you perform a complete backup of the database.

Procedure

- To stop database services:
  1. Verify that no clients are logged on to SAP Business One.
  2. To open SQL Server Management Studio, in Windows, choose Start → All Programs → Microsoft SQL Server 2008 → SQL Server Management Studio.
  3. In the Object Explorer window, right-click the database server on which your SAP Business One database is installed and choose Stop.
- To start database services:
  1. To open SQL Server Management Studio, in Windows, choose Start → All Programs → Microsoft SQL Server 2008 → SQL Server Management Studio.
2. In the Object Explorer window, right-click the database server on which your SAP Business One database is installed and choose Start.

**Note**

If you are not able to log on to SAP Business One, and the dialog box for choosing a company contains an empty list, check whether Microsoft SQL Server is running.

If you log off the Microsoft SQL Server services, all user processes are terminated, but the database services keep running.

### 8.1.2 Weekly Tasks

Perform the following tasks on at least a weekly basis:

- Checking database consistency
- Running the Update Statistics command

If the size of the SAP Business One database is large or your company has a large volume of daily or weekly transactions in SAP Business One, perform the previous tasks more often.

### 8.1.2.1 Checking Database Consistency

A database consistency check performs a thorough check of the entire database. It examines all tables in the database to ensure that index and data pages are linked correctly and that indexes are in the correctly sorted order. A database consistency check also ensures that all pointers are consistent and that the data information on each page and page offset is reasonable.

Performing database consistency checks enables you to recognize problems early, and prevent escalations and the possible loss of data.

When performing database consistency checks, ensure the following:

- Schedule consistency checks with the planning calendar.
- Run consistency checks outside of normal business hours, for example on the weekends.
- Do not schedule any other tasks at the same time as you run the consistency check.

**Note**

On the Microsoft SQL Server level, the SAP Business One database consistency check executes the `DBCC CHECKDB` command, which locks user tables, indexes, and system tables throughout the run.

In addition, a database consistency check is an I/O intensive process. Therefore, you should not run checks during normal business operations, but at times when the system load is low.

You can use the remote support platform for SAP Business One to automatically perform database consistency checks as part of a defined backup strategy. For more information, see the online help for the remote support platform.
8.1.2.2 Running the UPDATE STATISTICS Statement

The UPDATE STATISTICS statement defines the storage requirements of tables and indexes as well as the value distribution of columns, and stores this information in the database catalog. The Optimizer uses these values to determine the best strategy for executing SQL statements. Use the sp_updatestats procedure on all user-defined tables in the required database.

When the UPDATE STATISTICS statement is executed, the following information about the table is stored in the database catalog:

- Number of rows
- Number of pages used
- Size of indexes
- Value distribution within columns or indexes

You can use the remote support platform for SAP Business One to execute the UPDATE STATISTICS statement manually or as part of a scheduled task. You can also configure the remote support platform to create a job in the Microsoft SQL Server Agent, which updates statistics according to schedule.

8.1.3 Regular Tasks

Performing scheduled tasks is essential for ensuring database availability and minimizing the risk of data loss. Perform the following tasks on a regular basis, as determined by your database size and transaction volumes:

- Verify that the database server is running
- Verify that the backups run successfully
- Check the database
- Shrink the transaction log
- Monitor disk space

8.1.3.1 Verifying Database Servers Are Running

You must complete this task every morning. SAP Business One clients cannot work if the database server is not running.

Procedure

Run the SAP Business One client and log on to your database server. If you can log on, the database server is running.

Alternatively, you can use the System Status Report of the remote support platform for SAP Business One to automate the database verification process.
8.1.3.2 Verifying Backups

Backups of your database are essential for recovering the SAP Business One system in case of failure. Use this procedure to verify that previous backups ran successfully.

Alternatively, you can use the remote support platform for SAP Business One to automate the backup verification process as part of a defined backup strategy.

Procedure

1. To open SQL Server Management Studio, in Windows, choose Start → All Programs → Microsoft SQL Server 2008 → SQL Server Management Studio.
2. Select the Management folder and check the SQL server logs.
3. Search for the last backup message.
4. Verify that the backup ran successfully and that the date fits the scheduled settings.
   The following is an example of a successful backup message:
   "Database backed up. Database: myDB, creation date(time): 2005/12/21(10:57:16), pages dumped: 502701, first LSN: 37211:18:108, last LSN: 37211:91:1, number of dump devices: 1, device information: (FILE=1, TYPE=DISK: {'E:\temp\bck\myDB'}). This is an informational message only. No user action is required."

8.1.3.3 Checking Databases

The SQL Server database uses disk space to store the database data files and the daily transaction log files. If you do not establish a schedule for the backup of the transaction log, the log file can grow too large, causing a decline in system performance. Ultimately, this can stop the database system.

The transaction log should not occupy more than 60–70% of the total available disk size. If it regularly exceeds this level between subsequent backups, you must save the transaction log more frequently. In SQL Server Management Studio, you can determine whether the data file and transaction log file are set to grow automatically.

In addition, check the utilization of table space and the content of error logs on a regular basis.

Procedure

- To check the size of the data file and the transaction log file, do the following:
  1. To open SQL Server Management Studio, in Windows, choose Start → All Programs → Microsoft SQL Server 2008 → SQL Server Management Studio.
  2. Select the database for which you want to check the transaction log size.
  3. Right-click the selected database and choose Reports → Standard Reports → Disk Usage. In the right pane, you can see the report.
  4. Verify that there is enough free space, based on your organization’s needs, for both the data file and the transaction log.
To set grow options for database files, do the following:
1. Open SQL Server Management Studio and select a database.
2. Right-click the selected database and choose Properties.
3. In the Properties window, from the menu on the left, choose Files.
5. In the Autogrowth field, set a value according to your organization’s needs.

To check error logs, do the following:
1. Open SQL Server Management Studio.
2. Select the Management folder and check the SQL Server Logs folder.
3. Check for error messages and verify that no problems have occurred.

8.1.3.4 Shrinking Transaction Logs

Shrinking the transaction log file frees up disk space and minimizes the risk of data loss. Shrinking the transaction log does not reduce the size of a physical log file. It removes enough inactive virtual logs to reduce the log file to the requested size. Use this procedure to shrink the transaction first virtually and then physically.

In addition, you can use the remote support platform for SAP Business One to shrink the transaction log manually or as part of a scheduled task. You can also configure the remote support platform to create a job in the Microsoft SQL Server Agent, which shrinks the transaction log according to schedule.

Procedure

1. To open SQL Server Management Studio, in Windows, choose Start → All Programs → Microsoft SQL Server 2008 → SQL Server Management Studio.
2. Select the required system database.
3. Right-click the selected database and choose New Query. The right pane displays the Query window.
4. In the Query window, enter the following command:
   
   ```sql
   BACKUP LOG <sid> WITH NO_LOG
   ```

   Where:
   
   `<sid>` is name of the database, for example sbodemo_us
   
   Right-click anywhere on the query tab and choose Execute.
   
   This statement reduces the size of the logical log. It removes the inactive part of the log, without making a backup copy, and truncates the log.

   Specifying a backup device is unnecessary because the log backup is not saved.

   After you back up the log using NO_LOG, the changes recorded in the log are not recoverable. For recovery purposes, execute a manual backup of your database. For more information, see SAP Note 557412.

5. To reduce the size of the physical log file, enter the following command:
   
   ```sql
   DBCC SHRINKFILE (<name_logfile>, <size>)
   ```
Where:

- `<name_logfile>` is the logical name of the shrunk file, for example `sbodemo_us_log`
- `<size>` is the required size for the file, in megabytes, expressed as an integer. If the size is not specified, `DBCC SHRINKFILE` reduces the size to the default file size, for example 10 MB.

Right-click anywhere on the query tab and choose *Execute*.

**Note**

In SQL Server, a `DBCC SHRINKDATABASE` or `DBCC SHRINKFILE` operation attempts to shrink the physical log file to the requested size (subject to rounding).

### 8.1.3.5 Monitoring Disk Space

We recommend that you regularly check the amount of free space available on the disk. You can use the System Status Report of the remote support platform for SAP Business One to automate the process of monitoring the amount of free disk space.

### 8.1.4 Backing Up Databases

This section provides an introduction to backups and information about the necessity of a backup strategy. Databases are always at risk of damage and it is vital to implement a security strategy.

To keep the risk of data loss low, ensure that you develop a backup strategy that suits your business and the requirements of your customers. An important factor to consider is the volume of data that you process each day. In case of data loss, you are required to retrieve this data manually, back to the time of your last backup.

With SAP Business One, we recommend backing up your application database regularly.

**Caution**

SAP Business One can save the configuration data only when you have write and read access to the user profile folder.

You can use the following characters for a company database name:

- A-Z
- a-z
- 0-9
- Underscore (_)

Note that spaces are not allowed. In addition, the database name must start with A-Z or a-z.
8.1.4.1 Backup Strategies

To choose the appropriate backup-and-restore strategy, you need to identify the requirements for the availability of your data. Your overall backup strategy should define the type and frequency of backups and the nature and speed of the hardware.

Consider the complexity of each strategy. Full backups are easy to implement. If you are considering backing up your transaction log as well, test all backup-and-restore procedures intensively.

When choosing your backup strategy, you can use the following methods:

- **Full Backup**
  In Microsoft SQL Server, a full backup is a consistent copy of your database at a certain time. Since only used objects are saved, normally the copy is smaller than the original database. Full backups should be scheduled for a time when there is a low load on the database server.

- **Differential Backup**
  A differential backup is a backup of all data that has changed since the last full backup was performed. Compared with full backups, differential backups consume less time and disk space, but can result in a longer amount of time required to restore data.

- **Transaction Log Backup**
  The Transaction Log is a serial record of all the transactions that have been performed on the database since the transaction log was last backed up. With transaction log backups, you can recover the database to a specific point in time or to the point of failure.

  The transaction log grows over time. If the transaction log exceeds a certain size, it can cause problems in Microsoft SQL Server. To prevent those problems, we recommend doing regular backups of the transaction log, which truncates the transaction log.

- **Backup of SAP Business One Subdirectories**
  To avoid data loss, you must back up regularly the following subdirectories of SAP Business One:

  - `...\Program Files\SAP\SAP Business One\Attachments\`
  - `...\Program Files\SAP\SAP Business One\Bitmaps\`
  - `...\Program Files\SAP\SAP Business One\ExclDocs\`
  - `...\Program Files\SAP\SAP Business One\WordDocs\`

  These directories contain Microsoft Word and Microsoft Excel documents and bitmaps. To store the backed up directories, you can use a file archiving application.

  **Recommendation**

  Test your backup and recovery procedures thoroughly. Testing helps to ensure that you have the required backups to recover from various failures, and that your procedures can be executed smoothly and quickly if a failure occurs.

  The frequency of the backups depends on the following factors:

  - Processed data volume
  - Customer requirements
  - Number of users

  Consider how much time you would need to invest in retrieving your data manually after a data loss. After installing or upgrading SAP Business One, perform a full backup of the SBO_DB database.
8.1.4.2  Backup Types

You can back up your data using the backup functionality of remote support platform for SAP Business One or SQL Server Management Studio, using one of the backup types described below:

- **Full Backup and Differential Backup and/or Transaction Log Backup Using the Remote Support Platform for SAP Business One**
  
  This backup type saves backup data to a network folder. The setup is relatively simple, and you can configure the remote support platform to automatically perform scheduled backups according to a defined strategy. The remote support platform can also backup SAP Business One subdirectories.

- **Full Backup Using Microsoft SQL Server Management Studio**
  
  This backup type can save the backup data directly to tape. If you save the backups on disk, ensure the backup is copied to another medium, such as another hard disc, DVD, or tape.
  
  Do a manual backup of the files and directories of your hard disk.

- **Full Backup and Transaction Log Backup Using Microsoft SQL Server Management Studio**

  **Note**
  
  To use SQL Server Management Studio to perform transaction log backups, you should have already selected the Full recovery model option.

  The advantage of this type of backup is that the monitoring is partly automated and you can save the backups directly to a tape. You can also add alerts. Disadvantages include a relatively complicated setup and the need to manually back up the subdirectories of SAP Business One. However, SAP Business One does not fully support all of the features available with SQL Server Management Studio; therefore, if you require support from SAP in the future, your database backup may not be fully compatible.

  **Note**
  
  - **Full Recovery** — You can perform accumulated backups and move back to a specific point in time.
  
  - **Simple Recovery** — You can back up only the whole database; after the restoration, the database goes back to exactly the same point at which it was backed up.

**Example**

The following table summarizes the main options for each backup type:

<table>
<thead>
<tr>
<th>Backup Type</th>
<th>Full Backup and Differential Backup and/or Transaction Log Backup</th>
<th>Full Backup</th>
<th>Full Backup and Transaction Log Backup</th>
</tr>
</thead>
<tbody>
<tr>
<td><strong>Tool</strong></td>
<td>Remote support platform for SAP Business One</td>
<td>Microsoft SQL Server Management Studio</td>
<td>Microsoft SQL Server Management Studio</td>
</tr>
<tr>
<td><strong>Recovery model</strong></td>
<td>Full</td>
<td>Simple</td>
<td>Full</td>
</tr>
<tr>
<td><strong>Installation effort</strong></td>
<td>Low</td>
<td>Medium</td>
<td>High</td>
</tr>
<tr>
<td><strong>Monitoring effort</strong></td>
<td>Low</td>
<td>Medium</td>
<td>Medium</td>
</tr>
</tbody>
</table>
### Backup Type

<table>
<thead>
<tr>
<th>Backup Type</th>
<th>Full Backup and Differential Backup and/or Transaction Log Backup</th>
<th>Full Backup</th>
<th>Full Backup and Transaction Log Backup</th>
</tr>
</thead>
<tbody>
<tr>
<td>Backup destination</td>
<td>Disk or network share</td>
<td>Disk or tape</td>
<td>Disk or tape</td>
</tr>
<tr>
<td>Automatic file backup</td>
<td>Yes</td>
<td>Yes</td>
<td>No</td>
</tr>
<tr>
<td>Complexity</td>
<td>Low</td>
<td>Medium</td>
<td>High</td>
</tr>
</tbody>
</table>

**Note**

SAP Business One Product Support only accepts backups on destination disks. If you back up on tape, you must first restore it from there, and back it up again, using a destination disk, prior to sending it to SAP Support.

### 8.1.4.3 Troubleshooting Backups

To ensure that your database backups are successful, check your server at regular intervals. Ensure that you have enough disk space on the server on which your database is stored. If you store your backup on another server, check that there is enough free space.

The basic checks include:

- Drive space
- Disk subsystem errors
- Tape drive errors
- Event Viewer
- Regular evaluation of your recovery and restore process

### Procedure

1. To check the disk space, do the following:
   1. In the Microsoft Windows *My Computer* window, right-click *Hard Disk Drives* and choose *Properties*. The *Properties* window appears.
   2. Check the free space on your hard disk.
      
      The free space you need on your hard disk depends on the volume of data you process each day. Depending on the disk system and the tape drive, scan for disk errors at regular intervals. For more information, see your tape drive documentation.

2. To check whether errors occurred in the operating system or on the database server, do the following:
   1. In Windows, choose *Start → Control Panel → Administrative Tools → Event Viewer*. 
Events that occur in the system are stored in three different logs. Within these logs, events are classified as Information, Warning, or Error.

Events that occur within the database server are stored in the Application folder. In the Source column of the application log, you can see the source application for a specific event.

2. Double-click an event to display more information.
3. In the Application Log, look for error events that may indicate backup failures.
   If you perform network backups, look for network errors in the System and Application logs.

### 8.1.5 Restoring Databases

If a failure damages the system, restoring the database restores the integrity of the data in most cases. Ideally, the downtime of the system will be minimal and no data should be lost. Develop a restore strategy that considers the maximum downtime allowed for your system, and estimate how much time you need to react to a system failure. Analyze the problem and take appropriate measures.

You may be required to change hardware or reinstall the operating system before restoring your database.

Ensure that an employee familiar with the restore procedures is available at all times. Testing of the restore procedures improves the chances of a successful and fast recovery of your data. We recommend doing test backups and test restores at regular intervals.

Restore the database in the following situations:

- Hardware failure
- Migration to a new hardware
- Logical errors
- Virus
- Testing

### 8.1.5.1 Restore Checklist

The steps below comprise a general procedure for restoring data. You may find that you do not need to perform each step for your particular case.

1. Analyze the problem.
2. If possible, save the current active transaction log.

   **Note**

   If the database fails, but Microsoft SQL Server is still available, the transaction log contains data that has not been saved yet. You can save it only if the following are not damaged:
   
   - Hard disk on which the transaction log is saved
   - Hard disk on which the executable files are located

   If you cannot save the transaction log, you can only restore the changes that occurred after the backup of the last transaction log.

3. Use the necessary hardware.
4. Configure your database server.
5. Restore your last full backup.
6. Restore the transaction log.
7. Test all executed measures.
8. Release to productive operation.

8.1.5.2 Saving Current Transaction Logs

⚠️ Caution

Before you start the restore process, verify that the installed service pack has not changed since the time of the backup.

Procedure

1. Insert a new tape and, to open SQL Server Management Studio, in Windows, choose Start → All Programs → Microsoft SQL Server 2008 → SQL Server Management Studio.
2. Select the relevant database, right-click it, and choose the New Query menu.
3. In the Query window, run the following command:

   ```sql
   BACKUP LOG <sid> TO <tape> WITH NO_TRUNCATE, FORMAT
   ```

   Where:
   - `<sid>` is name of the database, for example, sbodemo_us
   - `<tape>` is your backup tape name (case sensitive)

4. After saving the transaction log file, you can change any damaged hardware and, if necessary, reinstall your operating system and your Microsoft SQL Server database, as described in Installing SAP Business One.
5. Restore your last full database backup.
   The database is now in the same condition as it was when the backup was carried out. After you restore the transaction logs, finished transactions are applied to the database again.
6. Perform a rollforward until the end of the transaction log.
   The database is now in the same condition as it was at the time of the last transaction log backup. Since this condition is not consistent, perform a rollback for all unfinished transactions.
   The `<msdb>` database stores the history of backups and of restore operations in the backup set and backup file of the tables. If the msdb database is available, the recovery is based on the saved history in msdb. For more information, see Restoring Data When msdb Is Available.
   If the system database msdb is not available, you have to restore it and reconstruct the history. For more information, see Restoring Data When msdb Is Unavailable.

Recommendation

To ensure a successful restore operation, you can test the restore process against a test database. If you use the transaction log file, we recommend testing all procedures thoroughly.
8.1.5.3 Restoring Backup Files and Application Folders

To restore backup files and application folders, perform the following procedures:

1. Extract the files from the backup archive, including:
   - Database backup .zip file
   - Application folder backup archive files
2. Extract the application folder backup archive files to separate folders.
3. Manually copy the extracted files back to the original shared folders.

8.1.5.4 Restoring Data When msdb Is Available

This procedure provides instructions for restoring your database when the database msdb is available. When you use the history function, the last backups are selected automatically.

Procedure

1. To enable the system to restore the database, close SAP Business One.
2. To open SQL Server Management Studio, in Windows, choose Start → All Programs → Microsoft SQL Server 2008 → SQL Server Management Studio.
3. Right-click the required database and choose Tasks → Restore → Database.
   
   A list of performed backups appears. The last full backup and the subsequent transaction log backups are selected automatically.
4. In the Restore Database window, on the Options tab, select the following options:
   - Overwrite over existing database — To overwrite the existing database, select this option.
   - Preserve the replication settings
   - Prompt before restoring each backup — Prompt the user before restoring each backup to prevent a user from inadvertently restoring a backup.
   - Restrict access to the restored database
   - Restore database file as — In the Restore As column, change the path name if you are restoring the database on a different server.

   Note

   To specify the .bu file, do the following:
   1. In the Microsoft SQL Server Management Studio window, on the General tab, select the From Device radio button and choose the Browse button.
   2. In the Specify Backup window, choose the Add button.
   3. In the Locate Backup File <computer_name> window, from the Files of Type dropdown list, select All Files.
   4. In the hierarchy tree, specify the .bu file that you want to restore.
   5. Choose the OK button.
5. To confirm, choose the **OK** button. The system starts the database restore process.

6. Wait until the following message is displayed:

   **Restore of Database <databasename> completed successfully.**

   SQL Server copies the data from the backups, restoring the database and creating all dependent files.

### 8.1.5.5 Restoring Data When msdb Is Unavailable

This section provides instructions for restoring your database when the history in the database <msdb> is not available, for example, after you reinstall SQL Server. For this procedure, you need your last full backup and all subsequent backups of the transaction log.

**Procedure**

1. To enable the system to restore the database, close SAP Business One.
2. To open SQL Server Management Studio, in Windows, choose **Start ➔ All Programs ➔ Microsoft SQL Server 2008 ➔ SQL Server Management Studio**.
3. Create a new database as follows:
   1. Right-click the **Databases** folder and choose **Tasks ➔ Restore ➔ Database**.
      The **Restore Database** window appears.
   2. Specify a name for your new database (the name of your company in SAP Business One).
4. Right-click the new database and choose **Tasks ➔ Restore ➔ Database**.
5. Select the **Restore: From Device** option and choose the **Browse** button.
6. In the **Specify Backup** window, choose the **Add** button.
7. In the **Locate Backup File** window, locate and select the file containing your last full backup.
   Choose the **OK** button.
8. In the **Specify Backup** window that opens, locate and select the file containing your last full backup.
   Choose the **OK** button.
9. In the **Restore Database** window, select the required back sets and on the **Options** tab make the following settings:
   o Select the **Overwrite the existing database** checkbox.
   o Under the **Restore As** column, change the path, if necessary, for example, if you are restoring the database on a different server where the path name does not exist.
   o In the **Recovery completion state** area, select the **Leave database non-operational but able to restore additional transaction logs** option.
      Choose the **OK** button.
      The system starts restoring the database.
10. Wait for the following message:
    **Restore of Database <sid> completed successfully.**
    Continue to the procedure for restoring transaction logs.
8.1.5.5.1 Restoring Transaction Logs

Procedure

1. Right-click the database you want to restore and choose Task → Restore → Transaction Log.
2. Select the Restore: From Device option and choose the Browse button.
3. In theSpecify Backup window, choose the Add button.
4. In theLocate Backup File window that appears, locate and select the file containing your last full backup. Choose the OK button, and do the same in the Specify Backup window that appears.
5. In the Restore Database window, on the Options tab, make the following settings:
   - Select Overwrite the existing database.
   - In the Recovery completion state area, select the Leave database not operational but able to restore additional transaction logs option.
   - Choose the OK button.
   - The system starts to restore the database.
6. Repeat this procedure for all transaction logs.

When you reach the last transaction log, in the Recovery Completion State pane, select the Leave database operational option. No additional transaction logs can be restored.

8.1.5.6 Troubleshooting Restore

The only way to verify that you can do so is to regularly restore backups using the same medium that you would use in disaster recovery.

Recommendation

At regular intervals, perform the procedures that would take place in case of a disaster, including the restore process of full and transaction log backups.

8.2 Data Transfer Workbench for SAP Business One

SAP Business One implementations require you to move data from legacy systems to the new SAP Business One system. Business data (such as customers, vendors, and products) must be available in the new system before it goes live.

Data Transfer Workbench provides a wizard that imports new data into SAP Business One and updates existing data. To simplify the preparation of data for the import, SAP provides predefined data file templates. Data Transfer Workbench records import activities so you can track the data migration process.

For more information, see the Data Transfer Workbench online help file in the document resource center at http://service.sap.com/smb/sbocustomer/documentation.

The data migration process consists of the following tasks:
1. Extracting data files from your legacy system
2. Cleaning data
3. Mapping data and converting data
4. Importing data into SAP Business One
5. Checking the results of the import

8.3 Stored Procedures

The stored procedures listed below are all used in the SAP Business One application. The first table is for the SBO-COMMON database and the second one is for the company database.

⚠️ Caution

You must not rename or remove any of the items in the list; otherwise, errors may occur when running SAP Business One.

### SBO-COMMON Database Procedures

<table>
<thead>
<tr>
<th>SBO-COMMON Procedures</th>
</tr>
</thead>
<tbody>
<tr>
<td>ClearEnumValues</td>
</tr>
<tr>
<td>DeleteAllEnumsAndClasses</td>
</tr>
<tr>
<td>DeleteAllObjects</td>
</tr>
<tr>
<td>DeleteAllPropertyDefs</td>
</tr>
<tr>
<td>DeleteClassDef</td>
</tr>
<tr>
<td>DeleteDependentProperties</td>
</tr>
<tr>
<td>DeleteEnumType</td>
</tr>
<tr>
<td>DeleteMetaObject</td>
</tr>
<tr>
<td>DeleteMetaProperty</td>
</tr>
<tr>
<td>DeleteMetaRelation</td>
</tr>
<tr>
<td>DeletePropertyDef</td>
</tr>
<tr>
<td>InsertClassDef</td>
</tr>
<tr>
<td>InsertClassDefId</td>
</tr>
<tr>
<td>InsertEnumType</td>
</tr>
<tr>
<td>InsertEnumTypeld</td>
</tr>
<tr>
<td>InsertEnumValue</td>
</tr>
<tr>
<td>InsertMetaObject</td>
</tr>
</tbody>
</table>
### SBO- COMMON Procedures

<table>
<thead>
<tr>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>InsertMetaProperty</td>
</tr>
<tr>
<td>InsertMetaRelation</td>
</tr>
<tr>
<td>InsertPropertyDef</td>
</tr>
<tr>
<td>InsertPropertyDefId</td>
</tr>
<tr>
<td>NumberPropertyDefs</td>
</tr>
<tr>
<td>NumberRelations</td>
</tr>
<tr>
<td>OBSSp_GetNextExecFromSchedule</td>
</tr>
<tr>
<td>OBSSp_GetServiceRecord</td>
</tr>
<tr>
<td>OBSSp_UpdateScheduleRecord</td>
</tr>
<tr>
<td>OBSSp_UpdateServiceExec</td>
</tr>
<tr>
<td>RGSp_UpdateInstance</td>
</tr>
<tr>
<td>RGSp_UpdateLicense</td>
</tr>
<tr>
<td>TmSp_AliasUpdate</td>
</tr>
<tr>
<td>TmSP_CheckDiskSpace</td>
</tr>
<tr>
<td>TmSp_CopyCompany</td>
</tr>
<tr>
<td>TmSp_GetCompList</td>
</tr>
<tr>
<td>TmSP_GetDbSizeByDrives</td>
</tr>
<tr>
<td>TmSp_GetServerTime</td>
</tr>
<tr>
<td>TmSp_GetUsers</td>
</tr>
<tr>
<td>TmSp_Installer_CreateTmSp</td>
</tr>
<tr>
<td>TmSp_Installer_SetFieldValue</td>
</tr>
<tr>
<td>TmSp_RefreshCompList</td>
</tr>
<tr>
<td>TmSp_RestoreCompany</td>
</tr>
<tr>
<td>UpdateClassDef</td>
</tr>
<tr>
<td>UpdateEnumType</td>
</tr>
<tr>
<td>UpdateMetaObject</td>
</tr>
<tr>
<td>UpdateMetaProperty</td>
</tr>
<tr>
<td>UpdateMetaRelationSeqNo</td>
</tr>
<tr>
<td>UpdatePropertyDef</td>
</tr>
<tr>
<td>UpdatePropertyDefSeqNo</td>
</tr>
<tr>
<td>ClearEnumValues</td>
</tr>
</tbody>
</table>
### SBO-COMMON Procedures

<table>
<thead>
<tr>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>DeleteAllEnumsAndClasses</td>
</tr>
<tr>
<td>DeleteAllObjects</td>
</tr>
<tr>
<td>DeleteAllPropertyDefs</td>
</tr>
<tr>
<td>DeleteClassDef</td>
</tr>
<tr>
<td>DeleteDependentProperties</td>
</tr>
<tr>
<td>DeleteEnumType</td>
</tr>
<tr>
<td>DeleteMetaObject</td>
</tr>
<tr>
<td>DeleteMetaProperty</td>
</tr>
<tr>
<td>DeleteMetaRelation</td>
</tr>
<tr>
<td>DeletePropertyDef</td>
</tr>
<tr>
<td>InsertClassDef</td>
</tr>
</tbody>
</table>

### Company Database Procedures

<table>
<thead>
<tr>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>_TmSp_AliasUpdate_OUSR</td>
</tr>
<tr>
<td>_TmSp_AliasUpdateAfter</td>
</tr>
<tr>
<td>_TmSp_AliasUpdateBefore</td>
</tr>
<tr>
<td>_TmSp_ControlAccountUpgrade_OCRD</td>
</tr>
<tr>
<td>_TmSp_ConvertGrpLine_OACT</td>
</tr>
<tr>
<td>_TmSp_ExpnsUpdateOnDocs</td>
</tr>
<tr>
<td>_TmSp_FormattedSearchUpdate</td>
</tr>
<tr>
<td>_TmSp_MthDate_Update_JDT1</td>
</tr>
<tr>
<td>_TmSp_RestoreIsCommited_OIBT</td>
</tr>
<tr>
<td>_TmSp_SetCategoryAtOFPR</td>
</tr>
<tr>
<td>_TmSp_SetLineNumAtADO3</td>
</tr>
<tr>
<td>_TmSp_SetLineNumAtDOC3</td>
</tr>
<tr>
<td>_TmSp_SetLineNumAtDOC5</td>
</tr>
<tr>
<td>_TmSp_SetLineSeqAtDOC4</td>
</tr>
<tr>
<td>_TmSp_SetLineSeqAtPMN5</td>
</tr>
<tr>
<td>_TmSp_SetUniqueDocEntryAtOCRD</td>
</tr>
</tbody>
</table>
## Company Database Procedures

- `_TmSp_ShekelUpdate`
- `_TmSp_UpdateCreateDateOnOINM`
- `_TmSp_UpdateDoubleName`
- `_TmSp_VariableUpdate_OUQR`
- `_TmSp_VatSumCalc`
- `SBO_SP_PostTransactionNotice`
- `SBO_SP_PostTransactionSupport`
- `SBO_SP_TransactionNotification`
- `SBO_SP_TransactionSupport`
- `TmSp_adding_To_OITW`
- `TmSp_AddSqlUser`
- `TmSp_ChooseCIN4Correction`
- `TmSp_ChooseINV4Correction`
- `TmSp_ConGrpLine_OACT_recur`
- `TmSp_ConvertGrpLine_OACT`
- `TmSp_CorrActReport`
- `TmSp_CorrActReport_BP`
- `TmSp_CorrActReport_BP_Split`
- `TmSp_CorrActReport_Split`
- `TmSp_DragOn`
- `TmSp_DragOnPk`
- `TmSp_FifoGetINM_Records`
- `TmSp_GetDocVatTotals`
- `TmSp_GetMaxRange`
- `TmSp_GetOpenRCTs`
- `TmSp_GetOpenRINs`
- `TmSp_GetUsers`
- `TmSp_GetWDD`
- `TmSp_Installer_SetFieldValue`
- `TmSp_OpportAnalysis`
- `TmSp_OpportAnalysis_CRD`
### Company Database Procedures

<table>
<thead>
<tr>
<th>Procedure Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>TmSp_OpportAnalysis_ITM</td>
</tr>
<tr>
<td>TmSp_OpportAnalysis_SLP</td>
</tr>
<tr>
<td>TmSp_OutboxSync</td>
</tr>
<tr>
<td>TmSp_PicknPackCreateTempTable</td>
</tr>
<tr>
<td>TmSp_Purch_An_Crd_Det_Y</td>
</tr>
<tr>
<td>TmSp_Purch_An_Crd_Grp_M</td>
</tr>
<tr>
<td>TmSp_Purch_An_Crd_Grp_Y</td>
</tr>
<tr>
<td>TmSp_Purch_An_Crd_Sng_M</td>
</tr>
<tr>
<td>TmSp_Purch_An_Crd_Sng_Y</td>
</tr>
<tr>
<td>TmSp_Purch_An_Itm_Det_Y</td>
</tr>
<tr>
<td>TmSp_Purch_An_Itm_Grp_M</td>
</tr>
<tr>
<td>TmSp_Purch_An_Itm_Grp_Y</td>
</tr>
<tr>
<td>TmSp_Purch_An_Itm_Sng_M</td>
</tr>
<tr>
<td>TmSp_Purch_An_Itm_Sng_Y</td>
</tr>
<tr>
<td>TmSp_Purch_An_Slp_Sng_M</td>
</tr>
<tr>
<td>TmSp_Purch_An_Slp_Sng_Y</td>
</tr>
<tr>
<td>TmSp_RebuildAcctMatch</td>
</tr>
<tr>
<td>TmSp_RebuildMatchHistory</td>
</tr>
<tr>
<td>TmSp_Replace_Table</td>
</tr>
<tr>
<td>TmSp_Sales_An_Crd_Det_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Crd_Grp_M</td>
</tr>
<tr>
<td>TmSp_Sales_An_Crd_Grp_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Crd_Sng_M</td>
</tr>
<tr>
<td>TmSp_Sales_An_Crd_Sng_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Itm_Det_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Itm_Grp_M</td>
</tr>
<tr>
<td>TmSp_Sales_An_Itm_Grp_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Itm_Sng_M</td>
</tr>
<tr>
<td>TmSp_Sales_An_Itm_Sng_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Slp_Sng_M</td>
</tr>
<tr>
<td>TmSp_Sales_An_Slp_Sng_Y</td>
</tr>
<tr>
<td>Company Database Procedures</td>
</tr>
<tr>
<td>------------------------------------------------------------------</td>
</tr>
<tr>
<td>TmSp_SetBalanceByJdt</td>
</tr>
<tr>
<td>TmSp_SetBgtAccumulators_ByJdt</td>
</tr>
<tr>
<td>TmSp_SetGIStamp</td>
</tr>
<tr>
<td>TmSp_SetVendorDeductPercent</td>
</tr>
<tr>
<td>_TmSp_AliasUpdate_OUSR</td>
</tr>
<tr>
<td>_TmSp_AliasUpdateAfter</td>
</tr>
<tr>
<td>_TmSp_AliasUpdateBefore</td>
</tr>
<tr>
<td>_TmSp_ControlAccountUpgrade_OCRD</td>
</tr>
<tr>
<td>_TmSp_ConvertGrpLine_OACT</td>
</tr>
<tr>
<td>_TmSp_ExpsnsUpdateOnDocs</td>
</tr>
<tr>
<td>_TmSp_FormattedSearchUpdate</td>
</tr>
<tr>
<td>_TmSp_MthDate_Update_JDT1</td>
</tr>
<tr>
<td>_TmSp_RestoreIsCommited_OIBT</td>
</tr>
<tr>
<td>_TmSp_SetCategoryAtOFPR</td>
</tr>
<tr>
<td>_TmSp_SetLineNumAtADO3</td>
</tr>
<tr>
<td>_TmSp_SetLineNumAtDOC3</td>
</tr>
<tr>
<td>_TmSp_SetLineNumAtDOC5</td>
</tr>
<tr>
<td>_TmSp_SetLineSeqAtDOC4</td>
</tr>
<tr>
<td>_TmSp_SetLineSeqAtPMN5</td>
</tr>
<tr>
<td>_TmSp_SetUniqueDocEntryAtOCRD</td>
</tr>
<tr>
<td>_TmSp_ShekelUpdate</td>
</tr>
<tr>
<td>_TmSp_UpdateCreateDateOnOINM</td>
</tr>
<tr>
<td>_TmSp_UpdateDoubleName</td>
</tr>
<tr>
<td>_TmSp_VariableUpdate_OUQR</td>
</tr>
<tr>
<td>_TmSp_VatSumCalc</td>
</tr>
<tr>
<td>SBO_SP_PostTransactionNotice</td>
</tr>
<tr>
<td>SBO_SP_PostTransactionSupport</td>
</tr>
<tr>
<td>SBO_SP_TransactionNotification</td>
</tr>
<tr>
<td>SBO_SP_TransactionSupport</td>
</tr>
<tr>
<td>TmSp_adding_To_OITW</td>
</tr>
<tr>
<td>TmSp_AddSqlUser</td>
</tr>
</tbody>
</table>
### Company Database Procedures

<table>
<thead>
<tr>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>TmSp_ChooseCIN4Correction</td>
</tr>
<tr>
<td>TmSp_ChooseINV4Correction</td>
</tr>
<tr>
<td>TmSp_ConGrpLine_OACT_recurs</td>
</tr>
<tr>
<td>TmSp_ConvertGrpLine_OACT</td>
</tr>
<tr>
<td>TmSp_CorrActReport</td>
</tr>
<tr>
<td>TmSp_CorrActReport_BP</td>
</tr>
<tr>
<td>TmSp_CorrActReport_BP_Split</td>
</tr>
<tr>
<td>TmSp_CorrActReport_Split</td>
</tr>
<tr>
<td>TmSp_DragOn</td>
</tr>
<tr>
<td>TmSp_DragOnPk</td>
</tr>
<tr>
<td>TmSp_FifoGetINM_Records</td>
</tr>
<tr>
<td>TmSp_GetDocVatTotals</td>
</tr>
<tr>
<td>TmSp_GetMaxRange</td>
</tr>
<tr>
<td>TmSp_GetOpenRCTs</td>
</tr>
<tr>
<td>TmSp_GetOpenRINs</td>
</tr>
<tr>
<td>TmSp_GetUsers</td>
</tr>
<tr>
<td>TmSp_GetWDD</td>
</tr>
<tr>
<td>TmSp_Installer_SetFieldValue</td>
</tr>
<tr>
<td>TmSp_OpportAnalysis</td>
</tr>
<tr>
<td>TmSp_OpportAnalysis_CRD</td>
</tr>
<tr>
<td>TmSp_OpportAnalysis_ITM</td>
</tr>
<tr>
<td>TmSp_OpportAnalysis_SLP</td>
</tr>
<tr>
<td>TmSp_OutboxSync</td>
</tr>
<tr>
<td>TmSp_PicknPackCreateTempTable</td>
</tr>
<tr>
<td>TmSp_Purch_An_Crd_Det_Y</td>
</tr>
<tr>
<td>TmSp_Purch_An_Crd_Grp_M</td>
</tr>
<tr>
<td>TmSp_Purch_An_Crd_Grp_Y</td>
</tr>
<tr>
<td>TmSp_Purch_An_Crd_Sng_M</td>
</tr>
<tr>
<td>TmSp_Purch_An_Crd_Sng_Y</td>
</tr>
<tr>
<td>TmSp_Purch_An_Itm_Det_Y</td>
</tr>
<tr>
<td>TmSp_Purch_An_Itm_Grp_M</td>
</tr>
</tbody>
</table>
### Company Database Procedures

<table>
<thead>
<tr>
<th>Procedure</th>
</tr>
</thead>
<tbody>
<tr>
<td>TmSp_Purch_An_Item_Grp_Y</td>
</tr>
<tr>
<td>TmSp_Purch_An_Item_Sng_M</td>
</tr>
<tr>
<td>TmSp_Purch_An_Item_Sng_Y</td>
</tr>
<tr>
<td>TmSp_Purch_An_Slp_Sng_M</td>
</tr>
<tr>
<td>TmSp_Purch_An_Slp_Sng_Y</td>
</tr>
<tr>
<td>TmSp_RebuildAcctMatch</td>
</tr>
<tr>
<td>TmSp_RebuildMatchHistory</td>
</tr>
<tr>
<td>TmSp_Replace_Table</td>
</tr>
<tr>
<td>TmSp_Sales_An_Crd_Det_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Crd_Grp_M</td>
</tr>
<tr>
<td>TmSp_Sales_An_Crd_Grp_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Crd_Sng_M</td>
</tr>
<tr>
<td>TmSp_Sales_An_Crd_Sng_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Item_Det_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Item_Grp_M</td>
</tr>
<tr>
<td>TmSp_Sales_An_Item_Grp_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Item_Sng_M</td>
</tr>
<tr>
<td>TmSp_Sales_An_Item_Sng_Y</td>
</tr>
<tr>
<td>TmSp_Sales_An_Slp_Sng_M</td>
</tr>
<tr>
<td>TmSp_Sales_An_Slp_Sng_Y</td>
</tr>
<tr>
<td>TmSp_SetBalanceByJdt</td>
</tr>
<tr>
<td>TmSp_SetBgtAccumulators_ByJdt</td>
</tr>
<tr>
<td>TmSp_SetGlStamp</td>
</tr>
<tr>
<td>TmSp_SetVendorDeductPercent</td>
</tr>
<tr>
<td>TmSp_UpdateOIT</td>
</tr>
</tbody>
</table>
# Managing Security in SAP Business One

Your security requirements are not limited to SAP Business One, but apply to your entire system landscape. Therefore, we recommend establishing a security policy that addresses the security issues of the entire company. This section offers several recommendations to help you meet the security demands of SAP Business One.

Your security policy should cover the following aspects:

- **Technical Landscape** — Provides an overview of the technical components and communication paths that SAP Business One uses.
- **User Management and Authentication** — Provides system access to only legitimate users and prevents identity impersonation.
- **Database Authentication** — Introduces a strong password definition mechanism to restrict unauthorized database access.
- **Data Integrity** — Allows specified SAP Business One users to run read-only queries on the company database using query editors to improve data integrity in the database.
- **SAP Business One Authentication and Authorization** — Describes how to restrict access to the SAP Business One database.
- **Network Security** — Supports your communication needs without allowing unauthorized access to your network.
- **Application Security** — Restricts access to users with the necessary permissions.
- **Security Solutions for Microsoft SQL Server and Database Tips** — Provides recommendations for ensuring the security of Microsoft SQL Server.
- **Data Storage Security** — Provides recommendations for secure data storage in SAP Business One.

After establishing a security policy, we recommend that you dedicate sufficient time and resources to implement and maintain the required level of security.

## 9.1 Technical Landscape

In SAP Business One, the System Landscape Directory serves as the security server, which saves database credentials in the SLD database. Database credentials are obtained by supplying SAP Business One logon credentials for authentication against the SLD service. Upon successful authentication, connections to common and company databases are established using database credentials from the SLD service.

The following figure provides an overview of the security workflow for SAP Business One.
This section provides an overview of how SAP Business One supports an integrated approach to user administration and authentication.

9.2 User Management

This section provides an overview of the various types of users and user administration within SAP Business One.

9.2.1 User Types

It is necessary to specify different security policies for different types of users. For example, your policy may specify that individual users who perform tasks interactively must change their passwords on a regular basis, but not users who process job runs. Therefore, SAP classifies the types of users in the application as follows:

Site Users

The site user is not a company user type that can log on to the SAP Business One client application, but serves as site-level authentication for performing the following activities:

- Creating new companies
- Installing or upgrading SAP Business One
• Importing or exporting the license configuration file
• Assigning read-only users
• Configuring security settings in the SLD service
• Registering databases in the SLD service

**B1SiteUser**

The site super user, whose account information should only be known to a few selected system administrators, is B1SiteUser. You can update the password of the B1SiteUser in the System Landscape Directory, on the Security Settings tab, by choosing the Change B1SiteUser Password button. You will need to provide the old password to make the change. The B1SiteUser account cannot be removed.

**Domain Users as Less-Privileged Site Users**

You can assign appropriate domain users as site users to perform administrative tasks that require fewer privileges in the System Landscape Directory. To do so, follow the steps below:

1. **Note**
   Before you can assign domain users as site users, ensure you have entered Windows domain user authentication information during the installation of the System Landscape Directory.

To assign a Windows domain user as a less-privileged site user, do the following:

1. In a Web browser, log on to the System Landscape Directory.
2. On the Security Settings tab, choose the Manage Site Users button.
3. In the Manage Site Users window, in the edit box on the top, enter a domain user account in the format of Domain\User.
4. To assign the domain user as a site user, choose Add.

   **Note**
   You can delete domain-user site users at any time. Additionally, a domain user can even remove itself as a site user. After the removal, the domain user can no longer log on to the System Landscape Directory.

**SAP Business One Company Superusers**

When you create a company, a predefined superuser named manager exists in the system. Due to the password policy, you must change the password of the manager user at the first logon.

The responsibilities of a superuser include:

• Defining users in companies and setting user permissions
• Assigning licenses
• Configuring password policies at the company level
• Upgrading companies
SAP Business One Company Regular Users

You can define company regular users according to different business role requirements.
The responsibilities of a regular user are to perform the relevant business work in the SAP Business One application.

SAP Business One Company Support User

A Support user (user code: Support) is created upon the installation or upgrade of SAP Business One companies. This new user is provided for support and consulting purposes.
The Support user does not require a license to access the system. This can minimize the disruption to business where a user may previously have needed to log off the system to free up a license for support.
While you do not need to assign a license to the Support user, it has the same access rights of a Professional license. Therefore, strict usage rules are applied to the support user to prevent misuse, as follows:
- After logging on to the company using the Support user account, the user must identify him/herself by entering his/her real name and selecting a login reason in the Support User Login window.

- The Support user account can only be used if the remote support platform (RSP) is active (an RSP system status report was uploaded within the last 7 days).
- The usage of the Support user is recorded (including the real name and the login reason). You can review the log records in the Administration -> License -> Support User Log window.

Notes for Upgraded Companies

If you have already created a user account Support before the upgrade, the Support user will have the features described above after the upgrade. The licenses assigned to the original user account, the password and all other settings for the original user account remain unchanged. You can transfer any license assignments of this account to another user because they are no longer required by the Support user.

9.2.2 User Administration

This section describes how to add, remove, or lock an SAP Business One user in the application.
Locking a user prevents this user from logging on to SAP Business One. By default, all users are unlocked. However, if the user fails to log on to the system the number of times defined in Administration → Setup → General → Security → Password Administration → Authentications Before User Account is Locked, the user is locked automatically.

Note
Only a superuser can add, remove, lock, or unlock an SAP Business One user.

To add a user in SAP Business One, do the following:

1. In the SAP Business One Main Menu, choose Administration → Setup → General → Users.
2. In the Users - Setup window, specify the required user-specific data.

3. Choose the Add button.

To remove a user in SAP Business One, proceed as follows:

1. In the SAP Business One Main Menu, choose Administration → Setup → General → Users.
2. In the Users - Setup window, in the User Code field, specify the user that you want to delete.
3. Right-click anywhere in the window and choose the Remove button.
4. Choose the Continue button.

To lock or unlock a user in SAP Business One, proceed as follows:

1. In the SAP Business One Main Menu, choose Administration → Setup → General → Users.
2. In the Users - Setup window, in the User Code field, specify the user you want to lock or unlock.
3. In the **Users – Setup** window, do the following:
   - To lock a user, select the **Locked** checkbox.
   - To unlock a user, deselect the **Locked** checkbox.

4. Choose the **Update** button.

### 9.2.2.1 Binding SAP Business One Users to Microsoft Windows Accounts

After binding SAP Business One users to Microsoft Windows domain accounts, the users can log on to SAP Business One without specifying the user credentials.

**Prerequisite**

You have enabled SSO functionality in the SLD. For more information, see [Enabling Single Sign-On](#).

**Manual Binding**

The following procedure describes how to bind SAP Business One users one by one:
1. In the SAP Business One Main Menu, choose Administration → Setup → General → Users.
2. In the Users - Setup window, in the User Code field, specify the user that you want to bind.

![User Code Setup Window]

3. In the Bind with Windows Account field, enter the domain and user name of the Microsoft Windows domain user account to which you want to bind the user.
4. Choose the Update button.

**Copy User Mappings Between Companies**

You can copy user mappings between two companies provided that the same user exists in both companies. Each user is identified by the user code (not the user name).

Typical scenarios for this function are as follows:

- You have moved your company database from a test system to a productive system.
- You have moved your company database to another server.
- You have imported and renamed your company database (the old database also exists on the same server).

To copy user mappings, do the following:

1. Log on to the System Landscape Directory in a Web browser.
2. On the Security Settings tab, in the Authentication section, choose the Copy User Mappings button.
3. In the Copy User Mappings Between Companies window, specify the source and target companies.
Note

To be available for selection, the servers must be registered in the System Landscape Directory. However, the company database versions do not matter.

4. To display SAP Business One users whose mappings can be copied, choose the Check button. If a user exists only in the source company but is bound to a domain account, the user is displayed as missing in the target company. However, if a user exists only in the target company, the user is not displayed.

5. To copy user mappings to the target company, choose the Copy button.

9.2.2.2 Enabling Single Sign-On

SAP Business One supports single sign-on (SSO) functionality. You can bind an SAP Business One user account to a Microsoft Windows domain account. After starting SAP Business One, users are able to bypass the Choose Company window and start using the application without being prompted to enter their SAP Business One logon credentials.

Note

After enabling SSO, the Choose Company window displays only the companies to which your Windows account is bound.

Caution

Enabling SSO in the SLD activates this functionality for all company databases in the landscape.

Caution

Before enabling SSO, ensure that the machine on which you have installed the server tools for SAP Business One is a member of the same Microsoft Windows domain as the machines on which SAP Business One clients are installed.

Procedure

To enable single sign-on functionality for all users, do the following:

1. To open SAP Business One Service Manager, in Windows, choose Start → All Programs → SAP Business One → Server Tools → Service Manager.
   - In the SAP Business One Service Manager window, from the Service dropdown list, select License Manager.
   - Choose the Settings button.
2. To access the SLD service, in the General Settings window, choose the Configure Security button.

![General Settings window](image)

1. **Note**

   You can also access the SLD service in a Web browser on the machine on which the SLD service is running using the following URL:
3. A Web browser opens and displays the logon page for the SLD service.
4. To log on, enter the site user name and password, and then choose the Log On button.
6. If you want to prevent logons using SAP Business One user accounts and enforce single sign-on using domain accounts, select the Disable logons with SAP Business One User Accounts checkbox.
   If you keep this checkbox deselected, users can log on using both SAP Business One user accounts and Windows domain accounts.
7. Choose the Update button.

Result

Each user must confirm the binding upon first logon. After confirmation, the user can log on to SAP Business One, using the bound Windows account.

If the system administrator has not disabled logons using SAP Business One user accounts, you can still log on with an SAP Business One user account (which does not have to be bound to a Windows account), as below:
1. In the logon window, deselect the Logon with Windows Account checkbox (or in the Choose Company window, deselect the Log on with Current Domain User checkbox).
2. Manually enter the company database name.
3. Enter your SAP Business One user name and password.
4. Choose the OK button.

⚠️ Caution

If the system administrator has disabled logons using SAP Business One user accounts, you must bind each SAP Business One user to a Windows account and each user must confirm the binding; otherwise, logon is not possible.

9.2.3 User Authentication

As standard practice, SAP Business One and the database authenticate users by their user codes and passwords. You can change passwords at any time. In addition, the application checks the password validity of each logon attempt according to the selected security level.

If you are required to change your password, the application displays the Password Expiration window. You must change the password to log on.

The new password must comply with the settings of the selected security level, containing at least:
- x characters
- x lowercase characters
- x uppercase characters
- x numeric digits
- x non-alphanumeric characters
The application saves passwords in the database in encrypted form. The last n passwords are also encrypted. When appraising a new password, the application first encrypts it and then compares it with the saved ones.

The password policy defines global guidelines and rules for password settings, such as the following:

- Time interval between password changes
- Required and forbidden letters and characters
- Minimum required number of characters
- Number of logon attempts before the system locks the user account

Password policies improve the security of SAP Business One and enable administrators to apply the required security level for their organization.

\[\text{Note}\]

Only superusers can change a security level.

SAP Business One supports the following methods for increasing the security level of user authentication:

- Increase the complexity of the password.
- Increase the frequency of password changes.

For more information about working with passwords in SAP Business One, see SAP Note 978292.

9.3 Database Authentication

The default user name of the database administrator is \texttt{sa} and it has full authorization. Therefore, you must assign a strong \texttt{sa} password, even on servers that are configured to require Microsoft Windows Authentication. This ensures that a blank or weak \texttt{sa} password is not exposed.

A strong password is the first step to securing your system. A password that can be easily guessed or compromised using a simple dictionary attack makes your system vulnerable. A strong password has the following characteristics:

- Contains alphabetic, numeric, and special characters
- Is at least seven characters in length
- Is NOT a common word or name
- Does NOT contain a name or user name
- Is significantly different from previous passwords

\[\text{Procedure}\]

To set the password for the \texttt{sa} logon, do the following:

1. Log on to the server as a domain or local Windows Administrator.
2. In Windows, choose \texttt{Start} \rightarrow \texttt{All Programs} \rightarrow \texttt{Microsoft SQL Server 2008} \rightarrow \texttt{SQL Server Management Studio}.

   Upon first logon, in the \texttt{Connect to Server} window, enter the server name (if required) and under \texttt{Authentication}, select \texttt{Windows Authentication}.

\[\text{Note}\]

We recommend that you create another superuser account with the same authorization as the \texttt{sa} user.
3. In the Object Explorer window, under the SQL Server instance, expand Security → Logins. Right-click sa and choose the Properties menu.

4. On the General page, enter and confirm the new password for the sa login.

5. Choose the OK button and close the SQL Server Management Studio window.

⚠️ Caution

To prevent dictionary attacks, create a substitute user for sa that can take daily responsibility for the SQL Server database assessment. For more information, see Setting Up an Alternative Admin User.

### 9.4 Data Integrity

To improve data integrity in the database and ensure that changes are not to the database while the application is running, you can allow specified SAP Business One users to run read-only queries on the company database using the query editors in SAP Business One. You can restrict queries to read-only statements. This means user permissions are read only for SQL executions, and querying the database is done using a read-only user.

### 9.4.1 Adding New Databases

For databases to appear on the logon screen of the application, they must be registered with SAP Business One. You can add databases using only the System Landscape Directory.

⚠️ Caution

The machine running the SLD service and license server should not be accessible physically to any users except those who own the site user password.

Locate the machine running the SLD service and license server in a place that is not easily accessible to unauthorized persons.

#### Procedure

To add new databases, do the following:

1. To open SAP Business One Service Manager, in Windows, choose Start → All Programs → SAP Business One → Server Tools → Service Manager.
   
   o In the SAP Business One Service Manager window, from the Service dropdown list, select License Manager.
   
   o Choose the Settings button.
2. To access the SLD service, in the General Settings window, choose the Configure Security button.

! Note
You can also access the SLD service in a Web browser on the machine on which the SLD service is running using the following URL:
A Web browser opens and displays the logon page for the SLD service.

3. To log on, enter the site user name and password and choose the Log On button.

4. On the Servers and Companies tab, in the Servers area, choose the Add button.

5. In the Add Server window, specify the following:

   - **Server Name** — Enter the name or IP address of the database server that you want to add.
     
     **Caution**
     
     Ensure that the name of the server on which you installed Microsoft SQL Server does not contain any special characters, such as: &, <, >, ", or ".

   - **Database Authentication** — Select the type of database authentication you want to use.
     
     **Recommendation**
     
     Select the Database Authentication option, as Windows Authentication has the following limitations:
     
     - Windows authentication in SAP Business One is a server level configuration. All users on the same SAP Business One server can use Windows authentication to connect to Microsoft SQL Server.
     - Windows authentication requires you to maintain each computer added to the domain, while SQL Server authentication shares database users (such as sa) on the same SAP Business One server.
     - Windows authentication requires the Microsoft Windows account on which the SLD service runs to have administrative permissions on the database.
     
     For more information about configuring trusted connections, see Troubleshooting Security.

   - **Database User Name** — Enter the user name of the administrator account for the database.
   - **Database User Password** — Enter the password of the administrator account for the database.

6. To add the database server, choose the OK button.
9.4.2 Editing Existing Databases

To edit an existing database server in the SLD, do the following:

1. Log on to the SLD service. For more information, see Adding New Databases.
2. On the Servers and Companies tab, in the Servers area, select the database server you want to edit. Choose the Edit button.
3. In the Edit Server window, specify the following:
   - **Database Authentication** — Select the type of database authentication you want to use.
   - **Database User Name** — Enter the user name of the administrator account for the database.
   - **Database User Password** — Enter the password of the administrator account for the database.

   **Recommendation**

   Select the **Database Authentication** option, as **Windows Authentication** has the following limitations:
   - Windows authentication in SAP Business One is a server level configuration. All users on the same SAP Business One server can use Windows authentication to connect to Microsoft SQL Server.
   - Windows authentication requires you to maintain each computer added to the domain, while SQL Server authentication shares database users (such as sa) on the same SAP Business One server.
   - Windows authentication requires the Microsoft Windows account on which the SLD service runs to have administrative permissions on the database.

   For more information about configuring trusted connections, see Troubleshooting Security.

4. To save the new settings, choose the OK button.

9.4.3 Managing Encryption Keys

You can encrypt data in SAP Business One company databases using a static key or dynamic key.
We strongly recommend you use a dynamic key to encrypt SAP Business One databases.

**Procedure**

To enable the use of dynamic keys, do the following:

1. Log on to the SLD service. For more information, see *Adding New Databases*.
2. On the *Security Settings* tab, in the *Encryption Key Management* area, choose the *Enable Dynamic Key* button.

   **Note**

   After enabling the use of dynamic keys, you can generate a new dynamic key at any time. To do so, choose the *Enable Dynamic Key* button again.

   **Caution**

   Enabling the use of dynamic keys is an irreversible process.

3. Open the SAP Business One client application, log on to each of your company databases in turn, and accept to update the company database.

   Note that this has to be done for all company databases on the servers registered in the System Landscape Directory.

### 9.5 SAP Business One Authentication and Authorization

SAP Business One has a mechanism to protect the database from easy changes through direct access. The advantages of restricting access to the SAP Business One database are:

- End users are not exposed to database credentials and so cannot change the databases directly, which protects the databases from being changed or attacked.
- Database credentials are stored in the license server and end users can access the database only after the application performs a successful site user authentication through the license server.

### 9.5.1 Restricting Database Access

SAP Business One has a mechanism to protect the database from easy changes through direct access. The advantages of restricting access to the SAP Business One database are:

- End users are not exposed to database credentials and so cannot change the databases directly, which protects the databases from being changed or attacked.
- Database credentials are stored in the System Landscape Directory (SLD) database and end users can access the database only after the application performs a successful site user authentication through the System Landscape Directory.
The System Landscape Directory is the central repository for credentials information, including the database user ID and password (one for all SAP Business One users).

The database credentials are stored safely in the SLD database, with additional encryption.

The security workflow is as follows:

1. Database consumers, such as the SAP Business One client, DI-API, and Services, provide their SAP Business One credentials (SAP Business One user ID and password) to authenticate against the SLD.
2. Following successful authentication, the SLD supplies its credentials and SAP Business One uses them to connect.

For more information, see Technical Landscape.

You can use the SLD service to create different database user accounts for each company database. After creating accounts, SAP Business One does not access company databases using the database administrator account. Instead SAP Business One uses a different read-only account supplied by the SLD service to access each company database.

### 9.5.2 Changing Security Levels

You can apply different security levels to database access through the SLD:

1. To access the SLD service, in a Web browser, navigate to the following URL:
   
   https://<Server Address>:<Port>/ControlCenter

2. In the logon page, enter the site user name (B1SiteUser) and password, and then choose the Log On button.

   ![Note]
   
   The site user name is case sensitive.

3. On the Servers and Companies tab, select the appropriate server.
   
   The companies that are registered on the server are displayed in the Companies area.

4. In the Companies area, select the company for which you want to define the security level and choose the Edit button.

5. In the Edit Company window, select one of the following options and choose the OK button:
   
   - Use Database Admin User: SAP Business One accesses the database using an SAP administrator account.
   - To grant read-only authorization to non-superusers for queries (system and user-defined) in SAP Business One, you must manually create a read-only database user and assign it to the company database. For more information, see Queries.
   - Use Specified Database User: The system automatically generates a pair of database users without the administrator privileges. SAP Business One accesses the database using one of the database users, depending on the specific database transaction.
   - Use Specified Database User for Each Business One User: Most secure and recommended. The system automatically generates a pair of database users without the administrator privileges for each SAP Business One user. SAP Business One accesses the database using one of the database users, depending on the login SAP Business One user and the specific database transaction.
Whenever a new SAP Business One user is added, a pair of corresponding database users is added. For the second and third options, you do not have to manually create a read-only database user for queries. For more information, see Queries.

6. If you selected the second or third option, you can configure the SLD service to automatically change the password of the automatically-created database users on a regular basis, as follows:

   1. On the Security Settings tab, in the Authentication area, select the Change Database User Password Every <Number> Days checkbox.
   2. Enter the number of days between password resets.
   3. Choose the Update button.

9.6 Network Security

We strongly recommend using SAP Business One in trusted environments only (corporate LAN with firewall protection).

9.6.1 Communication Channels

TCP provides the communication channels between the following:

- SAP Business One server ⇆ SAP Business One clients
- SAP Business One server ⇆ SAP Business One license server
- SAP Business One server ⇆ the agent of the remote support platform for SAP Business One
- SAP Business One license server ⇆ SAP Business One clients
- System Landscape Directory ⇆ SAP Business One clients

The default communication port is 1433.

The default ports of the SAP Business One license server are 30000 for license communication and 30001 for the license naming service.
The default ports of the SAP Business One license server are 30003 for SSL-encrypted license communication and 30002 for the SSL-encrypted license naming service. The default port of the SLD service is 30010.

9.6.2 SSL Encryption

You can secure the following communication channels using SSL encryption:

- SAP Business One server ↔ SAP Business One clients
- SAP Business One license server ↔ SAP Business One clients

**Note**

Using SSL encryption may degrade network performance. SSL encryption requires certificates, which are time limited and require annual renewal. You can acquire the necessary certificates using either of the following methods:

- Third-party Certificate Authority
  - You can purchase certificates from a third-party global Certificate Authority that Microsoft Windows trusts by default.
- Certificate Authority Server
  - You can configure a Certificate Authority (CA) server to issue certificates. If you choose this method, you must configure all machines in your SAP Business One landscape to trust the CA’s root certificate.

9.6.2.1 Encrypting Communication with Databases

To secure the TCP/IP communication channel between the database server and SAP Business One clients, you can implement SSL encryption. This prevents SAP Business One application data, including the database credentials, from being exposed.

SAP Business One fully supports SQL SSL. We recommend that you implement SSL in SAP Business One without making configuration changes in SAP Business One. For more information, see [http://support.microsoft.com/kb/316898](http://support.microsoft.com/kb/316898) or contact your IT administrator.

For information about Microsoft SSL encryption guidelines, see [www.msdn.microsoft.com](http://www.msdn.microsoft.com) and search for the following topics:

- Net-Library Encryption
- Client Net-Libraries
9.6.2.2 Encrypting Communication with License Servers

To secure the TCP/IP communication channel between the SAP Business One license server and SAP Business One clients, you can implement SSL encryption. Communication between the license server and DI API is also encrypted.

Prerequisites

- You have installed OpenSSL (32-bit) on the SAP Business One license server.
- You have installed OpenSSL on the client machines to which you want to encrypt communication, as follows:
  - If you are using the 32-bit version of the SAP Business One client and DI API, install the 32-bit version of OpenSSL.
  - If you are using the 64-bit version of the SAP Business One client and DI API, install the 64-bit version of OpenSSL.

Procedure

To implement SSL encryption for communication between the SAP Business One license server, do the following:

1. Prepare the following two certificates:
   2. ServerCert.pfx: a PKCS12 format certificate, for license server use.

   **Note**
   - Both certificates include a private key and public key. ServerCert.pfx must be signed by the private key of ClientCert.crt.

   **Note**
   - If you choose to purchase a signed certificate from a trusted third-party global Certificate Authority (CA), ensure that there is a public key certificate for the CA in your Windows Certificate Store.
   - If you do not choose to purchase a signed certificate from a trusted third-party global Certificate Authority (CA), you can manually generate certificates for both the SAP Business One Client and license server. To do so, perform the following:
     1. Navigate to the directory in which OpenSSL is installed (for example, C:\ C:\OpenSSL-Win32\bin).
     2. Enter the following command lines in OpenSSL:
        - To generate a private key for SAP Business One Client, enter the following command:
          ```bash
          openssl genrsa -des3 -out ClientKey.key 1024
          ```
        - To remove the passphrase for the SAP Business One Client certificate, enter the following command:
          ```bash
          openssl rsa -in ClientKey.key -out ClientKey.key
          ```
        - To generate a private key for the license server, enter the following command:
          ```bash
          openssl genrsa -des3 -out ServerKey.key 1024
          ```
        - To remove the passphrase of the license server certificate, enter the following command:
          ```bash
          openssl rsa -in ServerKey.key -out ServerKey.key
          ```
To generate a self-signed certificate for the SAP Business One Client (also used to sign the license server certificate), enter the following command:

`openssl req -new -x509 -key ClientKey.key -out ClientCert.crt -days 3650`

To generate a certificate request from the private key of the certificate for the license server, enter the following command:

`openssl req -new -key ServerKey.key -out ServerCertReq.csr`

To request the SAP Business One Client certificate to sign the license server certificate, enter the following command:

`openssl x509 -req -days 3650 -in ServerCertReq.csr -CA ClientCert.crt -CAkey ClientKey.key -CAcreateserial -out ServerCert.crt`

To create a PKCS12 format certificate for the license server from the private key and public key, enter the following command:

`certificate openssl pkcs12 -export -inkey ServerKey.key -in ServerCert.crt -out ServerCert.pfx`

When the certificates for the SAP Business One Client and license server are ready, import them as follows:

1. To import the certificate for the license server, do the following:
   1. To open the Microsoft Management Console (MMC), choose Start and enter `mmc` in the search box.
   2. In the Console Root window, in the menu bar, choose File → Add/Remove Snap-in...
   3. In the Add or Remove Snap-ins window, select Certificates and then choose Add.
   4. In the Certificates snap-in window, choose the Computer account radio button and then choose Next.
   5. In Select Computer window, choose the Local computer: (the computer this console is running on) radio button, choose Finish, and then choose OK.
   6. In the Console Root window, click Certificates (Local Computer), click the Personal folder, right-click Certificate, and select All Tasks → Import...
   7. In the Certificate Import Wizard window, choose Next.
   8. Choose the location of the license server certificate (ServerCert.pfx) and then choose Next.
   9. Enter the password of the private key (if you generate the certificate yourself, use the password you entered in last the step described in the Prerequisites section), then select the Mark this key as exportable...” checkbox and choose Next.

2. To import the certificate for the SAP Business One Client, do the following:
   1. To open the Microsoft Management Console (MMC), choose Start and enter `mmc` in the search box.
   2. In the Console Root window, in the menu bar, choose File → Add/Remove Snap-in...
   3. In the Add or Remove Snap-ins window, select Certificates and then choose Add.
   4. In the Certificates snap-in window, choose the My user account radio button and then choose Next.
   5. In the Select Computer window, choose Local computer: (the computer this console is running on), choose Finish, and then choose OK.
   6. In the Console Root window, click Certificates (Local Computer), click the Personal folder, right-click Certificate, and select All Tasks → Import...
   7. In the Certificate Import Wizard window, choose Next.
   8. Choose the location of the SAP Business One Client (ClientCert.crt), and then choose Next.

3. Configure the license server:
1. Import a valid SSL certificate to the Windows Certificate Store.
2. In the SAP Business One Service Manager window, from the Service dropdown list, select License Manager.
3. Choose the Settings button.
4. In the General Settings window, choose the Configure SSL button.
5. In the SSL Settings window, choose the Enable button.
6. In the Windows Security window, select the valid SSL certificate that you imported in step 2.
7. Choose the OK button.
4. Configure client machines:
   1. In HKEY_LOCAL_MACHINE\SOFTWARE\SAP\SAP Manage\SAP Business One, add the following registry key:
      - Key name – UseSSLInLicenseConnection
      - Key type – REG_DWORD
      - Key value – 0x0 (disabled) or 0x1 (enabled)
   2. Configure the client machine to trust the root certificate of your certificate authority server.

9.7 Application Security

SAP Business One provides features to ensure that unauthorized access to the application does not occur.

9.7.1 Password Encryption

In SAP Business One, a strong algorithm is used for data encryption and decryption. The site user ID and password are encrypted and saved in the System Landscape Directory.

Recommendation

Set a site user password that is at least as strong as that defined in the company password policy, and change it frequently.

You can change the site user password using the SLD by providing the current password or authenticating with database credentials to prove you have at least a database administration level.

To change the site user password, do the following:
1. To open SAP Business One Service Manager, in Windows, choose Start → All Programs → SAP Business One → Server Tools → Service Manager.
   - In the SAP Business One Service Manager window, from the Service dropdown list, select License Manager.
   - Choose the Settings button.
2. To access the SLD service, in the **General Settings** window, choose the **Configure Security** button.

Note

You can also access the SLD service in a Web browser using the following URL:

https://<hostname>:30010/ControlCenter
3. A Web browser opens and displays the logon page for the SLD service.
4. To log on, enter the site user name and password and choose the Log On button.
5. On the Security Settings tab, in the Site Password area, choose the Change button.
6. In the Change Site Password window, enter the current password, then enter and confirm the new password you want to use.

![Change Site Password](image)

7. To complete the process and change the password, choose the OK button.

### 9.7.2 B1_SHR Folder Permissions

The SAP Business One server installation process creates the B1_SHR folder, which contains the SAP Business One client setup files.

<table>
<thead>
<tr>
<th>Operating System</th>
<th>User</th>
<th>SBO_SHR Permission</th>
</tr>
</thead>
<tbody>
<tr>
<td></td>
<td>User</td>
<td>Read and execute List folder contents Read</td>
</tr>
</tbody>
</table>

### 9.7.3 Queries

The query wizard and query generator enables you to define queries on the SAP Business One database. These tools are designated for SELECT sentences only and cannot be used for any kind of update operation. To protect your data, we recommend that you make sure users have the appropriate permissions. However, the data results returned are not filtered according to the user’s authorization.
Granting Read-Only Authorization for Query Results

To enable an SAP Business One user to view the results of both system and user-defined queries, you can directly grant the user full authorization to the *Execute Non-select SQL Statement* permission item in the *General Authorizations* window in the SAP Business One client application. However, we recommend that you grant read-only authorization to all non-superusers in one of the following ways:

- Do the following:

  **Recommendation**

  1. Configure SAP Business One to access your company database using database users without administrator privileges.

  2. Grant No authorization to all non-superusers in the *General Authorizations* window.

     This way, users with No authorization to the *Execute Non-select SQL Statement* permission item will access the database through a read-only database user while users with authorization to the permission item will access the database through another database user with lower database privileges.

- If you configure SAP Business One to access your company database using a database administrator user, do the following:

  1. Apply No authorization to all users to the *Execute Non-select SQL Statement* item.

  2. Create a read-only database user in SAP Business One and define the user password.

  3. Assign the database user to the company in the *Read-Only DB User* window in the SAP Business One client application. For more information, see the online help.

For more information about configuring the way SAP Business One accesses your company database, see *Restricting Database Access*. 

9.7.4 Add-On Access Protection

When you install an add-on, SAP Business One creates a unique digital signature using the MD5 technique (message-digest algorithm). SAP Business One identifies the add-on by validating its digital signature.

9.7.5 SAP Business One Dashboards

Dashboards are an element of the cockpit, which is delivered as part of SAP Business One. They present an easy-to-understand visualization, such as a bar or pie chart, of transactional data from the SAP Business One database. With SAP Business One, SAP delivers predefined dashboards for financials, sales, and service. In addition, SAP Business One partners and customers can create their own dashboards.

**Recommendation**

When you receive dashboard content from your partner, we recommend that you copy this content to a computer that has a state-of-the-art virus scanning solution with the most current virus signature database installed and scan the file for infections before uploading it to the server.
9.8 Security Solutions for Microsoft SQL Server and Database Tips

We recommend that you take the following actions to ensure the security of your Microsoft SQL Server.

9.8.1 Upgrading Microsoft SQL Server

We recommend upgrading the SQL server to the latest service pack. Furthermore, administrators should regularly consult the SQL Server Security Center at www.microsoft.com.

Note
You must upgrade SAP Business One before upgrading the Microsoft SQL Server if the existing version of SAP Business One does not support the newer SQL version.

For information about the upgrade sequence for Microsoft SQL Server, see the following documents:

- SAP Note 928839.
- “Hardware and Software Requirements for Installing SQL Server 2014” as stipulated by Microsoft® Corp.

9.8.2 Securing Microsoft SQL Server

Since SAP Business One is a two-tier application, much of the application security depends on the database server security and on the authorization mechanism. Be aware that users can access the database using tools other than SAP Business One and, therefore, can modify the logon information. To secure your database, we recommend adhering to Microsoft security guidelines. For more information, see the Microsoft documents at www.microsoft.com.

9.8.2.1 Setting Up an Alternative Admin User

If you are using SQL authentication, when you register a database server in the SLD (9.0 and higher) or license server (release family 8.8), you need to specify a database admin user for the server. This alternative admin user can be used for creating and upgrading companies and performing other landscape management tasks in the SLD.

Procedure

To create an alternative admin user account for maintaining administration tasks for SAP Business One, do the following:

1. In Windows, choose Start → All Programs → Microsoft SQL Server 2008 → SQL Server Management Studio.
2. In the SQL Server Management Studio Object Explorer window, choose Security → Logins.

3. Right-click the Logins folder and choose New Login.

   The Login - New window appears.

4. On the General tab, select SQL Server authentication and enter a strong password.

5. On the Server Roles tab, select sysadmin.

6. Choose the OK button.

When you create a company database, we recommend that you enable the database user per company in SLD. To do so, perform the following:

1. Log on to the SLD service. For more information, see Adding New Databases.

2. Select the appropriate server and company and then choose Edit.

3. In the Edit Company window, select the Use Specified Database User radio button.

   The SLD creates a database user for this company with the appropriate database roles, which is then used by the SAP Business One client to connect to the database.

4. Choose the OK button.

If you are using Microsoft Windows authentication, you must grant SAP Business One admin users the sysadmin and public server roles. When creating or upgrade companies, you must use this admin user to launch the SAP Business One client or setup wizard.

For normal SAP Business One users, you need to grant admin users the following roles:

- For the common database: db_datawriter and db_datareader
- For the company database: db_owner

   **Note**

   You cannot set up a local user which is not in the Active Directory.
9.8.3 Revoking Guest Access to the msdb Database

2. In the Connect to Server window, specify values in the Server name and Authentication fields, and choose the Connect button.
4. In the structure, right-click the Guest user and choose Delete.

9.9 Data Storage Security

The security of the data saved in SAP Business One is generally the responsibility of the database provider and your database administrator. As with your application infrastructure, most of the measures that you should take depend on your strategy and priorities.

There are a few general measures, as well as database-specific measures, that you can take to increase the protection of your data. Details are provided in the following sections:
- Exporting the Configuration File
- Importing the Configuration File
- Configuration Logs and User Settings

9.9.1 Exporting Configuration Files

To secure your data, we recommend that you export your security configuration file right after you finish installing the license server and the SAP Business One server.

The configuration file contains the following important information:
- Site user password
- Database information
- Read-only database user information
- Algorithm information

Procedure

To export the security configuration file, do the following:

1. To open SAP Business One Service Manager, choose Start → All Programs → SAP Business One → Server Tools → Service Manager.
2. In the SAP Business One Service Manager window, from the Service dropdown list, select License Manager and choose the Settings button.
3. To access the SLD service, in the General Settings window, choose the Configure Security button.

Note
You can also access the SLD service in a Web browser using the following URL:

https://<hostname>:30010/ControlCenter
4. A Web browser opens and displays the logon page for the SLD service.
5. To log on, enter the site user name and password and choose the Log On button.
6. On the Security Settings tab, in the Encryption Key Management area, choose the Export Dynamic Key button.

**Recommendation**

The site user password is required if you later import the security configuration file to restore the configured security settings. Thus, keep a record of the site user password when you are exporting the configuration file, especially if you want to change the site user password after the configuration file is exported.

### 9.9.2 Importing Configuration Files

If your license server crashes or is corrupted, you must set up a new license server. After the new license server is started up, to restore all the security settings you had before, you can import the security configuration file.

#### Prerequisites

- You have a record of your old security configuration file. For more information, see Exporting Configuration Files.
- You have placed the appropriate configuration file on the server under the directory: C:\Program Files (x86)\SAP\SAP Business One ServerTools\System Landscape Directory\incoming.

#### Procedure

1. To open SAP Business One Service Manager, choose Start → All Programs → SAP Business One → Server Tools → Service Manager.
2. In the SAP Business One Service Manager window, from the Service dropdown list, select License Manager and choose the Settings button.
3. To access the SLD service, in the General Settings window, choose the Configure Security button.

![General Settings Window]

Note

You can also access the SLD service in a Web browser using the following URL:

https://<hostname>:30010/ControlCenter

4. A Web browser opens and displays the logon page for the SLD service.
5. To log on, enter the site user name and password and choose the Log On button.
6. On the Security Settings tab, in the Encryption Key Management area, choose the Import Dynamic Key button.
7. In the Import Dynamic Key window, do the following:
   - Select the configuration file that you want to import.
   - In the Site User Password For Export field, specify the site user password you had when the configuration file was exported.
   - To import the file, choose the OK button.
9.9.3 Configuration Logs and User Settings

In SAP Business One, configuration changes are logged in files formatted as xxx.pidxxxxx (xxx after pid can be the date, such as 20100325, so that you can find the latest log file) under %UserProfile%\Local Settings\Application Data\SAP\SAP Business One\Log\BusinessOne. The configuration changes include:

- Adding/Removing users
- Changing a user to a superuser / non superuser
- Changing user passwords
- Changing user permissions
- Changing password policy
- Changing company details

**Note**

To find the logs containing changes to company details, do the following:

1. From the SAP Business One Main Menu, choose Administration → System Initialization → Company Details.
2. In the menu bar, choose Tools → Change Logs.

However, the following configurations cannot be logged:

- Changing data ownership authorizations
- Changing data ownership exceptions
- Changing license settings
- Setting Read-Only DB users

If you fail to log on to SAP Business One, the log is recorded in the Event Viewer.
As of SAP Business One 2007, any specific user settings are saved in a file named `b1-current-user.xml` under `C:\Documents and Settings\XXX(user id)\Local Settings\Application Data\SAP\SAP Business One`. In this situation, if a user changes his or her settings in SAP Business One, the changes are saved in this folder and do not affect other users’ settings.

9.10 Security Information for Integration Solutions

9.10.1 Security Aspects Related to the DATEV-HR Solution

This scenario requires maximum levels of data security and sensitivity, because it exports personal data. The DATEV-HR scenario generates employee data for DATEV eG using SAP Business One data. The integration framework writes the data to a specified directory in the file system. Make sure that only authorized persons have access to the folder.

Ensure that only authorized persons have access to the integration framework administration user interfaces. Alternatively, collect confirmations from all users who have access that they are aware that this data is sensitive, and that they may not distribute any data to third parties or make data accessible to non-authorized persons.

9.10.2 Security Aspects Related to the Mobile Solution

After the mobile user enters the correct user name and password, the front-end application passes the mobile phone number and mobile device ID (MAC address), together with the user name and password, to integration framework.

After receiving the information, the integration framework verifies the following:
- Whether the user is enabled as a mobile user
- Whether the necessary license is assigned to the user
- Whether it can find the telephone number and device ID pair in the SAP Business One user administration
- Whether the user name matches the telephone number and the device ID
- Whether the user has been blocked by the SAP Business One system
- Whether the provided password is correct

Then the user is allowed to access the system.

The password is encrypted while it is transmitted to the integration framework, which decrypts the password after receiving it.

Using HTTPS

To make communication safer, you have the option to use HTTPS for the sessions in the integration framework. On the server side you can configure the communication protocol (HTTP or HTTPS). On the client side, you have the option to switch to the HTTPS protocol. By default, the solution runs with HTTPS, and the integration framework allows incoming calls through HTTPS only.
SAP Business One mobile apps require a valid SSL certificate. For more information about obtaining and installing valid certificates, see SAP Note 2019275.

**License Control**

All mobile users have to be licensed before being allowed to access the SAP Business One system through the mobile channel. License administration is integrated with the SAP Business One user and license. The mobile user also needs the assignment of the B1i license. Authorization within the SAP Business One application depends on the user’s SAP Business One application license.

9.10.3 Security Aspects Related to the Integration with SAP Customer Checkout

All connections between SAP Customer Checkout and the integration framework are http connections that can be secured. The system landscape directory entries related to SAP Customer Checkout are 001sap0011 and 001sap0013 configured using basic authentication with user name and password. The technical connection to the SAP Customer Checkout monitor (001sap0013) is an http connection using basic authentication.

9.10.4 Security Aspects Related to the RFQ Scenario with Online Quotation

1 Note

The configuration information for the RFQ integration solution is available in the integration framework. To access the documentation, logon to the integration framework, choose Scenarios → Control, and for the sap.B1RFQ scenario package, choose the Docu button.

You must provide vendors included in the RFQ process access to the online purchasing document on the integration framework server. You can accomplish this by restricting access to the server to a minimum. To restrict access to the server, configure the network (NAT) firewall as shown below:

- Only allow external access to the particular hostname / IP-address
- Only allow external access to the configured server port.
- Default: port 8080 for HTTP, or port 8443 for HTTPS
- If applicable and available for the particular firewall, configure the restricting URL: http://<hostname>:<portnumber>/B1iXcellerator/exec/ipo/vP.0010000100.in_HCSX/com.sap.b1i.vplatform.runtime/INB_HT_CALL_SYNC_XPT/INB_HT_CALL_SYNC_XPT.ipo/proc?
9.11 Troubleshooting Security

Windows Authentication support is only for SAP Business One backward compatibility.

To configure Windows Authentication, you must provide Windows credentials. Ensure the following prerequisites:

- The Windows user has permission to start the SAP Business One license service.
- The Windows user is registered in Microsoft SQL Server.

Ensure that your Microsoft Windows account has rights to log on to the license server, because after Windows Authentication is configured, the license server service runs with this Windows account.

To check the configuration of your Microsoft Windows account on the computer where your license server is running, do the following:

1. In Windows, choose Start → Control Panel → Administrative Tools → Local Security Policy.
2. In the Local Security Policy window, choose Local Policies → User Rights Assignment.
3. In the User Rights Assignment window, select the Log on as a service item and double-click the item.
4. In the Log on as a service Properties window, choose the Add User or Group button.
5. Check if your Microsoft Windows account is in the Enter the object names to select (examples) field, and if not, add it and try again.

To check or correct your computer name, which is necessary to install Microsoft SQL Server, do the following:

1. In Windows, choose Start → Control Panel → System.
2. In the System Properties window, select the Computer Name tab.
3. In the Computer name field, check the computer name.
4. To correct the computer name, choose the Change button.
5. In the Computer Name/Domain Changes window, specify a new name for the computer and choose the OK button.
Cannot change database user password for System Landscape Directory

When installing the System Landscape Directory (SLD), you must fill in the account information of an SAP Business One database administrator user. If you change the password of the database user after the installation, the SLD stops working.

To update the database user password, perform the following steps:

1. On the server, navigate to the folder `<Installation Path>`\System Landscape Directory\tools\.
2. Execute the batch file `update_db_credential.bat`.
3. In the command prompt, enter the following information step by step:
   1. Path to the `server.xml` file (`<Installation Path>`\System Landscape Directory\tomcat\conf\server.xml).
   2. JDBC URL: If you have not changed the hostname or IP address of the SQL server, you can directly press ENTER to skip this step. The format of the URL is:

```
jdbc:sqlserver://<Hostname/IP>\<Instance Name>:<Port>; DatabaseName=<SLD Database>
```

   3. The database user name.
   4. New password for the database user.

Cannot change security certificate for System Landscape Directory

If you use a database user to install the System Landscape Directory (SLD) and then later change the password for the database user, the SLD cannot connect to the SAP Business One client and you are unable to change the certificate for secure connection to the SLD.

To update the certificate, perform the following steps:

1. On the server, navigate to the folder `<Installation Path>`\System Landscape Directory\tools\.
2. Execute the batch file `update_https_certificate.bat`.
3. In the command prompt, enter the following information step by step:
   1. Path to the tomcat server for the SLD (`<Installation Path>`\System Landscape Directory\tomcat\).
   2. Path to the new certificate.
   3. Password for the new certificate.
10 Troubleshooting

Delay in Establishing a Connection with the License Service

Problem:
You have difficulty establishing a connection with the license service. This issue may lead to the workflow service not working (error message: “Failed to connect company from workflow service”). For more information, see SAP Note 1135705.

Solution 1:
1. Change the registry entry and add the IP address of the license server computer as follows:
   - For 32-bit operating systems: HKEY_LOCAL_MACHINE\SOFTWARE\ACE\TAO
   - For 64-bit operating systems: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ACE\TAO
   For example: -ORBEndPoint iiop://10.59.39.60:30000 -ORBDottedDecimalAddresses 1
2. Use the IP address instead of the computer name for the license server address where required, such as for the SAP Business One client, DI API, B1i, and so on.

Solution 2
1. In the Control Panel, disable additional network cards.
2. Ensure there is no dial-up interface or VPN interface configured.
3. Restart the server.
   Note that you can re-enable the additional network card after restart. This will resolve the issue until the next restart.
11 Getting Support

We recommend that you assign a contact person who can deal with issues concerning SAP Business One. This contact person should follow the support process described below. If you cannot solve a problem using this process, contact SAP support.

Note

Before you contact SAP support, check the version information of your SAP Business One application. To view the version number, from the SAP Business One Help menu, choose About.

You can get support from your partner using either the Customer Portal or the Hotline. The Hotline is a number provided by your partner that you can call to get support during official support hours. The partner support staff logs the problem on SAP Service Marketplace. The partner support staff try to solve your problem. If they are unsuccessful, they forward the problem to the SAP Support team.

Recommendation

You can log your problem message in SAP Business One Customer Portal at http://service.sap.com/smb/sbocustomer/documentation. This lets you track the status of the message. Your SAP Business One partner can provide a user name for this portal. There you can find more information about how to create a message and track its status.

11.1 Using Online Help and SAP Notes

If you have a question or problem concerning SAP Business One, check the online help. If that does not provide an answer, search for corresponding SAP Notes, as follows:

Procedure

1. Log on to the SAP Business One portal as follows:
   o If you are a partner, log on to http://sappartneredge.com.
   o If you are a customer, log on to https://service.sap.com/smb/sbocustomer.
2. Choose the SAP Notes option.

You can either display a Note directly by providing the number of the Note, or you can search for a Note by entering key words.

Recommendation

The following example illustrates the difference between a usable and an unusable search.

Problem Message

“The performance of the SAP Business One program is not acceptable. Executing all operations takes a long time. The problem occurs only on one front-end.”
11.2 Using the Support Desk

You can use the support desk to search for known solutions in the SAP support database on SAP Service Marketplace. The support desk establishes a direct link to SAP Service Marketplace, which stores all the known solutions to known problems.

For more information, see the online help for SAP Business One on the SAP Business One product DVD or in the documentation area of SAP Business One Customer Portal at https://service.sap.com/smb/sbocustomer/documentation.

Prerequisites

You have a valid S user ID number.

An S user has authorization to access online support functions offered by SAP. The S user ID information is shipped with the SAP Business One product. If this information is missing or incorrect, contact your SAP Business One partner.

Procedure

To find solutions on SAP Service Marketplace, do the following:

1. From the SAP Business One menu bar, choose Help → Support Desk → Find a Solution.
   The Support Desk – Find a Solution window appears.
2. In the Search Term field, enter one or more words for which to search.
   You can search for key words or phrases of up to 60 characters.
3. Choose the Find button.
   The system calls up the connection to SAP Service Marketplace.
4. Specify your S-user ID and password.
   The system defaults your search criteria and the application area to SBO* and starts the search.