How to Work with SAP Crystal Reports in SAP Business One
All Countries
Typographic Conventions

<table>
<thead>
<tr>
<th>Type Style</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><em>Example</em></td>
<td>Words or characters quoted from the screen. These include field names, screen titles, pushbuttons labels, menu names, menu paths, and menu options. Textual cross-references to other documents.</td>
</tr>
<tr>
<td><em>Example</em></td>
<td>Emphasized words or expressions.</td>
</tr>
<tr>
<td><strong>EXAMPLE</strong></td>
<td>Technical names of system objects. These include report names, program names, transaction codes, table names, and key concepts of a programming language when they are surrounded by body text, for example, SELECT and INCLUDE.</td>
</tr>
<tr>
<td><em>Example</em></td>
<td>Output on the screen. This includes file and directory names and their paths, messages, names of variables and parameters, source text, and names of installation, upgrade and database tools.</td>
</tr>
<tr>
<td><em>Example</em></td>
<td>Exact user entry. These are words or characters that you enter in the system exactly as they appear in the documentation.</td>
</tr>
<tr>
<td><em>&lt;Example&gt;</em></td>
<td>Variable user entry. Angle brackets indicate that you replace these words and characters with appropriate entries to make entries in the system.</td>
</tr>
<tr>
<td><strong>EXAMPLE</strong></td>
<td>Keys on the keyboard, for example, F2 or ENTER.</td>
</tr>
</tbody>
</table>
# Document History

<table>
<thead>
<tr>
<th>Version</th>
<th>Date</th>
<th>Change</th>
</tr>
</thead>
<tbody>
<tr>
<td>1.0</td>
<td>2012.12.13</td>
<td>Integration with 64-bit SAP Business One</td>
</tr>
<tr>
<td>1.1</td>
<td>2013.01.31</td>
<td>- Separate installation of the Crystal Reports integration component</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Link arrow functionality for user-defined objects</td>
</tr>
<tr>
<td>1.2</td>
<td>2013.05.14</td>
<td>- Multiple values allowed for both referencing and referenced parameters</td>
</tr>
<tr>
<td>1.3</td>
<td>2013.07.11</td>
<td>Updated section 2.2.3.1</td>
</tr>
<tr>
<td>1.4</td>
<td>2014.02.12</td>
<td>- Availability of SAP Crystal Reports 2013, version for the SAP Business One application</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Referencing multiple parameters in WHERE clauses</td>
</tr>
<tr>
<td>1.5</td>
<td>2014.09.22</td>
<td>- Database server value</td>
</tr>
<tr>
<td></td>
<td></td>
<td>- Multiple data sources and subreports</td>
</tr>
<tr>
<td>Chapter</td>
<td>Title</td>
<td>Page</td>
</tr>
<tr>
<td>---------</td>
<td>-----------------------------------------------------------------------</td>
<td>------</td>
</tr>
<tr>
<td>1</td>
<td><strong>Introduction</strong> ..................................................................................</td>
<td>6</td>
</tr>
<tr>
<td>1.1</td>
<td>Installing SAP Crystal Reports for SAP Business One .........................</td>
<td>6</td>
</tr>
<tr>
<td>1.2</td>
<td>Integration Features ............................................................................</td>
<td>7</td>
</tr>
<tr>
<td>1.3</td>
<td>Terms and Definitions ..........................................................................</td>
<td>8</td>
</tr>
<tr>
<td>1.4</td>
<td>Related Documentation ........................................................................</td>
<td>9</td>
</tr>
<tr>
<td>2</td>
<td><strong>Basic Operations</strong> ...........................................................................</td>
<td>10</td>
</tr>
<tr>
<td>2.1</td>
<td>Overview ..................................................................................................</td>
<td>10</td>
</tr>
<tr>
<td>2.2</td>
<td>Creating Reports and Layouts with SAP Crystal Reports for SAP Business One</td>
<td>10</td>
</tr>
<tr>
<td>2.2.1</td>
<td>Connecting to Data Sources ...................................................................</td>
<td>11</td>
</tr>
<tr>
<td>2.2.2</td>
<td>Creating Selection Criteria Windows ..................................................</td>
<td>15</td>
</tr>
<tr>
<td>2.2.3</td>
<td>Working with Selection Criteria Tokens ..............................................</td>
<td>19</td>
</tr>
<tr>
<td>2.2.4</td>
<td>Adding Drilldown Functionality with Link Arrows ..................................</td>
<td>29</td>
</tr>
<tr>
<td>2.2.5</td>
<td>Saving SAP Crystal Reports .rpt Files as Reports or Layouts ..................</td>
<td>32</td>
</tr>
<tr>
<td>2.2.6</td>
<td>Logging Off from a Data Source ..........................................................</td>
<td>35</td>
</tr>
<tr>
<td>2.3</td>
<td>Working with SAP Crystal Reports Layouts and Reports in SAP Business One</td>
<td>35</td>
</tr>
<tr>
<td>2.3.1</td>
<td>Running Layouts ....................................................................................</td>
<td>35</td>
</tr>
<tr>
<td>2.3.2</td>
<td>Editing Layouts .....................................................................................</td>
<td>36</td>
</tr>
<tr>
<td>2.3.3</td>
<td>Deleting Layouts ..................................................................................</td>
<td>38</td>
</tr>
<tr>
<td>2.3.4</td>
<td>Running Reports ...................................................................................</td>
<td>39</td>
</tr>
<tr>
<td>2.3.5</td>
<td>Editing Reports ....................................................................................</td>
<td>40</td>
</tr>
<tr>
<td>2.3.6</td>
<td>Deleting Reports ..................................................................................</td>
<td>41</td>
</tr>
<tr>
<td>3</td>
<td><strong>Working with Multilanguage Reports</strong> ...............................................</td>
<td>42</td>
</tr>
<tr>
<td>3.1</td>
<td>Translating Reports ...............................................................................</td>
<td>42</td>
</tr>
<tr>
<td>3.2</td>
<td>Generating Multilanguage Reports ........................................................</td>
<td>45</td>
</tr>
<tr>
<td>3.3</td>
<td>Viewing Translated Reports in SAP Business One ....................................</td>
<td>46</td>
</tr>
<tr>
<td>3.4</td>
<td>Deleting Translations ..........................................................................</td>
<td>46</td>
</tr>
<tr>
<td>3.5</td>
<td>Creating New Reports from a Generated Multilanguage Report ................</td>
<td>47</td>
</tr>
<tr>
<td>3.6</td>
<td>Exporting Translations .........................................................................</td>
<td>47</td>
</tr>
<tr>
<td>3.7</td>
<td>Importing Translations .........................................................................</td>
<td>48</td>
</tr>
<tr>
<td>4</td>
<td><strong>Setting Authorizations for Reports Created with the SAP Crystal Reports Software</strong></td>
<td>50</td>
</tr>
<tr>
<td>5</td>
<td>Setting Data Sources for User-Defined Crystal Reports and Crystal Reports Layouts</td>
<td>51</td>
</tr>
<tr>
<td>6</td>
<td>Developing Add-Ons to Import .rpt Files ..............................................</td>
<td>52</td>
</tr>
<tr>
<td>7</td>
<td>Master Layouts .......................................................................................</td>
<td>53</td>
</tr>
<tr>
<td>8</td>
<td>Exporting Reports and Layouts Created with the SAP Crystal Reports Software</td>
<td>55</td>
</tr>
<tr>
<td>9</td>
<td><strong>Importing Reports and Layouts Created with the SAP Crystal Reports Software</strong></td>
<td>58</td>
</tr>
<tr>
<td>9.1</td>
<td>Importing SAP Crystal Reports .rpt Files ............................................</td>
<td>58</td>
</tr>
</tbody>
</table>
## Table of Contents

9.2 Importing SAP Business One .b1p and .b1px Package Files ............................................................ 63

10 Searching for Layouts and Reports .................................................................................................. 69
  10.1 Searching for Layouts .................................................................................................................. 69
  10.2 Searching for Reports .................................................................................................................. 70

11 Previewing and Printing Reports and Layouts in SAP Business One ............................................. 71
  11.1 Previewing and Printing Reports and Layouts Saved in SAP Business One .......................... 71
  11.2 Previewing SAP Crystal Reports .rpt Files Saved on Your Computer .................................. 72

12 Working with Printing Sequences ................................................................................................ 74
  12.1 Creating Printing Sequences ..................................................................................................... 74
  12.2 Modifying Printing Sequences .................................................................................................. 76
  12.3 Deleting Printing Sequences ...................................................................................................... 77
  12.4 Previewing and Running Printing Sequences .......................................................................... 77
  12.5 Defining Printing Sequence As Default Printing Option ......................................................... 78

13 Report and Layout Manager Window .............................................................................................. 79

Appendix: Document Types and Source Tables .................................................................................. 80
1  Introduction

The SAP Business One 9.0 release provides integration with SAP Crystal Reports, version for the SAP Business One application.

Note
SAP Business One 9.0 integrates with SAP Crystal Reports 2011, including the SAP Crystal Reports viewer and designer.
As of patch level 09, SAP Crystal Reports 2013, version for the SAP Business One application is available. You can use either the 2011 or the 2013 OEM version of SAP Crystal Reports for SAP Business One 9.0 PL09 and higher. The 2013 version is the recommended version, which contains more advanced features and is compatible with more advanced platforms, for example, Microsoft Windows Server 2012 and Microsoft Windows 8.

Note
In addition to the SAP Crystal Reports software, SAP Business One supports Print Layout Designer (PLD). You can use either one to create layouts for SAP Business One documents. For information about working with PLD, go to http://service.sap.com/smb/sbocustomer/documentation.

1.1  Installing SAP Crystal Reports for SAP Business One

Note
You do not need to install the SAP Crystal Reports viewer in a separate procedure. It is an integral part of the SAP Business One core product.

Installation for Patch Level 00

For SAP Business One 9.0 patch level 00, to ensure that the SAP Business One data sources and the Add-ins menu are available for the SAP Crystal Reports designer, follow the installation sequence below:
1. In the SAP Crystal Reports package, locate and run the setup file setup.exe.
2. Install the SAP Business One application.

Note
For more information about installing SAP Crystal Reports, and installing and upgrading SAP Business One, see the Administrator’s Guide that is provided with the SAP Business One product package.
Installation for Patch Level 01 and Higher

As of SAP Business One 9.0 patch level 01, to make SAP Business One data sources and the Add-ins menu available for the SAP Crystal Reports designer, you must install the Crystal Reports integration component separately. The integration package script `Business One Crystal Report Integration Package.exe` is located in the ...Packages\SAP CRAddin Installation folder of the SAP Business One upgrade package. For more information, see the Administrator's Guide that is provided with the SAP Business One upgrade package.

1.2 Integration Features

Integration with SAP Crystal Reports includes the following features.

- **SAP Crystal Reports viewer**
  
  This WYSIWYG (what you see is what you get) application provides you with an accurate printing preview of reports and documents, and enables exporting reports to PDF and other formats. In addition, you can use the filtering function of the viewer by entering different values in the parameter panel. For more information, see the SAP Business One online help.

- **Report and layout management**
  
  In SAP Business One, you can access a report and layout management window. From one location, you can manage the properties of Crystal reports, Crystal Reports layouts, PLD layouts, and layouts that are created by third parties. In addition, you can define layout printing sequences. The Report and Layout Manager window allows you to export and import Crystal reports and Crystal Reports layouts. For more information, see the SAP Business One online help.

- **SAP Crystal Reports, version for the SAP Business One application**
  
  You can save reports and layouts from within SAP Crystal Reports for SAP Business One to SAP Business One databases. You can create reports and layouts more easily using SAP Business One database tables that are arranged according to the modules in the SAP Business One Main Menu.

  Using the SAP Crystal Reports software, you can draw data from SAP Business One tables and company databases as selection criteria. Additionally, you can create controls in reports and layouts that are aligned with standard SAP Business One user interface (UI) elements.

  **Note**

  This document includes the processes and procedures involved in working with the SAP Crystal Reports software. However, these processes and procedures relate to the SAP Business One context only. For more detailed information about working with the SAP Crystal Reports software, see the SAP Crystal Reports online help that is accessible from SAP Crystal Reports software or from the SAP Crystal Reports DVD.

- **Master layouts**
  
  You can create a master layout that can be applied to various document types. For example, a master layout that is created for a sales invoice can be applied to sales quotations or deliveries. For more information, see Master Layouts.

- **Multilanguage translator**
  
  You can maintain translations of a report created with the SAP Crystal Reports software. For more information, see Working with Multilanguage Reports.

- **Accessibility of source documents**
You can add drilldown functionality to a report by adding link arrows to display related details about specific objects when previewing a report created with SAP Crystal Reports in SAP Business One. For more information, see Adding Drilldown Functionality with Link Arrows.

Integration with 64-bit SAP Business One

As of SAP Business One 9.0, the 64-bit version of SAP Business One is available as well as the 32-bit version. 64-bit SAP Business One also supports integration with SAP Crystal Reports.

To make the Add-ins menu available in SAP Crystal Reports, ensure that you have installed 32-bit SAP Business One DI API. Otherwise, you cannot connect to SAP Business One and retrieve data from SAP Business One databases.

Note

The Preview in SAP Business One option in the Add-ins menu works only if you have logged on to your company on a 32-bit SAP Business One client.

1.3 Terms and Definitions

The following terms are used in this document:

<table>
<thead>
<tr>
<th>Term</th>
<th>Definition</th>
</tr>
</thead>
<tbody>
<tr>
<td>SAP Crystal Reports, version for the SAP Business One application</td>
<td>Software that is designed to work in conjunction with SAP Business One for creating layouts for SAP Business One documents</td>
</tr>
<tr>
<td>SAP Crystal report</td>
<td>Report that is created with SAP Crystal Reports, version of the SAP Business One application</td>
</tr>
<tr>
<td>SAP Crystal Reports layout</td>
<td>Printing layout created by SAP Crystal Reports, and applied to appropriate document types and reports</td>
</tr>
<tr>
<td>master layout</td>
<td>SAP Crystal Reports layout that is applicable to multiple document types</td>
</tr>
<tr>
<td>SAP Business One data source</td>
<td>Data repository from which to retrieve SAP Business One tables organized in a hierarchical tree structure according to the modules in the SAP Business One Main Menu</td>
</tr>
<tr>
<td>token</td>
<td>Special format of a parameter name containing SQL-syntax code in a report or layout created with SAP Crystal Reports software. You use tokens to create different types of report selection criteria and their controls for use in SAP Business One.</td>
</tr>
<tr>
<td>SAP Crystal Reports viewer</td>
<td>Fully integrated component of SAP Business One that lets you view reports and layouts that are created with the SAP Crystal Reports software</td>
</tr>
<tr>
<td>printing sequence</td>
<td>Defined set of rules for printing documents</td>
</tr>
</tbody>
</table>
## 1.4 Related Documentation

This document refers to some other materials, as listed below:

<table>
<thead>
<tr>
<th>Document</th>
<th>Location</th>
</tr>
</thead>
<tbody>
<tr>
<td>Print Layout Designer documentation and training materials available on the Print Layout Designer landing page</td>
<td><a href="http://channel.sap.com/sbo/pld">http://channel.sap.com/sbo/pld</a> (accessible by partners only)</td>
</tr>
<tr>
<td>SDK online help file SDK_EN.CHM</td>
<td><a href="http://service.sap.com/smb/sbocustomer/documentation">http://service.sap.com/smb/sbocustomer/documentation</a> Available also on the SAP Business One product DVD and in the download package from SAP Service Marketplace</td>
</tr>
<tr>
<td>SAP Crystal Reports 2011 online help</td>
<td>Available from within the SAP Crystal Reports software</td>
</tr>
<tr>
<td>SAP Crystal Reports User Guide</td>
<td>Available on the SAP Crystal Reports DVD</td>
</tr>
</tbody>
</table>
2 Basic Operations

You create reports with SAP Crystal Reports and save them as either reports or layouts in SAP Business One, depending on your needs.

2.1 Overview

There are many procedures and sub-procedures involved in the processes of working with SAP Crystal Reports. A typical high-level flow of procedures is as follows:

1. Create a report with SAP Crystal Reports
2. Import the report as either a Crystal report or Crystal Reports layout
3. Run the report or apply the layout to a document
4. Export the report or layout

Figure 1 is a high-level representation of the workflow for working with SAP Crystal Reports for SAP Business One:

![Figure 1: Working with SAP Crystal reports and SAP Crystal Reports layouts](image)

2.2 Creating Reports and Layouts with SAP Crystal Reports for SAP Business One

This section describes the following procedures involved in creating reports and layouts with SAP Crystal Reports for SAP Business One:

1. Connecting to data sources
2. Creating selection criteria windows
3. Working with selection criteria tokens
4. Adding link arrows
5. Saving SAP Crystal reports .rpt files into SAP Business One

Prerequisites

You must connect to at least one data source before you can begin creating a new report in the SAP Crystal Reports software. SAP Business One supports the following data sources in the SAP Crystal Reports software:

- SAP Business One
- ODBC
- OLE DB (ADO)

**Recommendation**

We recommend that you connect to the SAP Business One data source.

For more information, see *Installing SAP Crystal Reports for SAP Business One*.

2.2.1 Connecting to Data Sources

The following procedure describes how to connect to SAP Business One data sources when creating a new report. For information about data sources, see the SAP Crystal Reports online help.

**Caution**

When creating a report using more than one data source, you must create one subreport for each additional data source. For example, the primary report has already used one data source; if you want to use two additional data sources, you must create two subreports (one subreport for each additional data source).

**Procedure**

1. On the SAP Crystal Reports start page, choose **Blank report**.

   **Note**

   To create a report with a wizard, choose **Report wizard** instead of **Blank report** and enter the required information. For information about the standard report creation wizard, see the SAP Crystal Reports online help.

2. In the **Database Expert** window, in the **Available Data Sources** pane on the left side of the screen, create a new SAP Business One connection.

   **Note**

   In the course of creating or modifying a report, you can open the database expert by choosing **Database → Database Expert** in the menu bar.
3. In the *SAP Business One* window, enter the required information and choose the *Finish* pushbutton.

4. In the *Database Expert* window, in the *Available Data Sources* pane, under the *B1 Tables* node, select one or more tables and move the selected tables to the *Selected Tables* pane using the *Add (>)* arrow button.

**Note**

The **13 UDT** folder stores the tables of SAP add-ons. The **15 External Tables** folder stores the tables of third-party add-ons.
Note

You can view the descriptions of the SAP Business One tables in the data source shown above. For more information, see Viewing Table Information in SAP Business One Data Source.

For information about SAP Business One database tables, see the SDK_EN.CHM file on the SAP Business One product DVD or in the download package.

5. Choose the OK pushbutton.

6. If you have selected more than one table, the Links tab appears and displays the selected tables and their relationships. Choose the OK pushbutton to exit the database expert.

Note

If you select more than one table on which to base a new report, a foreign key relationship is automatically created between the tables.

Note

If you have connected to a different data source than an SAP Business One data source, select from all available tables by choosing <connected database> → dbo → Tables

Result

A new report appears in Design view on a new tab of the work area.

Recommendation

To open the Preview tab for a quick view of your report, in the menu bar, choose View → Print Preview. The Preview tab appears next to the Design tab in the work area.

2.2.1.1 Viewing Table Information in SAP Business One Data Source

Note

To find out the table information of a specific SAP Business One window, pane, or field, in the SAP Business One menu bar, choose View → System Information. Then, by moving your cursor around the window, you can see the window’s table information displayed in the SAP Business One status bar at the bottom of the screen. In the example below, the table is OINV and the Name field that the cursor is pointing to is based on the CardName column of the OINV table.
When selecting tables from an SAP Business One data source, you can display the table information as follows:

1. In the **Database Expert** window, in the **Available Data Sources** pane, right-click a connection and choose **Options**.
2. In the **Options** window, in the **Tables and Fields** area, select the **Show Both** radio button.
3. Choose the **OK** pushbutton.

A description is shown for each SAP Business One table in the hierarchy tree as shown below.
2.2.2 Creating Selection Criteria Windows

You can use tokens to create selection criteria windows for data filtering.

**Example**

In the window above, when you choose the (...) [Browse] button, the *Items List - Selection Criteria* window opens:

For each selection criteria window that you want to create, you create a blank report (.rpt file) and then add several parameters, each containing a different token. For example, you use different tokens to add a title, a separator line, and a dropdown list. You can change the order of these parameters to define how the related UI elements appear in the window.

The procedure below demonstrates how to create the example selection criteria dialog windows shown above. For more information, go to the following sections:

- Tokens for Creating SAP Business One Controls
- Creating and Updating Parameters
- Syntax and Rules for Defining Tokens

**Procedure**

1. In SAP Crystal Reports, create a blank report and connect to data sources as described in Connecting to Data Sources.
2. In the Database Expert window, select the OITM (item master data) table and choose the OK pushbutton.
3. In the Field Explorer pane on the right, open the Database Fields node, and then open the OITM node.
   
   **Note**
   
   The field explorer is displayed by default for a new report. If you have closed it and want to reopen it, choose View → Field Explorer in the menu bar.
4. Drag the following fields to the work area on the Design tab and drop them in the Details area:
   - ItemCode
   - ItemName
The fields appear in the Details area with their associated labels in the Page Header area. You can edit the label text. For more information, see the SAP Crystal Reports online help.

Recommendation

If a table contains many fields and you find it hard to locate the field you are looking for, right-click the table and choose Sort Fields Alphabetically.

5. In the Field Explorer pane, right-click Parameter Fields and choose New.

For information about parameters, see Creating and Updating Parameters.

6. In the Create New Parameter window, in the Name field, enter the following token: MyParameter@SELECT * FROM OITM

7. In the Value Options list at the bottom of the window, set the values in one of the following two configurations: choose one item from a list or browse for multiple items.

   - Choose from List field

     To create a choose-from-list field for single-choice selection, set the values according to the table below:

     | Value Option       | Setting         |
     |--------------------|-----------------|
     | Prompt Text        | Select an item  |
     | Allow multiple values | False          |
     | Allow discrete values | True           |
     | Allow range values | False           |

     As a result of setting values according to the table above, a user can make a single choice.

     When you click the Choose from List icon in the selection criteria window, a List of Items window appears.

     - (...) [Browse] button

       To create a (...) [Browse] button for multiple-choice selection, set the values according to the table below.
<table>
<thead>
<tr>
<th>Value/Option</th>
<th>Setting</th>
</tr>
</thead>
<tbody>
<tr>
<td>Prompt Text</td>
<td>Choose the (...) button</td>
</tr>
<tr>
<td>Allow multiple values</td>
<td>True</td>
</tr>
<tr>
<td>Allow discrete values</td>
<td>True</td>
</tr>
<tr>
<td>Allow range values</td>
<td>False</td>
</tr>
</tbody>
</table>

As a result of setting values according to the table, a user can make multiple selections.

When you choose the (...) [Browse] button, the following *Items List - Selection Criteria* window appears.

8. In the *Create New Parameter* window, choose the OK pushbutton.

### 2.2.2.1 Multiple Selection Grid

Each of the (...) [Browse] buttons in the following window opens the similar grid control for selecting multiple values. Each (...) [Browse] button has a checkbox for indicating if any value has been selected.

To create a multiple selection grid like the one below, proceed as follows:
1. In the Create Parameter or Edit Parameter window, in the Value list, enter a list of valid values:
   - Low
   - Medium
   - High
2. In the Value Options area, set the Allow multiple values option to True.

   Note
   If you set the Allow multiple values option to False, a dropdown list appears, such as the business-partner type control shown below, instead of the (…) [Browse] buttons and checkboxes above.

2.2.2.2 Viewing and Running Selection Criteria Windows in SAP Business One

After you have created selection criteria windows as described in the example above, you can view them in SAP Business One as described in the following procedure.

Procedure

1. In the SAP Crystal Reports window, in the menu bar, choose Add-ins → SAP Business One → Preview in SAP Business One.

   The Report Selection Criteria window opens in SAP Business One.

2. Choose the Choose from List icon or (…) [Browse] button, depending on the type of selection criteria you set.
3. In the selection window that opens, select the required criteria and choose the OK button.
4. In the Report Selection Criteria window, choose the OK button.
   The report opens in the SAP Crystal Reports viewer. For information about the viewer, see the SAP Business One online help.

Result

You can save your new report and run it in SAP Business One. For more information, see the following:
2.2.3 Working with Selection Criteria Tokens

You can create controls that align with standard SAP Business One UI elements. This section provides explanations for and examples of SAP Business One tokens as shown in the list below:

- Tokens for Creating SAP Business One Controls
- Creating and Updating Parameters
- Syntax and Rules for Defining Tokens

Prerequisites

- You are familiar with the guidelines of working with the SAP Business One user interface.

  Note

  For information about working with the SAP Business One user interface, see User Interface Standards and Guidelines at http://service.sap.com/smb/sbocustomer/documentation. This document provides the best practices for designing the SAP Business One interface. It describes the structure and appearance of the interface and the rules for performing actions that affect the system.

  By following these guidelines, you can improve the quality and consistency of the application. The document offers the latest GUI design rules and recommendations. It also includes relevant GUI information, including a glossary, case studies, reusable components, and international support standards.

- You are familiar with SQL syntax, which is required for creating the tokens described in the following sections.

- You are familiar with the syntax and rules for defining tokens (see Syntax and Rules for Defining Tokens).

2.2.3.1 Tokens for Creating SAP Business One Controls

SAP Business One provides tokens that can be used to create standard SAP Business One controls. Most of these tokens contain SQL statements that you can use to dynamically select data from tables and fields in SAP Business One. You can use other tokens to create UI elements such as titles and horizontal separator lines.

For more information about SAP Business One databases, tables, and fields, see the SDK online help file, SDK_EN.CHM, on the SAP Business One product DVD or in the download package.

Use the following basic structure to create SQL tokens in reports that you want to run in SAP Business One:

<parameter_name>@<SQL_Expression>

Example

An example SQL expression is SELECT * FROM OCRD WHERE cardType='c'.

In this case, the condition in the WHERE clause specifies the query scope.
**Titles**

You can assign a title token to group selection criteria, such as checkboxes. In the example below, *Business Partner Type* is the title.

To create a title, use the following token:

```
<parameter_name>@title
```

To define the text that you want to appear as the title, in the *Value Options* list, in the *Prompt Text* field, enter the required text. In the example above, the user entered *Business Partner Type* in the *Prompt Text* field.

**Separators**

Separators are horizontal lines that span the width of a window. You can use separators to separate selection criteria groups as in the example below:

```
<parameter_name>@separator
```

No other specific values are required for this token.

**Item Selection Criteria Groups**

This token is related to the OITM table and groups different selection criteria types together. You can use this token to select multiple items or a single item.

To select items from the OITM table, define the token as below:

```
<parameter_name>@SELECT * FROM OITM
```

If the parameter allows multiple values, a (...) [Browse] button appears in the selection criteria window when you run the report.

If the parameter does not allow multiple values, a field with a *Choose from List* icon appears in the selection criteria window when you run the report.

![](image)

**Note**

For specific instructions about creating this token, see *Creating Selection Criteria Windows*. 
Business Partner Selection Criteria

You can define a token that selects business partner data from the OCRD table as in the example shown below.

To create selection criteria controls related to business partners, use the following example tokens:

- To include all types of business partners:
  \(<\text{parameter\_name}@FROM\ OCRD\)

- To include only customer-type business partners:
  \(<\text{parameter\_name}@FROM\ OCRD\ WHERE\ cardType='c'\)

- To include only vendor-type business partners:
  \(<\text{parameter\_name}@FROM\ OCRD\ WHERE\ cardType='s'\)

- To include only lead-type business partners:
  \(<\text{parameter\_name}@FROM\ OCRD\ WHERE\ cardType='l'\)

Date Format Selection Criteria

You can define date selection criteria using one of the following types of date controls:

- **Date Selector** calendar window – Allows the user to enter any date by choosing the Calendar icon in a field, as shown below:

To create this control, do the following:

- Define the parameter type as Date or Date Time
- Set Allow multiple values to False
- Set Allow range values to True

- **Choose from List** control – Allows the user to choose only specific posting periods by clicking the Choose from List icon as shown below:

To create this control, do the following:

- Define the following token, which draws data from the OFPR table:
  \(<\text{parameter\_name}@SELECT\ *\ FROM\ OFPR\"
- Define the parameter type as Date or Date Time
- Set Allow multiple values to False
- Set Allow range values to True
Account Tree

The **Account Tree** object in SAP Business One allows the user to view different levels of account and multiple selection options of the nodes.

To create an account tree, use the following token, which allows you to define multiple values. Set the *Allow multiple values* value option to *True*.

```
<parameter_name>@SELECT * FROM OACT
```

### By Location and By Warehouse

Location and warehouse information is usually grouped together as tabs, as in the examples below:

To create this control, use the following token, which selects data from the OWHS table. Set the *Allow multiple values* value option to *True*.

```
<parameter_name>@SELECT * FROM OWHS
```
2.2.3.2 Creating and Updating Parameters

To create or update a parameter, in the SAP Crystal Reports window, in the Field Explorer pane on the right, right-click Parameter Fields and select New.

The Create New Parameter window appears.

![Create New Parameter Window](image)

In this window, you can define the name, type, and values of the parameter.

**Note**

After you have added a parameter, you cannot change its name; however, you can edit its type and values. For more information, see Creating Selection Criteria Windows and Working with Selection Criteria Tokens.

### Parameter Type

The following table provides a list of parameter types (the Type dropdown list) and their related control types in SAP Business One:

<table>
<thead>
<tr>
<th>Parameter Type</th>
<th>Control Type</th>
<th>Values</th>
</tr>
</thead>
<tbody>
<tr>
<td>Boolean</td>
<td>Checkbox</td>
<td>Fixed values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• True</td>
</tr>
</tbody>
</table>
**Parameter Type** | **Control Type** | **Values**
--- | --- | ---
Currency | Edit box with a calculator | N/A
Date | Calendar-type date picker; that is, an edit box with a calendar | N/A
Date Time | Calendar-type date picker; that is, an edit box with a calendar | **Note**

Because SAP Business One does not have a time control, this parameter provides a default time of 00:00.

Number | Edit box with a calculator | N/A
String | Edit box | N/A
Time | Not supported | N/A

**List of Values**

The type of the list of values can be defined as either static or dynamic.

- **Static**

  **Note**

  If *Allow multiple values* is set to *False*, the static type provides a field with a *Choose from List* button. If you set this value to *True*, the static type provides a (...) [Browse] button that opens a window with multiple selection options.

  This is the recommended option. A static prompt is one that always contains the same values. For example, if a parameter prompts a country value, you could create a static prompt because the country list contains a set of values that does not change often. If the token syntax is applied to the parameter name, the option values are dynamically populated for this parameter.

  It provides the following options:
  - Simple parameters (display options)
  - Hard-coded lists of values such as customer, vendor, and lead
  - Complex dynamic values

  **Note**

  For complex dynamic values, if you include a token in the parameter name, SAP Business One fetches the data list from the database dynamically.

  When you set the *List of Values* type to *Static*, either you can enter or import fixed values in the *Value* area or SAP Crystal Reports reads data from the database using the SQL code in the parameter name.
• Dynamic

This option is not recommended. The values of a dynamic prompt are retrieved dynamically and directly from the data source and are not stored within the report. For example, if you are prompting for customer name, you could create a dynamic prompt because the names in your customer database probably change frequently.

When you set the List of Values type to Dynamic, the value area is not available, and you can retrieve data only by using the SQL code in the parameter name. Furthermore, the static type with token and SQL statement provides a better way of getting the option list because the user can filter by adding a WHERE clause in the SQL part of the parameter name.

Value Area

The values that you enter or import in the Value fields appear for selection in SAP Business One selection criteria windows.

For information about the Value and Description fields, see the SAP Crystal Reports online help.

Value Options and Settings

In the Create New Parameter or Edit Parameter window, you can define settings for value options as shown in the table below. For information about these value options and settings, see the SAP Crystal Reports online help.

<table>
<thead>
<tr>
<th>Value Option</th>
<th>SAP Business One Control Type</th>
<th>Setting Descriptions</th>
</tr>
</thead>
<tbody>
<tr>
<td>Show on (Viewer) Panel</td>
<td>N/A</td>
<td>• Determines the Parameter Panel options in SAP Crystal Reports viewer:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Do not show</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Editable (default)</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• Read only</td>
</tr>
<tr>
<td>Prompt Text</td>
<td>N/A</td>
<td>Appears in the SAP Business One control as a UI string providing an instruction to the user, such as “Enter a value.”</td>
</tr>
<tr>
<td>Prompt With Description Only</td>
<td>N/A</td>
<td>Fixed values:</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• True – Prompts the user with only a description</td>
</tr>
<tr>
<td></td>
<td></td>
<td>• False (default) – Prompts the user with a value and its description</td>
</tr>
<tr>
<td>Optional Prompt</td>
<td>N/A</td>
<td>Set this to True if you want to allow the user to bypass entering a value for this parameter.</td>
</tr>
<tr>
<td>Default Value</td>
<td>N/A</td>
<td>Add a value to this field if you want a default to appear when the program prompts the user to select a value. If the user does not change it, the default value is applied.</td>
</tr>
</tbody>
</table>

Note

This option is available only for parameters with static prompts.
### Value Option | SAP Business One Control Type | Setting Descriptions
--- | --- | ---
Allow custom values | Not supported | N/A
Allow multiple values | (...) [Browse] button that can pop up a new window to allow the user to select multiple values | Fixed values:
- **True**
- **False**
Allow discrete values | Dropdown list | A user can select only one singular value. If you have Allow multiple values set to **True**, a user is able to select more than one discrete value for the parameter field, though these values will continue to function singularly as opposed to a range value. You can choose discrete values for this parameter field after you choose the **Refresh Report Data** command.
- Fixed values:
  - **True**
  - **False**
Allow range values | From/to fields | Fixed values:
- **True** – Provides From and To dropdown lists
- **False** – Provides a Choose from List icon
Min length | N/A | Restricts values, depending on the type. For example, if the type is **String**, this value is **Min Length**. If the type is **Date**, **Date time** or **Time**, the value is **Start**. If the type is **Number** or **Currency**, the value is **Min value**.
Max length | N/A | Restricts values, depending on the type. For example, if the type is **String**, this value is **Max Length**. If the type is **Date**, **Date time** or **Time**, the value is **End**. If the type is **Number** or **Currency**, the value is **Max value**.
Edit mask | N/A | Applicable only for the **String** parameter type. For more information, see the SAP Crystal Reports online help.

### 2.2.3.3 Syntax and Rules for Defining Tokens

When defining tokens for use in SAP Business One, you must follow the following rules:

- A parameter name must start with an alphanumeric character or an underscore (_). For information about creating parameters, see Creating and Updating Parameters.
- The special character @ (at sign) is reserved for SAP Business One tokens and must follow the parameter name with no space between them.

  For example, “My Parameter@” means that this parameter is specific to SAP Business One.
• An SQL statement usually follows the at sign (@) with no space in between.

• The general syntax for creating SAP Business One tokens is:

   `<Parameter Name>@SELECT ... FROM ... WHERE ...

When you are creating tokens, the SELECT command is not always mandatory for SAP Business One tables. For example, SELECT is not mandatory for the OCRD (business partners) and OACT (G/L accounts) tables. For an example where SELECT is not used, see Business Partner Selection Criteria.

• A parameter name may include another parameter name, which means that the first parameter references the second parameter. The referencing parameter must specify the parameter it references by adding the at sign (@) before the name of the referenced parameter.

   Example

   Country@SELECT distinct Country FROM OCST

   State@SELECT code, name FROM OCST WHERE (Country = '@Country')

   A state parameter references a country parameter. If you choose United States from the country list, the states of the United States appear in the State dropdown list. If you do not choose a country, the state dropdown list has no data.

   The first statement lists all countries, while the second parameter (state parameter) calls the country parameter. For the second parameter to work, you must have a parameter called "Country".

   Note

   As of SAP Business One 9.0 PL10, a parameter can reference more than one other parameter in WHERE clauses. However, each referenced parameter must fulfill the following requirements:
   o Its Allow multiple values setting is defined as False.
   o Its Allow range values setting is defined as False.

   The following combination of parameter value settings is not supported:
   o Allow multiple values: True
   o Allow discrete values: False
   o Allow range values: True

   However, if you allow multiple values and discrete values, the Allow range values setting can be False.

• If a parameter allows multiple values, you must use the IN clause to reference the parameter.

   Example

   Parameter B: Customer@select cardcode from OCRD where cardtype = 'C'
   o If parameter B allows multiple values,
     Parameter A: Invoice@select docnum, docdate from OINV where cardcode in (@Customer)
   o If parameter B does not allow multiple values,
     Parameter A: Invoice@select docnum, docdate from OINV where (cardcode = '@Customer')

   Note

   For SAP Business One 9.0 PL04 and earlier versions, only the referenced parameter at the lowest level can allow multiple values. For example, if parameter A references parameter B and parameter B in turn references parameter C, only parameter C can allow multiple values.
• The DocKey@ token is mandatory in an SAP Crystal Reports .rpt file that you want to use as a layout. The DocKey@ token is used to identify the current active document. SAP Business One populates its value when you preview or print a layout.

When you apply the DocKey@ token, in the Select Expert window, you need to specify a filter condition, such as:

\{OINV.DocEntry\}={?DocKey@}

If the DocKey@ token does not exist, create a new parameter with the following settings:

- In the Name field, enter DocKey@.
- In the Type dropdown list, select Number or String, depending on the type of the DocEntry value.
- In all other fields, leave the default settings.

Note

For information about the Select Expert window, see the SAP Crystal Reports online help.

• The ObjectId@ token provides specific document-type information. We recommend you use this token for SAP Crystal Reports layouts that you want to assign to multiple document types as master layouts. For example, you can apply the ObjectId@ token if you want to include dynamic titles that change according to different document types or if you want certain functions suppressed for particular document types. However, this token is optional in an SAP Crystal Reports .rpt file that you want to use as a layout for only one document type:

If the ObjectId@ token does not exist, create a new parameter with the following settings:

- In the Name field, enter ObjectId@.
- In the Type dropdown list, select Number.
- In all other fields, leave the default settings.

Recommendation

If you want to design a master layout for multiple document types, do not use the ONLY keyword.

For information about SAP Crystal Reports master layouts, see Master Layouts.

• The UserCode@ parameter is an optional token that is recommended only in SAP Crystal Reports layouts where you want to display the code of the user currently logged on to SAP Business One. The parameter type is String. This token is only for layouts; you cannot use it in reports.

• The FolioPref@ and FolioNum@ parameters are valid only for Mexico, Chile, Costa Rica, and Guatemala. They are optional tokens that are recommended only in SAP Crystal Reports layouts in which you want to display a folio prefix and a folio number. SAP Business One populates them with the folio prefix and folio number you assign to the document for the first printing. For the first printing of some legal documents, SAP Business One prompts users to enter the folio prefix and folio number. The values are taken for the subsequent printing.

Dropdown Lists and Choose from List Icons

If the SQL query part of a parameter name (token) does not specify which column to select from the database, such as aaa@SELECT * from OITM, SAP Business One provides a field with a standard Choose from List icon that opens a window with a list, in this case a list of existing items.

If the token specifies columns, such as bbb@SELECT code, name FROM OCST, SAP Business One provides a dropdown list control.
If two `SELECT` columns are specified, the first column is used as the dropdown list’s key, and the second column is used as descriptions for the dropdown list.

### SQL Token Codes Examples

The table below provides SAP Business One SQL token examples and descriptions.

<table>
<thead>
<tr>
<th>SAP Business One SQL Token</th>
<th>Description</th>
</tr>
</thead>
<tbody>
<tr>
<td><code>&lt;parameter_name&gt;@SELECT * FROM OPRJ WHERE PrjName LIKE 'World%'</code></td>
<td>This expression returns all projects whose name starts with “World”</td>
</tr>
<tr>
<td><code>&lt;parameter_name&gt;@SELECT CurrCode FROM OCRN WHERE ISOCurrCod &lt;&gt; 'CAD'</code></td>
<td>This expression returns all currency codes defined in SAP Business One except for the Canadian dollar.</td>
</tr>
<tr>
<td><code>&lt;parameter_name&gt;@SELECT * FROM ODSC WHERE CountryCod = 'US'</code></td>
<td>This expression returns all U.S. banks defined in SAP Business One.</td>
</tr>
</tbody>
</table>

### 2.2.4 Adding Drilldown Functionality with Link Arrows

To add the drilldown functionality to a report, create link arrows for specific objects in the report. When you preview the report in SAP Business One and click the arrow icon, related details about the object are displayed.

The drilldown functionality supports the following windows:

- Documents:
  - A/P Invoice
  - A/R Credit Memo
  - A/R Invoice
  - Delivery
  - Goods Receipt
  - Inventory Transfer
**Prerequisites**

In the *Database Expert* window, you have added the OITM table from an SAP Business One database. For more information, see Connecting to Data Sources.

**Procedure**

1. In the SAP Crystal Reports window, on the *Design* tab, insert the *Link Arrow* icon graphic.
2. Right-click the graphic and choose *Format Graphic*.
   
   The *Format Editor* window opens.
3. On the **Hyperlink** tab, in the **Hyperlink type** area, select the **A Website on the Internet** radio button.

4. In the **Hyperlink information** area, choose the **Formula** button to the right of the **Website Address** field. The **Formula Workshop - Format Formula Editor - Hyperlink Text** window opens.

   Note

   The **Formula** button changes color when a hyperlink formula has been added. For information about the **Formula** button, see the SAP Crystal Reports online help.

5. In the work area, enter the following formula:

   'http://$b1$/link?table=OITM&key='+{OITM.ItemCode}
Note

If you are creating a link arrow to drill down to deliveries, you should define the formula as below, using the "CStr" function:

'http://$b1$/link?table=ODLN&key='+CStr ({ODLN.DocEntry}, 0)

If you are creating a link arrow to drill down to a UDO linked to a UDT named @TEST, you should define the formula as below:

'http://$b1$/link?table=@TEST&key='+CStr ({_TEST.DocEntry}, 0)

6. In the toolbar, choose the **Save and close** button.
7. In the **Format Editor** window, choose the **OK** button.

2.2.5 Saving SAP Crystal Reports .rpt Files as Reports or Layouts

To define an SAP Crystal Reports .rpt file as a report or a layout and save it to the SAP Business One database, in the **Add-ins** menu, choose the **Save** or **Save As** option.
Before you save an .rpt file, you can preview it in SAP Business One. In the SAP Crystal Reports software toolbar, choose Add-ins → SAP Business One → Preview in SAP Business One.

Note

To save an SAP Crystal Reports .rpt file to your local hard drive, in the SAP Crystal Reports window, choose File → Save or File → Save As. If you decide later that you want to save the .rpt file to SAP Business One, you can import it using the report and layout import wizard. For more information, see Importing SAP Crystal Reports .rpt Files.

Prerequisites

You are designated as a superuser in SAP Business One.

Procedure

1. In the toolbar of the SAP Crystal Reports software, choose Add-ins → SAP Business One → Save or Save As. Alternatively, in the External Command toolbar, choose .

   ![Toolbar Screenshot]

2. In the Log On window, specify the necessary information and choose the OK button. This logs you on to SAP Business One, and you can proceed.

   ![Log On Window]

   Note

   The Database Server value must be registered in the System Landscape Directory. For example, if only the host name of the database server is registered, you can enter only the exact host name value; if you enter the IP address, logon will fail. For more information, see SAP Note 2026931.

   If you open the SAP Crystal Reports application from within SAP Business One by editing a report, you are automatically logged on to SAP Business One and this window is not displayed.
3. In the *Save As* window, do the following:

1. In the *Name* field, specify a name for the *rpt* file.
2. For document type, select either the *Layout* or the *Report* radio button and choose the *OK* button.
   
   - **Layout**

   ![Save As window](image)

   i **Note**

   It is important to note that an SAP Crystal Reports *rpt* file that you want to define as a layout in SAP Business One must contain a parameter with the `DocKey@` token. Check this in the SAP Crystal Reports software before you save the *rpt* file as a layout. For information about this token, see *Syntax and Rules for Defining Tokens*.

   - **Report**

   The report is saved to the *Lost Reports* folder in the *Report and Layout Manager* window. For more information, see *Creating New Report Folders*.

   ![Save As window](image)
2.2.6 Logging Off from a Data Source

If you want to connect to a different SAP Business One data source, you must first log off from the data source to which you are currently logged on.

In the SAP Crystal Reports menu bar, choose Add-ins → SAP Business One → Log Off.

2.3 Working with SAP Crystal Reports Layouts and Reports in SAP Business One

You can run, edit, or delete layouts and reports created with the SAP Crystal Reports software in SAP Business One. SAP Business One provides a central workplace.

For more information, see the SAP Business One online help.

2.3.1 Running Layouts

To run a layout created with the SAP Crystal Reports software in SAP Business One, proceed as follows:

1. In SAP Business One, open a document whose layout you want to view.
2. Choose one of the following menu paths:
   - File → Preview
     Choose this option if the SAP Crystal Reports layout you want to view is defined as the default layout of the document type.
   - File → Preview Layouts
     Choose this option if you want to view a non-default layout created with the SAP Crystal Reports software.

The document appears in the SAP Crystal Reports viewer.

1. Note

You can create a layout for one document type and apply this layout to another document type. When you view the latter document type in this layout, SAP Business One automatically redirects you to the tables relevant to this document type and displays the correct data despite the fact that the layout itself contains table information relevant to the former document type. For more information, see Master Layouts.
2.3.2 Editing Layouts

To edit an SAP Crystal Reports layout, proceed as follows:

1. To open an SAP Crystal Reports layout for editing, do one of the following:
   - Open the layout in the Report and Layout Manager window:
     1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.
     2. In the Report and Layout Manager window, in the navigation pane on the left, navigate to the document type of the layout you want to edit.
     3. In the work area on the right, select the SAP Crystal Reports layout you want to edit and choose the Edit button.

   Note
   If you want to edit a PLD-type layout, select it and choose the Edit button. The Print Layout Designer opens. For more information, see the Print Layout Designer documentation at http://service.sap.com/smb/sbocustomer/documentation.
Open the layout in the relevant window:

1. From the SAP Business One **Main Menu**, navigate to a document whose layout you want to edit and open it.
2. In the tool bar, choose  
   (Layout and Sequence).
3. In the Layout and Sequence window, select the SAP Crystal Reports layout that you want to edit and choose the **Manage Layout** button.

4. In the Report and Layout Manager window, choose the **Edit** button.

The SAP Crystal Reports software opens the layout you have selected, and you can make any required changes.

**Note**

Before adding any new tables, make sure that the option of **Automatic Smart Linking** is not selected under **File → Options → Database**.

3. In the menu bar, do one of the following:
   - To save the updated layout in the SAP Business One database, choose **Add-ins → SAP Business One → Save**. Alternatively, in the External Command toolbar, choose **.**
To save the updated layout as a new layout with a different name or to apply it to another document type in the SAP Business One database, choose Add-ins → SAP Business One → Save As. Alternatively, in the External Command toolbar, choose  

![Save As dialog](image)

Caution

In the window that opens, make sure the Layout radio button is selected; otherwise the updated layout is saved as a report.

- To save the updated layout as an .rpt file on your local hard drive, choose File → Save.
- To save the updated layout as a new .rpt file with a different name or in a different location on your local hard drive, choose File → Save As.

4. Choose the OK button.

### 2.3.3 Deleting Layouts

**Prerequisite**

You are designated as a superuser in SAP Business One.

**Procedure**

Note

You cannot delete a layout that is provided in the SAP Business One core product.
To delete an SAP Crystal Reports layout, proceed as follows:

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.
2. In the Report and Layout Manager window, in the navigation pane on the left, navigate to the document type of the layout you want to delete and select it.
3. In the work area on the right, select the layout that you want to delete and then choose You Can Also → Delete.
4. To confirm that you want to delete the layout, choose the Yes button.

### 2.3.4 Running Reports

You can run a report created with the SAP Crystal Reports software in SAP Business One from the Report and Layout Manager window or from the SAP Business One Main Menu.

#### Run the report from the Report and Layout Manager window

**Procedure**

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.
2. In the Report and Layout Manager window, in the navigation pane on the left, navigate to the report you want to run and select it.

   **Note**

   After you have saved an .rpt file as a report into SAP Business One, the report appears only in the Lost Reports folder in the Report and Layout Manager window. To make it appear in the SAP Business One Main Menu, assign it to a folder of a specific module. For information about assigning the report to a module in SAP Business One, see Saving SAP Crystal Reports .rpt Files As Reports or Layouts.
3. In the work area on the right, choose the Run Report button.
4. If the report contains multiple data source connections, the Log On to Data Source window opens. Specify the user code and password for each data source and choose the OK button.
5. If a selection criteria window appears, enter the required information and choose the OK button.

   The report appears in SAP Crystal Reports viewer.

#### Run the report from the SAP Business One Main Menu

**Procedure**

1. In the SAP Business One Main Menu, locate the report you want to run and select it.
If the report is created with the SAP Crystal Reports software, an SAP Crystal Reports icon appears to the left of the report name.

2. If a selection criteria window appears, enter required information and choose the OK button.
   The report appears in SAP Crystal Reports viewer.

2.3.5 Editing Reports

To edit a report created with the SAP Crystal Reports software, proceed as follows:

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.
2. In the Report and Layout Manager window, in the navigation pane on the left, navigate to the report you want to edit and select it.
3. In the work area on the right, choose the Edit button.
   The report opens in the SAP Crystal Reports software and you can make any desired changes.

   Note
   To avoid creating unwanted links or disrupting existing links in the report, before you add any new tables, make sure that the Automatic Smart Linking checkbox is not selected under File → Options → Database.

4. In the menu bar, do one of the following:
   o To save the updated report in the SAP Business One database, choose Add-ins → SAP Business One → Save. Alternatively, in the External Command toolbar, choose .
   o To save the updated report as a new report with a different name in the SAP Business One database, choose Add-ins → SAP Business One → Save As. Alternatively, in the External Command toolbar, choose .
Caution

In the window that opens, make sure the Report radio button is selected; otherwise the updated report is saved as a layout.

- To save the updated report as an .rpt file on your local hard drive, choose File → Save.
- To save the updated report as a new .rpt file with a different name or in a different location on your local hard drive, choose File → Save As.

5. Choose the OK button.

2.3.6 Deleting Reports

Prerequisite

You are designated as a superuser in SAP Business One.

Procedure

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.

2. In the Report and Layout Manager window, in the navigation pane on the left, navigate to the report you want to delete.

3. In the work area on the right, choose You Can Also → Delete.

4. To confirm that you want to delete the report, choose the Yes button.
3 Working with Multilanguage Reports

You can deliver reports created with the SAP Crystal Reports software in multiple languages. You can maintain translated content in multiple languages in one report.

The multilanguage translator tool in SAP Crystal Reports, version for SAP Business One, enables you to translate your reports in all the languages supported in SAP Business One.

To access the multilanguage translator in SAP Crystal Reports, do one of the following:

- Choose Add-ins → SAP Business One → Translate....
- Click (Translate).

If you have not logged on to a company database, the SAP Business One Log On window appears. Enter the required information.

The Multilanguage Translator window opens. All reports created with the SAP Crystal Reports software in the company database are listed in the Reports pane.

3.1 Translating Reports

Procedure

1. In the Multilanguage Translator window, from the Reports list, select the report you want to translate into other languages.

   The details of the report appear on the Translation tab.
2. To add or change target languages into which the report can be translated, choose the *Add/Change Languages* button.

3. In the *Add/Change Languages* window, from the *Available Languages* list, select the languages into which you want to translate the report. To move the selected languages to the *Selected Languages* list, choose the button.

4. In the *Selected Language(s)* list, to display the selected language(s) in the *Multilanguage Translator* window, select the *Visible* checkbox for each.
Note
If you do not select the Visible checkbox for a language, the translation in this language will not be displayed in the Multilanguage Translator window.

5. In the Add/Change Languages window, choose the OK button.

6. In the Multilanguage Translator window, on the Translation tab, select the field whose content you want to translate and enter translations.

Note
You can also translate a formula with a name starting with "_ _" into multiple languages. For a formula that contains both texts that need translation and other content that does not need translation such as functions, data fields, and so on, you can extract the texts from the original formula to a new formula starting with "_ _".

7. To prevent a field from being translated (for example, formulas without text, placeholders, and separators), select the field and choose the Lock Translation button.

Caution
All translations of a field are removed when it is locked. Its content cannot be translated until you unlock the field by choosing the Unlock Translation button.

8. To save new and updated translations into the database, choose the Update button.

Result
After creating a translation, you must activate it in SAP Business One by generating a corresponding multilanguage report. For more information, see Generating Multilanguage Reports.
3.2 Generating Multilanguage Reports

To activate a translation of a report in SAP Business One, you must generate a corresponding multilanguage report after either creating or importing a translation.

⚠️ Caution

Before you generate the language version, make sure the translations meet your requirements. If you determine that a language version is not correct after it has been generated, you have to delete the incorrect version and create a new language version of the report. For more information, see Deleting Translations.

Procedure

1. In the Multilanguage Translator window, select the report whose translations you want to activate.
2. Select the Generation tab and do one of the following:
   o To activate one or more individual translations, select each language that you want to activate and choose the Generate button.
   o To activate all languages, choose the Generate All button.

When you activate a language, the value in the Status column changes to Generated. The generated report is saved in the database. When you change the display language in SAP Business One to the language in which you have generated a report, the generated report is displayed instead of the source report.

For information about viewing a translated version of a report in SAP Business One, see Viewing Translated Reports in SAP Business One.
3.3  Viewing Translated Reports in SAP Business One

To view a report in SAP Business One that has been translated and activated (see Generating Multilanguage Reports) into one or more languages, proceed as follows:

1. In SAP Business One, change the display language into the language in which you want to view the report.
2. Run the report from one of the following locations:
   - Report and Layout Manager window
   - SAP Business One Main Menu
For more information, see Running Reports.

3.4  Deleting Translations

You can delete unwanted or incorrect translations of a report even after it has been activated (see Generating Multilanguage Reports).

Procedure

1. In the Multilanguage Translator window, from the Reports list, select the report whose translations you want to delete.
2. Choose the Add/Change Languages button.
3. In the Add/Change Languages window, from the Selected Languages list, select the language you want to remove and choose the button.
4. In the dialog window that asks for your confirmation, choose Yes.
   The translation in this language is removed.
3.5 Creating New Reports from a Generated Multilanguage Report

After you activate a translation for a multilanguage report (see Generating Multilanguage Reports), you can create a new report (.rpt file) using the activated translation. The new report, however, is not saved to the database; you save the report (.rpt file) to a directory on your local hard drive. You can import the .rpt file into SAP Business One later as a new report. For more information, see Importing SAP Crystal Reports .rpt Files.

Procedure

1. In the Multilanguage Translator window, select the report with the translation on which you want to base your new report.
2. Select the Generation tab.
3. Select the language version on which you want to base your new report and choose the Edit button.
4. In the SAP Crystal Reports window, edit the report.
   To save the edited report (.rpt file), choose File → Save As.

3.6 Exporting Translations

You can export translations of a multilanguage report and then import the translations into another report whose resource format is the same as the original report.
Procedure

1. In the Multilanguage Translator window, on the Translation tab, select the report whose translations you want to export.

2. To exclude translations you do not want to export, choose the Add/Change Languages button.

3. In the Add/Change Languages window, deselect the Visible checkbox for corresponding languages. Then choose Update and OK.

4. Choose the Export Translation button.

5. In the Export Translation window, specify a name and location for the .xml file of the exported translations, and choose the Save button.

3.7 Importing Translations

You can import translations of a multilanguage report into the existing report. This is useful, for example, when you want to correct some of the translations in a report that has already been generated, and you do not want to delete the translation and create a new one.

Prerequisite

You can import only .xml translation files. In addition, the files must have the same format as the resource format of the report that you are editing.
Procedure

1. In the Multilanguage Translator window, on the Translation tab, select the report for which you want to import translations.
2. Choose the Import Translation button.

3. In the Import Translation window, select the .xml file containing the translations and choose the Open button. Translations are imported. If the translation file contains translations in languages that already exist for the report, you can choose whether or not to replace the existing translations with the imported translations.

Result

After importing a translation file, you must activate the translations in SAP Business One by generating a corresponding multilanguage report. For more information, see Generating Multilanguage Reports.
4 Setting Authorizations for Reports Created with the SAP Crystal Reports Software

Prerequisite

You are designated as a superuser in SAP Business One.

Procedure

Note

You can apply only Full Authorization or No Authorization to reports created with the SAP Crystal Reports software. A user cannot have read-only access to these reports.

To set authorizations for a report, proceed as follows:

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.
2. In the Report and Layout Manager window, in the pane on the left, navigate to the report for which you want to set authorizations, select the report, and choose the Set Authorization button.
3. In the Authorizations window, in the pane on the left, select the user that you want to authorize for the report.
4. In the Authorization column, in the dropdown list, select one of the following:
   - Full Authorization
   - No Authorization
5. Choose the Update button and then choose the OK button.

For information about setting authorizations in SAP Business One, see the SAP Business One online help.
5 Setting Data Sources for User-Defined Crystal Reports and Crystal Reports Layouts

A report or layout created with the SAP Crystal Reports software can have more than one data sources. For example, your company runs a weekly report that includes sales from all your retail outlets in a single report. In SAP Business One you maintain one company database for each of the retail outlets. In this case, you need to be able to retrieve data from multiple sources (databases).

To set the data sources for an imported report or layout in SAP Business One, proceed as follows:

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.
2. In the Report and Layout Manager window, in the pane on the left, navigate to the report or layout for which you want to set data sources, select it, and choose You Can Also → Define Advanced Settings.
3. In the Report and Layout Manager: Advanced Settings window, do the following:
   1. Select the Data Source tab.
   2. Specify the server and the database for each data source connection in the report or layout.
   3. To use the current company database, select [Default] for both the server and database. The report or layout connects to the current company database depending on whatever company the user logs on to.

   **Note**
   The reference server and database is the data source used to create the report or layout. It is not necessarily the current company database and is displayed only for your information.

4. To save the changes, choose the Update button.
5. If you specified a server or database (did not choose [Default]), the Site User window opens. Specify the site password and choose the OK button.
6. Choose the OK button.
6 Developing Add-Ons to Import .rpt Files

The SAP Business One data interface (DI) API enables you to create add-ons that import SAP Crystal Reports .rpt files as either reports or layouts. The ReportLayoutsService object lets you do the following:

- Import an .rpt file as a layout and assign it to one or more document types. For more information, see Master Layouts.
- Import an .rpt file as a report and assign a menu entry to the report.

For information about SAP Business One APIs, see the SDK Help Center. To access the SDK Help Center, proceed as follows:

2. Under BUSINESS ONE KNOWLEDGE CENTER, click the link of the relevant SAP Business One release.
3. Click the SDK Help Center link.
Master Layouts

Using the SAP Crystal Reports software, you can create master layouts for certain document types in SAP Business One.

**Recommendation**

For a layout that you want to define as a master layout, we strongly recommend that you include the `ObjectId@` SQL token in the layout. For information about working with the `ObjectId@` SQL token, see Syntax and Rules for Defining Tokens.

You define and apply master layouts when importing `.b1p` or `.b1px` package files that contain layouts. For more information, see Importing SAP Business One `.b1p` and `.b1px` Package Files.

**Note**

You cannot define a single imported `.rpt` file as a master layout.

Document types to which you can apply master layouts fall into four categories: sales documents, purchasing documents, inventory documents, and production documents. These categories, related document types, and their source tables are listed below:

<table>
<thead>
<tr>
<th>Category</th>
<th>Document Type</th>
<th>Table Name</th>
</tr>
</thead>
<tbody>
<tr>
<td>Sales</td>
<td>A/R invoice</td>
<td>OINV</td>
</tr>
<tr>
<td></td>
<td>A/R credit memo</td>
<td>ORIN</td>
</tr>
<tr>
<td></td>
<td>A/R correction invoice</td>
<td>OCIN</td>
</tr>
<tr>
<td></td>
<td>Sales quotation</td>
<td>OQUT</td>
</tr>
<tr>
<td></td>
<td>Sales order</td>
<td>ORDR</td>
</tr>
<tr>
<td></td>
<td>Return</td>
<td>ORDN</td>
</tr>
<tr>
<td></td>
<td>A/R down payment invoice</td>
<td>ODPI</td>
</tr>
<tr>
<td></td>
<td>Delivery note</td>
<td>ODLN</td>
</tr>
<tr>
<td>Purchasing</td>
<td>A/P invoice</td>
<td>OPCH</td>
</tr>
<tr>
<td></td>
<td>A/P credit memo</td>
<td>ORPC</td>
</tr>
<tr>
<td></td>
<td>A/P correction invoice</td>
<td>OCPI</td>
</tr>
<tr>
<td></td>
<td>Purchase quotation</td>
<td>OPQT</td>
</tr>
<tr>
<td></td>
<td>Purchase order</td>
<td>OPOR</td>
</tr>
<tr>
<td></td>
<td>Purchase request</td>
<td>OPRQ</td>
</tr>
<tr>
<td></td>
<td>Goods return</td>
<td>ORPD</td>
</tr>
<tr>
<td></td>
<td>A/P down payment invoice</td>
<td>ODPO</td>
</tr>
<tr>
<td>Category</td>
<td>Document Type</td>
<td>Table Name</td>
</tr>
<tr>
<td>---------------</td>
<td>--------------------------------</td>
<td>------------</td>
</tr>
<tr>
<td>Goods receipt</td>
<td>PO</td>
<td>OPDN</td>
</tr>
<tr>
<td>Inventory</td>
<td>Goods issue</td>
<td>OIGE</td>
</tr>
<tr>
<td></td>
<td>Goods receipt</td>
<td>OIGN</td>
</tr>
<tr>
<td></td>
<td>Inventory transfer</td>
<td>OWTR</td>
</tr>
<tr>
<td></td>
<td>Inventory transfer request</td>
<td>OWTQ</td>
</tr>
<tr>
<td>Production</td>
<td>Receipt from production</td>
<td>OIGN</td>
</tr>
<tr>
<td></td>
<td>Issue for production</td>
<td>OIGE</td>
</tr>
</tbody>
</table>

For a complete listing of document types, document type codes, and corresponding source tables, see Appendix. You can create a layout for one document type and apply this layout to another document type. When you view the latter document type in this layout, SAP Business One automatically redirects you to the tables relevant to this document type and displays the correct data in spite of the fact that the layout itself contains table information relevant to the former document type.

Example

You create a layout with the tables OINV, INV1, and so on, which are relevant to the A/R invoice, and you apply the layout to the sales order. When you view sales orders in this layout, SAP Business One redirects you to the tables ORDR, RDR1, and so on, which are relevant to sales orders.

Note

To avoid the automatic redirection and to prevent the layout from being used as a master layout, proceed as follows:

1. Open the layout.
2. In the Database Expert window, rename the tables by adding ".ONLY" at the end of each table.
3. Save the layout.
8 Exporting Reports and Layouts Created with the SAP Crystal Reports Software

Note
If you have integrated SAP Business One with an SAP Crystal Server, you can export system and user-defined Crystal reports to the SAP Crystal Server. For more information, see the guide *How to Integrate SAP Crystal Server with SAP Business One* at http://service.sap.com/smb/sbocustomer/documentation.

You can export Crystal reports and Crystal Reports layouts from SAP Business One as .b1px package files using the report and layout export wizard.

.b1px package files are applicable only for SAP Business One 8.82 and any subsequent releases. Both Crystal reports and Crystal Reports layouts can be included in the same .b1px package file; by contrast, .b1p package files that are exported from SAP Business One 8.81 contain only layouts or only reports, but not both.

Note
You can export only user-defined reports and layouts created with the SAP Crystal Reports software; you cannot export reports or layouts delivered with SAP Business One.

Caution
Do not manually change the extension of a file to "b1px". It could have unpredictable results.

Data source connections of a report or layout are exported along with it. In addition, when exporting a report, SAP Business One exports all its existing language versions. For more information, see *Working with Multilanguage Reports*.

Prerequisites

- You have installed the following:
  - SAP Business One
  - SAP Crystal Reports, version for the SAP Business One application
- You have authorization to the *Report and Layout Manager* window.
- You have created one or more SAP Crystal Reports layouts or reports that are ready to be exported.

Procedure

1. From the SAP Business One *Main Menu*, choose *Administration* → *Setup* → *General* → *Report and Layout Manager*.
2. In the **Report and Layout Manager** window, in the work area on the right, choose the **Export** button.

   The report and layout export wizard starts.

   ![Report and Layout Manager Window]

3. In the **Report and Layout Export Wizard** window, choose the **Next** button.

4. In the **Report and Layout Selection** window, to view the layouts or reports you want to export, in the **Name** column, click the arrows to the left of the nodes.

   The add-on layouts appear in the **Add-On Layouts** folder.

   To open or close all the nodes at once, choose the **Expand** or **Collapse** button respectively.

   In the top right corner of the window, from the **Display** dropdown list, select to display layouts, reports, or both.

5. Select the checkbox to the left of each layout or report you want to export.

6. Choose the **Next** button.
7. In the **Package Details** window, enter the following information:
   - Package name
   - Description – Description of the package is optional. The description that you enter here is visible to a user when importing the package file into SAP Business One.
   - Folder location – Specify a location where you want to save the .b1px package file.

8. To complete the export, choose the **Finish** button.
   An SAP Business One .b1px package file is created. The **Export Complete** window appears, displaying the export details.

9. To exit the wizard, choose the **Close** button.
9 Importing Reports and Layouts Created with the SAP Crystal Reports Software

You can import SAP Crystal Reports layouts, reports, and .rpt files into SAP Business One using the report and layout import wizard. As of SAP Business One 8.82, SAP Business One imports three types of files:

- .rpt files
- .b1p package files
- .b1px package files

When importing either an .rpt file with multiple data source connections or a .b1p or .b1px package file that contains reports or layouts with multiple data source connections, you can change the data sources for the imported reports or layouts.

When importing an .rpt file as a report, you can create a folder for the report in the SAP Business One Main Menu. For more information, see Creating New Report Folders.

When importing a .b1p or .b1px package file that contains reports, you can define authorizations for the reports.

When importing a .b1p or .b1px package file that contains layouts that can be applied to multiple document types, you can define these layouts as master layouts. For information about master layouts, see Master Layouts.

When importing a .b1p or .b1px package file, SAP Business One automatically detects whether the contents are layouts or reports, the document types of the layouts, and the menu paths of the reports.

When importing a .b1px package file that contains reports, SAP Business One imports all existing language versions of the reports. For more information, see Working with Multilanguage Reports.

9.1 Importing SAP Crystal Reports .rpt Files

To import SAP Crystal Reports .rpt files into SAP Business One, you use the report and layout import wizard.

**Recommendation**

Before importing an .rpt file, verify with the provider whether the file is intended as a layout or report.

**Procedure**

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.
2. In the Report and Layout Manager window, in the work area on the right, choose the Import button. The report and layout import wizard starts.
3. In the Report and Layout Import Wizard window, choose the Next button.
4. In the File Selection window, choose the Browse button.
5. In the Open window, navigate to the .rpt file you want to import and choose the Open button.
6. Select the appropriate content type.

   Note

   If you are not sure whether the .rpt file is intended as a report or a layout, verify this with the provider of the file.

7. Choose the ellipsis button.
   - If you selected the layout content type, the List of Document Types window opens.
Select a document type and choose the **Choose** button.

**Note**

In the *List of Document Types* window, the list of document types is similar to the document list in the Print Layout Designer (PLD). There is an entry for each specific document type, such as *A/R invoice* (items).

- If you selected the report content type, the *Menu Selection Form* window opens. Select a report folder and choose the **OK** button. Alternatively, to create a new folder, select the **New Folder** button. For more information, see *Creating New Report Folders*.

8. If the *.rpt* file contains multiple data source connections, in the *File Selection* window, choose the **Next** button. Otherwise, continue to the next step.
   The *Select Data Source* window opens.
For each data source connection select a server and database.
To use the current company database, select [Default] for both the server and database. The report or layout connects to the current company database depending on whatever company the user logs on to.

Note
If an .rpt file with only one data source connection is imported as a report or a layout, you can change its data source later in the Report and Layout Manager window. For more information, see Setting Data Sources for SAP Crystal Reports Layouts and Reports.

9. In the File Selection window or the Select Data Source window, choose the Finish button.
If you specified a server or database other than [Default], the Site User window opens. Specify the site password and choose the OK button.
If the name of the .rpt file already exists in SAP Business One as a report or for a specific document type as a layout, the RPT File window opens. Do one of the following:
  o To replace the existing layout or report, select the Overwrite radio button and choose the OK button.
  o To keep the existing layout or report, select the Rename radio button, enter a new name, and choose the OK button.
10. In the Import Summary window, a summary of the import results appears. To exit the wizard, choose the Close button.

Creating New Report Folders

You can create new report folders in the SAP Business One Main Menu when using the wizard to import an .rpt file as a report into SAP Business One.

Note

You can create new report folders directly by choosing Administration → System Initialization → Menu Structure. For more information, see the SAP Business One online help.

Procedure

1. In the Menu Selection Form window (see step 7 in Importing SAP Crystal Reports .rpt Files), select a module or folder in which you want to create a new folder.

   Alternatively, in the Report and Layout Manager window, you can open the Menu Selection Form window by selecting a report and choosing the ellipsis button in the Menu Location area.

2. Choose the New Folder button.

3. In the Create New Folder window, enter a name for the new folder.
4. Choose the Add button.

   Note
   The new folder won’t appear in the SAP Business One Main Menu until a report is successfully imported into it.

9.2 Importing SAP Business One .b1p and .b1px Package Files

To import .b1p and .b1px package files into SAP Business One, you use the report and layout import wizard. When importing a .b1p or .b1px package file, SAP Business One automatically detects whether the contents are layouts or reports, the document types of the layouts, and the menu paths of the reports. After the import, reports appear in the detected menu paths; layouts are displayed when you choose corresponding document types; and add-on layouts also appear in the Add-On Layouts folder.

Procedure

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.

2. In the Report and Layout Manager window, in the work area on the right, choose the Import button. The report and layout wizard starts.
3. In the Report and Layout Import Wizard window, choose the Next button.
4. In the File Selection window, choose the Browse button.
5. In the Open window, navigate to the SAP Business One .blp or .blpx package file you want to import and choose the Open button.

**Note**

SAP Business One automatically distinguishes between layouts and reports in the .blp and .blpx package file as well as their corresponding document types or menu paths. After the import wizard completes successfully, you can change the menu paths of the imported reports using the Report and Layout Manager window.

A description appears in the Description text box if a description was added during the export process of the .blp or .blpx package file.

For information about the export process, see Exporting Reports and Layouts Created with the SAP Crystal Reports Software.

6. Choose the Next button.
7. In the Report and Layout Selection window, to view the layouts or reports you want to import, in the Name column, click the arrows to the left of the nodes.

To open or close all the nodes at once, choose the Expand or Collapse button respectively.

In the top right corner of the window, from the Display dropdown list, select to display layouts, reports, or both.

8. Select the checkbox to the left of each report or layout that you want to import.

9. If a report or a layout for a certain document type and the same name already exists in SAP Business One, select the Overwrite checkbox to replace the existing report or layout.

   **Note**

   If you do not select the Overwrite checkbox, you will be prompted to rename the imported report or layout later.

10. If the .blp or .blpx package file contains layouts that can be applied to multiple document types, you can choose to define them as master layouts.

   **Caution**

   You define a layout as a master layout only during this process. For more information, see Master Layouts.

   **Recommendation**

   For a layout that you want to define as a master layout, we strongly recommended that you include the ObjectId@ SQL token in the layout. For information about working with the ObjectId@ SQL token, see Syntax and Rules for Defining Tokens.

   To define a layout as a master layout, proceed as follows:

   1. In the Report and Layout Selection window, select the Master Layout checkbox.

   2. In the Set Master Layout window, select the document types to which you want to assign the layout.
3. If a document type that you selected already has a layout with the same name, select the Overwrite checkbox to replace the existing layout.

   Note
   If you do not select the Overwrite checkbox, you will be prompted to rename the imported layout in the next step.

4. Choose the OK button.
   If there are no naming conflicts, you return to the Report and Layout Selection window.
   Otherwise, the Rename window opens. Enter a new name for each duplicate layout listed and choose the OK button.
Recommendation

After the import wizard completes successfully and before you start using a master layout, make sure it appears with all the document types to which it has been applied. If not, make the required corrections to the layout. For more information, see Searching for Layouts.

11. If the package file contains reports or layouts with multiple data source connections, to specify data source connections for a report or layout, proceed as follows:

1. In the Data Source column, click the Default link.
2. In the Select Data Source window, select a server and database for each data source connection.
3. To use the current company database, select [Default] for both the server and database. The report or layout connects to the current company database depending on whatever company the user logs on to.
4. To save the changes, in the Select Data Source window, choose the Update button.
5. If you specified a server or database other than [Default], in the Site User window that opens, specify the site password.
6. In the Select Data Source window, choose the OK button.

If you changed the default settings of servers and databases, in the Report and Layout Selection window, the value in the Data Source column changes to Assigned.

Note

If an .rpt file with only one data source connection is imported as a report or a layout, you can change its data source later in the Report and Layout Manager window. For more information, see Setting Data Sources for SAP Crystal Reports Layouts and Reports.

12. In the Authorization column, select one of the following permission levels for each report you are importing:
   - Full – All users have full authorization for the report.
   - None – Only superusers have full authorization for the report.

For information about setting authorizations in SAP Business One, see Setting Authorizations for Reports Created with the SAP Crystal Reports Software and SAP Business One online help.

13. Choose the Finish button.

If you did not select Overwrite checkboxes in step 8, the Rename window opens. Enter a new name for each report or layout, and choose the OK button.
The *Import Summary* window appears with a summary of the import results.

14. To exit the wizard, choose the *Close* button.
10 Searching for Layouts and Reports

In the report and layout manager, you can search for reports and reports by keyword.

10.1 Searching for Layouts

Procedure

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.
2. Select the Search tab.
3. Select the Document Type radio button.
4. Enter keywords and choose the Find button.
   A list of document types that match the keywords is displayed.

   **Note**
   You can search by one of the following keywords:
   - Document type name
   - Document type code
   - Layout ID
   - Layout name

5. Select the document type to which the layout you are searching for is applied.
   The layout is displayed in the list of layouts on the Layouts tab.
6. To view the details of the layout, select it.
   Details are displayed in the work area on the Layouts tab.

7. To locate the layout in the main menu, select the List tab.

10.2 Searching for Reports

Procedure

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.

2. Select the Search tab.

3. Select the Report radio button.

4. Enter keywords and choose the Find button.
   A list of reports that match the keywords is displayed.

5. To view the details of a report, select it.
   Details are displayed in the work area on the right.

6. To locate the report in the main menu, select the List tab.

   Note

   To change the location of the report, choose the ellipsis button in the Menu Location area. For information about creating a new folder for a report, see Creating New Report Folders.
11 Preparing and Printing Reports and Layouts in SAP Business One

In SAP Business One you can preview and print SAP Crystal Reports layouts and reports:

- To preview and print layouts and reports that are saved in SAP Business One, use the File menu.
- To preview SAP Crystal Reports .rpt files that are not saved in SAP Business One (external files) but reside on your computer, use the Tools menu.

11.1 Preparing and Printing Reports and Layouts Saved in SAP Business One

In the SAP Business One menu bar, in the File menu, you can use any of the following preview and printing options:

- **Preview**
  Provides a preview window displaying a printing preview of the open document or report based on the default layout. If the document or report has a default SAP Crystal Reports layout, the print preview opens in SAP Crystal Reports viewer. Alternatively, you can click the icon in the toolbar. For information about SAP Crystal Reports viewer, see the SAP Business One online help.

- **Preview Layouts**
  Opens the Choose Layout window, displaying both SAP Crystal Reports layouts and PLD-type layouts. You can select a layout other than the default layout to view the open document or report. If you select an SAP Crystal Reports layout, the document or report is displayed in SAP Crystal Reports viewer.

- **Print**
  Opens the standard Microsoft Windows Print window. Alternatively, you can click the icon in the toolbar to directly print the layout or report according to the default printing settings.

- **Select Layout and Print**
Opens the Choose Layout window, displaying both SAP Crystal Reports layouts and PLD-type layouts. You can select any layout to print the open document or report. When you choose the OK button, the standard Microsoft Windows Print window opens.

- **Print Sequence**
  Opens the Print Sequence window. Select a print sequence that you want to apply to an open document, and choose the Print button. For information about printing sequences, see Working with Printing Sequences.

  **Note**
  When you choose File → Print Sequence, the Print Sequence window opens, but there are no items listed if no printing sequence has been created for the specific document type.

For information about printing in SAP Business One, see Printing in SAP Business One in the online help for SAP Business One.

### 11.2 Previewing SAP Crystal Reports .rpt Files Saved on Your Computer

You can preview SAP Crystal Reports .rpt files that are saved on your computer but not saved or imported into SAP Business One as reports or layouts.

**Procedure**

1. In the SAP Business One menu bar, in the Tools menu, select Preview External SAP Crystal Reports File.

2. In the Preview External SAP Crystal Reports File window, choose the (…) [Browse] button.
3. In the Select SAP Crystal Reports .rpt File window, specify a file on your computer that you want to preview in SAP Business One.

4. Choose the Open button.

5. In the Preview External SAP Crystal Reports File window, choose the OK button.

The external file appears in SAP Crystal Reports viewer.

Note

You may need to specify selection criteria as you would when you run a report created with the SAP Crystal Reports software. For more information, see Running Reports.
12 Working with Printing Sequences

You can create printing sequences for certain document types in SAP Business One. You can apply printing sequences to the following:

- Standard SAP Business One layouts (PLD-type)
- Layouts that you have created or edited using Print Layout Designer (PLD)
- SAP Crystal Reports layouts

**Prerequisite**

Only users who have been designated as superusers in SAP Business One can perform the following actions regarding printing sequences:

- Create a printing sequence
- Modify a printing sequence
- Delete a printing sequence

12.1 Creating Printing Sequences

**Procedure**

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.
   
   The Report and Layout Manager window opens.

2. In the navigation pane on the left side of the window, select a document type for which you want to create a new printing sequence, such as A/R Invoice (Items).
3. In the work area on the right side of the window, select the **Printing Seqs** tab.

![Image of Report and Layout Manager window with Printing Seqs tab selected.](image)

4. On the **Printing Seqs** tab, choose the **New** button.

   The **Sequence Details** window opens.

   ![Image of Sequence Details window.](image)

   **Note**

   The document type for the new sequence is indicated in the **Document Type** field at the top right of the window. You cannot edit this field. If you want to create a printing sequence for a different document type, close the **Sequence Details** window. In the navigation pane on the left of the **Report and Layout Manager** window, select a different document type.

5. In the **Sequence Details** window, do the following:
1. In the **Sequence Name** field at the top of the window, enter a name for the printing sequence.

2. In the **Object** column, in the dropdown list, select a category of document types, for example, *A/R Invoices*.

3. In the **Layout** column, select a layout.
   
   **Note**
   
   You cannot delete a layout that is added to a printing sequence.

4. In the **Copies** column, enter the number of copies that you want to be printed each time this sequence is used.

5. In the **Printer** column, select a printer that you want to use each time this printing sequence is used.

6. In the **1st Page Printer** column, select a printer for printing the first page of the printing sequence.
   
   **Note**
   
   This field is optional. If you do not select a first-page printer, the printer you select in the **Printer** column prints the entire sequence including the first page.

6. Choose the **Add** button.

   The new printing sequence appears in the table on the **Printing Seqs** tab.

---

12.2  **Modifying Printing Sequences**

**Procedure**

1. From the SAP Business One **Main Menu**, choose **Administration → Setup → General → Report and Layout Manager**.

   The **Report and Layout Manager** window opens.

2. In the navigation pane on the left side of the window, select a document type whose printing sequence you want to modify.

3. In the work area on the right side of the window, select the **Printing Seqs** tab.

4. On the **Printing Seqs** tab, select the row of the printing sequence you want to modify and choose the **Edit** button.

   The **Sequence Details** window opens.

5. In the **Sequence Details** window, make required changes.

6. Choose the **Update** button, and then choose the **OK** button.
12.3 Deleting Printing Sequences

**Caution**
Deleting a printing sequence is irreversible.

**Procedure**

1. From the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.
   The Report and Layout Manager window opens.
2. In the navigation pane on the left side of the window, select a document type whose printing sequence you want to delete.
3. In the work area on the right side of the window, select the Printing Seqs tab.
4. On the Printing Seqs tab, select the row of the printing sequence you want to delete and choose the Delete button.
   The printing sequence is permanently deleted from SAP Business One.

12.4 Previewing and Running Printing Sequences

**Procedure**

1. Open a document to which a printing sequence has been applied.
2. In the SAP Business One menu bar, choose File → Print Sequence.
3. In the Print Sequence window, select a sequence and choose the Preview or Print button.
The document and all documents defined in the printing sequence are previewed or printed in the order of the printing sequence.

12.5 Defining Printing Sequence As Default Printing Option

Procedure

1. Open a document whose default printing option you want to define, for example, the A/R invoice.
2. Select the specific document type whose printing sequence you want to define as its default printing option, for example, the A/R invoice (items).
3. In the SAP Business One tool bar, choose the (Layout and Sequence) button.
4. In the Layout and Sequence window, select a printing sequence of the document type and choose the Set as Default button.
13 Report and Layout Manager Window

To open the Report and Layout Manager window, from the SAP Business One Main Menu, choose Administration → Setup → General → Report and Layout Manager.

You use the Report and Layout Manager window to perform the following functions:

- View and change the details of the following:
  - Crystal reports
  - Crystal Reports layouts
  - Customized PLD layouts
- Import Crystal reports and Crystal Reports layouts
- Export Crystal reports to a local disk or your Crystal Server
  For more information, see the guide How to Integrate SAP Crystal Server with SAP Business One at http://service.sap.com/smb/sbocustomer/documentation.
- Export Crystal Reports layouts to a local disk
- Access the SAP Crystal Reports software to edit Crystal reports and Crystal Reports layouts
- Set user authorizations for running user-defined Crystal reports
- Manage data sources for user-defined Crystal reports and Crystal Reports layouts
- Run Crystal reports
- Work with printing sequences for certain document types

Prerequisite

- For the following actions, you have to be designated as a superuser in SAP Business One:
  - Import and delete Crystal reports and Crystal Reports layouts
  - Define authorizations for user-defined Crystal reports
  - Set data sources for Crystal reports and Crystal Reports layouts

  Note

  The Import, Advanced (for setting data sources), Set Authorization, and Delete buttons are inactive for regular users.

For detailed descriptions of the UI elements and controls in the Report and Layout Manager window, see the SAP Business One online help.
Appendix: Document Types and Source Tables

The following table lists document types and corresponding source tables available in SAP Business One.

<table>
<thead>
<tr>
<th>Document Type Code</th>
<th>Table Name</th>
<th>Document Type</th>
</tr>
</thead>
<tbody>
<tr>
<td>1</td>
<td>ACT</td>
<td>Accounts</td>
</tr>
<tr>
<td>2</td>
<td>CRD</td>
<td>Cards</td>
</tr>
<tr>
<td>3</td>
<td>DSC</td>
<td>Discount codes</td>
</tr>
<tr>
<td>4</td>
<td>ITM</td>
<td>Items</td>
</tr>
<tr>
<td>5</td>
<td>VTG</td>
<td>VAT groups</td>
</tr>
<tr>
<td>6</td>
<td>PLN</td>
<td>Price list names</td>
</tr>
<tr>
<td>7</td>
<td>SPP</td>
<td>Special prices</td>
</tr>
<tr>
<td>8</td>
<td>ITG</td>
<td>Item groups</td>
</tr>
<tr>
<td>9</td>
<td>RTM</td>
<td>Rates matching</td>
</tr>
<tr>
<td>10</td>
<td>CRG</td>
<td>Card payment groups</td>
</tr>
<tr>
<td>11</td>
<td>CPR</td>
<td>Contact persons</td>
</tr>
<tr>
<td>12</td>
<td>USR</td>
<td>Users</td>
</tr>
<tr>
<td>13</td>
<td>INV</td>
<td>Invoices</td>
</tr>
<tr>
<td>14</td>
<td>RIN</td>
<td>Revert invoices</td>
</tr>
<tr>
<td>15</td>
<td>DLN</td>
<td>Delivery notes</td>
</tr>
<tr>
<td>16</td>
<td>RDN</td>
<td>Revert delivery notes</td>
</tr>
<tr>
<td>17</td>
<td>RDR</td>
<td>Orders</td>
</tr>
<tr>
<td>18</td>
<td>PCH</td>
<td>Purchases</td>
</tr>
<tr>
<td>19</td>
<td>RPC</td>
<td>Revert purchases</td>
</tr>
<tr>
<td>20</td>
<td>PDN</td>
<td>Purchase delivery notes</td>
</tr>
<tr>
<td>21</td>
<td>RPD</td>
<td>Revert purchase delivery notes</td>
</tr>
<tr>
<td>22</td>
<td>POR</td>
<td>Purchase orders</td>
</tr>
<tr>
<td>23</td>
<td>QUT</td>
<td>Quotations</td>
</tr>
<tr>
<td>24</td>
<td>RCT</td>
<td>Receipts</td>
</tr>
<tr>
<td>25</td>
<td>DPS</td>
<td>Deposits</td>
</tr>
<tr>
<td>26</td>
<td>MTH</td>
<td>Match history</td>
</tr>
<tr>
<td>Document Type Code</td>
<td>Table Name</td>
<td>Document Type</td>
</tr>
<tr>
<td>--------------------</td>
<td>------------</td>
<td>----------------------------------------------------</td>
</tr>
<tr>
<td>27</td>
<td>CHH</td>
<td>Checks history</td>
</tr>
<tr>
<td>28</td>
<td>BTF</td>
<td>Journal batches</td>
</tr>
<tr>
<td>29</td>
<td>BTD</td>
<td>Journal batches directory</td>
</tr>
<tr>
<td>30</td>
<td>JDT</td>
<td>Journal transactions</td>
</tr>
<tr>
<td>31</td>
<td>ITW</td>
<td>Item – warehouse accumulators</td>
</tr>
<tr>
<td>32</td>
<td>ADP</td>
<td>Printing administration</td>
</tr>
<tr>
<td>33</td>
<td>CLG</td>
<td>Contact log</td>
</tr>
<tr>
<td>34</td>
<td>RCR</td>
<td>Recurring transactions</td>
</tr>
<tr>
<td>35</td>
<td>NNM</td>
<td>Object’s next serial number</td>
</tr>
<tr>
<td>36</td>
<td>CRC</td>
<td>Credit cards</td>
</tr>
<tr>
<td>37</td>
<td>CRN</td>
<td>Currency codes</td>
</tr>
<tr>
<td>38</td>
<td>IDX</td>
<td>Index (Madad)</td>
</tr>
<tr>
<td>39</td>
<td>ADM</td>
<td>Administration</td>
</tr>
<tr>
<td>40</td>
<td>CTG</td>
<td>Credit terms</td>
</tr>
<tr>
<td>41</td>
<td>PRF</td>
<td>Form preferences</td>
</tr>
<tr>
<td>42</td>
<td>BNK</td>
<td>Bank pages</td>
</tr>
<tr>
<td>43</td>
<td>MRC</td>
<td>Firm groups (Marca)</td>
</tr>
<tr>
<td>44</td>
<td>CQG</td>
<td>Card query groups</td>
</tr>
<tr>
<td>45</td>
<td>TRC</td>
<td>Transaction codes</td>
</tr>
<tr>
<td>46</td>
<td>VPM</td>
<td>Payment to vendor</td>
</tr>
<tr>
<td>47</td>
<td>SRL</td>
<td>Serial numbers</td>
</tr>
<tr>
<td>48</td>
<td>ALC</td>
<td>Import expenses</td>
</tr>
<tr>
<td>49</td>
<td>SHP</td>
<td>Shipment types</td>
</tr>
<tr>
<td>50</td>
<td>LGT</td>
<td>Length units</td>
</tr>
<tr>
<td>51</td>
<td>WGT</td>
<td>Weight units</td>
</tr>
<tr>
<td>52</td>
<td>ITB</td>
<td>Item groups</td>
</tr>
<tr>
<td>53</td>
<td>SLP</td>
<td>Sales person</td>
</tr>
<tr>
<td>54</td>
<td>FLT</td>
<td>Reports filter</td>
</tr>
<tr>
<td>55</td>
<td>TRT</td>
<td>Transaction types</td>
</tr>
<tr>
<td>56</td>
<td>ARG</td>
<td>Arancel (custom) groups</td>
</tr>
<tr>
<td>57</td>
<td>CHO</td>
<td>Checks paid to vendors (outgoing checks)</td>
</tr>
<tr>
<td>Document Type Code</td>
<td>Table Name</td>
<td>Document Type</td>
</tr>
<tr>
<td>--------------------</td>
<td>------------</td>
<td>------------------------------------</td>
</tr>
<tr>
<td>58</td>
<td>INM</td>
<td>Inventory match</td>
</tr>
<tr>
<td>59</td>
<td>IGN</td>
<td>Inventory general entry</td>
</tr>
<tr>
<td>60</td>
<td>IGE</td>
<td>Inventory general exit</td>
</tr>
<tr>
<td>61</td>
<td>PRC</td>
<td>Profit center</td>
</tr>
<tr>
<td>62</td>
<td>OCR</td>
<td>Overhead cost rate</td>
</tr>
<tr>
<td>63</td>
<td>PRJ</td>
<td>Project</td>
</tr>
<tr>
<td>64</td>
<td>WHS</td>
<td>Warehouses codes and names</td>
</tr>
<tr>
<td>65</td>
<td>COG</td>
<td>Commission groups</td>
</tr>
<tr>
<td>66</td>
<td>ITT</td>
<td>Item tree links</td>
</tr>
<tr>
<td>67</td>
<td>WTR</td>
<td>Warehouses transfers</td>
</tr>
<tr>
<td>68</td>
<td>WKO</td>
<td>Work orders</td>
</tr>
<tr>
<td>69</td>
<td>IPF</td>
<td>Import file</td>
</tr>
<tr>
<td>70</td>
<td>CRP</td>
<td>Credit pay systems</td>
</tr>
<tr>
<td>71</td>
<td>CDT</td>
<td>Credit due terms</td>
</tr>
<tr>
<td>72</td>
<td>CRH</td>
<td>Credit history</td>
</tr>
<tr>
<td>73</td>
<td>SCN</td>
<td>Substitutional catalog number</td>
</tr>
<tr>
<td>74</td>
<td>CRV</td>
<td>Credit payments</td>
</tr>
<tr>
<td>75</td>
<td>RTT</td>
<td>Index and currency rates</td>
</tr>
<tr>
<td>76</td>
<td>DPT</td>
<td>Deposit temporary</td>
</tr>
<tr>
<td>77</td>
<td>BGT</td>
<td>Budget</td>
</tr>
<tr>
<td>78</td>
<td>BGD</td>
<td>Budget STR system</td>
</tr>
<tr>
<td>79</td>
<td>RCN</td>
<td>Retailer chains</td>
</tr>
<tr>
<td>80</td>
<td>ALT</td>
<td>Alert templates</td>
</tr>
<tr>
<td>81</td>
<td>ALR</td>
<td>Alerts pool</td>
</tr>
<tr>
<td>82</td>
<td>AIB</td>
<td>Alerts inbox</td>
</tr>
<tr>
<td>83</td>
<td>AOB</td>
<td>Alerts outbox</td>
</tr>
<tr>
<td>84</td>
<td>CLS</td>
<td>Contact log subjects</td>
</tr>
<tr>
<td>85</td>
<td>SPG</td>
<td>Special prices for groups</td>
</tr>
<tr>
<td>86</td>
<td>SPRG</td>
<td>Run externals applications</td>
</tr>
<tr>
<td>87</td>
<td>MLS</td>
<td>Mailing lists</td>
</tr>
<tr>
<td>88</td>
<td>ENT</td>
<td>Panama – enterada</td>
</tr>
<tr>
<td>Document Type Code</td>
<td>Table Name</td>
<td>Document Type</td>
</tr>
<tr>
<td>--------------------</td>
<td>------------</td>
<td>---------------</td>
</tr>
<tr>
<td>89</td>
<td>SAL</td>
<td>Panama – salida</td>
</tr>
<tr>
<td>90</td>
<td>TRA</td>
<td>Panama – traspaso</td>
</tr>
<tr>
<td>91</td>
<td>BGS</td>
<td>Budget scenario</td>
</tr>
<tr>
<td>92</td>
<td>IRT</td>
<td>Interest rates</td>
</tr>
<tr>
<td>93</td>
<td>UDG</td>
<td>User defaults groups</td>
</tr>
<tr>
<td>94</td>
<td>SRI</td>
<td>Items serial numbers</td>
</tr>
<tr>
<td>95</td>
<td>FRT</td>
<td>Finance reports template</td>
</tr>
<tr>
<td>96</td>
<td>FRC</td>
<td>Finance reports categories</td>
</tr>
<tr>
<td>97</td>
<td>OPR</td>
<td>Sales opportunities</td>
</tr>
<tr>
<td>98</td>
<td>OIN</td>
<td>Interest</td>
</tr>
<tr>
<td>99</td>
<td>OIR</td>
<td>Interest level</td>
</tr>
<tr>
<td>100</td>
<td>OSR</td>
<td>Information source</td>
</tr>
<tr>
<td>101</td>
<td>OST</td>
<td>Sales stage</td>
</tr>
<tr>
<td>102</td>
<td>OFR</td>
<td>Defect cause</td>
</tr>
<tr>
<td>103</td>
<td>CLT</td>
<td>Contact log types</td>
</tr>
<tr>
<td>104</td>
<td>CLO</td>
<td>Contact log locations</td>
</tr>
<tr>
<td>105</td>
<td>ISR</td>
<td>Internet service request</td>
</tr>
<tr>
<td>106</td>
<td>IBT</td>
<td>Item batch numbers</td>
</tr>
<tr>
<td>107</td>
<td>ALI</td>
<td>Alternative items</td>
</tr>
<tr>
<td>108</td>
<td>PRT</td>
<td>Partners</td>
</tr>
<tr>
<td>109</td>
<td>CMT</td>
<td>Competitors</td>
</tr>
<tr>
<td>110</td>
<td>UVV</td>
<td>User valid values</td>
</tr>
<tr>
<td>111</td>
<td>FPR</td>
<td>Finance period</td>
</tr>
<tr>
<td>112</td>
<td>DRF</td>
<td>Document draft</td>
</tr>
<tr>
<td>113</td>
<td>SRD</td>
<td>Internal manage of SRI and IBT</td>
</tr>
<tr>
<td>114</td>
<td>UDC</td>
<td>User display categories</td>
</tr>
<tr>
<td>115</td>
<td>PVL</td>
<td>Pelecard vendors list</td>
</tr>
<tr>
<td>116</td>
<td>DDT</td>
<td>Deduction at source – terraces</td>
</tr>
<tr>
<td>117</td>
<td>DDG</td>
<td>Deduction at source – groups</td>
</tr>
<tr>
<td>118</td>
<td>UBR</td>
<td>Users – branch</td>
</tr>
<tr>
<td>119</td>
<td>UDP</td>
<td>Users – departments</td>
</tr>
<tr>
<td>Document Type Code</td>
<td>Table Name</td>
<td>Document Type</td>
</tr>
<tr>
<td>--------------------</td>
<td>------------</td>
<td>-------------------------------------</td>
</tr>
<tr>
<td>120</td>
<td>WST</td>
<td>Workflow steps</td>
</tr>
<tr>
<td>121</td>
<td>WTM</td>
<td>Workflow templates</td>
</tr>
<tr>
<td>122</td>
<td>WDD</td>
<td>Workflow documents</td>
</tr>
<tr>
<td>123</td>
<td>CHD</td>
<td>Check out drafts</td>
</tr>
<tr>
<td>124</td>
<td>CINF</td>
<td>Company info</td>
</tr>
<tr>
<td>125</td>
<td>EXD</td>
<td>Expenses definition</td>
</tr>
<tr>
<td>126</td>
<td>STA</td>
<td>Sales tax authorities</td>
</tr>
<tr>
<td>127</td>
<td>STT</td>
<td>Sales tax authorities type</td>
</tr>
<tr>
<td>128</td>
<td>STC</td>
<td>Sales tax code</td>
</tr>
<tr>
<td>129</td>
<td>CRY</td>
<td>Countries</td>
</tr>
<tr>
<td>130</td>
<td>CST</td>
<td>States</td>
</tr>
<tr>
<td>131</td>
<td>ADF</td>
<td>Address format</td>
</tr>
<tr>
<td>132</td>
<td>CIN</td>
<td>Correction invoice</td>
</tr>
<tr>
<td>133</td>
<td>CDC</td>
<td>Cash discount</td>
</tr>
<tr>
<td>134</td>
<td>QCN</td>
<td>User query category names</td>
</tr>
<tr>
<td>135</td>
<td>IND</td>
<td>VAT indicator EC</td>
</tr>
<tr>
<td>136</td>
<td>DMW</td>
<td>Data migrate wizard packages</td>
</tr>
<tr>
<td>137</td>
<td>CSTN</td>
<td>Station ID</td>
</tr>
<tr>
<td>138</td>
<td>IDC</td>
<td>Indicator</td>
</tr>
<tr>
<td>139</td>
<td>GSP</td>
<td>Goods shipment</td>
</tr>
<tr>
<td>140</td>
<td>PDF</td>
<td>Payment draft</td>
</tr>
<tr>
<td>141</td>
<td>QWZ</td>
<td>Query wizard</td>
</tr>
<tr>
<td>142</td>
<td>ASG</td>
<td>Account segmentation</td>
</tr>
<tr>
<td>143</td>
<td>ASC</td>
<td>Account segmentation categories</td>
</tr>
<tr>
<td>144</td>
<td>LCT</td>
<td>Location</td>
</tr>
<tr>
<td>145</td>
<td>TNN</td>
<td>1099</td>
</tr>
<tr>
<td>146</td>
<td>CYC</td>
<td>Cycle</td>
</tr>
<tr>
<td>147</td>
<td>PYM</td>
<td>Payment method</td>
</tr>
<tr>
<td>148</td>
<td>TOB</td>
<td>1099 beginning balances</td>
</tr>
<tr>
<td>149</td>
<td>RIT</td>
<td>Dunning interest rate</td>
</tr>
<tr>
<td>150</td>
<td>BPP</td>
<td>BP priorities</td>
</tr>
<tr>
<td>Document Type Code</td>
<td>Table Name</td>
<td>Document Type</td>
</tr>
<tr>
<td>--------------------</td>
<td>------------</td>
<td>--------------------------------------</td>
</tr>
<tr>
<td>151</td>
<td>DUN</td>
<td>Dunning letter</td>
</tr>
<tr>
<td>152</td>
<td>UFD</td>
<td>User fields – description</td>
</tr>
<tr>
<td>153</td>
<td>UTB</td>
<td>User tables</td>
</tr>
<tr>
<td>154</td>
<td>CUMI</td>
<td>User menu</td>
</tr>
<tr>
<td>155</td>
<td>PYD</td>
<td>Payment run</td>
</tr>
<tr>
<td>156</td>
<td>PKL</td>
<td>Pick list</td>
</tr>
<tr>
<td>157</td>
<td>PWZ</td>
<td>Payment wizard</td>
</tr>
<tr>
<td>158</td>
<td>PEX</td>
<td>Payment results table</td>
</tr>
<tr>
<td>159</td>
<td>PYB</td>
<td>Payment block</td>
</tr>
<tr>
<td>160</td>
<td>UQR</td>
<td>Queries</td>
</tr>
<tr>
<td>161</td>
<td>CBI</td>
<td>Central bank indicator</td>
</tr>
</tbody>
</table>