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Icons
Icon

Meaning
Caution
Example
Note
Recommendation
Syntax

Typographic Conventions
Type Style

Description

Example text

Words or characters that appear on the screen. These include field
names, screen titles, pushbuttons as well as menu names, paths and
options.
Cross-references to other documentation.

Example text

Emphasized words or phrases in body text, titles of graphics and tables.

EXAMPLE TEXT

Names of elements in the system. These include report names,
program names, transaction codes, table names, and individual key
words of a programming language, when surrounded by body text, for
example, SELECT and INCLUDE.

Example text

Screen output. This includes file and directory names and their paths,
messages, source code, names of variables and parameters as well as
names of installation, upgrade and database tools.

EXAMPLE TEXT

Keys on the keyboard, for example, function keys (such as F2) or the
ENTER key.

Example text

Exact user entry. These are words or characters that you enter in the
system exactly as they appear in the documentation.

<Example text>

Variable user entry. Pointed brackets indicate that you replace these
words and characters with appropriate entries.
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How to Define and Use Formatted Search
Introduction
The Formatted Search function enables SAP Business One users to enter values, originated by a predefined search process, to any field in the system (including user-defined fields).
The following are examples of using the formatted search function:
{

Automatic entering of values into fields using various objects in the system

{

Entering values into fields using a pre-defined list

{

Automatic entering of values into fields via pre-defined queries (defined by the user)

{

Creating dependence between fields in the system. For example, the value in field X
influences the value in field Y.

{

Displaying fields that can only be displayed using queries. For example, User Signature,
Creation Date, Open Checks Balance (for business partner), etc.

The Formatted Search Menu
Use
Open any window in SAP Business One and select from the menu bar Tools → Search Function:

Field

Description/Activity

Search

Selecting this option after placing the cursor in a field,
for which a formatted search had been defined, will
activate the search.

Define

Select this option to define a formatted search for any
field in the current open window. Make sure the cursor is
placed in the appropriate field before selecting Define.

Search Field

From the menu bar select View → Search Field.
Select this option to display a special icon in fields with
formatted search. A magnifying glass icon
will be
displayed in all the fields for which a formatted search
had been defined.
Select this option again to hide the search icon.
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Defining a Formatted Search
Procedure
1. Place the cursor in a required field (any field in the current open window) and select from the
menu bar Tools → Search Function → Define, or use the key combination Alt+Shift+F2.
2. The Define Formatted Search window then opens:

Field

Description/Activity

Without Search

Select this option to indicate that no formatted search is
defined for this field.
This option will be effective if you want to cancel a
formatted search defined for a certain field.

Search in Existing Values

Select this option to define a list of fixed values
applicable for this field.

Search in Saved Query

Select this option to link a user-defined query to the
search field.

Search in Existing Values
When selecting this option, the icon
Setup window:
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In this window enter a list of values relevant for the field. Choose Update and OK to confirm the data.
This will close the Field Values – Setup window. You are now back in the Field Values – Setup
window. Choose Update again to complete the definition.
Now you can search in the existing values you have defined for this field.

Procedure
...

1. Place the cursor in the field
2. Select from the menu bar Tools → Search Function → Search (or use the key combination
Shift+F2).
This action opens a Choose From List window, displaying the values entered in the Field Values
– Setup window:

3. Choose the appropriate value from the list. The value will be entered automatically in the field.
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Adding and Updating Values to a List of Existing Values
Procedure
...

1. Place the cursor in the search field and select from the menu bar Tools → Search Function →
Define (or use the key combination Alt+Shift+F2).
2. The Define Formatted Search window opens. Choose the

icon.

3. The Field Values – Setup window opens. The cursor is placed in the next available row.
4. Enter a relevant value in this row and choose Update. You can also updating an existing value
and choose Update to save your changes.

Another way to add new values to a list of existing values is to choose the New
button in the List of User-Defined Values window which opens as a result of performing
the formatted search.

Deleting Values from a List of Existing Values
Procedure
...

1. Place the cursor in the search field and select from the menu bar Tools → Search Function →
Define (or use the key combination Alt+Shift+F2).
2. The Define Formatted Search window opens. Choose the

icon.

3. The Field Values – Setup window opens. The cursor is placed in the next available row.
4. Place the cursor in the relevant row and select from the menu bar Data Æ Remove or right click
the mouse and select Remove.
5. Choose on Update. A system message appears: "Are you sure you want to delete this data?"
Choose Yes to approve the removal.

The existing values reservoir is saved in the CUVV table in the company's database.

Search by Saved Query
Use
You can use two types of queries in a formatted search:
1. Queries that retrieve data from the current active window
2. Queries that retrieve data from various tables found in the company database

When selecting the Search by Saved Query option in the Define Formatted Search window, it is
possible to link a saved query to the search field:
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Procedure
...

1. Place the cursor over the blank field under Search by Saved Query.
2. The cursor transforms from an arrow to a palm.
3. Double click the blank field to open the Query Manager window.
4. Locate the required query, click it and choose Open.
5. The query name is entered in the field.

The Define Formatted Search window changes its display for the Auto Refresh option according to the
selected field type: Title or Table.

Auto Refresh When Fields Change - Title Type Fields

When the box Auto Refresh When Fields Change is deselected, the query linked to the field will be
activated only when placing the cursor in the field and selecting from the menu bar Tools → Search
Function → Search (or using the key combination Shift+F2).
Select the box Auto Refresh When Fields Change to enable an automatic refresh of the values in a
field defined with a formatted search.
The meaning of Refresh is a re-execution of the linked query and the display of its results in the field to
which it is linked.
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Auto Refresh When Fields Change - Table Type Fields

When the box Auto Refresh is deselected, the query linked to the field will be activated only when
placing the cursor in the field and selecting from the menu bar Tools → Search Function → Search (or
using the key combination Shift+F2).
When the box Auto Refresh is selected an additional field is displayed on the right.
Two elements must be selected to conduct an Auto Refresh for a Table type field:
The first element is the field type used for the refresh operation: by Title field or by Table field.
The second element is the field name.
Field

Description/Activity

When Fields Changes

Select to refresh the field when a Title field changes.
Select the required field from the list of Title fields found
in the drop down list located below the Auto Refresh
box.
Any change in the selected field will
cause the search field to be refreshed. For
example, a change in the selected Title
field will refresh all the rows in the table.

When Exiting Altered
Column

Select to refresh the field when a Table type field
changes.
Select the required field from the list of Table type fields
found in the drop down list located below the Auto
Refresh box.
Any change in the selected field will
cause the search field to be refreshed.
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Field

Description/Activity

Refresh Regularly

Select to refresh the search field each time you open or
browse to the document or window containing the
formatted search.
If the field is linked to a query that opens a multi-row
Choose From List window, the first value appearing on
the list will be selected.
Avoid using the Refresh Regularly
option under this type of query since it
might affect documents you did not intend
to affect.

Display Saved Values

•

The Refresh Regularly option
should be used in specific cases
only, since each time you browse to
an existing document, all the
formatted searches defined in the
document are activated. This might
cause the document to be displayed
very slowly.

•

If you manually change a value
retrieved by a formatted search and
save the document, the next time
the document is displayed, the
manually changed value will be
calculated again!

Select to display the value saved in the field during the
addition/update of the document. That is, the value
saved in the database.
The field will be refreshed only if you
replace the field linked to the query.

•

Auto Refresh will not be implemented in fields that cannot be updated. For
example, the G/L Account Code in an existing journal entry, the Item Number in
an existing Delivery and so on.

•

Auto Refresh + Refresh Regularly is similar to Auto Refresh + Display Saved
Values, apart from the fact that the last one will not refresh the value when
browsing or finding the document.

Limitation: When browsing through editable documents (such as Sales Orders),
fields with Auto Refresh will be refreshed, however the document status will not change
from OK to Update.
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Updating a Linked Query
The link to the query is saved even if the actual query sentence is updated.

Procedure
To replace a linked query:
...

1. Select from the menu bar Tools → Search Function → Define (or use the key combination
Alt+Shift+F2) to open the Define Formatted Search window.
2. Place the cursor over the query name, hold down the Ctrl key and double click the field.
3. The Query Manager window opens.
4. Select a new query by clicking its name and choose Open.
5. The new query name is entered in the Define Formatted Search window.
6. Choose Update to save your changes.

Retrieving Data by Linking a Query to a Search Field
Data can be retrieved in two ways by linking a query to a search field:
...

1. Data from the various database tables
2. Data from the current active window (form)
...

Data from the Current Active Window (Form)
You can retrieve two types of data from the active window:
Type

Description/Activity

Table Data

Refers to any table inside SAP Business One
documents.
The Items table in sales and
purchasing documents or journal entry
rows in a journal entry.

Title Data

Refers to any data outside the table data
Document numbers and business
partner codes in sales and purchasing
documents or journal entry numbers in the
journal entry window.

To retrieve data from the active window, a special query should be created. SAP Business One
provides two different syntaxes for this type of query:
1. $[Tablename.Fieldname]
{

Tablename – Indicates the table to which the active window relates.

{

Fieldname – The field from the active window.

2. $[$Field Index.Field Column.Number/Currency/Date/0]
This syntax uses the field’s index instead of the specific document table.
This query syntax includes 3 elements:
{

Field Index - Each field in the active window can be related by a unique index.

{

Field Column - If the required field is a Table field (Item Number, Item Description,
Price, Quantity in sales and purchasing documents and so on) it has to be related by
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index and column numbers. If the required field is a Title field, this element should be set
to 0.
{

Number / Currency / Date / 0



Use Number if the required field includes a number + a currency symbol (item
price, document total), to retrieve the number (without the currency symbol or the
unit of measurement). This separation is essential when the user wishes to use
the price for arithmetic expressions.



Use Currency to retrieve the currency symbol or the unit of measurement.



Use Date If the required field is a Date field and it has to be used for computation



Use 0 if the field contains a single value (Quantity, Item Number, Item Description,
Business Partner Code or Document Number)

Example 1
Objective
Retrieve the business partner code from the A/R Invoice window to the Remarks field in the A/R
Invoice window.

Procedure
...

1. Open the Query Generator window.
2. In the Select area type $[$4.0.0] or $[OINV.CARDCODE]. The digit 4 stands for the
business partner code's index. The first 0 digit indicates that the business partner code is a Title
field. The last 0 digit indicates that the business partner code contains a single value.
3. Choose the Execute button.
4. Choose Save to save the query.
5. Open the A/R Invoice window.
6. Enter a business partner code in the Customer field.
7. Click the Remarks field.
8. To define the Remarks field as a search field, select from the menu bar Tools → Search
Function → Define (or use the key combination Alt+Shift+F2).
9. Select Search by Saved Query.
10. Select the saved query.
11. Select Auto Refresh When Fields Change.
12. Click the drop down list and select Customer/Vendor Code.
13. Select Display Saved Values.

To test the search field, change the customer code in the A/R Invoice. Changing the customer code
will update the Remarks field automatically.
It is recommended to use the string $[$4.0.0] rather than the string
$[OINV.CARDCODE], since the first one can be linked to search fields in any sales or
purchasing document while the second one can be linked only to A/R Invoices.

Example 2
Objective
Retrieve the item number from an active Sales Order window into a user-defined field.
© SAP AG 2005
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Procedure
1. Create a new user-defined field in Marketing Documents - Rows. Since the user-defined field
properties should be identical to the Item Number properties, the user-defined field has to be
alphanumeric, regular and with a length of 20 characters.
2. Open the Query Generator window.
3. In the Select area type $[$38.1.0] or $[RDR1.ITEMCODE]
4. Save the query. The number 38 stands for the item index. The digit 1 stands for the item
column. The digit 0 indicates that the item contains a single value.
5. Open the Sales Order window.
6. Type a customer code in the Customer field.
7. Type an item number in the Item No. column.
8. Locate the user field in the items table and place the cursor in it.
9. To define a formatted search for this user-defined field (step1), select from the menu bar Tools
→ Search Function → Define (or use the key combination Alt+Shift+F2).
10. Select Search by Saved Query.
11. Select the saved query (step 4).
12. Select the box Auto Refresh.
13. Select When Exiting Altered Column.
14. Select the field Item No. field
15. Select Display Saved Values.

To test this search field, change the item number. Changing the item number will update the search
field automatically.

Example 3
Objective
Retrieve the item price (the numeric value) from a sales or purchasing document window into a userdefined field.

Procedure
1. Create a new user-defined field in Marketing Documents - Rows. The user-defined field type Units and Totals. Structure – Amount.

2. Open the Query Generator window.
3. In the Select area type $[$38.17.NUMBER]. The number 38 stands for the price index. The
number 17 stands for the Price column. NUMBER indicates the price's numeric value.

4. Save the query.
5. Open any sales or purchasing document window.
6. Type a business partner code in the Customer or Vendor field.
7. Type an item number in the Item No. column.
8. Locate the user-defined field (Step 1) in the document table and place the cursor in it.
9. Select from the menu bar Tools → Search Function → Define (or use the key combination
Alt+Shift+F2).

10. Select Search by Saved Query.
© SAP AG 2005
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11. Select the saved query you have created in step 3.
12. Select Auto Refresh.
13. Select When Exiting Altered Column.
14. Select the Price field.
15. Select Display Saved Values.
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To test this search field, change the price. Changing the price will update the search field
automatically.
The numeric value retrieved to the user-defined field can be used for arithmetic
expressions.

Example 4
Objective
Retrieve the item price currency (the currency symbol) from a sales or purchasing document window
into a user-defined field.

Procedure
1. Create a new user-defined field in Marketing Documents - Rows. User-defined field type Alphanumeric. Structure – Regular. Size – 3.
2. Open the Query Generator window.
3. In the Select area type $[$38.17.CURRENCY]
4. Save the query.
5. Open any sales or purchasing document window.
6. Type a business partner code in the Customer or Vendor field.
7. Type an item number in the Item No. field.
8. Locate the user-defined field in the document table and place the cursor in it.
9. Select from the menu bar Tools → Search Function → Define (or use the key combination
Alt+Shift+F2).
10. Select Search by Saved Query.
11. Select the saved query you have created in step 3.
12. Select Auto Refresh.
13. Select When Exiting Altered Column.
14. Select the Price field
15. Select Display Saved Values.
To test the search field, change the price currency. Changing the price currency will update the search
field automatically.

Example 5
Objective
Retrieve the document's Posting Date + 20 days from any sales or purchasing document to the Due
Date field.

Procedure
1. Create the query $[$10.0.DATE] + 20
2. Link the query to the Due Date or Delivery Date field (depending on the document type).
3. Select Auto Refresh.
4. Select When Field Changes.
5. Select the Posting Date field.
6. Select Display Saved Values.
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To test this search field, change the Posting Date. Changing the Posting Date will update the search
field automatically.

Example 6
Objective
Retrieve the tax amount per 1 item unit from any sales or purchasing documents to a user-defined
field.
To get the tax amount per 1 item unit, the price before tax has to be subtracted from
the price including tax.

Procedure



The string $[$38.17.NUMBER] represents the price before tax.



The string $[$38.20.NUMBER] represents the price including tax.

1. Create the query $[$38.20.NUMBER] - $[$38.17.NUMBER]
2. Link the query to a user-defined field. Field type - Units and Totals. Structure – Amount.
3. Select Auto Refresh.
4. Select When Exiting Altered Column.
5. Select the Price field.
6. Select Display Saved Values.

To test this search field, change the item price. Changing the item price will update the search field
automatically.

Example 7
Objective
In this example you will add the currency symbol to the value retrieved in example 6.
Since Tax is a numeric value and the currency symbol is an alphanumeric value, you need to use the
SQL function CAST.

Procedure
...

1. Create the query: CAST($[$38.20.NUMBER] - $[$38.17.NUMBER] AS VARCHAR(20))
+ [$38.20.CURRENCY]
2. Link the query to a user-defined field. Field type - Alphanumeric. Structure – Regular.
3. Select Auto Refresh.
4. Select When Exiting Altered Column.
5. Select the Price field.
6. Select Display Saved Values.
AS VARCHAR (20) indicates the size allocated to the subtraction result.
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Example 8
Objective
Retrieve the business partner’s bookkeeping balance to a sales or purchasing document.

Procedure
1. Create the query as follows:

2. Link the query to a user-defined field. Field type - Units and Totals. Structure – Amount.
3. You now face three options to refresh the Balance field:
{

If you deselect the box Auto Refresh When Fields Change, each time you click the
Balance field and select Search from the Search Function menu (or use the key
combination Shift+F2), the current business partner balance will be entered to it.

{

If you select the box Auto Refresh When Fields Change and select the Refresh
Regularly option, each time the refreshed field selected in the Define Formatted Search
window changes, the Balance field will be refreshed. The current business partner
balance will be entered to the Balance field. The balance will be refreshed each time you
browse or find the document. In other words, if the business partner's balance has
changed since the document had been issued; the updated balance will be displayed in
the Balance field each time you enter the document.

{

If you select the box Auto Refresh When Fields Change and select the Display Saved
Values option, each time the refreshed field selected in the Define Formatted Search
window changes, the Balance field will be refreshed. The current business partner
balance will be entered to the Balance field. However, the balance will not be refreshed
each time you browse or display the document. You can, however, change the Balance
field manually.
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Example 9
Objective
Retrieve to a purchasing document, items from the Item Master Data window in which the Default
Vendor field is identical to the Vendor Code selected in the document.

Procedure
1. Create the query as follows:

2. Link the query to the Item No. field in the required purchasing document.

Example 10
Objective
Copy a Sales Quotation to a Purchase Order.
If an item in the Sales Quotation is found in more than one row, the Quantity field will
be incorrect.

Procedure
...

1. Select from the menu bar Tools → User-Defined Fields → Manage User Fields. Click on
Marketing Documents and click on Title.
2. Create a user-defined field and name it QUOTNO.
3. To retrieve items from the required Sales Quotation, create the following query: SELECT
T0.ITEMCODE, T0.QUANTITY, T1.DOCNUM FROM QUT1 T0 INNER JOIN OQUT T1 ON
T0.DocEntry = T1.DocEntry WHERE T1.DocNum = $[OPOR.U_QUOTNO]
4. Name the query: Get Items from Quotation to Purchase Order.
5. To retrieve each item’s quantity from the required Sales Quotation, create the following query:
SELECT T0.QUANTITY, T0.ITEMCODE, T1.DOCNUM FROM QUT1 T0 INNER JOIN
OQUT T1 ON T0.DocEntry = T1.DocEntry WHERE T1.DocNum =
$[OPOR.U_QUOTNO] AND T0.ITEMCODE = $[$38.1.0]
6. Name the query: Get Quantity from Quotation to Purchase Order.
© SAP AG 2005
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7. Open the Purchase Order window.
8. Display the user-defined fields (View → User-Defined Fields).
9. Link the query Get Items from Quotation to Purchase Order to the Item No. field.
10. Link the query Get Quantity from Quotation to Purchase Order to the Quantity field.
11. Select the box Auto Refresh.
12. Select the Item No. field.
13. Select Display Saved Values.
14. Enter the required Sales Quotation number in the QUOTNO user-defined field.
15. Click the Item No. field in the first row of the table.
16. Press Shift+F2.
17. Select the required items from the list.
18. The Quantity field is updated automatically.

Example 11 - Referring to User Tables in Formatted Search Queries
Use
A user table can be used for storing different types of data. Later, the formatted search functionality
can be used to retrieve required data from this user table.

Objective
When creating a business partner, the user wishes to select the Zip Code of the business partner from
predefined data storage according to the country, city and address.

Procedure
...

1. Select from the menu bar Tools → User-Defined Fields → Manage User Fields, create a User
Table. Name it ZIP.

2. Add to the ZIP table the fields as follows: Country, City, Street, and ZipCode.
3. Fill this table manually (using Tools → User Tables) or automatically (by importing data into the
@ZIP table using an existing list of addresses).
4. The Code and Name fields are created automatically when creating a user table. You can enter
successive numbers into these fields.

5. Create the query:
SELECT T0.U_ZipCode FROM [@ZIP] T0 WHERE T0.U_City = $[CRD1.City] and
T0.U_Country = $[CRD1.country] AND T0.U_STREET = $[CRD1.STREET]
6. Name the query: Getting zip code from user table.

7. Open the Business Partner Master Data window.
8. Switch to Add mode.
9. Type a business partner code in the Code field.
10. Choose the Addresses tab.
11. Choose Bill to or Ship to.
12. Type the address, city and country.
13. Link the query Getting zip code from user table to the Zip Code field.
14. Place the cursor in the Zip Code field and press Shift + F2 to execute the formatted search.
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15. As a result, the required zip code will be retrieved from the user table @ZIP.

Example 12 - Additional Functions for Formatted Search Queries
Use
The current user logged in SAP Business One can be retrieved using the string $[USER].
The current posting period can be retrieved by using the string $[PERIOD].

Objective
When creating a new document, the user wishes to display the document’s creator name in the
Remarks field.

Procedure
...

1. Create the query:
SELECT T0.u_name FROM OUSR T0 WHERE T0.internal_k = $[USER]

2. Link the query to the Remarks field in the document.
The $USER string and the $PERIOD string can be used from any window in SAP
Business One.

Example 13 – Entering Line Breaks in a Formatted Search Query
Objective
A user wishes to display the user name in a document along with a proper text and line break between
the text and the user name.
The required display: "This document was created by: User Name"

Procedure
...

1. Use the query:
SELECT 'This document was created by: '+ char(13) + (SELECT T0.u_name
FROM OUSR T0 WHERE T0.internal_k = $[USER])
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Special Notes Regarding the Refresh Regularly Option
The option to refresh a formatted search query regularly should be used very carefully.
The following example demonstrates the consequences of using Refresh Regularly in an unnecessary
situation.

Objective
A user wants to open a limited list of items from a certain Item Group named Printers as a default in
the Sales Order window.

Procedure
...

1. Create the query as follows:
SELECT T0.ItemCode FROM OITM T0 INNER JOIN OITB T1 ON T0.ItmsGrpCod =
T1.ItmsGrpCod WHERE T1.ItmsGrpNam = 'Printers'

2. Name the query "Printers List”.
3. Link this query to the Item No. field in the Sales Order window.

4. Select the box Auto Refresh.
5. Select When Field Changes.
6. Select Customer/Vendor Code.
The Auto Refresh will cause undesired results in 2 cases:
{

When opening the Sales Order window, SAP Business One will automatically select the
first item retrieved by the query “Printers List”.

{

When opening an existing Sales Order (Status = Open), SAP Business One will replace
each existing item in the Sales Order with the first item retrieved by the query “Printers
List”.

The Refresh Regularly option might cause undesired results in some other cases.

Objective
When creating a Sales Order, the user is interested in displaying the customer’s account balance.

Procedure
...

1. Create a user-defined field in Marketing Documents - Title. Name it “Balance”.
2. Field properties: Type – Units and Totals, Structure – Amount.

3. Open the Query Generator and create the query:
SELECT T0.Balance FROM OCRD T0 WHERE T0.CardCode = $[ORDR.CardCode]

4. Name the query “Business Partner Balance".
5. Link the query “Business Partner Balance“ to the field “Balance”.
6. Open the Sales Order window.
7. Display user-defined fields (View → User-Defined Fields)
8. In the field “Balance” select from the menu bar Tools → Search Function → Search (or use the
key combination Shift+F2) to execute the formatted search.

9. As a result, the system displays the business partner's bookkeeping balance.
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10. Select items in the Sales Order and add it.

When browsing to this Sales Order after the customer was credited or debited for additional postings,
the Refresh Regularly option will change the balance in the Sales Order to the current balance and will
not to the balance which was displayed when the Sales Order was issued. However, the current
balance will not be saved in the database unless the Sales Order is updated, that is, choosing Update
in the document window.
To avoid this, use the Display Saved Values option.

Defining Formatted Search in Fields Influenced by Other
Fields
There are some fields in the system which might be affected when updating other fields.
Examples in sales and purchasing documents:
{

Updating the Discount field in a row affects the Price After Discount and the Row Total
fields

{

Updating the Row Total affects the Discount and the Price After Discount fields

{

Updating one of the Factors affects the Quantity field

{

Updating the Quantity sets the Factor values to 1

When defining formatted search for this type of fields you should take into consideration that the value
which was retrieved by executing the formatted search might be affected by the update of certain
fields in SAP Business One, as mentioned earlier.

Troubleshooting
Analyzing Problems when Executing a Formatted Search
When executing a formatted search from a field linked to an incorrect SQL query, SAP Business One
might display an error message in the status bar or do nothing while a specific result is expected.
This means that the formatted search does not work.
To get detail information about the cause of the problem you should run the formatted search query
manually while the window referring to the formatted search is open.
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Common Errors
1. Open Window
When opening a query which refers to a specific window while this window is open, do not save the
query since then the field‘s references will be replaced by the current values.

2. Error Converting Data Type
To simplify this issue, use the query:
$[RDR1.Quantity] * 2
This query is incorrect since it is impossible to multiply the string $[RDR1.Quantity], which is a nonnumeric value, by the number 2, which is a numeric value.
Correct query syntax is:
$[RDR1.Quantity.number] * 2

3. “Character number is greater than allowed”
This error message is displayed when the result of a formatted search contains a number of
characters which is greater than allowed for the field related to the formatted search.
Update the field's size according to the maximum expected result (relevant only to user-defined fields).
Otherwise, if the field is a system field, adjust the result to the field’s size.

4. "Error -1003"
Several reasons might cause this error:
{

The formatted search query refers to a field which does not exist

{

A common mistake is to use a user-defined field without the "U_" prefix

{

SQL syntax error

{

A Space is missing between the Equal sign (=) and the field/string before the Equal sign

{

Comparing a field of Alpha type to a variable such as [%0] without using a single
quotation mark → ‘[%0]’

{

No values were returned after executing a formatted search
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Fields Indexes for the Formatted Search Function
Item Type Documents Index Numbers and Column Numbers
The 'text' in the field name indicates the field header (rather than the field content)

Field Name
Items

I

C
3

Summary Type

75

Currency Type

70

Document Currency

63

Customer/Vendor (text)

5

Customer/Vendor

4

Name (text)

55

Name

54

Contact Emp. (text)

83

Contact Emp.

85

Manual

78

No. (text)

9

No.

8

Posting Date (text)

11

Posting Date

10

Due Date (text)

13

Due Date

12

Customer Ref. No. (text)

15

Customer Ref. No.

14

Series (text)

84

Series

88

Code/Catalog no.

79

Item Number

38

1

Catalog No.

38

2

Item Description

38

3

Bar Code

38

4

Catalog No.

38

5

Serial Number

38

6

Factor 1

38

7

Factor 2

38

8

Factor 3

38

9

Factor 4

38

10
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I

C

Quantity

38

11

Base Units

38

12

No. of Packages

38

13

Price w/o Dscnt

38

14

Discount %

38

15

Rate

38

16

Price

38

17

Tax Code

38

18

Price Including Tax

38

20

Total (LC)

38

21

Total (SC)

38

22

Total (Doc)

38

23

Whse

38

24

Del. Date

38

25

SE Code

38

26

SE

38

27

Comm. %

38

28

Acct. No.

38

29

Costing Code

38

30

Project Code

38

31

Open Qty.

38

32

On Hand

38

33

Sales Order

38

34

Committed

38

35

COGM

38

37

BOM Type

38

39

Tgt. Tab.

38

41

Target Key

38

42

Base Type

38

43

Base Ref.

38

44

Base Key

38

45

Base Row

38

46

BP Card

38

49

Length

38

53

Width

38

54

Height

38

55

Volume

38

56

Vol. Unit.

38

57
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I

C

Weight

38

58

Total Tax (LC)

38

82

Total Tax (Doc.)

38

83

Block No.

38

86

Import Log

38

87

Acquis.

38

88

Total Before Discount
(text)

23

Total Before Discount

22

%Discount (text)

25

%Discount

24

Discount Sum

42

Tax (text)

99

Tax

27

Total (text)

30

Total

29

Paid/Credited (text)

32

Paid/Credited

31

Balance Due (text)

34

Balance Due

33

Remarks (text)

17

Remarks

16

Journal Remark (text)

19

Journal Remark

18

Sales Employee (text)

21

Sales Employee

20

Payment Terms (text)

48
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Service Type Documents Index Numbers and Column Numbers
Field Name
Items

I

C
3

Summary Type

75

Currency Type

70

Document Currency

63

Customer/Vendor (text)

5

Customer/Vendor

4

Name (text)

55

Name

54

Contact Emp. (text)

83

Contact Emp.

85

Manual

78

No. (text)

9

No.

8

Posting Date (text)

11

Posting Date

10

Due Date (text)

13

Due Date

12

Customer Ref. No. (text)

15

Customer Ref. No.

14

Series (text)

84

Series

88

Code/Catalog no.

79

Description

39

1

G/L Account

39

2

Costing Code

39

3

Project Code

39

4

Price w/o Dscnt

39

5

Discount %

39

6

Rate

39

7

Price

39

8

Tax Code

39

9

Tax%

39

10

Price Including Tax

39

11

Total (LC)

39

12

Total (SC)

39

13

Total (Doc)

39

14

SE Code

39

15
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SE

39

16

Commission %

39

17

Open Amount

39

18

Tgt Type

39

21

Target Key

39

22

Base Type

39

23

Base Ref.

39

24

Base Key

39

25

Base Row

39

26

Base Card

39

28

Tax Total (LC)

39

32

Acquis.

39

35

Total Before Discount
(text)

23

Total Before Discount

22

%Discount (text)

25

%Discount

24

Discount Sum

42

Tax (text)

99

Tax

27

Total (text)

30

Total

29

Paid/Credited (text)

32

Paid/Credited

31

Balance Due (text)

34

Balance Due

33

Remarks (text)

17

Remarks

16

Journal Remark (text)

19

Journal Remark

18

Sales Employee (text)

21

Sales Employee

20

Payment Terms (text)

48

Payment Terms

47
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Copyright
© Copyright 2005 SAP AG. All rights reserved.
No part of this publication may be reproduced or transmitted in any form or for any purpose without the express
permission of SAP AG. The information contained herein may be changed without prior notice.
Some software products marketed by SAP AG and its distributors contain proprietary software components of
other software vendors.
Microsoft, Windows, Outlook, and PowerPoint are registered trademarks of Microsoft Corporation.
IBM, DB2, DB2 Universal Database, OS/2, Parallel Sysplex, MVS/ESA, AIX, S/390, AS/400, OS/390, OS/400,
iSeries, pSeries, xSeries, zSeries, z/OS, AFP, Intelligent Miner, WebSphere, Netfinity, Tivoli, and Informix are
trademarks or registered trademarks of IBM Corporation in the United States and/or other countries.
ORACLE® is a registered trademark of ORACLE Corporation.
UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group.
Citrix, ICA, Program Neighborhood, MetaFrame, WinFrame, VideoFrame, and MultiWin are trademarks or
registered trademarks of Citrix Systems, Inc.
HTML, XML, XHTML and W3C are trademarks or registered trademarks of W3C®, World Wide Web Consortium,
Massachusetts Institute of Technology.
JAVA® is a registered trademark of Sun Microsystems, Inc.
JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology invented
and implemented by Netscape.
MaxDB is a trademark of MySQL AB, Sweden.
SAP, R/3, mySAP, mySAP.com, xApps, xApp, and other SAP products and services mentioned herein as well as
their respective logos are trademarks or registered trademarks of SAP AG in Germany and in several other
countries all over the world. All other product and service names mentioned are the trademarks of their respective
companies. Data contained in this document serves informational purposes only. National product specifications
may vary.
These materials are subject to change without notice. These materials are provided by SAP AG and its affiliated
companies ("SAP Group") for informational purposes only, without representation or warranty of any kind, and
SAP Group shall not be liable for errors or omissions with respect to the materials. The only warranties for SAP
Group products and services are those that are set forth in the express warranty statements accompanying such
products and services, if any. Nothing herein should be construed as constituting an additional warranty.
SQL Server® is a registered trademark of Microsoft Corporation.
WinFax® is a U.S. registered Trademark from Symantec Corporation.
Sybase and SYBASE (logo) are trademarks of Sybase, Inc.
Intel and Intel JPEG Library are trademarks of Intel, Inc.
SEE4C (SMTP/POP3 Email Engine Library for C/C++) is the copyright of - MarshallSoft Computing, Inc.
Victor Image Processing Library and VIC32 are trademarks of Catenary Systems. The Victor Image Processing
Library is copyright material. This includes the source code, object code, dlls, examples, and documentation. This
material is protected by United States copyright law as well as international copyright treaty provisions.
THE APACHE SOFTWARE LICENSE, VERSION 1.1
Copyright (c) 1999 The Apache Software Foundation. All rights reserved. Redistribution and use in source and
binary forms, with or without modification, are permitted provided that the following conditions are met:

•

Redistributions of source code must retain the above copyright notice, this list of conditions and
the following disclaimer.

•

Redistributions in binary form must reproduce the above copyright notice, this list of conditions
and the following disclaimer in the documentation and/or other materials provided with the
distribution.

•

The end-user documentation included with the redistribution, if any, must include the following
acknowledgment: "This product includes software developed by the Apache Software

© SAP AG 2005

29

SAP Business One 2005

How to Define and Use Formatted Search

Foundation (http://www.apache.org/)." Alternately, this acknowledgment may appear in the
software itself, if and wherever such third-party acknowledgments normally appear.
•

The names "Xerces" and "Apache Software Foundation" must not be used to endorse or
promote products derived from this software without prior written permission. For written
permission, please contact apache@apache.org.

•

Products derived from this software may not be called "Apache", nor may "Apache" appear in
their name, without prior written permission of the Apache Software Foundation.

THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING,
BUT NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A
PARTICULAR PURPOSE ARE DISCLAIMED. IN NO EVENT SHALL THE APACHE SOFTWARE FOUNDATION
OR ITS CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY,
OR CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE
GOODS OR SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER
CAUSED AND ON ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT
(INCLUDING NEGLIGENCE OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS
SOFTWARE, EVEN IF ADVISED OF THE POSSIBILITY OF SUCH DAMAGE.

This product includes software developed by the Apache Software Foundation
(http://www.apache.org/) and Info-Zip (http://www.info-zip.org/pub/INFO-ZIP/).
This software consists of voluntary contributions made by many individuals on behalf of the Apache
Software Foundation and was originally based on software copyright (c) 1999, International Business
Machines, Inc., http://www.ibm.com. For more information on the Apache Software Foundation,
please see <http://www.apache.org/>.
SAP and/or its distributors may offer, and charge a fee for, warranty, support, indemnity or liability
obligations to one or more recipients of the software. However, SAP and/or its distributors may do so
only on its/their own behalf, and not on behalf of the Apache Software Foundation or its contributors.
UNZIP. This is version 2003-May-08 of the Info-ZIP copyright and license. The definitive version of this
document should be available at ftp://ftp.info-zip.org/pub/infozip/license.html indefinitely.
Copyright (c) 1990-2003 Info-ZIP. All rights reserved.
For the purposes of this copyright and license, "Info-ZIP" is defined as the following set of individuals:
Mark Adler, John Bush, Karl Davis, Harald Denker, Jean-Michel Dubois, Jean-loup Gailly, Hunter
Goatley, Ian Gorman, Chris Herborth, Dirk Haase, Greg Hartwig, Robert Heath, Jonathan Hudson,
Paul Kienitz, David Kirschbaum, Johnny Lee, Onno van der Linden, Igor Mandrichenko, Steve P.
Miller, Sergio Monesi, Keith Owens, George Petrov, Greg Roelofs, Kai Uwe Rommel, Steve Salisbury,
Dave Smith, Christian Spieler, Antoine Verheijen, Paul von Behren, Rich Wales, Mike White
This software is provided "as is," without warranty of any kind, express or implied. In no event shall
Info-ZIP or its contributors be held liable for any direct, indirect, incidental, special or consequential
damages arising out of the use of or inability to use this software.
Permission is granted to anyone to use this software for any purpose, including commercial
applications, and to alter it and redistribute it freely, subject to the following restrictions:
Redistributions of source code must retain the above copyright notice, definition, disclaimer, and this
list of conditions.
Redistributions in binary form (compiled executables) must reproduce the above copyright notice,
definition, disclaimer, and this list of conditions in documentation and/or other materials provided with
the distribution. The sole exception to this condition is redistribution of a standard UnZipSFX binary
(including SFXWiz) as part of a self-extracting archive; that is permitted without inclusion of this
license, as long as the normal SFX banner has not been removed from the binary or disabled.
Altered versions--including, but not limited to, ports to new operating systems, existing ports with new
graphical interfaces, and dynamic, shared, or static library versions--must be plainly marked as such
and must not be misrepresented as being the original source. Such altered versions also must not be
misrepresented as being Info-ZIP releases--including, but not limited to, labeling of the altered
versions with the names "Info-ZIP" (or any variation thereof, including, but not limited to, different
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capitalizations), "Pocket UnZip," "WiZ" or "MacZip" without the explicit permission of Info-ZIP. Such
altered versions are further prohibited from misrepresentative use of the Zip-Bugs or Info-ZIP e-mail
addresses or of the Info-ZIP URL(s).
Info-ZIP retains the right to use the names "Info-ZIP," "Zip," "UnZip," "UnZipSFX," "WiZ," "Pocket
UnZip," "Pocket Zip," and "MacZip" for its own source and binary releases.
MarketSet and Enterprise Buyer are jointly owned trademarks of SAP AG and Commerce One.
SAP, SAP Logo, R/2, R/3, mySAP, mySAP.com, and other SAP products and services mentioned
herein as well as their respective logos are trademarks or registered trademarks of SAP AG in
Germany and in several other countries all over the world. All other product and service names
mentioned are the trademarks of their respective companies.
Copyright and Licensing Information for ACE(TM) and TAO(TM)
ACE(TM) and TAO(TM) are copyrighted by Douglas C. Schmidt and his research group at Washington
University, University of California, Irvine, and Vanderbilt University Copyright (c) 1993-2003, all rights
reserved. Since ACE+TAO are open-source, free software, you are free to use, modify, copy, and
distribute--perpetually and irrevocably--the ACE+TAO source code and object code produced from the
source, as well as copy and distribute modified versions of this software. You must, however, include
this copyright statement along with code built using ACE+TAO.
You can use ACE+TAO in proprietary software and are under no obligation to redistribute any of your
source code that is built using ACE+TAO. Note, however, that you may not do anything to the
ACE+TAO code, such as copyrighting it yourself or claiming authorship of the ACE+TAO code that will
prevent ACE+ TAO from being distributed freely using an open-source development model. You
needn't inform anyone that you're using ACE+TAO in your software, though we encourage you to let
us know so we can promote your project in the ACE+TAO success stories..
ACE+TAO are provided as is with no warranties of any kind, including the warranties of design,
merchantability, and fitness for a particular purpose, noninfringement, or arising from a course of
dealing, usage or trade practice. Moreover, ACE+TAO are provided with no support and without any
obligation on the part of Washington University, UC Irvine, Vanderbilt University, their employees, or
students to assist in its use, correction, modification, or enhancement. However, commercial support
for ACE is available from Riverace and commercial support for TAO is available from OCI and
PrismTech. Both ACE and TAO are Y2K-compliant, as long as the underlying OS platform is Y2Kcompliant.
Washington University, UC Irvine, Vanderbilt University, their employees, and students shall have no
liability with respect to the infringement of copyrights, trade secrets or any patents by ACE+TAO or
any part thereof. Moreover, in no event will Washington University, UC Irvine, or Vanderbilt University,
their employees, or students be liable for any lost revenue or profits or other special, indirect and
consequential damages.
The ACE and TAO web sites are maintained by the Center for Distributed Object Computing of
Washington University for the development of open-source software as part of the open-source
software community. By submitting comments, suggestions, code, code snippets, techniques
(including that of usage), and algorithms, submitters acknowledge that they have the right to do so,
that any such submissions are given freely and unreservedly, and that they waive any claims to
copyright or ownership. In addition, submitters acknowledge that any such submission might become
part of the copyright maintained on the overall body of code, which comprises the ACE and TAO
software. By making a submission, submitter agrees to these terms. Furthermore, submitters
acknowledge that the incorporation or modification of such submissions is entirely at the discretion of
the moderators of the open-source ACE+TAO projects or their designees.
The names ACE(TM), TAO(TM), Washington University, UC Irvine, and Vanderbilt University, may not
be used to endorse or promote products or services derived from this source without express written
permission from Washington University, UC Irvine, or Vanderbilt University. Further, products or
services derived from this source may not be called ACE(TM) or TAO(TM), nor may the name
Washington University, UC Irvine, or Vanderbilt University appear in their names, without express
written permission from Washington University, UC Irvine, and Vanderbilt University.
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