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Icons 

 

Icon Meaning 

 
Caution 

 
Example 

 
Note 

 
Recommendation 

 
Syntax 

 

 

Typographic Conventions 

 

Type Style Description 

Example text Words or characters that appear on the screen. These include field 
names, screen titles, pushbuttons as well as menu names, paths 
and options. 

Cross-references to other documentation. 

Example text Emphasized words or phrases in body text, titles of graphics and 
tables. 

EXAMPLE TEXT Names of elements in the system. These include report names, 
program names, transaction codes, table names, and individual 
key words of a programming language, when surrounded by body 
text, for example, SELECT and INCLUDE. 

Example text Screen output. This includes file and directory names and their 
paths, messages, source code, names of variables and 
parameters as well as names of installation, upgrade and 
database tools. 

EXAMPLE TEXT Keys on the keyboard, for example, function keys (such as F2) or 
the ENTER key.  

Example text Exact user entry. These are words or characters that you enter in 
the system exactly as they appear in the documentation.  

<Example text> Variable user entry. Pointed brackets indicate that you replace 
these words and characters with appropriate entries. 
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How to Customize Printing Templates with Print Layout 
Designer 

Introduction 
The Print Layout Designer tool allows you to modify and customize the SAP Business One default printing 
templates according to your requirements.  

You can set one template as the default for all or some SAP Business One users, and link specific print 
templates to selected business partners. 

Opening Print Layout Designer 
Use 
You can open a printing template for any document or report in SAP Business One. 

To design a new layout for the document or report, make the required modifications in one of the system 
templates and save your changes under a new name. 

Procedure 
To open Print Layout Designer: 

1. Open the required document or report, for example, Sales Order. 

2. Choose the icon  on the tool bar, or select from the menu bar Tools → Print Layout Designer. 

The Layout Designer window opens: 

 
This window displays both the SAP Business One default print templates and the user-created 
templates. 

3. Select a template by clicking its name, and choose OK. 
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The Print Layout Designer opens: 

 
4. You can now make changes in the layout. 
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Defining Document Properties 
Use 
The Document Properties window contains general data regarding the current printing template. 

Procedure 
To define the document properties for your new template: 

1. From the menu bar, select Print Layout Designer → Display Document Properties.  

2. Choose the General tab and enter the required data: 

 

Document Properties – General tab 

Field name Description 

Document ID Combines three elements:  

1. Document type  

For example, RDR stands for Sales Order. 

2. Item type (2) or Service type (1) 

3. Document number in the layout sequence 

For example, 0001 represents the first layout for this document type. 

Template Name The name of the print template. 

Language The language in which the document was created. 

Foreign Select this box to print the foreign name of the currency code (Administration →  
Setup → Financials → Currencies → International Code) when printing a 
document for foreign business partners. 

Author The user who created the template (System refers to SAP Business One 
default templates). 

Remarks Enter remarks, if required. 
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3.  Choose the Paper Format tab and enter the required data: 

  

Document Properties – Paper Format tab 

Field name Description 

Number of 
Layout Pages

To increase the page layout to more than one page, enter a number indicating 
the required number of pages. 

Number of 
Copies

Enter the default number of copies for print. The default (1) is defined in System 
Initialization → Print Preferences.  

Printer Default refers to your default printer as defined in Windows. Choose another 
printer from the drop down list, if required. 

Paper Format Set the paper format for printing this specific layout. Changing the paper format 
automatically changes the display on the screen. 

Width, Height Manually set a specific paper format, which is not defined in the Paper Format 
drop-down list. 

Orientation Portrait is selected as default. Selecting Landscape will extend the print layout, 
allowing more space for fields in the repetitive area. 

Margins Add margins to the entire document. We recommend adding margins of 30 on 
the left, if you intend to file the document in a folder. 

4. Choose the Grid tab and enter required data: 
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Document Properties – Grid tab 

Field name Description 

Format Select the grid's line style. A preview of the selected style is displayed on the 
right. 

Size Enter the size of the squares in the grid (in pixels). 

Display Grid Select to display the grid in the layout. 

Adjust to Grid Select to make the fields snap-to-grid. 

5. Choose the Format tab and enter the required data: 

  

Document Properties – Format tab 

Field name Description 

Time and Date 
Format

Thee default values are determined by the selection in the Administration → 
System Initialization → General Settings → Display tab. 

Time Set the time to 24H or 12H. A specific time format can be selected for each 
template. 

Select Default to use the setting from General Settings. 

Date Set the date format for the template. 

Select Default to use the setting from General Settings. 

Separator Select a date and time separator for the template. What’s that? 

Preview Printing 
Layout

To define the layout of the Print Preview window, select this box and set a font 
style and size. 

 
If the actual printed document looks different than its preview, 
check if this box is selected and try again. 

E-Mail Layout To define the E-Mail layout, select this box and set a font style and size. 

 
If the actual printed document looks different than the one sent via 
E-mail, check if this box is selected and try again. 
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6. Choose the Picture tab to add a background picture to the document. 

 
 Choose Browse and navigate to the required graphic file. 

 To remove the selected picture, choose . 
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The Structure of a Print Template 
SAP Business One print templates contain several areas. 

Page Header 
The page header area contains the document and report header fields, including business partner, date, and 
document name. 

The Page Header is printed on every page of the document or report. 
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Start of Report 
The start of report area is located directly above the table titles. 

It is printed on the first page of the document or report. 
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Repetitive Area Header 
The repetitive area header contains the table titles and the sub-total titles. 

It is printed on every page of the document or report. 
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Repetitive Area 
The repetitive area duplicates itself according to the number of rows in the table. 
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Repetitive Area Footer 
In the repetitive area footer you can add summaries to the table using formula fields and also sub-totals. It is 
located directly under the repetitive area. 
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End of Report 
The end of report area contains the totals, remarks and other general document data. 

It is printed on the last page of the document or report. 
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Blank Area 
The blank area enables the repetitive area to expand according to the number of table rows in the printed 
document. 
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Page Footer 
The page footer area is always printed at the end of the page and normally contains company details.  

This is printed on all pages of the document. 
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Field Index  
When you open the print template, you see the Field Index window on the right of the screen. This window 
displays all the fields in the template, including hidden fields.  

• Clicking a field or area highlights it in yellow.  

• Hidden fields are displayed in a light grey color. 

 

Field Index 

Field name Description 

Unique ID An external unique identifier of each field generated upon field creation. You 
can update this field manually. 

 
We recommend that you give significant names to the fields. This 
will allow you to better identify them when, for example, you create 
formulas. 

Type Displays an icon matching the field's type and Source Type (Free Text, 
Database, Formula, System Variable, Picture, Bar Code, and External Data). 

Content Displays the field content. In the case of a formula, the entire formula is shown. 

Find Unique ID Fields are divided into areas. Under each area, the fields are sorted according 
to their Unique ID. You can search for a field by its Unique ID. If the field is 
found, it is highlighted in yellow and simultaneously selected in the template 
and in the Properties window. You cannot perform sorting in the Field Index.  
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Defining Area and Field Properties 
The Properties window relates to both area and field properties. It opens automatically when a print template 
is opened, and remains open unless you close it. 

To open the Properties window, right-click anywhere on the template and select Display Properties. 

 
When you create a new field, the Properties window automatically displays the properties of the new field. 
Click any area or field to display its properties. Clicking on another field will change the contents of the 
Properties window. The title of the Properties window displays the name of the selected field or area. 

If you select multiple areas or fields, the title of the Properties window becomes Properties- Multiple Areas or 
Properties- Multiple Fields.  

You can modify both field and area information in the Properties window. If you select several fields for 
modification, the system disables the Unique ID field on the General tab. As a result, some of the individual 
field or area information may be disabled, depending on the common characteristics of the selections. 
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Defining Area Properties 
To modify an entire area: 

1. Click anywhere on the area (where there are no fields). 

The system displays information relevant to the selected area in the Properties window. 

2. Enter the data on the General tab. 

 

Properties Window – General tab 

Field name Description 

Unique ID A unique identifier generated automatically on creation of a new area; can be 
manually updated by the user.  

Creating two areas with the same unique ID will generate a corresponding error 

message:  

Height The area height in pixels. 

Visible Select to make the area visible on the screen. 

3. To add a picture to the area, on the Content tab, choose Browse and navigate to the required graphic 
file. 

 
The Print Layout Designer supports the file formats: jpg, gif and bmp. 
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4. To activate automatic height adjustment of the area, on the Format tab, select Area Height 
Adjustment: 

  
The height of an area is adjusted automatically if the fields: 

 At the top or bottom are blank 

 Are linked to themselves 

 Do not contain values. 

5. To align the End of Report area to the end of the last page, on the Format tab select Align to Bottom: 

 
This is available in the End of Report area only and should not be used together with the Area Height 
Adjustment option. 
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6. To format the area borders and margins, on the Border tab, enter the required data. 

 

Properties Window – Border tab 

Field name Description 

Border, Margins To define a border around the area, or margins for the area, enter numbers in 
the Right, Left, Upper and Low fields. The numbers set the thickness of the 
border in pixels. 

7. To determine the color of the area, on the Color tab, enter the required data: 

 
You can apply color separately to the Frame, Background and Grid. 
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Creating Multiple Repetitive Areas 
Use 
Additional repetitive areas can be created in all the print templates. 

 
Print a separate table of item images in addition to the standard item table in sales or 
purchasing documents. 

In the USA it is mandatory to print invoice details in two locations in the layout of checks for 
payment. The multiple repetitive areas option enables you to print this type of layout. 

You can print two different item tables in the same document and determine, using a formula 
type field, which items will appear in each table. For example, print a table of regular items, 
including the Quantity column, along with a table of labor items, with an extra description and 
no quantity. 

Procedure 
To create a new repetitive area: 

1. Open a print template and select  on the tool bar.  

A new Repetitive Area is added to the template: 

 
2. Create fields in the new area. 

 
You can add as many repetitive areas as required. 

To sort a repetitive area, click the area, and in the menu bar, choose Print Layout Designer →  
Repetitive Area → Sort. 
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Creating New Fields 
Use 
You can create four different field types using Print Layout Designer: text, picture, barcode and external data. 
Each field can obtain its value from several sources. The type of field and source can be changed after the 
field has been created. 

Procedure 
To create a new field: 

1. Choose one of the following toolbar icons: 

Field Icons 

Icon Description of Field Type Default Source Type 

 
Text  Free Text

 Text Database

 
Text Formula

 Text System Variable

 Picture File

 Barcode Free Text

 
External Data Procedure Name

After you have chosen the required field type, the system displays the cursor's icon accordingly.  

  
If you choose to create a text field with database as its default source, the cursor is displayed 

as . 

2. Place the cursor on the required location, press and drag the frame to extend the field. 

  
The minimum size of a field is 10x10 pixels. 

The minimum size restriction applies only when creating a new field. Once a field has been 
created, you can decrease or increase the field size using the 4 gray squares on each corner of 
the field: 

 
Place the cursor over a selected corner, drag to expand or shrink the field as needed. 

 

We recommend that you choose the toolbar icon   after you have finished creating the field. 
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Defining General Field Properties 
Use 
After you have created a new field you need to modify its properties to meet your requirements. Once the 
field has been created the Properties window displays information about the new field. 

Procedure 
Make the required entries on the General tab. 

 

Properties Window – General tab 

Field name Description 

Unique ID A unique identifier of each field; behaves in the same way as the Unique ID of an area. 

Field Type There are four field types: Text, Picture, Bar Code and External Data. The default value 
of the field is determined by the icon you selected when the field was created 

You can change the field type at any time. 

Link to Creates a link between several fields, to determine if the system collectively displays or 
hides them. If a field is blank or hidden, its linked fields are not printed either. 

To create the link, choose the Unique ID of the field to which you want to link the 
selected field.  

 
If the field Total Liable in the document is set to zero there is no need to 
print the Tax, Discount, and Total fields. It is possible to link these fields to 
the field Total Liable by selecting its unique ID in the field Link to, found in 
each one of their Properties windows. This will then hide the fields when 
Total Liable is zero.  

 
If a linked field is not yet calculated, the field is ignored. 
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Visible Select/Deselect to print/not print the field. 

Fields used as conditions are usually hidden.  

Group The number of the group to which the field is linked.  

In a template with no sub-sorts or sub-totals, all the fields are linked to group 0. For 
further explanations on groups, see the Defining Sorts section below. 

 
Left, Top, 
Width, 
Height

The location and size of the field in the template.  

Left and Top define location; Width and Height define size.  

Enter different values to change the field's size and location, if needed. 

Hidden fields are not displayed in the Print Layout Designer window and appear in light grey in 
the Field Index window. However, you can display them on the screen for editing by selecting 
from the menu bar Print Layout Designer → Display Hidden Fields. 

Defining Source Type 
Use 
The Source Type field defines the data source of the field.  

The available source types for text type fields are: 

• Free Text 

• Database 

• Formula  

• System Variable 

The system automatically displays a default source type according to the type of field you selected when the 
field was created. Change the source type by selecting another source type, and then exiting the properties 
display for the selected field by clicking another field or area. 
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Procedure – Defining Free Text as Source Type 
To choose free text as the source type:  

1. Choose Properties - Field → Content tab. 

2. Select Free Text in the Source Type field. 

  
Use a free text source type for printing fixed remarks, notes, instructions or comments. 

3. Enter the required text. 

 
You can enter text up to 64,000 characters. 

 

Procedure – Defining Database as Source Type 
To choose Database as the source type: 

1. Choose Properties - Field → Content tab. 

 
2. Select Database in the Source Type field and make the required entries in the Content tab. 

  
Use a database source type to print information from a selected table and column. 

The system creates Database source type fields automatically in every system template. 

You can create as many database fields as you require in your own print templates. 
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Properties– General tab, Database fields 

Field name Description 

Table Select the table from which to retrieve the information printed in this field. 

Column Select the field you want to print in the document.  

 
If you want to print the customer's channel business partner in a print 
template for invoices you should select Business Partner in the Table field 
and Channel BP in the Column field. 

Get 
Description

Select to print the field's description rather than its code.  

 
If you select Business Partner in the Table field and BP Type in the 
Column field, SAP Business One will print the code values: C, S or L. 
When the box is selected the actual names of these code letters are 
printed: Customer, Supplier or Lead. 

Relate to This option is relevant for special scenarios only and requires knowledge of SQL.  

This field is used for retrieving data related to key records found in tables other than the 
table linked as default to the current print template. 

A key record is a field used as a primary key in a certain table. This key record functions 
as the identifier of the record, and, therefore, it is required to retrieve any additional data 
related to it. 

 
If you need to print the name of a certain bank, which is not linked to the 
table used in the current print template, you must first create a Text field of 
Database source type using the required table and select a key record, 
such as Bank Code.  

Then, you need to create an additional Text field of Database source type. 
Select the table again, select the required column (such as Bank Name), 
and enter the unique ID of the field with the key record in the Relate to 
field. 

There might be two or more key records in the same table. In such a case, 
these two key records are both required for retrieving the data. 

 
Identical bank codes are used in many countries. If you need to print the 
name of a specific bank, you need to link it to a relevant country, in 
addition to its relevant bank code. 

 
You are currently working on a print template for Incoming Payments. 
However, you need to retrieve data (such as the business partner's bank 
name) linked to the key record Bank Code from the Bill of Exchange for 
Payment table, rather than from the Incoming Payments table. 

In the Relate to field, select the unique ID of the field containing the 
required key record. In this example, this is a Text field of Database 
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source type containing Bill of Exchange for Payment in the Table field and 
BP Bank Country in the Column field. The drop-down list contains the 
unique IDs of all the fields that are situated in the same area as the current 
field. 

This link makes the system retrieve the Bank Code linked to the BP Bank 
Country field found in the Bill of Exchange for Payment table. 

Next 
Segment

Use this field when a validation of two or more key records is required, for example, the 
field BP Bank Country and the field BP Bank Code. 

To make this double validation, select the unique ID of the next key record field in this 
field. 

The field with this unique ID is used as the secondary validation key record. 

Procedure – Defining Formula as Source Type 
1. Choose Properties – Field, Content tab. 

2. Select Formula in the Source Type field and make the required entries. 

A formula source type field allows you to display the results of certain calculations, either built 
manually or with the Formula Editor. 
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3. To open the formula editor window choose Formula Editor. 

 
4. To find the required field by its unique ID, enter the ID in Find Field. 

The matching field is highlighted in yellow. 

  
Fields from different areas can be selected as long as they are already calculated and located 
in an area above the calculation field. 

5. To add a field to the formula in the formula area on the right side of the window, do one of the 
following: 

 Double-click the selected field. 

 Enter the unique ID into the formula area. 

 
If you enter a non-valid unique ID, or modify the unique ID of a field used in a formula, the 
system generates a warning message.  

6. To add numbers to the formula, enter them directly into the formula area. 

7. To add operations to the formula, select the required operation from the Operation field and choose 
Insert. 
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Formula Editor – Operations 

Operation Description 

Arithmetic 
Operations

• % 

This operation is an operator rather than a percent calculation. It displays the 
remainder of a division of 2 numbers, for example, 10 % 3 results in 1, since 10/3 
= 3+ a remainder of 1. 

• *  

Multiplication 

• +  

Addition 

• -  

Subtraction 

• /  

Division.  

If the two variables you use are of integer type (natural numbers), the result is 
also an integer number. For example, dividing 10 by 3 results in 3.  

On the other hand, a division of a float type number (decimal fraction) by any 
other number results in a float type number as well, for example, dividing 10.00 
by 3 results in 3.33. 

• Abs (Number) 

Displays the absolute value of a number. 

• Avg (, …) 

Displays the average of a list of numbers. 

• DecimalLeft (Number) 

Displays the integer part of a numeric value up to its decimal point. For example, 
for a field containing the value 241.32, this operation results in the integer number 
241. 

• DecimalRight (Number) 

Displays the decimal fraction of a numeric value. For example, for a field 
containing the value 241.32, this operation results in the decimal fraction .32. 

• Pow (Base as Number, Exponent as Number) 

Displays a number raised by a power. 

• Round (Number, Decimals as Number) 

This operation rounds a numeric value according to the number of characters 
selected in Field 2. For example, a field contains the value 524.18. Selecting in 
Field 2 a text field containing the number '1' results in 524.2. 

© SAP AG 2006 31  



SAP Business One 2005 A SP01    How to Customize Printing Templates with the PLD    

  

 

String 
Operations 

 

• Amount (Money) 

Extracts only the number out of a field containing a value comprised of a number 
and a currency symbol. For example, selecting this operation for the field Amount 
Due containing the value €154, prints 154.  

This operation is mainly required in cases where a number is needed for 
calculation between fields. 

• Concat (, …) 

Concatenates strings. For example, "A" Concat "B" results in "AB". 

• Currency (Money) 

Extracts only the currency symbol out of a field containing a value with a currency 
symbol. For example, selecting this operation for the field Amount Due containing 
the value $154, prints $. 

• Length (Text as String) 

Displays the number of characters in the selected field (a space is regarded as a 
character). For example, using this operation on a Remarks field that contains a 
value with 100 characters, results in the value 100 being printedt. 

• Sentence (Text as String, SentenceIndex as Number) 

Cuts an entire sentence from the selected field (up to the next Enter mark). In 
Field 2 select a number to indicate the required sentence number to cut. 

• Substring (Text as String, SubStringLength as Number) 

Cuts a selected number of characters from the right of a selected field (a Text 
field containing a number should be linked). For example, selecting Substring 
(Unique_ID, 3) using the unique ID of a field containing the string BOSTON will 
print TON. 

Substring (Text as String, SubStringStartIndex as Number) 

Cuts a selected number of characters from the left of a selected field. 

Date 
Operations 

 

• Day (Date as String) 

Returns the day part of a date. 

• Month (Date as String) 

Returns the month part of a date. 

• MonthName (Month as Number) 

Returns the name of the month. 

• Year (Date as String) 

Returns the year part of a date. 
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Condition 
Operations 

 

• In order to use condition operations: 

 The condition must be IF, and must consist of 2 fields. 

 The calculation field displaying the result must be located in an area below 
its calculated fields. 

To use conditions on fields, follow these steps: 

1. Create a Text field of Formula source type for displaying the result. The result will 
be 1 if the condition is met and NULL if the condition is not met. 

2. In the Formula field choose Formula Editor. 

3. Select the fields for the condition by searching for them in the Field Index or 
typing them manually. 

4. In the Operation field, select the condition to apply to the selected fields  
(Equal !=, Less than <, Greater than > and so on.). 

You can also select hidden fields.  

The main use of conditions involves the Relate to option. If the condition is not met and 
the field is NULL, then none of the fields linked to it are printed. 

Cast 
Operations 

 

• ToNumber (String) 

Explicit cast from string to number. 

• ToString (Number) 

Explicit cast from number to string. 

Other 
Specific 
Operations 

 

• ColAvg(UniqueID as String) 

A calculation of the average value of numbers in a selected column, for example, 
average price. This formula field can be created below the repetitive area.  

• ColSum(UniqueID as String) 

A calculation of the total values in a selected column, for example, total quantity. 
This formula field can be created below the repetitive area. . 

• CopyNumber() 

Enables the user to manage the number of printed copies. 

• CurrentPage() 

The number of the page in the document printout. 

• Date() 

The printing date. 

• GroupLineNum() 

The row number in the group for which a sub-sort or subtotal is calculated. When 
creating this type of field in the repetitive area footer, for a group on which a sort 
is performed, the field will display the total number of rows in each subtotal. 

• LineNum() 

The successive number of the row in the repetitive area. 

• PageAvg(UniqueID as String) 

A calculation of the average value of numbers in a selected column in every 

© SAP AG 2006 33  



SAP Business One 2005 A SP01    How to Customize Printing Templates with the PLD    

  
printed page. 

• PageSum(UniqueID as String) 

A calculation of the total pages in the document. 

• ReportAvg(UniqueID as String) 

A calculation of the average value of numbers in a selected column for the entire 
report. 

• ReportSum(UniqueID as String) 

A summary of the values in a selected column for the entire report. 

• SortFieldName(SortNumber as Number) 

The name of the sort field selected in the template, for example, Item Group. 

• SortValue()  

The content of the sort field selected in the template. for example, the item group 
name. 

• SystemString(B1Notice) 

Select this operation to print the message: Printed by SAP Business One. 

• SystemString(ContinueNextPageNotice) 

Select this operation to print the relevant message on each page, except for the 
last one. 

• SystemString(ContinueNotice) 

Select this operation to print this message on each page. 

• Time() 

The printing time. 

• TotalPages() 

The total number of printed pages. 

8. After completing the formula choose Update.  

The system generates a message to inform you that the formula has been successfully created. 

If there are errors in the formula the system generates a warning message, such as: 

 

 
You can define a calculative ratio between fields using a formula field. In such a case, the 
formula field displaying the result must be located in an area below its calculated fields. 
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Procedure – Defining System Variable as Source Type 
A System Variable field contains a link to an actual variable found in SAP Business One. 
To choose a system variable as the source type: 

Select System Variable in the Source Type field and make the required entries. 

 
We recommend reading SAP Note 723783 before you define system variable fields. 

 

Properties – Content tab, System Variable fields 

Field name Description 

Variable No. Enter the variable number. 

Variables are unique to the specific document you are designing. To place a text field of 
System Variable source type, you need to know the variable number.  

To display the variable number in SAP Business One: 

1. From the menu bar choose View → System Information.  

2. Place the cursor on the field. 

The system displays the field details on the status bar (located at the bottom left 
part of the screen). 

The variable number assigned to the field is displayed as Variable = 
<number> 

Comment Enter a description of the variable. This text will not be printed. 

 
Examples for using variable fields: 

 Data calculated during the printing process or in the actual document, for example, the field 
Total Before Discount in sales and purchasing documents. 

 Fields appearing as columns in a table, but which are not printed, for example, the fields Credit 
(SC), Debit (SC) and Balance (SC) in the General Ledger report.  

For a list of additional variables available for printing in the General Ledger report, see SAP 
Note 867048. 
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Procedure – Defining Picture Fields as Source Type 
Picture fields enable you to print the company logo on documents, as well as pictures of items, and even 
images of company employees. 

The source types available for picture type fields include: 

• File (default) 

Use File source type to print a fixed image, such as the company logo, on the document. 

• Database 

Use Database source type to print pictures saved in your database tables. For example, you can print 
a catalog of items along with their pictures.  

To associate a picture with an item, from the Main Menu choose Inventory → Item Master Data → 
Details tab. 

• Bar Code 

The Content tab of a Bar Code type field is identical to the Content tab of a Text field. The source 
types available for Bar Code fields include the values Free Text, Database, Formula and System 
Variable. Free Text is the default source type. 

• External Data  

You can use this type of field to print secured images, such as official stamps, which you are not 
legally permitted to save on your computer as regular pictures, but as *.dll files. The source types 
available for External Data fields include the values Procedure Name, Database, Formula and System 
Variable. 

To select a file source type to print a fixed image: 

1. Choose Properties - Field → Content tab. 

2. Select File in the Source Type field. 

 
3. Choose Browse and select the required picture file. 

The Browse button opens the picture folder as defined in Administration → System Initialization → 
General Settings → Path tab → Picture Folder. 
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To select a database source type to print a fixed image: 

1. Choose Properties - Field → Content tab. 

2. Select Database in the Source Type field: 

 
3. Select the required database table in the Table field. 

4. Select the required field in the Column field. 

To select an external data source type to print a fixed image: 

1. Choose Properties - Field → Content tab.  

2. Select Procedure Name in the Source Type field: 

 
3. Enter the name of the required *.dll file in the Procedure Name field. 

  
The *.dll file must be located in the extensions folder defined in Administration → System 
Initialization → General Settings → Path tab → Extensions Folder. 

4. To define a dependency between a hidden field in the template and the extension's printing, do the 
following: 

a. In the Source Type field, select Database.  

b. In the Table field, select the required table. 

c. In the Column field, select the field on which the extension's printing depends. 

A dependency could be, for example, when an extension is printed only if its linked field contains a certain 
number, date or string. 
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Defining Field Text Format 
Use  
Use the Format tab to customize the appearance of the text in the field. 

Procedure 
To format the text in the field: 

1. Choose Properties - Field → Format tab. 

 
2. Enter the data as described in the following table. 

Properties – Format tab 

Field name Description 

Font, Size Select an appropriate font.  

Enter the size manually in the Size field.  

Choose Font… to open a corresponding window where you can also change the font 
type, style, size and color. 

Block 
Overall Font 
Change 

Select to keep the font defined for the field, even when changing the font from Print 
Layout Designer → Display Document Properties → Format tab → Preview Printing 
Layout and E-Mail Layout fields. 

Horizontal Select the required horizontal alignment method. 

Vertical Select the required vertical alignment method. 
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Line Break Select a line-breaking method for fields containing long texts. For example, define how 
to break a long text typed in the field Remarks in a document, using one of the following 
methods: 

• Allow Overflow 

Choose to print the text even if it crosses the frame's border. 

• Adjust to Cell  

Choose to cut the text when it reaches the frame's border. The remaining text will 
not be printed beyond the border. 

• Divide into Rows 

Choose to continue the text in the next row when the text reaches the frame's 
border. To enable this option it is recommended to maintain spaces between 
words.  

To divide into rows according to the original text, press Enter on the keyboard 
each time you want to order the system to move on to a new row. 

Length Set a fixed number of characters to be printed in selected fields.  

For example, print only the first 5 digits of an item number:  

Original Item Number: 5822107, Printed Item Number: 58221. 

Filler Define a symbol for filling up remaining spaces when the field contains fewer characters 
than defined in the Length field.  

For example, if an item number is less than 5 characters long, the filler * is printed 
instead of the cut characters.  

Original Item Number: 582, Printed Item Number: 582** 

Field Height 
Adjustment 

Select to automatically adjust the field height to the text it contains. 

Sum in 
Words 

If the field displays a number, you can select this box to print the number in words. For 
example, the amount $25 will be printed as Twenty-Five Dollars. 

Suppress 
Zeros 

If the field displays a number, select this box to remove decimal zeros. For example, 
233.00 will be printed as 233. 
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Defining Field Border 
Use  
Use the Border tab to customize the appearance of the field border. 

Procedure 
To format the field border: 

1. Choose Properties - Field → Border tab. 

 
2. Enter the data as described in the following table. 

Properties – Border tab 

Field name Description 

Border Draws a border around the field.  

Enter numbers (pixels) in the Right, Left, Upper and Low fields to set the thickness of 
the frame. 

Margins Enter numbers (pixels) in the Right, Left, Upper and Low fields to set the location of the 
content inside the frame.  

Shade Enter a number to set the degree of shading. 
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Defining Field Color 
Use  
Use the Color tab to set the print color for the text, background, highlighted text, and frame. 

Procedure 
To set field color: 

1. Choose Properties - Field → Color tab. 

 

2. Choose  to open the Color window. 

3. Choose required colors.  

 
To define the highlighted text, frame or background color as transparent, select the box next to 
the field name. 
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Field Dependencies  
Use 
Dependency Types  
There are two types of field dependencies: 

• Formula Dependency 

This dependency occurs when you create a field with Formula source type. This field may use other 
fields as operands. The calculated field becomes dependant on its operand fields. If you delete other 
fields, the dependent field becomes invalid and the document cannot be printed. 

• Link Dependency 

This dependency is created by the Link to option (in the General tab of the Properties window). The 
field becomes visually dependent on the field to which it is linked. The link affects only the visibility of 
the dependent field; its visibility depends on the visibility or value of the other field. If you delete the 
field on which it depends, the document will still print.  

The Relate to and Next Segment options also create a link dependency. A field may also be 
recursively dependent on another field. For example, Field A depends on Field B, and Field B depends 
on Field C. This makes Field A also (recursively) dependent on Field C. 

Displaying and Hiding Dependant Fields 
Use 
You can display and hide dependent fields using commands from the menu bar or from the toolbar. 
Displaying dependencies highlights both visible and hidden fields in both Print Layout Designer and the Field 
Index windows: 

Procedure – Displaying Dependent Fields 
This command is enabled when a field or several fields in the layout are activated.  

To display dependant fields: 

1. Select the field whose dependent fields you want to display. 

2. Choose  from the toolbar. 

The status bar displays one of the following messages depending on whether or not the system found 
dependent fields: 

  

Procedure – Hiding Dependent Fields 
This command is enabled only when dependencies are shown.  

To hide dependent fields: 

1. Select the field whose dependent fields you want to hide. 

2. Choose  from the toolbar. 
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Example 
If field A is not visible, then field B should not be visible either. Therefore, a link should be created between A 
and B. 

1. Create Field A: 

 
2. Create Field B and link Field A to Field B so that Field B is dependent on Field A. This is a link 

dependency. 

 

3. To display the fields that are dependent on Field A, select Field A and choose .  

The system displays Field A with a green background color in Print Layout Designer, while Field B (the 
link-dependent field) is displayed with a white background color and a green border: 
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The dependency is highlighted in the same way in the Field Index window: 

 
The system colors the Type column according to the dependency type. 

When dependency is shown, a legend also appears at the bottom of this window, displaying a 
rectangle for each color. 

The legend disappears when dependent fields are hidden.  

The system displays Formula dependent fields with a light green background color and a green 
border. In a recursive dependency, if at least one of the dependencies along the chain is a Formula 
Dependency, then the dependent fields are marked as Formula Dependent. 

4. To show dependencies of another field, select the field and choose  again. 

5. Choose  to hide the dependency.  

This icon is active only when dependencies are shown. The command de-highlights Field A and both 
fields revert to their original properties. 
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Deleting Fields 
Use 
When you attempt to delete a field or fields on which other fields depend, the system issues a warning 
message, asking you if you want to proceed with the deletion. 

Example 
1. You have four text fields, A, B, C and D. 

Field B is dependent on Field A and Field D is dependent on Field C; therefore, Fields A and C have 
dependencies. 

2. Select the four fields and press Delete. 

3. The following warning message appears: 

 
4. Choose the relevant option as described in the following table: 

Options for Deleting Fields  

Option Action 

Yes Deletes the first field with dependencies (Field A).  

The warning message reappears before the second field with dependencies (Field B) 
can be deleted. 

Yes to All Deletes all fields with dependencies (Field A and C) and without dependencies (Field B 
and Field D) 

No Default. Cancels the Delete operation for the first selected field with dependencies. 
(Field A). The window then reappears to issue the same warning message for the next 
field with dependencies (Field C). 

No to All Cancels the Delete operation for all fields with dependencies (Field A and Field C) but 
deletes the fields without dependencies (Field B and Field D). 

Cancel Cancels the entire Delete operation for all fields. 
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Defining Sorts 
Use 
You can sort the printed table according to the data found in each repetitive area (including hidden fields).  

Procedure 
To sort a certain table in a repetitive area: 

1. Click the selected area. 

2. From the menu bar choose Print Layout Designer → Repetitive Area → Sort. 

 
3. Make selections as described in the following table: 

Sort 

Option Action 

Field Name Select the sort field. The first field you select is the primary sort; the second field is the 
secondary sort, and so on. 

Sort Type Choose Alpha, Numeric, Currency or Date. 

Order Choose Ascending or Descending. 

Summary Choose to perform a summary for this sort. Selecting this box does not perform the 
actual summary, but indicates to the system to search for a sub-sort or a subtotal. 

New Page Select to move on to a new page after a summary or sort takes place. 
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Performing Sub-sorts and Subtotals 
Use 
You must create sorts in order to perform sub-sorts or subtotals. For example, sort the Items table in a sales 
quotation by the Item Number field and display a relevant title each time the item number changes. This is a 
sub-sort.  

In addition, perform a sub-total displaying the cumulative quantity of each item. This can be used in 
documents containing multiple rows of the same item, displayed with a different description in each row. 

Procedure 
After defining the sort, perform the following steps 

1. From the menu bar choose Print Layout Designer → Group. 

2. Select a group number.  

3. Select 1 for a sub-sort or sub-total for the primary sort, select 2 for the secondary sort and so on. 

Each group is linked to its relevant row number in the Sort window described above. Thus, every field 
created in a certain group relates only to its group's corresponding row in the Sort window. 

The Repetitive Area Header titles are now hidden as well as any field created in the Repetitive Area 
Footer. The reason is that these two areas are linked to groups. Each one of the groups has two areas 
of its own. 

4. To define the sub-sort, do the following: 

a. In the Repetitive Area Header assign a title for the required sort. 

b. Create a new Formula field 

c. Choose the Formula Editor button and select the operand SortValue() in the Operation field. 

This action will print the Items table divided into separate titles each time the Item number 
changes. 

5. To define sub-totals do the following: 

a. In the Repetitive Area Footer create a Formula field. 

b. Choose the Formula Editor pushbutton and select the operand ColSum(UniqueID as 
String) in the Operation field (for the Quantity field from the rows in the Sales Quotation).  

The field within the brackets defines the column for which a total will be calculated. You can 
also calculate totals for the Price and Total columns. 

6. To save the changes choose  on the toolbar. 
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Setting a Default Print Template 
Use 
For each new company, SAP Business One creates default print templates for each document and report 
type (according to the localization). 

After creating your own user-defined templates, you can set them as default, so that each document is 
printed using the customized template. 

Procedure 
To set a print template as default: 

1. Open the required document or report. 

2. Choose  from the toolbar. 

The Layout Designer window opens: 

 
The document name displayed in bold letters is the current default print template. 

In the above example, the template Sales Order Preprinted USA (System) is set as the default 
template for the document type Order (Items). 

3. To set a different template as default, click the required document name once, and choose Set as 
Default. 
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The Default Template window appears: 

  
4. Select one of the following: 

 Set as Default for All Users 

This option sets the selected template as default for all SAP Business One users. 

 Set as Default for Current User 

This option sets the selected template as default only for the SAP Business One user who is 
currently logged on. 

5. Choose OK to apply the selection. 

 
Only a superuser can set a template as default for all users. 
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Setting a Default Print Template for Business Partners 
Use 
SAP Business One enables you to set specific print templates as default for selected business partners. 

For example, you can set separate print templates in different languages for business partners according to 
their local language. 

 
You can set default print templates for the following documents: sales & purchasing (Invoice, 
Delivery, and so on), payments (Incoming Payments, Outgoing Payments, and so on), Checks 
for Payment and Sales Opportunity. 

Procedure 
To set a default print template for business partners: 

1. Open a document and select a business partner. 

  
An invoice in Italian would be appropriate for customers who speak Italian, for example, from 
Italy, Switzerland and New York.  

2. Choose  from the toolbar. 

The Layout Designer window opens: 

 
3. Click the required print template. 

4. Choose Set as Default. 
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The Default Template window opens: 

 
5. Select one of the following: 

• Set as Default for All BPs (for whom a Default Template has not been assigned) 

Choose this option to set the selected print template as default for all the business partners for whom 
no default template has been assigned yet. 

In the example described for Italian speaking customers, you should not select this option since you 
do not wish to print all your invoices in Italian. 

• Set as Default for Specified BP 

Choose this option to set the selected print template as default for the business partner specified in the 
document. 

6. Choose OK. 

The Business Partner – Selection Criteria window opens: 

 
The system displays the business partner specified in the document in this window.  

7. To set the selected print template as default for this business partner, select the box next to the 
Language column and choose Update. 
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Setting a Print Template as Default for Several Business 
Partners 
You can set a print template as default for several business partners using the Business Partner – Selection 
Criteria window. 

Example 
In this example you have several business partners who speak Italian and you decide to set a print template 
in Italian as default for all of them. 

Procedure 
1. In the Business Partner – Selection Criteria window choose Add: 

 
The BP Properties window opens: 

 
2. Use the BP Properties window to select additional business partners according to their codes, groups, 

properties and language. 

3. Choose OK. 
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The Business Partners – Selection Criteria window opens: 

 
4. Select the boxes of all the Italian speaking business partners for whom you would like to set an invoice 

in Italian as the default print template. 

 
To define a language for a business partner, choose Business Partners → Business Partner 
Master Data → General tab → Language. 

5. Choose Update to confirm, or Clear to reset your selection. 
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Tips and Tricks 
Backing-Up Print Templates 
Save your print template under a new name each time you modify it. This helps in keeping backups of the 
user-defined templates, and allows you to return to a previous template in case the new one does not meet 
your requirements. 

 
After you have made a change in a print template and saved it under a new name, you can set the new 
template as default, print the document and see if the modifications are as required. 

Deleting Templates 
You can delete the backup templates at any stage.  

To delete a template: 

1. Open the required print template. 

2. From the menu bar choose Print Layout Designer → Delete Layout. 

Printing the Ship To Address, Bill To fields 
To display the fields Ship To or Bill To address in the print layout of a document, use the default values from 
the Business Partners table or from the document table (for example, Delivery).  

 
When issuing the document, remember to select the Ship To address you want to print. 

Do not use values from the Business Partners – Addresses table (CRD1). Connecting fields 
from this table will cause document printing to fail.  

If you connect any field from a sub-table (for example, CRD1, 2 or 3) to a print layout, the 
document printing will fail. 
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Using Formula Fields as Sort Fields 
You can use formula fields as sort fields in the Sort window. 

 
To use a formula field as a sort field: 

1. Open the drop-down list in Field Name.  

2. Select the required Formula field. 

Multiple Predefined Print Templates (System) 
Some reports and document types have several SAP Business One default (System) templates. 

 
The number of these predefined templates varies according to the document/report type and your 
localization. 
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Saving a Layout as an Image 
You can save documents and reports as graphic files (*.jpg).  

To save a document as a graphic file: 

1. Display the required document, for example, a sales order. 

2. From the menu bar choose File → Print Preview. 

The system displays a preview of the printed document. 

3. From the menu bar choose Goto → Save as Image. 

 

 
The system saves the file in the Picture folder defined in Administration → System Initialization 
→ General Settings → Path tab. 

Cumulative Summary Field 
You can create a field for a cumulative summary of a selected field.  

Example 
To create a cumulative quantity per row: 

1. Create a new Formula field in the Repetitive Area. 

2. Apply the operand ColSum(var) to the selected field. 
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Increasing the Number of Printed Rows on each Page 
To increase the number of printed rows: 

1. From the Main Menu choose Administration → System Initialization → Print Preferences → General 
tab → Max. Rows per Page. 

2. From the Main Menu choose Administration → System Initialization → Print Preferences → General 
tab → Print with Vertical Compression. 

All the rows in the document will be compressed according to this definition. 

3. To extend the blank area, reduce the area above it. 

4. To reduce the repetitive area, reduce the fonts, the fields (including hidden ones), and the entire area. 

Printing Pictures in their Original Size 
To print pictures in their original size: 

1. From the Main Menu choose Administration → System Initialization → General Settings → Display tab 
→ Ext. Image Processing. 

The Ext. Image Processing field sets the print style of your logo and pictures. The field is relevant 
when attached pictures are not printed according to their original size. 

 
2. Select Full from the drop down list to enable a print style that sharpens the picture's printout and 

reduces the printout of a text-containing logo. 
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Printing the Manufacturer or Group Name 
To print the manufacturer or the Item Group name of an item or business partner: 

1. Add a new hidden database field in the Repetitive Area. 

2. In the Table field of the Properties window, select Items or Business Partner. 

3. In the Column field select Item Group or Group Code. 

 
4. Add another database field in the same area. You can now select the item or business partner group 

in Table; and Group Name in Column. 

 

Picture Formats 
You can use the following graphic formats: 

• *.bmp  

• *.gif 

• *.jpg. 

The files must not be compressed. 
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Error Messages 
"File name missing in data field" 
The system displays this error message when you attempt to save a print template that contains a Database 
field with no values in the Table and Column fields.  

 
The system highlights the relevant field in both the template and the Field Index window to indicate where 
the problem is.  

You can remove or update the field. 

"Printing Error" 
When the system generates error messages related to fields in the layout, the unique ID numbers of the 
field(s) causing the error are displayed as part of the message: 
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Maintaining the Original Display Order 
After creating subtotals and sub-sorts, you can determine that the items inside each sub-sort appear in their 
original order, as displayed in the document. 

To maintain the original display order: 

1. Create a hidden system variable field in the repetitive area containing the Row Number field from the 
document: 

  
2. Define this field as the secondary sort in the Sort window: 
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Printing Using the Format "Page X of Y" 
To print page numbers in reports and documents in a “Page X of Y” format: 

1. Create two formula fields using the following operands: 

 CurrentPage() 

 TotalPages() 

2. Create two text fields containing the texts: 

 Page 

 Of 

Printing Query Parameters in User Reports 
You can create user reports for your user-defined queries. 

If a query involves conditions, these will be printed in the report header. 

 
A query retrieves all the business partners with a positive account balance and uses the 
condition "Balance > 0.00". 

When you create a user report for this query, the condition you use in the query is printed in the 
report header. 
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Printing Additional Barcode Types 
Use 
With SAP Business One you can print the most widely used barcode types: EAN 13 and Code 39.  

In addition, you can print other barcode types by following the procedure below. 

Prerequisites 
You have saved the required barcode font on your computer. 

 
Barcode fonts can be obtained via the Internet. 

Procedure 
1. To install the barcode font in the Microsoft Windows font library, from the Windows taskbar choose 

Start → Control Panel → Fonts. 

2. From the menu bar choose File → Install New Font..  

3. Navigate to the required font and choose OK. 

4. In SAP Business One, open the required print layout in Print Layout Designer, create a new field, and 
define it as Free Text or Database. 

5. In the Properties window of the new field, choose the Format tab. 

6. In the Font field, select the barcode font from the drop-down list. 

Result 
When the document is printed, the content of the new field is printed as a barcode. 

 
To also view the barcode when print previewing the layout and sending it via mail, make sure 
that the boxes Preview Printing Layout and E-Mail Layout are deselected in Document 
Properties → Format tab. 
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Informix are trademarks or registered trademarks of IBM Corporation in the United States and/or other 
countries.  
ORACLE® is a registered trademark of ORACLE Corporation. 
 
UNIX®, X/Open®, OSF/1®, and Motif® are registered trademarks of the Open Group. 
Citrix, ICA, Program Neighborhood, MetaFrame, WinFrame, VideoFrame, and MultiWin are trademarks or 
registered trademarks of Citrix Systems, Inc.  

HTML, XML, XHTML and W3C are trademarks or registered trademarks of W3C®, World Wide Web 
Consortium, Massachusetts Institute of Technology.  
JAVA® is a registered trademark of Sun Microsystems, Inc.  
 
JAVASCRIPT® is a registered trademark of Sun Microsystems, Inc., used under license for technology 
invented and implemented by Netscape.  
MaxDB is a trademark of MySQL AB, Sweden.   

SAP, R/3, mySAP, mySAP.com, xApps, xApp, and other SAP products and services mentioned herein as 
well as their respective logos are trademarks or registered trademarks of SAP AG in Germany and in several 
other countries all over the world. All other product and service names mentioned are the trademarks of their 
respective companies. Data contained in this document serves informational purposes only. National product 
specifications may vary.  

These materials are subject to change without notice. These materials are provided by SAP AG and 
its affiliated companies ("SAP Group") for informational purposes only, without representation or warranty of 
any kind, and SAP Group shall not be liable for errors or omissions with respect to the materials. The only 
warranties for SAP Group products and services are those that are set forth in the express warranty 
statements accompanying such products and services, if any. Nothing herein should be construed as 
constituting an additional warranty. 
 
SQL Server® is a registered trademark of Microsoft Corporation. 
 
WinFax® is a U.S. registered Trademark from Symantec Corporation. 
 
Sybase and SYBASE (logo) are trademarks of Sybase, Inc. 
 
Intel and Intel JPEG Library are trademarks of Intel, Inc. 
 
SEE4C (SMTP/POP3 Email Engine Library for C/C++) is the copyright of - MarshallSoft Computing, Inc. 
 
Victor Image Processing Library and VIC32 are trademarks of Catenary Systems. The Victor Image Processing Library is 
copyright material. This includes the source code, object code, dlls, examples, and documentation. This material is 
protected by United States copyright law as well as international copyright treaty provisions. 

© SAP AG 2006 63  



SAP Business One 2005 A SP01    How to Customize Printing Templates with the PLD    

  
 
 
THE APACHE SOFTWARE LICENSE, VERSION 1.1 
Copyright (c) 1999 The Apache Software Foundation.  All rights reserved. Redistribution and use in source 
and binary forms, with or without modification, are permitted provided that the following conditions are met: 

• Redistributions of source code must retain the above copyright notice, this list of conditions and the 
following disclaimer. 

• Redistributions in binary form must reproduce the above copyright notice, this list of conditions and 
the following disclaimer in the documentation and/or other materials provided with the distribution. 

• The end-user documentation included with the redistribution, if any, must include the following 
acknowledgment: "This product includes software developed by the Apache Software Foundation 
(http://www.apache.org/)." Alternately, this acknowledgment may appear in the software itself, if and 
wherever such third-party acknowledgments normally appear. 

• The names "Xerces" and "Apache Software Foundation" must not be used to endorse or promote 
products derived from this software without prior written permission. For written permission, please 
contact apache@apache.org. 

• Products derived from this software may not be called "Apache", nor may "Apache" appear in their 
name, without prior written permission of the Apache Software Foundation. 

 
THIS SOFTWARE IS PROVIDED ``AS IS'' AND ANY EXPRESSED OR IMPLIED WARRANTIES, INCLUDING, BUT 
NOT LIMITED TO, THE IMPLIED WARRANTIES OF MERCHANTABILITY AND FITNESS FOR A PARTICULAR 
PURPOSE ARE DISCLAIMED.  IN NO EVENT SHALL THE APACHE SOFTWARE FOUNDATION OR ITS 
CONTRIBUTORS BE LIABLE FOR ANY DIRECT, INDIRECT, INCIDENTAL, SPECIAL, EXEMPLARY, OR 
CONSEQUENTIAL DAMAGES (INCLUDING, BUT NOT LIMITED TO, PROCUREMENT OF SUBSTITUTE GOODS OR 
SERVICES; LOSS OF USE, DATA, OR PROFITS; OR BUSINESS INTERRUPTION) HOWEVER CAUSED AND ON 
ANY THEORY OF LIABILITY, WHETHER IN CONTRACT, STRICT LIABILITY, OR TORT (INCLUDING NEGLIGENCE 
OR OTHERWISE) ARISING IN ANY WAY OUT OF THE USE OF THIS SOFTWARE, EVEN IF ADVISED OF THE 
POSSIBILITY OF SUCH DAMAGE. 
 
This product includes software developed by the Apache Software Foundation (http://www.apache.org/) and 
Info-Zip (http://www.info-zip.org/pub/INFO-ZIP/). 
This software consists of voluntary contributions made by many individuals on behalf of the Apache Software 
Foundation and was originally based on software copyright (c) 1999, International Business Machines, Inc., 
http://www.ibm.com.  For more information on the Apache Software Foundation, please see 
<http://www.apache.org/>. 
SAP and/or its distributors may offer, and charge a fee for, warranty, support, indemnity or liability obligations 
to one or more recipients of the software. However, SAP and/or its distributors may do so only on its/their 
own behalf, and not on behalf of the Apache Software Foundation or its contributors. 
 
UNZIP. This is version 2003-May-08 of the Info-ZIP copyright and license. The definitive version of this 
document should be available at ftp://ftp.info-zip.org/pub/infozip/license.html indefinitely.  
Copyright (c) 1990-2003 Info-ZIP. All rights reserved. 
For the purposes of this copyright and license, "Info-ZIP" is defined as the following set of individuals: 
Mark Adler, John Bush, Karl Davis, Harald Denker, Jean-Michel Dubois, Jean-loup Gailly, Hunter Goatley, 
Ian Gorman, Chris Herborth, Dirk Haase, Greg Hartwig, Robert Heath, Jonathan Hudson, Paul Kienitz, David 
Kirschbaum, Johnny Lee, Onno van der Linden, Igor Mandrichenko, Steve P. Miller, Sergio Monesi, Keith 
Owens, George Petrov, Greg Roelofs, Kai Uwe Rommel, Steve Salisbury, Dave Smith, Christian Spieler, 
Antoine Verheijen, Paul von Behren, Rich Wales, Mike White  
This software is provided "as is," without warranty of any kind, express or implied. In no event shall Info-ZIP 
or its contributors be held liable for any direct, indirect, incidental, special or consequential damages arising 
out of the use of or inability to use this software.  
Permission is granted to anyone to use this software for any purpose, including commercial applications, and 
to alter it and redistribute it freely, subject to the following restrictions:  
Redistributions of source code must retain the above copyright notice, definition, disclaimer, and this list of 
conditions.  
Redistributions in binary form (compiled executables) must reproduce the above copyright notice, definition, 
disclaimer, and this list of conditions in documentation and/or other materials provided with the distribution. 
The sole exception to this condition is redistribution of a standard UnZipSFX binary (including SFXWiz) as 
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part of a self-extracting archive; that is permitted without inclusion of this license, as long as the normal SFX 
banner has not been removed from the binary or disabled.  
Altered versions--including, but not limited to, ports to new operating systems, existing ports with new 
graphical interfaces, and dynamic, shared, or static library versions--must be plainly marked as such and 
must not be misrepresented as being the original source. Such altered versions also must not be 
misrepresented as being Info-ZIP releases--including, but not limited to, labeling of the altered versions with 
the names "Info-ZIP" (or any variation thereof, including, but not limited to, different capitalizations), "Pocket 
UnZip," "WiZ" or "MacZip" without the explicit permission of Info-ZIP. Such altered versions are further 
prohibited from misrepresentative use of the Zip-Bugs or Info-ZIP e-mail addresses or of the Info-ZIP URL(s). 
Info-ZIP retains the right to use the names "Info-ZIP," "Zip," "UnZip," "UnZipSFX," "WiZ," "Pocket UnZip," 
"Pocket Zip," and "MacZip" for its own source and binary releases.  
MarketSet and Enterprise Buyer are jointly owned trademarks of SAP AG and Commerce One.  
SAP, SAP Logo, R/2, R/3, mySAP, mySAP.com, and other SAP products and services mentioned herein as 
well as their respective logos are trademarks or registered trademarks of SAP AG in Germany and in several 
other countries all over the world.  All other product and service names mentioned are the trademarks of their 
respective companies. 
 
Copyright and Licensing Information for ACE(TM) and TAO(TM) 
ACE(TM) and TAO(TM) are copyrighted by Douglas C. Schmidt and his research group at Washington 
University, University of California, Irvine, and Vanderbilt University Copyright (c) 1993-2003, all rights 
reserved. Since ACE+TAO are open-source, free software, you are free to use, modify, copy, and distribute--
perpetually and irrevocably--the ACE+TAO source code and object code produced from the source, as well 
as copy and distribute modified versions of this software. You must, however, include this copyright 
statement along with code built using ACE+TAO.  
You can use ACE+TAO in proprietary software and are under no obligation to redistribute any of your source 
code that is built using ACE+TAO. Note, however, that you may not do anything to the ACE+TAO code, such 
as copyrighting it yourself or claiming authorship of the ACE+TAO code that will prevent ACE+ TAO from 
being distributed freely using an open-source development model. You needn't inform anyone that you're 
using ACE+TAO in your software, though we encourage you to let us know so we can promote your project 
in the ACE+TAO success stories..  
ACE+TAO are provided as is with no warranties of any kind, including the warranties of design, 
merchantability, and fitness for a particular purpose, noninfringement, or arising from a course of dealing, 
usage or trade practice. Moreover, ACE+TAO are provided with no support and without any obligation on the 
part of Washington University, UC Irvine, Vanderbilt University, their employees, or students to assist in its 
use, correction, modification, or enhancement. However, commercial support for ACE is available from 
Riverace and commercial support for TAO is available from OCI and PrismTech. Both ACE and TAO are 
Y2K-compliant, as long as the underlying OS platform is Y2K-compliant.  
Washington University, UC Irvine, Vanderbilt University, their employees, and students shall have no liability 
with respect to the infringement of copyrights, trade secrets or any patents by ACE+TAO or any part thereof. 
Moreover, in no event will Washington University, UC Irvine, or Vanderbilt University, their employees, or 
students be liable for any lost revenue or profits or other special, indirect and consequential damages.  
The ACE and TAO web sites are maintained by the Center for Distributed Object Computing of Washington 
University for the development of open-source software as part of the open-source software community. By 
submitting comments, suggestions, code, code snippets, techniques (including that of usage), and 
algorithms, submitters acknowledge that they have the right to do so, that any such submissions are given 
freely and unreservedly, and that they waive any claims to copyright or ownership. In addition, submitters 
acknowledge that any such submission might become part of the copyright maintained on the overall body of 
code, which comprises the ACE and TAO software. By making a submission, submitter agrees to these 
terms. Furthermore, submitters acknowledge that the incorporation or modification of such submissions is 
entirely at the discretion of the moderators of the open-source ACE+TAO projects or their designees.  
The names ACE(TM), TAO(TM), Washington University, UC Irvine, and Vanderbilt University, may not be 
used to endorse or promote products or services derived from this source without express written permission 
from Washington University, UC Irvine, or Vanderbilt University. Further, products or services derived from 
this source may not be called ACE(TM) or TAO(TM), nor may the name Washington University, UC Irvine, or 
Vanderbilt University appear in their names, without express written permission from Washington University, 
UC Irvine, and Vanderbilt University. 
 
SAP Library document classification: PUBLIC 
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