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How to Customize Printing Layouts with the Print Layout Designer  

Introduction  
The Print Layout Designer tool lets you modify and customize the SAP Business One default printing 
layouts according to your requirements.  

You can set one layout as the default for all or some SAP Business One users and link specific print 
layouts to selected business partners. 
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Opening Print Layout Designer 
You can open a printing layout for any document or report in SAP Business One. 

To design a new layout for the document or report, make the required modifications in one of the 
system layouts and save your changes under a new name. 

Procedure 
... 

1. From the SAP Business One Main Menu, open the required document or report, for example, 
Sales → A/R → Sales Order. 

2. In the displayed window, choose Tools → Print Layout Designer. Alternatively, choose  in 
the toolbar. The Layout Designer – Selection Criteria window opens: 

 
This window displays the SAP Business One default print layouts and the user-created layouts. 

3. Select a layout by clicking its name and choosing the Edit button or by double-clicking the name. 

4. The Report and Layout Management window opens.  

 Note 
For more information about the Report and Layout Management window, see the how-to 
guide How To Work with Crystal Reports in Release 8.8 in the documentation area of 
SAP Business One Customer Portal at 
http://service.sap.com/smb/sbocustomer/documentation.  

5. Select a layout on the Layouts tab by clicking its name and choosing the Edit button or by 
double-clicking the layout name. 
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6. Print Layout Designer opens: 

 
7. Make the required changes in the layout. 

8. To save the changes, close the Print Layout Designer window and when the prompt appears, 
enter a new name for the layout. In the future, you can save this layout using the Save button. 
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Defining Document Properties 
The Document Properties window contains general data regarding the current printing layout. 

Procedure 
... 

1. In the Print Layout Designer menu bar, choose Print Layout Designer → Display Document 
Properties. Alternatively, right-click anywhere in Print Layout Designer, and choose Display 
Document Properties. 

2. In the Document Properties window, select the General tab and specify the required data. 

 

Document Properties – General tab 

Field Name Description 

Document ID Comprises the following 3 elements:  

• Document type   

For example, RDR stands for sales order. 

• Item type (2) or Service type (1). 

• Document number in the layout sequence 

For example, 0001 represents the first layout for this document type. 

Layout Name The name of the print layout. 

Language The language in which the document was created. 

Foreign Prints the foreign name of the currency code (Administration → Setup → 
Financials → Currencies → International Code) when printing a document for 
foreign business partners. 

Author The user who created the layout.  

System refers to SAP Business One default layouts. 

Remarks Enter remarks, if required. 
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3. On the Paper Format tab, specify the required data. 

 

Document Properties – Paper Format tab 

Field Name Description 

Number of 
Layout Pages 

To increase the page layout to more than one page, enter a number 
indicating the required number of pages. 

Number of 
Copies 

Enter the default number of copies for print.  

Printer Default refers to your default printer as defined in Microsoft Windows. Select 
another printer from the dropdown list, if required. 

Printer for 1st 
page 

You can print the first page on a different printer. 

Paper Format Set the paper format for printing this specific layout. Changing the paper 
format automatically changes the display on the screen. 

Width, Height Manually set a specific paper format that is not defined in the Paper Format 
dropdown list. 

Orientation Portrait is the default setting. Selecting Landscape extends the print layout, 
providing more space for fields in the repetitive area. However, fewer rows 
are printed on each page. 

Margins Add margins to the entire document. If you intend to file the document in a 
folder, we recommend adding a margin of 30 on the left. 

Use Custom 
Margins 

Margins defined in Administration → System Initialization → Print Preferences 
are automatically selected. If you want to select different margins for this 
document, select the checkbox and change the margins. 
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4. On the Grid tab, specify the required data. 

 

Document Properties – Grid tab 

Field name Description 

Format Select a line style for the grid. A preview of the selected style is displayed 
on the right.  

Size Enter the size of the squares in the grid (in pixels). 

Display Grid Displays the grid in the layout. 

Adjust to Grid The fields snap to the grid. 

5. On the Format tab, specify the required data. 

 

Document Properties – Format tab 

Field Name Description 

Time and 
Date 
Format 

The selections you make on the Display tab in Administration → 
System Initialization → General Settings determine the default values. 

Time Set the time to 24H or 12H. You can select a specific time format for 
each layout. 
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Field Name Description 

Date Set the date format for the layout. 

Separator Select a date and time separator for the layout. If this field remains 
empty, the application uses the default value. 

Preview 
Printing 
Layout 

To define the layout of the Print Preview window, select this checkbox 
and set a font style and size. 

 CAUTION 
If the actual printed document looks different from its 
preview, deselect this checkbox and try again. 

E-Mail 
Layout 

To define the e-mail layout, select this checkbox and set a font style 
and size. 

 CAUTION 
If the actual printed document looks different from the one 
sent through e-mail, deselect this checkbox and try again. 

6. To add a background picture to the document, select the Picture tab. 

 
Browse to the Pictures Folder (defined on the Path tab in Administration → System Initialization 
→ General Settings) and choose the required graphic file.  

To remove the selected picture, choose . 
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7. To add DLL files to the layout (to enhance its functionality), select the Extension tab. 

 
Browse to the Extensions Folder (defined on the Path tab in Administration → System 
Initialization → General Settings) and choose the required graphic file.  

 Example 
You can e-mail the document in addition to sending it to the printer. 
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Structure of a Print Layout 
SAP Business One print layouts contain several areas. 

Page Header 
The area highlighted in the figure below contains the document fields and the report header fields, 
including business partner, date, and document name. 

The page header is printed on every page of the document or report. 
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Start of Report 
The area highlighted in the figure below is located directly above the table titles. 

It is printed only on the first page of the document or report. In this area you can find, for example, the 
Ship From and Ship To details. 
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Repetitive Area Header 
The area highlighted in the figure below contains the table titles and the subtotal titles. 

It is printed on every page of the document or report. 
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Repetitive Area 
The area highlighted in the figure below duplicates itself according to the number of rows in the table. 
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Repetitive Area Footer 
In the area highlighted in the figure below you can add summaries to the table using formula fields, as 
well as subtotals. It is located directly under the repetitive area. 
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End of Report 
The area highlighted in the figure below contains the totals, remarks, and other general document 
data. 

It is printed only on the last page of the document or report. 
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Blank Area 
The area highlighted in the figure below is a virtual area, which you cannot control in the layout. It 
enables the repetitive area to expand according to the number of table rows in the printed document. 
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Page Footer 
The area highlighted in the figure below appears at the end of the page and contains company details.  

It is printed on all pages of the document. 

 
... 
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Field Index 
When you open a print layout, you see the Field Index window on the right of the screen. This window 
displays all the fields in the layout, including hidden fields. 

To open the Field Index window, right-click anywhere in the layout and choose Display Fields Index. 
Alternatively, in the menu bar, choose Print Layout Designer → Display Fields Index. 

• Clicking a field or area highlights it in yellow.  

• Hidden fields are displayed in a light grey color. 

 

Field Index 

Field Name Description 

Find Unique ID Fields are divided into areas. Within each area, the fields are sorted according to 
their Unique ID value. You can search for a field by its unique ID. If the field is 
found, it is highlighted in yellow and simultaneously selected in the layout and in the 
Properties window. You cannot perform sorting in the Field Index window.  

Unique ID An external unique identifier of each field generated upon field creation. You can 
update this field manually in the Properties – Field (Text) window. 

 Recommendation 
Assign significant names to the fields. You are better able to identify 
them when, for example, you create formulas. 

Type Displays an icon matching the field type and source type (free text, database, 
formula, system variable, picture, bar code, and external data). 

Content Displays the field content. In the case of a formula, the entire formula is shown. 
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Defining Area and Field Properties 
The Properties window relates to both area and field properties. It opens automatically when a print 
layout is opened and remains open unless you close it.  

To open the Properties window, do one of the following: 

• Right-click anywhere in the layout and choose Display Properties.  

• In the menu bar, choose Print Layout Designer → Display Fields Index. 

• In the Field Index window, double-click the field’s Unique ID value. 

 

When you create a new field, the Properties window automatically displays the properties of the new 
field. Click any area or field to display its properties. Clicking another field changes the contents of the 
Properties window. The title of the Properties window displays the name of the selected field or area. 

If you select multiple areas or fields, the title of the Properties window becomes Properties - Multiple 
Areas, Properties - Multiple Fields, or Properties – Multiple. 

You can modify both field and area information in the Properties window. If you select several fields for 
modification, the system disables the Unique ID field on the General tab. As a result, some of the 
individual field or area information may be disabled, depending on the common characteristics of the 
selections. 
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Defining Area Properties 
To modify an entire area: 

1. Click anywhere in the area (where there are no fields). 

The system displays information relevant to the selected area in the Properties window. 

2. Specify the required data on the General tab. 

 

Properties Window – General tab 

Field Name Description 

Unique ID A unique identifier generated automatically on creation of a new area; can be 
manually updated by the user.  

Creating two areas with the same unique ID generates the error message: 
 

Height The area height in pixels. 

Visible Renders the area visible on the screen. 
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3. To add a picture to the area, on the Content tab, choose the Browse button. Navigate to the 
picture folder you defined in Administration → System Initialization → General Settings → Path 
→ Picture Folder and choose the required graphic file. 

 
Print Layout Designer supports the file formats: jpg, gif, png, tif, pcx, tga, bif and bmp. 

4. To activate automatic height adjustment of the area, on the Format tab, select the Area Height 
Adjustment checkbox. 

 
The height of an area is adjusted automatically if the fields: 

 At the top or bottom are blank 

 Are linked to themselves 

 Do not contain values 
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5. To align the end of report area to the end of the last page, on the Format tab select the Align to 
Bottom checkbox.  

 
This function is available in the End of Report area only and should not be used together with 
the Area Height Adjustment option. 

6. To format the area borders and margins, on the Border tab, enter the required data. 

 

Properties Window – Border tab 

Field Name Description 

Border, Margins To define a border around the area, or margins for the area, enter 
numeric values in the Right, Left, Upper, and Low fields. These 
numbers set the thickness of the border in pixels. 
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7. To determine the color of the area, on the Color tab, enter the required data: 

 
You can apply color separately to the frame, background, and grid. To select a color, 

choose . 
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Creating Multiple Repetitive Areas 
Additional repetitive areas can be created in all the print layouts. 

 Example 
 In addition to the standard item table, print a separate table of item images in 

sales or purchasing documents. 

 In the USA it is mandatory to print invoice details in two locations in the layout of 
checks for payment. The multiple repetitive areas option enables you to print this 
type of layout. 

 You can print two different item tables in the same document and, using a formula 
type field, determine, which items appear in each table. For example, print a table 
of regular items, including a Quantity column, along with a table of labor items, 
with an extra description and no quantity. 

Procedure 

1. Open a print layout and in the menu bar, choose Print Layout Designer → Repetitive Area → 
Add. 

The application adds a new repetitive area to the layout, as shown in the following figure: 

 

2. Create fields in the new area. 

 Note 
You can add as many repetitive areas as required. 

You can sort every repetitive area. To sort a repetitive area, click inside the area you 
would like to sort, and in the menu bar, choose Print Layout Designer → Repetitive Area 
→ Sort.  
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Creating New Fields 
Using Print Layout Designer, you can create the following field types: free text, database, formula, 
system variable, picture, bar code, and external data. Each field can obtain its value from several 
sources. You can change the field and source types after creating the field. 

Procedure 

1. In the menu bar, choose Print Layout Designer → Add Field. Alternatively, in the toolbar, choose 
one of the following icons: 

Field Icons 

Icon Field Type 

 Free Text 

 Database 

 Formula 

 System Variable 

 Picture 

 Bar Code 

 External Data 

After you have chosen the required field type, the system displays the cursor icon accordingly.  

  Example 
If you choose to create a text field with a database as its default source, the cursor is 

displayed as . 

2. Place the cursor on the required location, and then press and drag the frame to extend the field. 

 Note 
The minimum size of a field is 10x10 pixels. 

The minimum size restriction applies only when creating a new field. Once a field has 
been created, you can decrease or increase the field size using the 4 gray squares on 
each corner of the field: 

 
Place the cursor over a selected corner, drag to expand or shrink the field, as needed. 
You can also decrease or increase the field size using the General tab of the Properties - 
Field window. 

 Recommendation 

After you have finished creating the field, click  in the toolbar. 
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Defining General Field Properties 
After you have created a new field, the Properties window displays information about it. You can 
modify its properties to meet your requirements. 

Procedure 

Specify the required information on the General tab. 

 

Properties Window – General tab 

Field Name Description 

Unique ID A unique identifier of each field; behaves in the same way as the unique ID of an area. 

Field Type There are 5 field types: text, picture, bar code, external data, and Logo. The icon you 
select when you create the field determines the default value of the field.  

You can change the field type at any time. 

Link to Creates a link between several fields, to determine if the system collectively displays 
or hides them. If a field is blank, its linked fields are not printed either. 

To create the link, choose the unique ID of the field to which you want to link the 
selected field.  

 Example 
If the Total Liable field in the document is set to zero, there is no need to 
print the Tax, Discount, and Total fields. It is possible to link these fields 
to the Total Liable field by selecting the unique ID in the Link to field of 
each respective property window. This hides the fields when Total Liable 
is zero.  

 Note 
If a linked field is not yet calculated, the field is ignored. 

Visible Prints the field. 

Group The number of the group to which the field is linked.  

In a layout with no subsorts or subtotals, all the fields are linked to group 0. For more 
information about groups, see Defining Sorts. 
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Field Name Description 

Left, Top, 
Width, Height 

The location and size of the field in the layout.  

Left and Top define location; Width and Height define size.  

Specify different values, if needed. 

 Note 
Hidden fields are not displayed in the Print Layout Designer window and appear in light 
grey in the Field Index window. However, you can display them on the screen for editing 

by choosing Print Layout Designer →  Display Hidden Fields. Alternatively, click  in 
the toolbar. 
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Defining Source Types 
The Source Type field defines the data source of the field.  

The available source types for text type fields are: 

• Free Text 

• Database 

• Formula  

• System Variable 

The application automatically displays a default source type according to the type of field you select 
when creating the field. Change the source type by selecting another source type and then exiting the 
properties display for the selected field by clicking another field or area. 

Defining Free Text as a Source Type 
Use a free text source type for printing fixed remarks, notes, instructions, or comments.  

To define free text as the source type:  

1. In the Properties - Field window, select the Content tab. 

2. In the Source Type field, select Free Text. 

3. Enter the required text. 

 

 Note 
You can enter up to 64,000 characters. 
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Defining Databases as a Source Type 
Use a database source type to print information from a selected table and column.  

To choose a database source type: 

1. In the Properties - Field window, select the Content tab. 

2. In the Source Type field, select Database and specify the required information. 

 

 Note 
The system automatically creates fields of database source type in every system layout. 

You can create as many database fields as you require in your own print layouts. 

Properties – Content tab, Database fields 

Field Name Description 

Table Select the table from which to retrieve the information printed in this field. 

Column Select the field you want to print in the document.  

 Example 
If you want to print the customer's channel business partner in a print layout for 
invoices, you should select Business Partner in the Table field and Channel BP 
in the Column field. 

Get 
Description 

Prints the field's description rather than its code.  

 Example 
If you select Business Partner in the Table field and BP Type in the Column 
field, SAP Business One prints the code values: C, S, or L. When you select 
the checkbox, the actual names of these code letters are printed: Customer, 
Supplier, or Lead. 
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Field Name Description 

Relate to This option is relevant for special scenarios only and requires knowledge of SQL.  

This field is used for retrieving data related to key records found in tables other than the 
table linked as default to the current print layout. 

A key record is a field used as a primary key in a specific table. This key record functions as 
the identifier of the record, and, therefore, it is required to retrieve any additional data related 
to it. 

 Example 
You need to print the name of a certain bank that is not linked to the table used 
in the current print layout. You must first create a text field of database source 
type using the required table. Then select a key record, such as Bank Code.  

Next, you need to create an additional text field of database source type. 
Select the table again, select the required column (such as Bank Name), and in 
the Relate to field, enter the unique ID of the field with the key record. 

When a table contains two or more key records, all its key records are required 
for retrieving the data. 

 Example 
Identical bank codes are used in many countries. If you need to print the name 
of a specific bank, you need to link it to a relevant country, in addition to its 
relevant bank code. 

 Example 
You are currently working in a print layout for incoming payments. However, 
you need to retrieve data (such as the business partner's bank name) linked to 
the key record Bank Code from the Bill of Exchange for Payment table, rather 
than from the Incoming Payments table. 

In the Relate to field, select the unique ID of the field containing the required 
key record. In this example, this is a text field of database source type 
containing Bill of Exchange for Payment in the Table field and BP Bank 
Country in the Column field. The dropdown list contains the unique IDs of all 
the fields situated in the same area as the current field. 

This link makes the application retrieve the Bank Code value linked to the BP 
Bank Country field found in the Bill of Exchange for Payment table. 

Next 
Segment 

Use this field when a validation of two or more key records is required, for example, the BP 
Bank Country field and the BP Bank Code field. 

To make this double validation, select the unique ID of the next key record field in this field. 

The field with this unique ID is used as the secondary validation key record. 
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Defining Formulas as a Source Type 
1. In the Properties – Field window, select the Content tab. 

2. In the Source Type field, select Formula and specify the required information. 

A formula source type field lets you display the results of certain calculations, which you can 
build either manually or with the formula editor. 

 

3. Choose the Formula Editor button. The Formula Editor window opens. 

 

4. To find the required field by its unique ID, enter the ID in Find Field. 

The matching field is highlighted in yellow. 

  Note 
You can select fields from different areas as long as they are already calculated and 
located in an area above the calculation field. 
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5. To add a field to the formula in the formula area on the right side of the window, do one of the 
following: 

 Double-click the selected field. 

 Enter the unique ID in the formula area. 

 Note 
If you enter an invalid unique ID, or modify the unique ID of a field used in a formula, the 
application generates a warning message. 

6. To add numbers to the formula, enter them directly in the formula area. 

7. To add an operation to the formula, select it in the Operation dropdown list and choose the 
Insert button. 

Formula Editor – Operations 

Operation Description 

Arithmetical 
Operations 

• % 

This operation is an operator rather than a percent calculation. It displays the 
remainder of a division of 2 numbers, for example, 10 % 3 results in 1, since 
10/3 = 3+ a remainder of 1. 

• *  

Multiplication 

• +  

Addition 

• -  

Subtraction 

• /  

Division  

If the two variables you use are of integer type (natural numbers), the result is 
also an integer number. For example, dividing 10 by 3 results in 3.  

On the other hand, a division of a float type number (decimal fraction) by any 
other number results in a float type number as well, for example, dividing 10.00 
by 3 results in 3.33. 

• Abs (Number) 

Displays the absolute value of a number. 

• Avg (, …) 

Displays the average of a list of numbers. 

• DecimalLeft (Number) 

Displays the integer part of a numeric value up to its decimal point. For 
example, for a field containing the value 241.32, this operation results in the 
integer number 241. 

• DecimalRight (Number) 

Displays the decimal fraction of a numeric value. For example, for a field 
containing the value 241.32, this operation results in the decimal fraction .32. 
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Operation Description 

 

• Pow (Base as Number, Exponent as Number) 

Displays a number raised by a power. 

• Round (Number, Decimals as Number) 

This operation rounds a numeric value according to the number of characters 
selected in Field 2. For example, a field contains the value 524.18. Selecting the 
number '1' in Field 2 results in 524.2. 

String 
Operations 

 

• Amount (Money) 

Extracts only the number out of a field containing a value comprised of a 
number and a currency symbol. For example, selecting this operation for the 
field Amount Due containing the value €154 prints 154.  

This operation is mainly required in cases where a number is needed for 
calculation between fields. 

• Concat (, …) 

Concatenates strings. For example, "A" Concat "B" results in "AB". 

• Currency (Money) 

Extracts only the currency symbol out of a field containing a value with a 
currency symbol. For example, selecting this operation for the Amount Due field 
containing the value $154, prints $. 

• Length (Text as String) 

Displays the number of characters in the selected field (a space is regarded as 
a character). For example, using this operation on a Remarks field that contains 
a value with 100 characters, results in the value 100 being printed. 

• Sentence (Text as String, SentenceIndex as Number) 

Cuts an entire sentence from the selected field (up to the next Enter mark). In 
Field 2 select a number to indicate the required sentence number to cut. 

• Substring (Text as String, SubStringLength as Number) 

Cuts a selected number of characters from the left of a selected field (a text field 
containing a number should be linked). For example, selecting Substring 
(Unique_ID, 2) using the unique ID of a field containing the string ‘SAP 
Business One’ prints ‘P Business One’. 

Substring (Text as String, SubStringStartIndex as Number) 

Cuts a selected number of characters from the left of a selected substring of a 
field. For example, selecting Substring (Unique_ID, 0, 5) using the unique ID of 
a field containing the string ‘SAP Business One’ prints ‘SAP B’ (it takes the first 
5 characters and cuts 0), and selecting (Unique_ID, 2, 5) prints ‘P B’. 

Date 
Operations 

 

• Day (Date as String) 

Returns the day part of a date. 

• Month (Date as String) 

Returns the month part of a date. 

• MonthName (Month as Number) 

Returns the name of the month. You enter the number (for example, 6) and it 
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Operation Description 
prints June.  

• Year (Date as String) 

Returns the year part of a date. 

Condition 
Operations 

 

To use condition operations: 

• The condition must be IF and must consist of 2 fields. 

• The calculation field displaying the result must be located in an area below its 
calculated fields. 

To use conditions on fields, follow these steps: 

1. Create a text field of formula source type for displaying the result. The 
result is 1 if the condition is met and NULL if the condition is not met. 

2. In the Formula field, select Formula Editor. 

3. Select the fields for the condition by searching for them in the field index or 
entering them manually. You can also select hidden fields. 

4. In the Operation field, select the condition to apply to the selected fields. 
(Not equal !=, Less than <, Greater than >, and so on) 

The main use of conditions involves the link to option. If the condition is not met and 
the field is NULL, then none of the fields linked to it are printed. 

Cast 
Operations 

 

• ToNumber (String) 

Explicit cast from string to number. 

• ToString (Number) 

Explicit cast from number to string. 

Other 
Specific 
Operations 

 

• ColAvg(UniqueID as String) 

A calculation of the average value of numbers in a selected column, for 
example, average price. This formula field can be created below the repetitive 
area.  

• ColSum(UniqueID as String) 

A calculation of the total values in a selected column, for example, total 
quantity. This formula field can be created below the repetitive area. . 

• CopyNumber() 

Lets you manage the number of printed copies. 

• CurrentPage() 

The number of the page in the document printout. 

• Date() 

The printing date. 

• GroupLineNum() 

The row number in the group for which a subsort or subtotal is calculated. When 
you create this type of field in the repetitive area footer, for a group on which a 
sort is performed, the field displays the total number of rows in each subtotal. 

• LineNum() 

The successive number of the row in the repetitive area. 
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Operation Description 

• PageAvg(UniqueID as String) 

A calculation of the average value of numbers in a selected column on every 
printed page. 

• PageSum(UniqueID as String) 

• A summary of the values in a selected column for every page. 

• ReportAvg(UniqueID as String) 

A calculation of the average value of numbers in a selected column for the 
entire report. 

• ReportSum(UniqueID as String) 

A summary of the values in a selected column for the entire report. 

• SortFieldName(SortNumber as Number) 

The name of the sort field selected in the layout, for example, Item Group. 

• SortValue()  

The content of the sort field selected in the layout, for example, the item group 
name. 

• SystemString(B1Notice) 

Select this operation to print the message: Printed by SAP Business One. 

• SystemString(ContinueNextPageNotice) 

Select this operation to print the relevant message on each page, except for the 
last one. 

• SystemString(ContinueNotice) 

Select this operation to print the message on each page. 

• Time() 

The printing time. 

• TotalPages() 

The total number of printed pages. 

8. After completing the formula, choose the Update button. 

The system generates a message to inform you that the formula has been successfully created. 

If there are errors in the formula the system generates a warning message, such as: 
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 Note 
You can define a calculative ratio between fields using a formula field. In such a case, 
the formula field displaying the result must be located in an area below its calculated 
fields. 

Defining System Variables as a Source Type 
The System Variable field contains a link to an actual variable found in SAP Business One. 
To choose a system variable as the source type: 

In the Source Type field, select System Variable and specify the required information. 

 

 Note 
The document editing functionality does not support variable fields due to the following 
reasons: 

 Variable numbers might change after you upgrade to a higher version.  

 You can use variable numbers that are not linked to the document or form related 
to the document editing. 

You can retrieve a system variable by using the system information function. From the View menu, 
choose System Information. 

Properties – Content tab, System Variable fields 

Field Name Description 

Variable No. Specify the variable number. 

Variables are unique to the specific document you are designing. To place a text 
field of system variable source type, you need to know the variable number.  

To display the variable number in SAP Business One: 

1. In the menu bar choose View → System Information.  

2. Place the cursor on the field. 

The system displays the field details in the status bar (located in the bottom 
left part of the screen). 

The variable number assigned to the field is displayed as Variable = 
<number> 
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Field Name Description 

Comment Enter a description of the variable. This text is not printed. 

 Example 
Examples for using variable fields include: 

 Data calculated during the printing process or in the actual document, for 
example, the Total Before Discount field in sales and purchasing documents 

 Fields appearing as columns in a table, but which are not printed, for example, the 
Credit (SC), Debit (SC) and Balance (SC) fields in the General Ledger report  

Use one of the following methods for printing the Price field: 

• Choose System Variable as Source Type and Variable No. 81. 

• Choose Database as Source Type and select Unit Price in Column.  

When you use the Database field, the application prints only the amount, but when 
you use the system variable, it prints the amount with the currency. 

 Note 
For more information on variables available for printing, see the how-to guide How to 
Use the PLD Variables File in the documentation area of SAP Business One Customer 
Portal at http://service.sap.com/smb/sbocustomer/documentation. 

Defining Picture Fields as a Source Type 
Picture fields let you print the company logo, pictures of items, and even images of company 
employees in your documents. 

 Note 
To print the company logo, you can also select the Logo field type on the General tab. 
This selection automatically adds the logo you defined in Print Preferences → General 
tab → Co. Logo.  

The source types available for picture type fields include: 

• File (default) 

Use the file source type to print a fixed image, such as the company logo, in the document. 

• Database 

Use the database source type to print pictures saved in your database tables. For example, you 
can print a catalog of items along with their pictures.  

To associate a picture with an item, choose Inventory → Item Master Data, and on the Remarks 

tab, click . 

• Bar Code 

The Content tab of a bar code type field is identical to the Content tab of a text field. The source 
types available for bar code fields include the values Free Text, Database, Formula, and 
System Variable. Free text is the default source type. 

• External Data  

You can use this type of field to print secured images, such as official stamps, which you are not 
legally permitted to save on your computer as regular pictures, but as *.dll files. The source 
types available for external data fields include the values Procedure Name, Database, Formula, 
and System Variable. 

http://service.sap.com/smb/sbocustomer/documentation
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To select a file source type to print a fixed image, proceed as follows: 

1. In the Properties - Field window, select the Content tab. 

2. In the Source Type field, select File. 

3. Choose the Browse button, navigate to the picture folder you defined on the Path tab in 
Administration → System Initialization → General Settings, and select the required picture file. 

 

To select a database source type to print a fixed image, proceed as follows: 

1. In the Properties - Field window, select the Content tab. 

2. In the Source Type field, select Database. 

 

3. In the Table field, select the required database table. 

4. In the Column field, select the required field. 
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To select a procedure name as a source type to print a fixed image, proceed as follows: 

1. In the Properties - Field window, select the General tab.  

2. In the Field Type field, select External Data. 

3. Select the Content tab.  

4. In the Source Type field, select Procedure Name. 

5. In the Procedure Name field, specify the name of the required *.dll file. 

 

 Note 
The *.dll file must be located in the extensions folder defined on the Path tab in 
Administration → System Initialization → General Settings → Path → Extensions Folder. 

6. To define a dependency between a hidden field in the layout and the extension's printing, do the 
following: 

a. In the Source Type field, select Database.  

b. In the Table field, select the required table. 

c. In the Column field, select the field on which the extension's printing depends. 

A dependency could be, for example, when an extension is printed only if its linked field 
contains a certain number, date, or string. 
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Defining Field Text Formats 
Use the Format tab to customize the appearance of the text in the field. 

Procedure 

1. In the Properties - Field window, select the Format tab. 

 

2. Specify the required data as described in the following table. 

Properties – Format tab 

Field Name Description 

Font, Size In the corresponding fields, select an appropriate font and manually enter the size.  

Choosing the Font… button opens a window in which you can change the font type, 
style, size, and color. 

Block Overall 
Font Change 

Keeps the font defined for the field, even if you try to change it from either the Preview 
Printing Layout or E-Mail Layout field on the Format tab in Print Layout Designer → 
Display Document Properties. 

Horizontal Select the required horizontal alignment method. 

Vertical Select the required vertical alignment method. 

© SAP AG 2009 42 



How to Customize Printing Layouts with the Print Layout Designer  

© SAP AG 2009 43 

Field Name Description 

Line Break Select a line-breaking method for fields containing long texts. For example, define how 
to break a long text in the Remarks field of a document, using one of the following 
methods: 

• Allow Overflow 

Prints the text even if it crosses the frame's border. 

• Adjust to Cell  

Cuts the text when the text reaches the frame's border. The remaining text is 
not printed beyond the border. 

• Divide into Rows 

Continues the text in the next row when the text reaches the frame's border. To 
enable this option, we recommend maintaining spaces between words.  

To divide into rows according to the original text, press ENTER on the keyboard 
each time you want a new row. 

Length Set a fixed number of characters to be printed in selected fields.  

For example, print only the first 5 digits of an item number:  

Original Item Number: 5822107. Printed Item Number: 58221. 

Filler Define a symbol for filling up the remaining spaces when the field contains fewer 
characters than defined in the Length field.  

For example, if an item number is less than 5 characters long, the filler * is printed 
instead of the missing characters.  

Original Item Number: 582, Printed Item Number: 582** 

Field Height 
Adjustment 

Automatically adjusts the field height to the text it contains. 

Sum in 
Words 

Prints in words a number displayed in a field. For example, the amount $25 is printed 
as Twenty-Five Dollars. 

Suppress 
Zeros 

Removes decimal zeros from a number displayed in a field. For example, 233.00 is 
printed as 233. 

 



How to Customize Printing Layouts with the Print Layout Designer  

Defining Field Borders 
Use the Border tab to customize the appearance of a field border. 

Procedure 

1. In the Properties - Field window, select the Border tab. 

 

2. Specify the data as described in the following table. 

Properties – Border tab 

Field Name Description 

Border Draws a border around the field.  

Enter numbers (pixels) in the Right, Left, Upper, and Low fields to set the thickness 
of the frame. 

Margins Enter numbers (pixels) in the Right, Left, Upper, and Low fields to set the location of 
the content inside the frame.  

Shade Enter a number to set the degree of shading. 
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Defining Field Colors 
Use the Color tab to set the print color for the text, background, highlighted text, and frame. 

Procedure 

1. In the Properties - Field window, select the Color tab. 

 

2. To open the Color window, choose . 

3. Select the required colors.  

 Note 
To define the highlighted text, frame, or background color as transparent, deselect the 
checkbox next to the field name. 
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Field Dependencies 

Dependency Types  
These are the two types of field dependencies: 

• Formula Dependency 

This dependency occurs when you create a field with a formula source type. This field may use 
other fields as operands. The calculated field becomes dependant on its operand fields. If you 
delete any of the other fields, the dependent field becomes invalid and you cannot print the 
document. 

• Link Dependency 

This dependency is created by the Link to option on the General tab of the Properties window. 
The field becomes visually dependent on the field to which it is linked. The link affects only the 
visibility of the dependent field; its visibility depends on the visibility or value of the other field. If 
you delete the field on which it depends, the document still prints.  

The Relate to and Next Segment options also create a link dependency. A field may also be 
recursively dependent on another field. For example, field A depends on field B, and field B 
depends on field C. This makes field A recursively dependent on field C. 

Displaying and Hiding Dependant Fields 
You can display or hide dependent fields using commands in the menu bar or in the toolbar. 
Displaying dependencies highlights both visible and hidden fields in both Print Layout Designer and 
the Field Index window: 

Displaying Dependent Fields 
This command is enabled when a field or several fields in the layout are activated.  

To display dependant fields: 

1. Select the field whose dependent fields you want to display. 

2. In the toolbar, choose . 

The status bar displays one of the following messages, depending on whether or not the system 
found dependent fields: 
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Example 

If field A is not visible, then field B should not be visible either. Therefore, a link should be created 
between A and B. 

1. Create Field A: 

 

2. Create Field B and link Field A to Field B so that Field B is dependent on Field A. This is a link 
dependency. 

 

3. To display the fields that are dependent on Field A, select Field A and choose .  

The application displays Field A with a dark green background color in Print Layout Designer 
and Field B (the link-dependent field) with a light green background color and a green border: 
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The dependency is highlighted in the same way in the Field Index window: 

 
The application colors the Type column according to the dependency type. 

When dependency is shown, a legend appears at the bottom of this window, displaying a 
square for each color. 

The legend disappears when dependent fields are hidden.  

The application displays formula-dependent fields with a medium green background color and a 
green border. In a recursive dependency, if at least one of the dependencies along the chain is 
a formula dependency, then the dependent fields are marked as formula dependent. 

4. To show dependencies of another field, select the field and choose  again. 

5. Choose  to hide the dependency.  

This icon is active only when dependencies are shown. The command de-highlights Field A and 
both fields revert to their original properties. 
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Deleting Fields 
When you attempt to delete fields on which other fields depend, the application issues a warning 
message asking you if you want to proceed with the deletion. 

Example 

You have four text fields, A, B, C, and D. Field B is dependent on Field A and Field D is dependent on 
Field C; therefore, Fields A and C have dependencies. 

1. Select the four fields and press Delete. 

2. The following warning message appears: 

 

3. Choose the relevant option, as described in the following table: 

Options for Deleting Fields  

Option Action 

Yes Deletes the first field with dependencies (Field A).  

The warning message reappears before the second field with dependencies (Field B) 
can be deleted. 

Yes to All Deletes all fields with dependencies (Field A and C) and without dependencies (Field 
B and Field D). 

No Default. Cancels the delete operation for the first selected field with dependencies 
(Field A). The window then reappears to issue the same warning message for the next 
field with dependencies (Field C). 

No to All Cancels the delete operation for all fields with dependencies (Field A and Field C) but 
deletes the fields without dependencies (Field B and Field D). 

Cancel Cancels the entire delete operation for all fields. 
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Defining Sorts 
You can sort the printed table according to the data found in each repetitive area (including hidden 
fields).  

Procedure 

To sort a certain table in a repetitive area, do the following: 

1. Click the selected area. 

2. In the menu bar, choose Print Layout Designer → Repetitive Area → Sort. 

 

3. Make selections as described in the following table: 

Sort 

Option Action 

Field Name Select the sort field. The first field you select is the primary sort; the second field is the 
secondary sort, and so on. 

Sort Type Select Alpha, Numeric, Currency, or Date. 

Order Select Ascending or Descending. 

Summary Indicates to the application to search for a subsort or a subtotal when performing a 
summary for this sort. 

New Page Moves on to a new page after a summary or a sort takes place. 
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Performing Subsorts and Subtotals 
You must create sorts to perform subsorts or subtotals. For example, sort the Items table in a sales 
quotation by the Item Number field and display a relevant title each time the item number changes. 
This is a subsort.  

In addition, perform a subtotal displaying the cumulative quantity of each item. This is useful in 
documents containing multiple rows of the same item, displayed with a different description in each 
row. 

Procedure 

After defining the sort, do the following: 

1. In the menu bar, choose Print Layout Designer → Group. 

2. Select a group number.  

3. Select 1 for a subsort or subtotal for the primary sort, select 2 for the secondary sort, and so on. 

Each group is linked to its relevant row number in the Sort window described above. Thus, 
every field created in a certain group relates only to its group's corresponding row in the Sort 
window. 

The titles of the repetitive area header are now hidden, as well as any field created in the 
repetitive area footer. The reason is that these two areas are linked to groups. Each of the 
groups has two areas of its own. 

4. To define the subsort, do the following: 

a. In the repetitive area header, assign a title for the required sort. 

b. Create a new formula field. 

c. Choose the Formula Editor button and in the Operation field, select the operand 
SortValue(). 

This action prints the Items table divided into separate titles each time the item number 
changes. 

5. To define subtotals, do the following: 

a. In the repetitive area footer, create a formula field. 

b. Choose the Formula Editor button and in the Operation field (for the Quantity field from 
the rows in the sales quotation), select the operand ColSum (UniqueID as 
String). 

The field inside the brackets defines the column for which a total is calculated. You can 
also calculate totals for the Total column. 

6. Save the changes.  
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Setting a Default Print Layout 
For each new company, SAP Business One creates default print layouts for each document and 
report type (according to the localization). 

After creating your own user-defined layouts, you can set them as default, so that each document is 
printed using the customized layout. 

Procedure 

1. Open the required document or report. 

2. Choose Tools → Print Layout Designer. Alternatively, choose  in the toolbar. 

The Layout Designer – Selection Criteria window opens: 

 
The document name displayed in bold letters is the current default print layout. 

In the above example, the layout Sales Order Preprinted USA (System) is set as the default 
layout for the document type Order (Items). 

3. To set a different layout as default, click the required document name and choose the Set as 
Default button. 

The Default Layout window appears. 
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4. Set a default print layout for users and for business partners using the following options: 

 Users: 

 Set as Default for All Users 

Sets the selected layout as default for all SAP Business One users. Only a 
superuser can set a layout as default for all users. 

 Set as Default for Current User 

Sets the selected layout as default only for the SAP Business One user who is 
currently logged on. 

 Set as Default for Specified Users 

Lets you select specified users from the List of Users window displayed when you 
choose . 

 Business Partners: 

 Set as Default for All BPs (for whom a Default Layout has not been assigned) 

Sets the selected print layout as default for all the business partners for whom no 
default layout has been assigned yet. 

 Set as Default for Specified BP 

Lets you select specific business partners from the BP Properties window 
displayed when you choose .  

 Note 
You can set a print layout as default for one or several business partners using the 
Business Partner – Selection Criteria window:  

i. Open the BP Properties window.  

ii. Using the From and To fields, define a range of the wanted business partners. 

iii. Choose the OK button. 

5. Choose the OK button to apply the selections. 

 Note 
You can set default print layouts for business partners for the following documents: sales 
and purchasing (invoice, delivery, and so on); payments (incoming payments, outgoing 
payments, and so on); checks for payment; and sales opportunity. 
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Tips and Tricks 

Backing Up Print Layouts 
Save your print layout under a new name each time you modify it. This helps in keeping backups of 
the user-defined layouts and lets you return to a previous layout in case the new one does not meet 
your requirements. 

After you have made a change in a print layout and saved it under a new name, you can set the new 
layout as default, print the document, and see if the modifications are as required. 

Deleting Layouts 
You can delete the backup layouts at any stage by doing the following: 

1. Open the required print layout. 

2. In the menu bar choose Print Layout Designer → Delete Layout. If you delete a default layout, 
the application chooses another layout as the default. 

 Note 
You cannot delete SAP Business One default (System) print layouts. 

Printing the Ship-To Address and the Bill-To Address 
To display the ship-to or bill-to address in the print layout of a document, use the default values from 
the business partners table or from the document table (for example, delivery).  

Using Formula Fields as Sort Fields 
You can use formula fields as sort fields in the Sort window. 

 

To use a formula field as a sort field, in the Field Name column, select the required formula field. 
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Multiple Predefined Print Layouts (System) 
Some reports and document types have several SAP Business One default (System) layouts: 

 

The number of these predefined layouts varies according to the document/report type and your 
localization. 

Saving Layouts as Images 
You can save documents and reports as graphic files (*.jpg).  

To save a document as a graphic file, do the following: 

1. Display the required document, for example, a sales order. 

2. In the menu bar, choose File → Print Preview. 

The system displays a preview of the printed document. 

3. In the menu bar, choose Goto → Save as Image. 

 Note 
The application saves the file in the Picture folder defined on the Path tab in 
Administration → System Initialization → General Settings. 

Cumulative Summary Field 
You can create a field for a cumulative summary of a selected field.  

Example 

To create a cumulative quantity per row, do the following: 

1. In the repetitive area, create a new formula field. 

2. Apply the operand ColSum(var) to the selected field. 
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Increasing the Number of Printed Rows on Each Page 
To increase the number of printed rows, do the following: 

1. From the SAP Business One Main Menu, choose Administration → System Initialization → Print 
Preferences, and on the General tab, do the following: 

a. Select Max. Rows per Page. 

b. Select Print with Vertical Compression. 

All the rows in the document are compressed according to this definition.  

To extend the blank area, reduce the height of any other area in the layout. 

2. To reduce the repetitive area, reduce the fonts, the fields (including hidden ones), and the entire 
area. 

Printing Pictures in Their Original Size 
The Ext. Image Processing field sets the print style of your logo and pictures. The field is relevant 
when attached pictures are not printed according to their original size. 

To print pictures in their original size, do the following: 

1. From the SAP Business One Main Menu, choose Administration → System Initialization → 
General Settings. 

2. On the Display tab, in the Ext. Image Processing field, select Full. 

 
This enables a print style that sharpens the picture's printout and reduces the printout of a text-
containing logo. 
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Printing the Manufacturer or Group Name 
To print the manufacturer or the item group name of an item or business partner, do the following: 

1. In the repetitive area, add a new hidden database field. 

2. In the Table field of the Properties window, on the Content tab, select Items. 

3. In the Column field select Item Group. 

 

4. Add another database field in the same area. You can now select the Item Groups in the Table 
field and Group Name in the Column field 

Picture Formats 
You can use the following graphic formats: 

• *.bmp  

• *.gif 

• *.jpg 

• *.png 

• *.tif 

• *.pcx 

• *.tga 

• *.bif 

The files must not be compressed. 

Error Messages 
"File name missing in data field": 

The system displays this error message when you attempt to save a print layout that contains a 
database field with no values in the Table and Column fields.  

 

The system highlights the relevant field in both the layout and the Field Index window to indicate 
where the problem is. You can remove or update the field. 
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"Printing Error": 

When the system generates error messages related to fields in the layout, the unique ID numbers of 
the field(s) causing the error are displayed as part of the message: 

 

Maintaining the Original Display Order 
After creating subtotals and subsorts, you can determine that the items inside each subsort appear in 
their original order, as displayed in the document. 

To maintain the original display order, do the following: 

1. In the repetitive area that contains the Row Number field from the document, create a hidden 
system variable field: 

 

2. In the Sort window, define this field as the secondary sort. 
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Printing Using the Page X of Y Format 
To print page numbers in reports and documents in a Page X of Y format, do the following: 

1. Create two formula fields using the following operands: 

 CurrentPage() 

 TotalPages() 

2. Create two text fields containing the texts: 

 Page 

 of 

Printing Query Parameters in User Reports 
You can create user reports for your user-defined queries.  

If a query contains conditions, these are printed in the report header. 

 Example 
A query retrieves all the business partners with a positive account balance and uses the 
condition "Balance > 0.00". 

When you create a user report for this query, the condition you use in the query is printed 
in the report header. 

 

Printing Additional Bar Code Types 
With SAP Business One you can print the most widely used bar code types: EAN 13 and Code 39.  

In addition, you can print other bar code types by following the procedure below. 

Prerequisites 

You have saved the required bar code font on your computer. 

 Note 
You can obtain bar code fonts on the Internet. 

Procedure 

1. To install the bar code font in the Microsoft Windows font library, from the Windows taskbar 
choose Start → Control Panel → Fonts. 

2. In the menu bar choose File → Install New Font.  

3. Navigate to the required font and choose the OK button. 

4. In SAP Business One, open the required print layout in Print Layout Designer, create a new 
field, and define it as Free Text or Database 

5. In the Properties window of the new field, select the Format tab. 

6. In the Font field, select the bar code font. 
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Result 

When the document is printed, the content of the new field is printed as a bar code. 

 Note 
To view the bar code when print previewing the layout and sending it through e-mail, 
make sure that the Preview Printing Layout and E-Mail Layout checkboxes on the 
Format tab in the Document Properties window are deselected. 
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Copyrights, Trademarks, and Disclaimers 
© Copyright 2009 SAP AG. All rights reserved. 

 

The current version of the copyrights, trademarks, and disclaimers at 
http://service.sap.com/smb/sbocustomer/documentation is valid for this document. 
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